Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-10-2017 09:16:28

babak
Membre
Inscription : 14-05-2017

Xdebug not working

Bonjour

J'ai installé Xdebug sur debian 9 avec php 7 et apache, en suivant pas à pas les conseils du site officiel.

Xdebug ne marche pas il y a rien dans phpinfo et le port 9000 ne "listen" pas.

Une idée ? svp

Hors ligne

#2 25-10-2017 09:18:45

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Xdebug not working

Salut babak,

Désolé, pas de solution mais si tu renseignes ton profil les aides en seront facilitées :
Voir le tuto : Trop cool d'indiquer son installation dans son profil ! smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 25-10-2017 11:00:04

babak
Membre
Inscription : 14-05-2017

Re : Xdebug not working

merci smolski quand même
J'ai trouvé, c'était tout bête.
En fait le wizard du site officiel Xdebug.org prend ton phpinfo, l'analyse et te dit comment l'installer.
Tu compile, tu installe et tu rajoute le parametrage du Xdebug dans cli/php.ini
ce que j'avais bêtement fait. Mais il faut le faire dans apache/php.ini
après il faut aussi rajouté à ce qu'ils ne te disent pas :

xdebug.dump.SERVER = REMOTE_ADDR,REQUEST_METHOD
xdebug.dump.GET = *



un

apache2 restart


et le tour est joué.

Je marque ça pour la posterité. Des gens qui vont passer une demi journée à chercher la merde chez eux sans mettre en doute le site de Xdebug.

Comment tu fermes cette question mon ami ?

Edit à toto :

Mis les codes php dans la balise Code option php.

Hors ligne

#4 25-10-2017 11:25:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Xdebug not working

Pour mettre le sujet en résolu , y' a le tuto en choco là :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. smile

C'est à dire que tu édites ton premier post et tu modifie le titre. wink

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums