Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-11-2017 15:06:15

Vince99
Membre
Inscription : 23-05-2017

Erreur de mise à jours

Bonjour,

J'espère que je poste dans la bonne section. Je suis très débutant avec Débian, j'aime bien le projet et je suis super content de l'utiliser mais je suis vite limité. Par exemple, là j'ai un problème de mise à jour, dont je vous donne le rapport ci-dessous, apparemment il y a quelque chose que je n'ai pas fait ou mal fait.
En plus j'ai un problème de mise a jour de firefox et il me semble que c'est en lien avec des paquets manquants, peut-être pourrez-vous me renseigner sur cette question aussi.

Merci pour vos réponses...



root@packard:~# dpkg --configure -a && apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --yes --force-yes upgrade && apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --yes --force-yes dist-upgrade && exit 0 || exit 1
dpkg: des problèmes de dépendances empêchent le traitement des actions différées pour libc-bin :
libc-bin dépend de libc6 (>> 2.19) ; cependant :
  Le paquet libc6:amd64 n'est pas installé.
libc-bin dépend de libc6 (<< 2.20) ; cependant :
  Le paquet libc6:amd64 n'est pas installé.

dpkg: erreur de traitement du paquet libc-bin (--configure) :
problèmes de dépendances - actions différées non exécutées
dpkg: des problèmes de dépendances empêchent le traitement des actions différées pour man-db :
man-db dépend de libc6 (>= 2.17) ; cependant :
  Le paquet libc6:amd64 n'est pas installé.

dpkg: erreur de traitement du paquet man-db (--configure) :
problèmes de dépendances - actions différées non exécutées
dpkg: des problèmes de dépendances empêchent la configuration de libc-dev-bin :
libc-dev-bin dépend de libc6 (>> 2.24) ; cependant :
  Le paquet libc6:amd64 n'est pas installé.
libc-dev-bin dépend de libc6 (<< 2.25) ; cependant :
  Le paquet libc6:amd64 n'est pas installé.

dpkg: erreur de traitement du paquet libc-dev-bin (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libc6-dev:amd64 :
libc6-dev:amd64 dépend de libc6 (= 2.24-11+deb9u1) ; cependant :
  Le paquet libc6:amd64 n'est pas installé.
libc6-dev:amd64 dépend de libc-dev-bin (= 2.24-11+deb9u1) ; cependant :
Le paquet libc-dev-bin n'est pas encore configuré.

dpkg: erreur de traitement du paquet libc6-dev:amd64 (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de locales :
locales dépend de libc-bin (>> 2.24) ; cependant :
  La version de libc-bin sur le système est 2.19-18+deb8u9.

dpkg: erreur de traitement du paquet locales (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
libc-bin
man-db
libc-dev-bin
libc6-dev:amd64
locales
exit

Hors ligne

#2 02-11-2017 15:11:04

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Salut Vince99,

Peut-être voir tes sources aiderait :
que donne la commande :

cat /etc/apt/sources.list


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 02-11-2017 15:15:00

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Salut Smolsky,

Merci pour ta réponse (super) rapide.

Voilà ce que ça donne:

dewhite01@packard:~/Bureau$ cat /etc/apt/sources.list
##DEBIAN Jessie##
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

#deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free
#deb-src http://ftp.debian.org/debian/ jessie-backports main contrib non-free
deb http://ftp.debian.org/debian/ stable main contrib non-free
deb http://ftp.de.debian.org/debian jessie main

dewhite01@packard:~/Bureau$ ^C
dewhite01@packard:~/Bureau$

Edit à toto :

Voici comment représenter la commande et son retour sur le forum avec les balises code :

cat /etc/apt/sources.list


deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

#deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free
#deb-src http://ftp.debian.org/debian/ jessie-backports main contrib non-free
deb http://ftp.debian.org/debian/ stable main contrib non-free
deb http://ftp.de.debian.org/debian jessie main

Hors ligne

#4 02-11-2017 15:27:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

toto a modifié ton post, pour éclairer ses dires voir :
Voir le tuto : Le code, ça pique moins les yeux en couleur smile

Modifie tes sources non libre selon le modèle du wiki df ici :
https://debian-facile.org/doc:systeme:a … -non-libre

Ensuite :

apt-get update


apt-get dist-upgrade


Tu surveilles si tu as des trucs qui vont être supprimés et tu valides si ça va.
Sinon, si tu as un doute, tu nous reportes le message ici et tu refuses en attendant.


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 02-11-2017 15:45:50

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

Bonjour
Lire le wiki sur les sources.list -->https://debian-facile.org/doc:systeme:apt:sources.list

WikiDF a écrit :

Un fichier sources.list mal configuré peut aboutir à un système instable ou ne plus fonctionner du tout.



La branche peut être désignée sous son nom de code (jessie, stretch, buster, sid) ou son nom d’archive (oldstable, stable, testing, unstable).


WikiDF a écrit :

On ne mélange jamais nom de code et nom d’archive dans le même sources.list.



deb http://ftp.debian.org/debian/ stable main contrib non-free


cette ligne dans ton sources.list est sûrement la responsable de tes problèmes, Debian stretch est passé en version stable et de ce fait Jessie est passé en oldstable.
Comme tu as déclaré le nom d'archive stable dans ton fichier sources.list , tu te retrouve maintenant avec un dépôt "pointant" vers la version Stretch

Voici mon sources.list fonctionnel sous Jessie
cat /etc/apt/sources.list

#####DEBIAN Jessie##
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
# deb-src http://httpredir.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
# deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
# deb-src http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
deb http://ftp.debian.org/debian/ jessie-backports non-free contrib main
# deb-src http://ftp.debian.org/debian/ jessie-backports main contrib non-free



Il nous faudrait connaître le contenu du répertoire des fichiers sources supplémentaire

ls /etc/apt/sources.list.d


Note que ce répertoire peut être vide

Edit: il existe une option de la commande apt qui permet d'éditer le fichier sources.list et de faire une vérification de base en sortie

apt edit-sources

Dernière modification par Croutons (02-11-2017 15:50:35)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 02-11-2017 15:52:09

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Merci pour vos réponses, je suis largué complet, mais j'essaye déjà de répondre en couleur smile est-ce que ça marche?

Voilà ce que ça me donne:

dewhite01@packard:~/Bureau$ ls /etc/apt/sources.list.d
dflinux.list  videolan.list
dewhite01@packard:~/Bureau$
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#7 02-11-2017 15:54:18

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Donc Croutons, que dois-je faire de cette ligne qui me met le bazar d'après toi?

Hors ligne

#8 02-11-2017 16:02:18

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

Tu peux la supprimé, elle y est déja avec le nom de code Jessie
Bon du coup vu qu'il existe 2 fichiers sources supplémentaire il faudrait en contrôler le contenu

cat /etc/apt/sources.list.d/dflinux.list


cat /etc/apt/sources.list.d/videolan.list



Edit: Le dépot videolan te sert pour quel logiciel?

Dernière modification par Croutons (02-11-2017 16:05:39)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 02-11-2017 16:02:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

@Vince99
Qu'as-tu utilisé pour installer debian ?
Quel iso, d'où vient-elle ?

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#10 02-11-2017 16:16:47

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Pffiou alors là je sais plus où je l'ai pris cet iso, je l'avais mis sur une clef et suivi un tuto mais ça me dépasse tellement que j'ai pas le souvenir de où je l'ai pris.scratchhead.gif

Pour supprimer la ligne en question, il faut faire comment?

merci.

Hors ligne

#11 02-11-2017 16:31:54

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

Tu édites le fichier sources.list , la commande apt permet de le faire avec une vérification de base

apt edit-sources

Dernière modification par Croutons (02-11-2017 16:32:54)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#12 02-11-2017 16:38:28

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

sad ben ça marche pas...

dewhite01@packard:~/Bureau$ apt edit-sources
E: Impossible d'ouvrir le fichier verrou /etc/apt/sources.list - open (13: Permission non accordée)
dewhite01@packard:~/Bureau$


bloc à supprimer si la commande n’affiche rien

Hors ligne

#13 02-11-2017 16:49:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Pour moi, l'iso de reference est DFLinux, d'après les sources additives. smile

Je les sauvegarderai puis je corrigerai les sources jessie et je mettrai à jour le bazar.

Tu passes en superutilisateur :
le tuto :
https://debian-facile.org/doc:systeme:superutilisateur

su -


tu tapes le code root et tu le valides, rien ne s'écrit mais le $ de la ligne de commande passe en # ce qui indique que tu es en root maintenant wink
Sauvegarde des sources additives :

cd /etc/apt/sources.list.d


mv dflinux.list dflinux.sav


mv videolan.list videolan.sav


Ensuite, retour aux sources jessie :

cd ../


mv sources.list sources.sav


nano source.list


Ensuite tu copie colle (avec la souris, pas au clavier) les sources jessie que voici :

    # Debian Jessie, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ jessie main contrib non-free
    # Debian Jessie, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ jessie/updates main contrib non-free
    # Debian Jessie, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ jessie-updates main contrib non-free


La combinaison de touches pour enregistrer :
Ctrl o
Pour quitter :
Ctrl x
tu retournes à la racine :

cd


tu mets à jour le cache :

apt-get update


tu mets à jour les paquets :

apt-get upgrade


Tu valides que si tu n'as pas de suppression de paquet ou en cas de doute, dans ces deux cas, tu nous fais le retour de la commande ici.

Yep ? smile

Force et courage

Dernière modification par smolski (02-11-2017 16:58:48)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#14 02-11-2017 17:01:58

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

c'est pas sudo pour DFlinux?, comme sur Handylinux y'a pas de compte root , le premier utilisateur qui est l'administrateur du système
Je dis çà mais je l'ai pas sous la main pour vérifier

Don c si
su ne fonctionne pas il faut taper sudo pour entrer une commande en root

Dernière modification par Croutons (02-11-2017 17:03:10)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#15 02-11-2017 17:03:04

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Merci smolski c'est bien détaillé, sauf que d'entrée de jeu ça bloque et ça me dit "erreur d'authentification", alors que c'est le bon mot de passe scratchhead.gif

Hors ligne

#16 02-11-2017 17:06:20

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

ah oui donc c'est bien sudo qu'il faut, et vu qu'il y a plein de commande a passer en root tu peux taper

sudo -i

, le prompt passera de $ à #, # voulant dire que tu es sous le compte root
une fois fini on quitte root en tapant exit , ou en fermant le terminale


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#17 02-11-2017 17:19:44

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Pinaise c'est pas évident. J'ai pu passer en root avec sudo, j'ai bien fait des copier/coller de chaque étape, mais ça n'a rien écrit dans le terminal, sauf le nano source.list, et là ja'i copié/collé les sources jessie, mais le ctrl o et ctrl x ne m'ont pas ramené a la racine, c'est normal, ya un truc à faire? Du coup je suis pas sur d'avoir enregistré l'opération...?

Merci pour votre aide en tout cas!

Hors ligne

#18 02-11-2017 17:33:00

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Ok tu es en root, c'est le principal pour la suite.

Vince99 a écrit :

j'ai bien fait des copier/coller de chaque étape


Il vaut mieux que tu écrives chaque commande en utilisant l'autocompletion :
Le tuto :
https://debian-facile.org/doc:programma … completion

En fait, tu tapes les premières lettres des commandes et tu tapes sur la touche tabulation du clavier et cela complète la ligne ou bien te propose plusieurs possibilités.
Tu avances d'une ou deux lettres et tu tapes de nouveau sur la touche tabulation, et ainsi de suite
Si cela n'aboutit pas, tu nous envois ici la ligne et on cherchera ensemble.

Dernière modification par smolski (02-11-2017 17:33:37)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#19 02-11-2017 17:40:44

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Ok, alors je ré-essaye mais de nouveau ça fait des trucs bizarres du genre:

dewhite01@packard:~/Bureau$ sudo -i
[sudo] Mot de passe de dewhite01 : 
root@packard:~# cd/etc/apt/sources.list.d
-bash: cd/etc/apt/sources.list.d: Aucun fichier ou dossier de ce type
root@packard:~# mv dflinux.list dflinux.sav
mv: impossible d'évaluer 'dflinux.list': Aucun fichier ou dossier de ce type
root@packard:~# ^C
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#20 02-11-2017 17:50:57

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

attention a la syntaxe wink
après cd il faut un espace

cd /etc/apt/sources.list.d



la commande cd sert a te positionner dans le bon répertoire, donc comme il manquait un espace après la commande
Les commandes suivante non pas fonctionné non plus vu que tu n'étais pas dans le bon répertoire

Dernière modification par Croutons (02-11-2017 17:54:46)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#21 02-11-2017 18:10:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Vince99 utilise l'autocompletion, c'est très important parce que tu es en root et dans ton système.

Consulte ce lien avant de continuer :
https://debian-facile.org/doc:programma … completion

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#22 02-11-2017 18:13:24

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Ah ok je comprends. J'ai refait la manip, jusqu’à copier coller les sources jessie mais ça me laisse avec un terminal où s'affichent les lignes collées, mais ctrl o et ctrl x ne me ramènent pas à la racine, c'est normal?

Hors ligne

#23 02-11-2017 18:24:11

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

oui tu retourne sous /root, dans le dossier root , le comportement ne doit pas être le même sous le système a smolski qui doit utilisé su
mais ceci n'est pas bien grave les commandes de mise a jour peuvent être exécuté

Dernière modification par Croutons (02-11-2017 18:25:52)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#24 02-11-2017 18:30:43

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Vince99 Voici le tuto de l'éditeur nano :
https://debian-facile.org/doc:editeurs:nano

Tu peux le consulter pour mieux comprendre...

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#25 02-11-2017 19:01:07

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Merci pour vos réponses c'est trop cool, mais j'y arrive pas, je suis dépassé de partout. Je dois faire quoi maintenant pour retourner à root?

Hors ligne

Pied de page des forums