Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 02-11-2017 19:20:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

sudo i


pour retourner à root.
J'aimerai voir les modifs que tu as faites avant de te lancer dans l'update.
donc, on revient à la commande cat :

cat /etc/apt/sources.list


et me lister les fichiers dflinux et videolan ainsi :

ls /etc/apt/sources.list.d/


et tu nous donnes ce que cela renvoie.
smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#27 02-11-2017 19:42:12

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

merci pour votre patience smile

ça donne pas grand chose:

dewhite01@packard:~/Bureau$ sudo -i
[sudo] Mot de passe de dewhite01 : 
root@packard:~# cat /etc/apt/sources.list
cat: /etc/apt/sources.list: Aucun fichier ou dossier de ce type
root@packard:~# ls /etc/apt/sources.list.d/
dflinux.sav  videolan.sav
root@packard:~#
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#28 02-11-2017 19:55:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

ok
tu va recréer le fichier des sources.
toujours en root :

cd /etc/apt/


Puis tu copies colles cette commande en entier :

cat > /etc/apt/sources.list <<EOF
    # Debian Jessie, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ jessie main contrib non-free
    # Debian Jessie, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ jessie/updates main contrib non-free
    # Debian Jessie, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
EOF


Et tu me renvoies la commande cat précédente :

cat /etc/apt/sources.list



On touche au but big_smile

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#29 02-11-2017 20:14:38

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Yep. Alors voilà ce que j'obtiens:

dewhite01@packard:~/Bureau$ sudo -i
[sudo] Mot de passe de dewhite01 : 
root@packard:~# cat /etc/apt/sources.list
cat: /etc/apt/sources.list: Aucun fichier ou dossier de ce type
root@packard:~# ls /etc/apt/sources.list.d/
dflinux.sav  videolan.sav
root@packard:~# cd /etc/apt/
root@packard:/etc/apt# cat > /etc/apt/sources.list <<EOF
>     # Debian Jessie, dépôt principal + paquets non libres
>     deb http://deb.debian.org/debian/ jessie main contrib non-free
>     # Debian Jessie, mises à jour de sécurité + paquets non libres
>     deb http://security.debian.org/ jessie/updates main contrib non-free
>     # Debian Jessie, mises à jour "volatiles" + paquets non libres
>     deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
> EOF
root@packard:/etc/apt# cat /etc/apt/sources.list
    # Debian Jessie, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ jessie main contrib non-free
    # Debian Jessie, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ jessie/updates main contrib non-free
    # Debian Jessie, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
root@packard:/etc/apt#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#30 02-11-2017 20:32:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Ok Vince99,

Maintenant tu reviens à la racine :

cd


et tu fais la mise à jour :

apt-get update


tu me renvoies ici ce que cela a donné par copie colle avec la souris, toujours smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#31 02-11-2017 21:04:57

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Bon il semble que ça avance bien, y a des trucs qui ont pas marché à la fin:

root@packard:~# cd /etc/apt/
root@packard:/etc/apt# cat > /etc/apt/sources.list <<EOF
>     # Debian Jessie, dépôt principal + paquets non libres
>     deb http://deb.debian.org/debian/ jessie main contrib non-free
>     # Debian Jessie, mises à jour de sécurité + paquets non libres
>     deb http://security.debian.org/ jessie/updates main contrib non-free
>     # Debian Jessie, mises à jour "volatiles" + paquets non libres
>     deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
> EOF
root@packard:/etc/apt# cat /etc/apt/sources.list
    # Debian Jessie, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ jessie main contrib non-free
    # Debian Jessie, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ jessie/updates main contrib non-free
    # Debian Jessie, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
root@packard:/etc/apt# cd
root@packard:~# apt-get update
Réception de : 1 http://security.debian.org jessie/updates InRelease [63,1 kB]
Ign http://deb.debian.org jessie InRelease                                    
Réception de : 2 http://deb.debian.org jessie-updates InRelease [145 kB]      
Réception de : 3 http://security.debian.org jessie/updates/main amd64 Packages [486 kB]
Atteint http://security.debian.org jessie/updates/contrib amd64 Packages      
Atteint http://security.debian.org jessie/updates/non-free amd64 Packages      
Atteint http://security.debian.org jessie/updates/contrib Translation-en      
Réception de : 4 http://deb.debian.org jessie Release.gpg [2 373 B]            
Réception de : 5 http://security.debian.org jessie/updates/main Translation-en [233 kB]
Réception de : 6 http://deb.debian.org jessie-updates/contrib amd64 Packages [32 B]
Atteint http://security.debian.org jessie/updates/non-free Translation-en      
Réception de : 7 http://deb.debian.org jessie-updates/contrib Translation-en [14 B]
Réception de : 8 http://deb.debian.org jessie-updates/main Translation-en [14,9 kB]
Réception de : 9 http://deb.debian.org jessie-updates/non-free Translation-en [496 B]
Réception de : 10 http://deb.debian.org jessie Release [148 kB]          
Réception de : 11 http://deb.debian.org jessie-updates/main amd64 Packages [20,1 kB]
Réception de : 12 http://deb.debian.org jessie-updates/non-free amd64 Packages [516 B]
Réception de : 13 http://deb.debian.org jessie/main amd64 Packages [6 789 kB]
Réception de : 14 http://deb.debian.org jessie/contrib amd64 Packages [49,8 kB]
Réception de : 15 http://deb.debian.org jessie/non-free amd64 Packages [83,6 kB]
Réception de : 16 http://deb.debian.org jessie/contrib Translation-en [38,3 kB]
Réception de : 17 http://deb.debian.org jessie/main Translation-fr [846 kB]    
Réception de : 18 http://deb.debian.org jessie/main Translation-en [4 582 kB]  
Réception de : 19 http://deb.debian.org jessie/non-free Translation-en [72,1 kB]
13,6 Mo réceptionnés en 23s (572 ko/s)                                        
Lecture des listes de paquets... Fait
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#32 02-11-2017 21:51:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Ok Vince99.

On poursuit :

apt-get upgrade


Tu regardes s'il te demande de supprimer des trucs, ce qui est peu probable, et tu valides par o.
Sinon, tu donnes ici le résultat avant de valider, mais à ce stade, on est plutôt au point.

Si tu as validé, ben normalement c'est cool et tu te sers de ton pc, si y'a des ratés alors, tu les indiques ici à la suite.

Hop ! smile

Dernière modification par smolski (02-11-2017 21:52:25)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#33 02-11-2017 23:38:54

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Hello smolski, j'ai fait un petit break aussi smile
Donc voici ce que ça donne, c'est quoi ces dépendances?

root@packard:~# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc-dev-bin : Dépend: libc6 (> 2.24) mais 2.19-18+deb8u9 est installé
 libc6-dev : Dépend: libc6 (= 2.24-11+deb9u1) mais 2.19-18+deb8u9 est installé
 locales : Dépend: libc-bin (> 2.24) mais 2.19-18+deb8u9 est installé
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#34 02-11-2017 23:50:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Attends, je te m'en vas te proposer la suite immédiatement smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#35 03-11-2017 00:03:27

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

ok vu.

Tes sources d'avant t'ont fait monter à stretch, la nouvelle stable.
on va effacer les sources actuelles et mettre ton pc sous stretch l eplus facilement possible.
1/ effacer les sources actuelles sous root.
Si tu es toujours sous root ça va, sinon tu commences par t'y mettre comme d'hab avec la commande :

sudo -i


ensuite tu te place dans le répertoire des sources :

cd /etc/apt/


tu supprimes le fichier que nous avons créé :

rm sources.list


on refait les sources mais en utilisant stretch et même les backports :

cat > /etc/apt/sources.list <<EOF
    # Debian Stretch, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ stretch main contrib non-free
    # Debian Stretch, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ stretch/updates main contrib non-free
    # Debian Stretch, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
    # Debian Stretch, dépôt de rétroportages ("backports")
    deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
EOF


tu simules la mise à jour à jour voir que rien ne cloche :

apt-get -s update


et tu renvoies le retour ici.

Oups ! doublon de copie avec la molette de la souris ! Réparé Merci Crouton wink

Dernière modification par smolski (03-11-2017 17:21:34)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#36 03-11-2017 00:11:32

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

merci, alors voilà le résultat, pour l'update ça  a pas l'air d'être ça:

root@packard:~# cd /etc/apt/
root@packard:/etc/apt# cat > /etc/apt/sources.list <<EOF
>     # Debian Jessie, dépôt principal + paquets non libres
>     deb http://deb.debian.org/debian/ jessie main contrib non-free
>     # Debian Jessie, mises à jour de sécurité + paquets non libres
>     deb http://security.debian.org/ jessie/updates main contrib non-free
>     # Debian Jessie, mises à jour "volatiles" + paquets non libres
>     deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
> EOF
root@packard:/etc/apt# cat /etc/apt/sources.list
    # Debian Jessie, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ jessie main contrib non-free
    # Debian Jessie, mises à jour de sécurité + paquets non libres
    deb http://security.debian.org/ jessie/updates main contrib non-free
    # Debian Jessie, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
root@packard:/etc/apt# cd
root@packard:~# apt-get update
Réception de : 1 http://security.debian.org jessie/updates InRelease [63,1 kB]
Ign http://deb.debian.org jessie InRelease                                    
Réception de : 2 http://deb.debian.org jessie-updates InRelease [145 kB]      
Réception de : 3 http://security.debian.org jessie/updates/main amd64 Packages [486 kB]
Atteint http://security.debian.org jessie/updates/contrib amd64 Packages      
Atteint http://security.debian.org jessie/updates/non-free amd64 Packages      
Atteint http://security.debian.org jessie/updates/contrib Translation-en      
Réception de : 4 http://deb.debian.org jessie Release.gpg [2 373 B]            
Réception de : 5 http://security.debian.org jessie/updates/main Translation-en [233 kB]
Réception de : 6 http://deb.debian.org jessie-updates/contrib amd64 Packages [32 B]
Atteint http://security.debian.org jessie/updates/non-free Translation-en      
Réception de : 7 http://deb.debian.org jessie-updates/contrib Translation-en [14 B]
Réception de : 8 http://deb.debian.org jessie-updates/main Translation-en [14,9 kB]
Réception de : 9 http://deb.debian.org jessie-updates/non-free Translation-en [496 B]
Réception de : 10 http://deb.debian.org jessie Release [148 kB]          
Réception de : 11 http://deb.debian.org jessie-updates/main amd64 Packages [20,1 kB]
Réception de : 12 http://deb.debian.org jessie-updates/non-free amd64 Packages [516 B]
Réception de : 13 http://deb.debian.org jessie/main amd64 Packages [6 789 kB]
Réception de : 14 http://deb.debian.org jessie/contrib amd64 Packages [49,8 kB]
Réception de : 15 http://deb.debian.org jessie/non-free amd64 Packages [83,6 kB]
Réception de : 16 http://deb.debian.org jessie/contrib Translation-en [38,3 kB]
Réception de : 17 http://deb.debian.org jessie/main Translation-fr [846 kB]    
Réception de : 18 http://deb.debian.org jessie/main Translation-en [4 582 kB]  
Réception de : 19 http://deb.debian.org jessie/non-free Translation-en [72,1 kB]
13,6 Mo réceptionnés en 23s (572 ko/s)                                        
Lecture des listes de paquets... Fait
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
root@packard:~# apt-get uprgrade
E: L'opération uprgrade n'est pas valable
root@packard:~# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc-dev-bin : Dépend: libc6 (> 2.24) mais 2.19-18+deb8u9 est installé
 libc6-dev : Dépend: libc6 (= 2.24-11+deb9u1) mais 2.19-18+deb8u9 est installé
 locales : Dépend: libc-bin (> 2.24) mais 2.19-18+deb8u9 est installé
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
root@packard:~# cd /etc/apt/
root@packard:/etc/apt# rm sources.list
root@packard:/etc/apt# cat > /etc/apt/sources.list <<EOF
>     # Debian Stretch, dépôt principal + paquets non libres
>     deb http://deb.debian.org/debian/ stretch main contrib non-free
>     # Debian Stretch, mises à jour de sécurité + paquets non libres
>     deb http://security.debian.org/ stretch/updates main contrib non-free
>     # Debian Stretch, mises à jour "volatiles" + paquets non libres
>     deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
>     # Debian Stretch, dépôt de rétroportages ("backports")
>     deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
>     # Debian Stretch, dépôt principal + paquets non libres
>     deb http://deb.debian.org/debian/ stretch main contrib non-free
>     # Debian Stretch, mises à jour de sécurité + paquets non libres
>     deb http://security.debian.org/ stretch/updates main contrib non-free
>     # Debian Stretch, mises à jour "volatiles" + paquets non libres
>     deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
>     # Debian Stretch, dépôt de rétroportages ("backports")
>     deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
> EOF
root@packard:/etc/apt# apt-get -s update
E: L'option « s » de la ligne de commande [d'origine -s] est inconnue.
root@packard:/etc/apt# apt-get -s update
E: L'option « s » de la ligne de commande [d'origine -s] est inconnue.
root@packard:/etc/apt#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#37 03-11-2017 00:17:03

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Ok.
reviens à la racine de root :

cd


et recommence le update simulé

apt-get -s update

Dernière modification par smolski (03-11-2017 00:19:00)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#38 03-11-2017 00:21:42

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

oups, ça marche toujours pas:

root@packard:/etc/apt# cd
root@packard:~# apt-get -s update
E: L'option « s » de la ligne de commande [d'origine -s] est inconnue.
root@packard:~#
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#39 03-11-2017 00:24:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

bon, on va se lancer alors :

apt-get update


Peut-être que la simulation fonctionnera sur le upgrade que nous ferons ensuite ? smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#40 03-11-2017 00:29:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

tu m e renvoies ce que ça donne avant l'upgrade smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#41 03-11-2017 00:33:20

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

.... here it is:

root@packard:~# apt-get update
Réception de : 1 http://security.debian.org stretch/updates InRelease [63,0 kB]
Réception de : 2 http://security.debian.org stretch/updates/main amd64 Packages [212 kB]
Ign http://deb.debian.org stretch InRelease                                    
Réception de : 3 http://security.debian.org stretch/updates/contrib amd64 Packages [1 352 B]
Réception de : 4 http://deb.debian.org stretch-updates InRelease [91,0 kB]    
Réception de : 5 http://security.debian.org stretch/updates/non-free amd64 Packages [1 272 B]
Réception de : 6 http://security.debian.org stretch/updates/contrib Translation-en [1 023 B]
Réception de : 7 http://security.debian.org stretch/updates/main Translation-en [89,4 kB]
Réception de : 8 http://deb.debian.org stretch-backports InRelease [91,8 kB]  
Réception de : 9 http://deb.debian.org stretch Release.gpg [2 479 B]          
Réception de : 10 http://security.debian.org stretch/updates/non-free Translation-en [481 B]
Réception de : 11 http://deb.debian.org stretch-updates/contrib amd64 Packages [32 B]
Réception de : 12 http://deb.debian.org stretch-updates/non-free amd64 Packages [32 B]
Réception de : 13 http://deb.debian.org stretch-updates/contrib Translation-en [14 B]
Réception de : 14 http://deb.debian.org stretch-updates/main Translation-en [3 583 B]
Réception de : 15 http://deb.debian.org stretch-updates/non-free Translation-en [14 B]
Réception de : 16 http://deb.debian.org stretch-backports/contrib Translation-en [3 302 B]
Réception de : 17 http://deb.debian.org stretch-backports/main Translation-en [114 kB]
Réception de : 18 http://deb.debian.org stretch-backports/non-free Translation-en [18,9 kB]
Réception de : 19 http://deb.debian.org stretch Release [118 kB]          
Réception de : 20 http://deb.debian.org stretch-updates/main amd64 Packages [5 976 B]
Réception de : 21 http://deb.debian.org stretch-backports/main amd64 Packages [173 kB]
Réception de : 22 http://deb.debian.org stretch-backports/contrib amd64 Packages [4 364 B]
Réception de : 23 http://deb.debian.org stretch-backports/non-free amd64 Packages [12,1 kB]
Réception de : 24 http://deb.debian.org stretch/main amd64 Packages [7 097 kB]
Réception de : 25 http://deb.debian.org stretch/contrib amd64 Packages [50,9 kB]
Réception de : 26 http://deb.debian.org stretch/non-free amd64 Packages [78,0 kB]
Réception de : 27 http://deb.debian.org stretch/contrib Translation-en [45,9 kB]
Réception de : 28 http://deb.debian.org stretch/main Translation-fr [1 894 kB]
Réception de : 29 http://deb.debian.org stretch/main Translation-en [5 395 kB]
Réception de : 30 http://deb.debian.org stretch/non-free Translation-en [79,2 kB]
15,6 Mo réceptionnés en 42s (370 ko/s)                                        
Lecture des listes de paquets... Fait
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch/main amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch/contrib amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch_contrib_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch/non-free amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.debian.org/ stretch/updates/main amd64 Packages (/var/lib/apt/lists/security.debian.org_dists_stretch_updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.debian.org/ stretch/updates/contrib amd64 Packages (/var/lib/apt/lists/security.debian.org_dists_stretch_updates_contrib_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.debian.org/ stretch/updates/non-free amd64 Packages (/var/lib/apt/lists/security.debian.org_dists_stretch_updates_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch-updates/main amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch-updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch-updates/contrib amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch-updates_contrib_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch-updates/non-free amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch-updates_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch-backports/main amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch-backports_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch-backports/contrib amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch-backports_contrib_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.debian.org/debian/ stretch-backports/non-free amd64 Packages (/var/lib/apt/lists/deb.debian.org_debian_dists_stretch-backports_non-free_binary-amd64_Packages)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#42 03-11-2017 00:37:58

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Parfait.
On migre.
Tu éteins d'abord toutes les applications que tu utilises actuellement.
Ensuite :

apt-get dist-upgrade


tu regardes ce qui est éventuellement supprimé, si tu as des doutes, tu les indiques ici.


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#43 03-11-2017 00:41:12

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

bon, rien à supprimer mais:

root@packard:~# apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc-dev-bin : Dépend: libc6 (> 2.24) mais 2.19-18+deb8u9 est installé
 libc6-dev : Dépend: libc6 (= 2.24-11+deb9u1) mais 2.19-18+deb8u9 est installé
 locales : Dépend: libc-bin (> 2.24) mais 2.19-18+deb8u9 est installé
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#44 03-11-2017 00:43:21

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

la commande apt-cache suivante nous dira si la libc6 réclamée est disponible :

apt-cache policy libc6

Dernière modification par smolski (03-11-2017 00:45:40)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#45 03-11-2017 00:46:13

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

et hop

root@packard:~# apt-cache policy libc6
libc6:
  Installé : 2.19-18+deb8u9
  Candidat : 2.24-11+deb9u1
 Table de version :
     2.24-11+deb9u1 0
        500 http://deb.debian.org/debian/ stretch/main amd64 Packages
        500 http://security.debian.org/ stretch/updates/main amd64 Packages
 *** 2.19-18+deb8u9 0
        100 /var/lib/dpkg/status
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
root@packard:~#
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#46 03-11-2017 00:51:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Ok, la version est disp.
On l'installe :

apt-get -t stretch-backports install 2.24-11+deb9u1


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#47 03-11-2017 00:54:35

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

ces manœuvres sont dans les tutos comme ici pour les backports : https://debian-facile.org/doc:systeme:a … -non-libre

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#48 03-11-2017 00:57:04

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

...

root@packard:~# apt-get -t stretch-backports install 2.24-11+deb9u1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Impossible de trouver le paquet 2.24-11+deb9u1
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « 2.24-11+deb9u1 »
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#49 03-11-2017 00:59:47

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

oui merci pour les tutos mais si t'es pas là à chaque étape je suis dans le décor en deux cliques sos.gif

Hors ligne

#50 03-11-2017 01:01:50

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

ah merde c'est libc6 :

apt-get -t stretch-backports install libc6


il se fait tard mon gars, pardon smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums