Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 03-11-2017 01:04:32

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

je t'en prie, c'est clair ça fait un bon moment que t'es sur le coup smile

root@packard:~# apt-get -t stretch-backports install libc6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libc-bin : Dépend: libc6 (< 2.20) mais 2.24-11+deb9u1 devra être installé
 locales : Dépend: libc-bin (> 2.24) mais 2.19-18+deb8u9 devra être installé
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@packard:~#
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#52 03-11-2017 01:07:03

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

apt-cache policy libc6


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#53 03-11-2017 01:08:38

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

...

root@packard:~# apt-cache policy libc6
libc6:
  Installé : 2.19-18+deb8u9
  Candidat : 2.24-11+deb9u1
 Table de version :
     2.24-11+deb9u1 0
        500 http://deb.debian.org/debian/ stretch/main amd64 Packages
        500 http://security.debian.org/ stretch/updates/main amd64 Packages
 *** 2.19-18+deb8u9 0
        100 /var/lib/dpkg/status
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
root@packard:~#
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#54 03-11-2017 01:13:30

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Là je suis collé...
La libc6 est un paquet important, essaie de rebooter et recommence l'installation :

apt -t stretch-backports install libc6


nota : stretch utilise l'outil apt maintenant. wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#55 03-11-2017 01:16:43

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

ok je reboote et j'essaye la manip...

Hors ligne

#56 03-11-2017 01:21:30

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

...bon ça l'air guère mieux non?

dewhite01@packard:~/Bureau$ sudo -i
[sudo] Mot de passe de dewhite01 : 
root@packard:~# apt -t stretch-backports install libc6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libc-bin : Dépend: libc6 (< 2.20) mais 2.24-11+deb9u1 devra être installé
 locales : Dépend: libc-bin (> 2.24) mais 2.19-18+deb8u9 devra être installé
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « videolan.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « dflinux.sav » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@packard:~#


bloc à supprimer si la commande n’affiche rien

Hors ligne

#57 03-11-2017 01:29:29

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Oui, j'ai pris les renseignements, y faut juste supprimer tous les fichiers mis en .sav maintenant :
en root :

cd /etc/apt/


rm *.sav


rm sources.list.d/*.sav


ATTENTION te gourreS pas c'est une manœuvre où il ne faut pas prendre de risque. smile

puis tu vérifies l'upgrade pour voir.

apt upgrade


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#58 03-11-2017 01:36:37

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

ça donne ça:

root@packard:~# cd /etc/apt/
root@packard:/etc/apt# rm *.sav
root@packard:/etc/apt# rm sources.list.d/*.sav
root@packard:/etc/apt# apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc-dev-bin : Dépend: libc6 (> 2.24) mais 2.19-18+deb8u9 est installé
 libc6-dev : Dépend: libc6 (= 2.24-11+deb9u1) mais 2.19-18+deb8u9 est installé
 locales : Dépend: libc-bin (> 2.24) mais 2.19-18+deb8u9 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
root@packard:/etc/apt#
 


bloc à supprimer si la commande n’affiche rien

Hors ligne

#59 03-11-2017 01:42:16

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Ok, c'est vraiment une installation particulière qui a été faite, je baisse les bras pour ce soir, je vois des libc6 qui viennent peut-être de sid ou d'ailleurs, si ça marche, c'est bon et laisse ton post non résolu pour que des citoyens plus qualifiés viennent y mettre la patte.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#60 03-11-2017 01:46:13

Vince99
Membre
Inscription : 23-05-2017

Re : Erreur de mise à jours

Ok, en tout cas merci beaucoup pour ton aide, je crois que t'as fait le max, c'est vraiment cool de ta part.

Bonne nuit...

Hors ligne

#61 03-11-2017 01:51:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Merci à toi aussi, il y a là un beau post pour qui veut le visiter...
Bonne nuit à toi aussi et à demain, pour de nouvelles z'aventures, car ce n'est pas réglé tout ça et peut-être qu'un bout de tuto va en naître dans le wiki au bout du bout smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#62 03-11-2017 01:52:07

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : Erreur de mise à jours

Aptitude ne propose rien ? En général quand ça commence à devenir compliqué, je lui demande gentiment et il trouve ce qui va pas. Ce genre d'erreur ne vient pas dutout de nulle part, libc c'est genre, une brique de base.

Dernière modification par otyugh (03-11-2017 02:09:37)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#63 03-11-2017 08:37:39

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Erreur de mise à jours

Bonjour smile
libc6 n’a pas de candidat dans stretch-backports wink
Essaie avec

apt update


qui met à jour la liste des paquets disponibles mais n’installe rien, ensuite

apt -s install libc6


pour simuler l’installation de ce paquet.

Hors ligne

#64 03-11-2017 08:57:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

chalu a écrit :

libc6 n’a pas de candidat dans stretch-backports


@ chalu : Il semble que si :

apt-cache policy libc6


libc6:
  Installé : 2.19-18+deb8u9
  Candidat : 2.24-11+deb9u1
 Table de version :
     2.24-11+deb9u1 0
        500 http://deb.debian.org/debian/ stretch/main amd64 Packages
        500 http://security.debian.org/ stretch/updates/main amd64 Packages
 *** 2.19-18+deb8u9 0
        100 /var/lib/dpkg/status


Non ? smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#65 03-11-2017 09:56:21

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Erreur de mise à jours

smolski a écrit :

@ chalu : Il semble que si :
apt-cache policy libc6


libc6:
  Installé : 2.19-18+deb8u9
  Candidat : 2.24-11+deb9u1
Table de version :
     2.24-11+deb9u1 0
        500 http://deb.debian.org/debian/ stretch/main amd64 Packages
        500 http://security.debian.org/ stretch/updates/main amd64 Packages
*** 2.19-18+deb8u9 0
        100 /var/lib/dpkg/status


Non ? smile


ben je vois un candidat dans sécurité/stretch/update et un dans stretch/main mais pas dans stretch-backports ?
pour comparer, voici le retour pour libreoffice qui a un candidat dans les backports (la ligne stretch-backports apparait bien)

libreoffice:
  Installé : 1:5.2.7-1
  Candidat : 1:5.2.7-1
 Table de version :
     1:5.4.2-3~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 1:5.2.7-1 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
 

Hors ligne

#66 03-11-2017 09:56:56

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Erreur de mise à jours

Bonjour

non => https://packages.debian.org/fr/stretch/libc6 , pas de backports pour libc6

la version Candidat : 2.24-11+deb9u1 est pour stretch (voir le lien pour les autres versions )

en #64 la version installé est celle de jessie  =>  https://packages.debian.org/fr/jessie/libc6   =>  "Installé : 2.19-18+deb8u9"

Dernière modification par robert2a (03-11-2017 10:00:40)

Hors ligne

#67 03-11-2017 10:06:09

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

il me semble que la version lbc6 est liée au noyau...
Comment mettre la version stretch ? smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#68 03-11-2017 10:14:41

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

Bonjour
Bon l'idée de migré pour résoudre des problèmes de dépendance ce n'est pas la chose a faire
vu le problème de dépendance, Jessie n'est peut être même pas à jour
apt-get -t stretch-backports install libc6
non il n'y a pas de version backports du paquet, la version installé est celle de Jessie, la version candidat est celle disponible dans les sources de stretch
L'idée de supprimé les sauvegardes des sources supplémetaire n'est pas bonne non plus ...on n'a pas consulté ses fichiers pour savoir ce qu'il y avait dedans hmm

edit: il serait interessant de savoir ce que renvoie

lsb_release -ds


Je soupçonne qu'il faudra repasser par les sources.list de Jessie
Ayant eu un problème de dépendance tout récent je peux vous dire que on a vite fait de s'enliser, en fait on s'en sort trés bien mais je dois dire que avant de connaître la manipe j'avais agiter mes grand doigts sur le clavier ba rien n'y faisait

Dernière modification par Croutons (03-11-2017 10:36:02)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#69 03-11-2017 11:18:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Croutons a écrit :

supprimé les sauvegardes des sources supplémetaire n'est pas bonne non plus


Oui, j'ai envoyé l'idée puis je me suis interrogé... Trop tard (et minuit, l'heure du crime avait sonnée...) smile

Je désapprouve le retour à jessie, peut-être ajouter jessie dans les sources pourrait rééquilibrer le système en l'état ?


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#70 03-11-2017 11:36:42

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

ba le retour a Jessie je sais pas c'est pour çà que je demande le retour de lsb_release
Je ne sais pas si les mises a jour ce sont quand même déroulé, j'ai un doute sur le fait que ce problème de dépendance a tout bloqué et que on soit toujours avec une Jessie
D'après le résultat de la commande on avisera savoir quel sources utiliser, migration je suis pas contre mais ce n'est pas le problème
c'est un peu mettre la charrue avant les bœufs
Mais en lisant le poste ce matin je me suis bien amusé on voyait clairement la fatigue venir au fur et a mesure que l'heure avançait tongue

Edit: Donc après résultat de

lsb_release -ds


On saura vraiment ou on en est
Apres il faudra utiliser les bonnes sources , puis faire comme préconisé

apt-get install -f

Dernière modification par Croutons (03-11-2017 11:49:04)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#71 03-11-2017 11:44:03

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Erreur de mise à jours

Croutons a écrit :

le retour de lsb_release


Ah oui, malin ça...
Je pense que nous sommes bien sur stretch, toutefois, peut-être que des installations combinées notamment avec les sources videolan (en général pour lire les dvd) posent problème ?
J'ai pensé aussi à utiliser aptitude-ncurse, mais on peut pas lire le retour pour visionner les paquets éventuellement cassés.
Il y a aptitude pour le faire, je vais regarder le wiki...

Force et courage, hein ! big_smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#72 03-11-2017 12:40:11

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Erreur de mise à jours

smolski a écrit :

il me semble que la version lbc6 est liée au noyau...
Comment mettre la version stretch ? smile



non libc6 est lié a la version de debian pas du noyau
si tu utilise un noyau des backports (de jessie) , tu utilise libc6 de jessie
nota : les paquets des backports sont modifiés pour etre compatible avec la version de libc6 correspondant a la version de debian (8 , 9 , 10 etc .....  )

si tu est en stretch tu a un souci..........  tongue

si tu est en stretch , commencer par commenter les lignes hors dépots debian et voir ce que te propose un apt-get upgrade , apt-get dist-upgrade avec l option -s
utiliser aptitude une bonne idée aussi (il prend aussi l option -s ) bien que moins utile puisque tu peu annuler a tout moment
PS: apt-get -s  va te faire une simulation complète , ça aide et aptitude trouver des solutions si conflit .

nota : commenter  la ligne des backports de stretch aussi , si elle existe

re,
hors sujet pour stretch
il y a un souci sur le dépot de sid en "ftp.fr" et en "deb" , erreur fatale , dépots stretch et buster fonctionnent bien
je sais pas si il faut le signaler .

Dernière modification par robert2a (03-11-2017 12:57:21)

Hors ligne

#73 03-11-2017 12:54:31

fatpat
Membre
Distrib. : Windows 10
Inscription : 30-10-2017

Re : Erreur de mise à jours

Petite question de "noob" Pourquoi repasser en "root"en ligne de commande alors qu'il y a un terminal pour "root" plus facile d'usage (je sais, je suis paresseux c'est pour ça que j'utilise le simple clic!)?

Hors ligne

#74 03-11-2017 12:57:52

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Erreur de mise à jours

nota : commenter  la ligne des backports de stretch aussi , si elle existe


oui a la rigueur si on veut mais ça ne sert a rien les backports on une priorité bien inférieur et ne gêne en rien
Edit:

Petite question de "noob" Pourquoi repasser en "root"en ligne de commande alors qu'il y a un terminal pour "root" plus facile d'usage (je sais, je suis paresseux c'est pour ça que j'utilise le simple clic!)?


Parce que cela compliquerait les choses, vu que le profil n'est pas renseigné et que on connaît pas le bureau utilisé et il existe une floppé de terminale
Après il faudrait expliqué ou aller cherché le terminale root...enfin bref aussi simple de taper sudo -i

Dernière modification par Croutons (03-11-2017 13:02:45)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#75 03-11-2017 13:03:26

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Erreur de mise à jours

Pour sid c'est Debian Alain qui me la signalé ce matin

pour les backports juste pour alléger la mise a jour du cache de apt , un "apt-get clean" et "apt-get autoclean" utile aussi pour nettoyer les fichiers inutiles et partir d un cache propre

Hors ligne

Pied de page des forums