Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-11-2017 15:16:41

zealot
Membre
Distrib. : Debian 9.2.1
(G)UI : xfce
Inscription : 03-11-2017

[resolu] Perte de connection réseau sans raisons apparentes

Bonjour,

Alors, après avoir installée debian 9.2.1 sur un PC appartenant à des amis, tout fonctionnait bien, jusqu’à ce qu'il y'ait une perte de connexion réseau.
En fouillant dans l'applet network manager de xfce, je constate que l'ordi ne récupère pas d'adresse ip via le DHCP de la livebox (la section IPV4 indique la valeur "inconue" sur les lignes -adresse IP, Broadcast, et Masque de sous réseau), sachant qu'il y a un autre ordi sous debian 8 qui lui fonctionne parfaitement en dhcp.

J'ai essayé de fixer une IP statique sur la box et de la configurer sur le PC via la commande

ip addr add 192.168.1.24/24 dev enp0s4



A partir de là, l'applet network Manager affichait bien une ip, une adresse broadcast et un masque de sous réseau, mais toujours impossible de pinger la livebox ou quoi que ce soit d'autre, ni même d’apparaître dans l'interface de la box.



Je suis désolé pour ce post peut être un peu leger comme diag de départ, mais je suis relativement novice.

Merci par avance...

Dernière modification par zealot (07-11-2017 15:19:12)

Hors ligne

#2 03-11-2017 15:36:29

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

Bonjour
poster ton fichier interfaces


cat /etc/network/interfaces
 


nota : qui ne doit pas etre renseigné (a priori tu utilise network-manager)
tenter une configuration par ce fichier en dhcp ou en ip fixe (peut etre network-manager qui te fait des misères sur stretch hmm

un exemple de fichier interfaces (en dhcp)


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp5s0
iface enp5s0 inet dhcp
 


ps : remplacé enp5so  par le bon nom de ta carte

Dernière modification par robert2a (03-11-2017 15:38:44)

Hors ligne

#3 03-11-2017 16:11:29

zealot
Membre
Distrib. : Debian 9.2.1
(G)UI : xfce
Inscription : 03-11-2017

Re : [resolu] Perte de connection réseau sans raisons apparentes

Bonjour et merci,

Alors la commande

cat /etc/network/interfaces


retourne, comme tu l'avais prévu, pas grand chose


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback



J'ai donc modifié le fichier interfaces via "nano" en root, en rajoutant:

# The primary network interface
allow-hotplug enp0s4
iface enp0s4 inet dhcp

, puis redémarré, et là, lorsque je vais voir dans les informations de connexion via l'applet, ça m'indique:

Erreur lors de l'affichage des informations de connexion
Aucune connexion valide trouvée!



A partir de là je tente:

ip -o -4 addr show


qui me renvoie juste

1: lo    inet 127.0.0.1/8 scope host lo



Suite à ça je teste par hasard de remplacer "enp0s4" par "eth0" dans le fichier interfaces, et après un redémarrage, j'ai de nouveau accès à l'affichage des informations de connexion via l'applet, qui indique toujours "inconnu" sur toutes les lignes de la section IPV4.

Je fais de la bidouille là, mais si ça peut donner une piste?

Dernière modification par zealot (03-11-2017 17:11:08)

Hors ligne

#4 03-11-2017 18:10:36

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

il te faut trouver le nom de la carte
avec ifconfig -a  (ou l équivalent sous stretch avec IP que je n utilise pas et que je connais pas)
ou sinon chercher dans /var/log/syslog le nom de la carte réseau utilisé
ce que donne chez moi ifconfig -a


ifconfig -a
 


retour


enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.10.45  netmask 255.255.255.0  broadcast 192.168.10.51
        inet6 fe80::127b:44ff:fe92:137d  prefixlen 64  scopeid 0x20<link>
        ether 10:7b:44:92:13:7d  txqueuelen 1000  (Ethernet)
        RX packets 43719  bytes 36220761 (34.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 44949  bytes 44988353 (42.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xef600000-ef61ffff  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 14669  bytes 8405294 (8.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 14669  bytes 8405294 (8.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 



ma carte se nomme => enp5s0

le paquet a installer net-tools pour "ifconfig -a" sinon attendre un membre qui te donne la commande avec IP pour avoir le nom de la carte réseau ou chercher le wiki réseau sur le forum

nota : pour info en plus que stretch renomme la carte , en plus si ces ressources changes par exemple tu la déplace d un connecteur pci (ou pcie ) la carte va porté un autre nom
idem pour les ressources du pc avec ou sans carte vidéo sur pcie la carte réseau change de nom (dans le cas par exemple d une carte nvidia pcie que tu remplace par le gpu du processeur)
personnellement je préfère la méthode de jessie en ethx

si tu renseigne le fichier interfaces , network-manager est désactivé (pas de renseignement sur la carte réseau ) ,  comme test un ping de la box par exemple.
moi je ne supporte pas la commande IP (et je maitrise pas )  tongue

ceci peu peut etre t' aider  =>  https://debian-facile.org/doc:reseau:interfaces

Dernière modification par robert2a (03-11-2017 18:30:22)

Hors ligne

#5 03-11-2017 19:05:32

zealot
Membre
Distrib. : Debian 9.2.1
(G)UI : xfce
Inscription : 03-11-2017

Re : [resolu] Perte de connection réseau sans raisons apparentes

Re!

Bon eh bien, j'ai un peu tout essayé.
Pour info la commande est:

ip link


Et la carte est bien nommée enp0s4.

Ce que j'ai fait, en suivant le lien que tu m'as donné, j'ai supprimé l'applet network-manager via apt-get remove, j'ai desactivé le service réseau, édité le fichier interfaces, sauvegardé, relancé le service réseau, activé la connexion enp0s4 via la commande IP, bref, tout dans les règles de l'art, mais rien de nouveau, toujours pas d'attribution d'ip.

Je commence à me demander si la carte n'a pas un problème materiel où si la livebox bugue.

Je décroche pour aujourd'hui, mais je ferais une réinstall complete de debian dimanche, et je viendrais faire un retour.

Merci pour ton aide en tout cas, et à bientôt!

Hors ligne

#6 03-11-2017 19:59:40

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [resolu] Perte de connection réseau sans raisons apparentes

Bonjour

Je commence à me demander si la carte n'a pas un problème materiel où si la livebox bugue.


Essai de redémarrer la Livebox, le DHCP a régulièrement des problèmes sur la mienne, la Box te connait sur le réseau elle distribue bien une adresse IP , mais du coté du périphérique il y a un message comme quoi tu es connecté mais sans connexion internet
reboot de la box et après tout fonctionne
Et ceci aussi bien avec windows 8.1 que avec android, pour être  tranquille sous Stretch j'ai réservé une adresse ip fixe hors plage dans l'interface de la livebox


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 03-11-2017 20:10:50

zealot
Membre
Distrib. : Debian 9.2.1
(G)UI : xfce
Inscription : 03-11-2017

Re : [resolu] Perte de connection réseau sans raisons apparentes

Salut,

J'ai déjà redémarré la box, j'ai tenté aussi de la réinitialiser, mais sans succès.
Ensuite, là je viens de configurer le fichier interface en y mettant une ip statique, puis en attribuant la même sur la box, pas mieux...

Quand tu dis hors plage, c'est une ip au delà de 192.168.1.50?

Hors ligne

#8 03-11-2017 21:44:45

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [resolu] Perte de connection réseau sans raisons apparentes

ah oui j'ai mis carrément en dehors, 192.168.1.201, mais j'ai rien configuré sur Debian , je suis avec networkmanager
mais mon adresse MAC est enregistré avec l'adresse IP sur la livebox
Mais si cela améliore rien c'est que la vérité est ailleur
Tu es sur le bon wifi? fais pas comme mon fréro qui a réussi a ce connecter sur le wifi public tongue

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 04-11-2017 08:17:12

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

Bonjour
en général une réservation d IP par dhcp ce fait dans la plage du dhcp , ce qui semble logique , le dhcp donnera toujours la meme IP a cette machine (reconnu par son mac adresse)
la carte réseau reste en dhcp
mais bon je connais pas toutes les box , et j'utilise plutot des modem routeurs (pas de box )

coté carte réseau configuré une IP fixe , et une passerelle (ta box) et un DNS  (IP en dehors de la plage du dhcp )

les voyants de la carte réseau donne une activité ?

nota : c'est du filaire ou du wifi ?   roll

Hors ligne

#10 04-11-2017 14:58:29

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

zealot a écrit :

impossible de pinger la livebox ou quoi que ce soit d'autre


Mais encore ? Commandes, réponses ?

Hors ligne

#11 04-11-2017 14:58:59

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

robert2a a écrit :

c'est du filaire ou du wifi ?


en* = ethernet.

Hors ligne

#12 04-11-2017 21:15:45

zealot
Membre
Distrib. : Debian 9.2.1
(G)UI : xfce
Inscription : 03-11-2017

Re : [resolu] Perte de connection réseau sans raisons apparentes

Bonsoir

raleur a écrit :

zealot a écrit :

impossible de pinger la livebox ou quoi que ce soit d'autre


Mais encore ? Commandes, réponses ?



J'avais tenté de faire les commandes:

ping 192.168.1.1


puis

ping 8.8.8.8


Et dans les deux cas, il m'étais retourné quelque chose comme "host unreachable", tous les paquets perdus etc... (je n'ai pas accès à l'ordi aujourd'hui, j'y retourne demain).

La commande

ip link


retournait bien que la carte était reconnue et UP.

Le plus étrange dans tout ça, est qu'à la base, tout fonctionnait bien, jusqu'à la perte de connexion sur le PC en question, et depuis, plus moyen de se voir attribuer une adresse en dhcp, et plus moyen non plus de voir le PC via l'interface livebox, y compris en fixant une IP statique des deux cotés.
L'ami utilisateur du pc m'assure n'avoir rien fait d'autre que d'utiliser thunar, firefox et vlc depuis l'installation que je lui ais faite il y a une semaine, jusqu'au plantage de sa connexion.

Sachant qu'un autre PC sous debian 8 ne pose aucun problèmes.
A voir demain, je tenterais une réinstallation complète, et je tiens au jus!

Merci

Hors ligne

#13 05-11-2017 10:44:27

raleur
Membre
Inscription : 03-10-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

zealot a écrit :

il m'étais retourné quelque chose comme "host unreachable"


"Quelque chose comme", c'est insuffisant. Il faut le message exact, car "host unreachable" n'est pas la même chose que "network unreachable" ou d'autres messags similaires.

Je ne pense pas que réinstaller soit utile. Tu peux essayer de démarrer un système live pour voir si c'est pareil.
Par contre il faut en savoir plus pour caractériser le problème.
- configurer une adresse IP fixe et tester la communication entre les adresses IP des deux PC du réseau avec ping
- examiner la sortie de "ip -s link" contenant les statistiques ethernet
- examiner les messages du noyau liés au réseau avec dmesg
- faire une capture de trafic avec tcpdump s'il est possible de l'installer

Tu es sûr que la livebox a l'adresse 192.168.1.1 ?

Hors ligne

#14 05-11-2017 11:15:14

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [resolu] Perte de connection réseau sans raisons apparentes

proposition peut être bête, mais as tu testé en changeant le câble ?
si tu pense à un problème matériel, as tu vérifié l'état des voyants rj45 du pc et de la box quand le câble est branché ?

Dernière modification par Severian (05-11-2017 11:15:36)

Hors ligne

#15 07-11-2017 15:18:40

zealot
Membre
Distrib. : Debian 9.2.1
(G)UI : xfce
Inscription : 03-11-2017

Re : [resolu] Perte de connection réseau sans raisons apparentes

Bonjour,

Eh  bien c'est résolu mais la panne reste floue:
En lançant un système live, la connexion fonctionnait, j'ai donc redémarré sur le système du PC, réinstallé l'applet network-manager, néttoyé le fichier interfaces, et tout est rentré dans l'ordre.

Merci pour tout!

Hors ligne

Pied de page des forums