Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-11-2017 18:18:00

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

[Resolu]Problème avec apt-get

Salut ,

quand j'essaie de faire apt-get install (avec un logiciel après) , ça me retourne

apt-get install simplescreenrecorder


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Le paquet virtualbox-5.2 doit être réinstallé, mais il est impossible de trouver son archive.
 



je sais pas pourquoi ca fait ça (j'ai installé virtualbox via le paquet .deb avec

dpkg -i virtualbox-5.2.deb


tout avait marché , virtualbox aussi , j'ai redémarré et ... mon problème

Merci d'avance!

Caerroff big_smile

Dernière modification par Caerroff (12-11-2017 23:08:21)

Hors ligne

#2 07-11-2017 19:27:27

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Resolu]Problème avec apt-get

Bonsoir smile
Et tu n'as pas essayé de réinstaller le paquet ?

Hors ligne

#3 07-11-2017 21:20:29

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Resolu]Problème avec apt-get

donne nous le contenu de ton fichier sources.list:

cat /etc/apt/sources.list



Virtualbox est dispo dans la section contrib des dépôts backports pour stretch. mieux vaut éviter d'installer un paquet .deb comme ça.
Virtualbox propose également le paquet dans ses propres dépôts.
https://wiki.debian.org/VirtualBox#Debi … Stretch.22

En ligne

#4 07-11-2017 23:31:15

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

chalu a écrit :

Bonsoir smile
Et tu n'as pas essayé de réinstaller le paquet ?



si en commancant par faire

apt-get purge virtualbox-5.2


ça m'a renvoyer la même chose que tout à l'heure



virtualbox marche sans souci , avant redémarrage de la machine , il y avait pas d'erreur

Hors ligne

#5 07-11-2017 23:32:08

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

nIQnutn a écrit :

donne nous le contenu de ton fichier sources.list:

cat /etc/apt/sources.list



Virtualbox est dispo dans la section contrib des dépôts backports pour stretch. mieux vaut éviter d'installer un paquet .deb comme ça.
Virtualbox propose également le paquet dans ses propres dépôts.
https://wiki.debian.org/VirtualBox#Debi … Stretch.22



cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 NETINST 20171013-13:07]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 NETINST 20171013-13:07]/ stretch main

deb http://ftp.fr.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
 

Hors ligne

#6 08-11-2017 01:08:03

lebardix
Adhérent(e)
Lieu : Plan de Cuques
Distrib. : Version 9.2 (Stretch) 64 bits
Noyau : Linux 4.9.0-3-amd64
(G)UI : MATE Desktop Environment 1.16.2
Inscription : 15-10-2013

Re : [Resolu]Problème avec apt-get

#

aptitude search simplescreenrecorder


i   simplescreenrecorder                                    - Feature-rich screen recorder for X11 and OpenGL                  
p   simplescreenrecorder:i386                               - Feature-rich screen recorder for X11 and OpenGL



#

aptitude show simplescreenrecorder


Paquet : simplescreenrecorder                          
Version : 0.3.8-2
État: installé
Automatiquement installé: non
Priorité : optionnel
Section : video
Responsable : Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 3 165 k
Dépend: libasound2 (>= 1.0.16), libavcodec57 (>= 7:3.2.2) | libavcodec-extra57 (>= 7:3.2.2), libavformat57 (>= 7:3.2.2),
        libavutil55 (>= 7:3.2.2), libc6 (>= 2.14), libgcc1 (>= 1:3.0), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1,
        libjack-jackd2-0 (>= 1.9.10+20150825) | libjack-0.125, libpulse0 (>= 0.99.1), libqtcore4 (>= 4:4.8.0), libqtgui4 (>=
        4:4.6.1), libstdc++6 (>= 6), libswscale4 (>= 7:3.2.2), libx11-6 (>= 2:1.2.99.901), libxext6, libxfixes3, libxi6 (>=
        2:1.2.99.4)
.....



Je ne vois pas le rapport avec virtualbox .... scratchhead.gif

aptitude install simplescreenrecorder


devrait suffire


Edit à toto :

Mis les commandes en balise Commande séparées de leur retour

Hors ligne

#7 08-11-2017 02:23:11

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Resolu]Problème avec apt-get

ajoute le dépot backports: https://debian-facile.org/doc:systeme:a … -backports

ensuite tu pourras installer virtualbox sans trop de problème:

apt install virtualbox

En ligne

#8 08-11-2017 07:19:46

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Resolu]Problème avec apt-get

Oui tu désinstalle ta version de virtualbox puis tu ajoutes les dépôts stretch-backports pour installer

Hors ligne

#9 08-11-2017 08:21:31

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

Je vais essayer tout ca

Hors ligne

#10 09-11-2017 22:22:51

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

chalu a écrit :

Oui tu désinstalle ta version de virtualbox puis tu ajoutes les dépôts stretch-backports pour installer



Ouais .. mais vu que j'ai plus accès à mon apt-get , je peux pas le désinstaller!

Hors ligne

#11 09-11-2017 22:27:19

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

même après ajout de backports et après apt-get update , ça me renvoi la meme erreur..

Hors ligne

#12 10-11-2017 09:01:01

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Resolu]Problème avec apt-get

Que donne le retour de

apt purge virtualbox*

Hors ligne

#13 10-11-2017 10:54:07

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Resolu]Problème avec apt-get

Bonjour
si apt ou apt-get ne fonctionne plus , peut etre voir avec aptitude (et l option -s pour simuler (pour apt ou apt-get )).

voir #10 et #11 (apt ne fonctionne plus)

Hors ligne

#14 10-11-2017 11:51:29

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Resolu]Problème avec apt-get

robert2a a écrit :

Bonjour
si apt ou apt-get ne fonctionne plus , peut etre voir avec aptitude (et l option -s pour simuler (pour apt ou apt-get )).

voir #10 et #11 (apt ne fonctionne plus)


sauf qu'aptitude n'est plus installé par défaut et donc si ça n'a pas été installé avant, on ne doit pas pouvoir le faire dans ce cas où apt/apt-get est bloqué non ?

Hors ligne

#15 10-11-2017 15:42:28

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Resolu]Problème avec apt-get

chalu a écrit :

on ne doit pas pouvoir le faire dans ce cas où apt/apt-get est bloqué non ?


il est toujours possible d'installer des paquet même si apt ou autres ne fonctionnent plus
il suffit de télécharger l'archive .deb et d'installer avec dpkg
tu peux même réinstaller dpkg si tu as endommagé celui-ci
un lien qui peut t'aider Chalu
https://debian-handbook.info/browse/fr- … -structure


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#16 10-11-2017 16:07:23

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Resolu]Problème avec apt-get

ah oui effectivement je n'avais pas pensé à la possibilité de télécharger et installer roll

Hors ligne

#17 10-11-2017 17:27:16

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Resolu]Problème avec apt-get

tient au fait que donne la commande

apt-get install -f

Dernière modification par Severian (10-11-2017 17:27:33)


"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#18 12-11-2017 21:55:07

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

chalu a écrit :

Que donne le retour de

apt purge virtualbox*



ça donne :

root@Caerroff-PCDEBIAN:/home/caerroff# apt purge virtualbox
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Le paquet virtualbox-5.2 doit être réinstallé, mais il est impossible de trouver son archive.
 



pareil pour

apt-get install -f

Dernière modification par Caerroff (12-11-2017 21:55:55)

Hors ligne

#19 12-11-2017 22:05:43

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

Après réinstallation de virtualbox avec

dpkg -i virtualbox-5.2.deb


et

apt-get purge virtualbox-5.2



ça me renvoi

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 brackets : Dépend: libpango1.0-0 (>= 1.22.0) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



en faisant

apt --fix-broken install


ça m'installe 338ko et après

apt-get install simplescreenrecorder


TOUT REMARCHE !!

Merci à tous pour vos idées !

Caerroff , Toujours aussi heureux de son debian et de D-F.org big_smile

Hors ligne

#20 12-11-2017 22:30:33

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Resolu]Problème avec apt-get

/me se penche vers un point choco df à la clé :
\o/
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#21 12-11-2017 23:07:44

Caerroff
Membre
Lieu : /home
Distrib. : Debian 9
(G)UI : KDE/Gnome3
Inscription : 13-08-2017

Re : [Resolu]Problème avec apt-get

Et mince ... oublie de le mettre !!

Hors ligne

#22 12-11-2017 23:09:55

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Resolu]Problème avec apt-get

tongue

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums