Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-11-2017 21:50:59

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

[Résolu] Brackets

Bonjour

Est-il imaginable d'installer Brackets sur Debian Strech ? et si oui comment ?
Où est-ce qu'il y à une bonne alternative ?

Merci d'avance

Jean-Luc

Dernière modification par robertjl (12-11-2017 13:33:13)

Hors ligne

#2 07-11-2017 22:02:29

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Brackets

c'est quoi Brackets ?
tu peux nous donner un lien vers le site du projet smile

Hors ligne

#3 07-11-2017 22:07:00

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

Re : [Résolu] Brackets

C'est un éditeur de texte pour le web

http://brackets.io/

Mais je ne suis pas sur qu'il soit vraiment libre

Jean-Luc

Hors ligne

#4 07-11-2017 22:19:03

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Brackets

https://github.com/adobe/brackets/releases

tu récupères le paquet: https://github.com/adobe/brackets/relea … 64-bit.deb
et ensuite:

apt install -s Brackets.Release.1.11.64-bit.deb


tu enlèves "-s" si la simulation ne te donnes pas d'erreurs

Hors ligne

#5 08-11-2017 11:29:56

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

Bonjour
apt install c'est pour installer depuis un dépot présent dans les sources n'est il pas?
Paquet a installer avec dpkg
Perso je préfere utiliser GDebi qui gere bien les dépendances
https://debian-facile.org/doc:systeme:apt:dpkg
https://dflinux.frama.io/lescahiersdude … ternes-deb

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 08-11-2017 11:31:54

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Brackets

Croutons a écrit :

Bonjour
apt install c'est pour installer depuis un dépot présent dans les sources n'est il pas?
Paquet a installer avec dpkg
Perso je préfere utiliser GDebi qui gere bien les dépendances
https://debian-facile.org/doc:systeme:apt:dpkg
https://dflinux.frama.io/lescahiersdude … ternes-deb



fais le test et dis moi s'il y a un problème de dépendances big_smile

Hors ligne

#7 08-11-2017 15:54:59

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Brackets

Ah oui apt install peut fonctionner pour installer un paquet en local et chercher les dépendances ?
C’est super ça smile

Hors ligne

#8 08-11-2017 17:05:22

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : [Résolu] Brackets

si il n'y as pas de soucis
place toi dans le ton dossier de téléchargement

cd /home/telechargements


(par exemple)

puis tu l'installes de la manière suivante :

dpkg --install Brackets.Release.1.11.64-bit.deb



(sauf si quelqu'un voit quelquechose de mieux a rajouter)
et ça marche ...Normalement


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#9 08-11-2017 17:06:22

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

ba je vois pas comment alors merci de développer
Edit: @Herbert west...oui la méthode classique en somme
en mettant le bon chemin ça le fait mieux wink  (en respectant la casse)

Dernière modification par Croutons (08-11-2017 17:09:52)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 08-11-2017 17:40:28

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Brackets

c'est trop beau apt lol
Je viens de tester sur virtualbox (une stretch+xfce)

test@debian:~/Téléchargements$ sudo apt install Brackets.Release.1.11.64-bit.deb


[sudo] Mot de passe de test : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet Brackets.Release.1.11.64-bit.deb
E: Couldn't find any package by glob 'Brackets.Release.1.11.64-bit.deb'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « Brackets.Release.1.11.64-bit.deb »


Mais en précisant le chemin du paquet dans la commande, ça marche woohoo.gif

test@debian:~/Téléchargements$ sudo apt install ~/Téléchargements/Brackets.Release.1.11.64-bit.deb



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « brackets » au lieu de « /home/test/Téléchargements/Brackets.Release.1.11.64-bit.deb »
The following additional packages will be installed:
  libcurl3 libpango1.0-0 libpangox-1.0-0
Les NOUVEAUX paquets suivants seront installés :
  brackets libcurl3 libpango1.0-0 libpangox-1.0-0
0 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 510 ko/62,7 Mo dans les archives.
Après cette opération, 280 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 libpangox-1.0-0 amd64 0.0.2-5+b2 [42,3 kB]
Réception de:2 http://security.debian.org/debian-security stretch/updates/main amd64 libcurl3 amd64 7.52.1-5+deb9u2 [291 kB]
Réception de:3 http://ftp.fr.debian.org/debian stretch/main amd64 libpango1.0-0 amd64 1.40.5-1 [177 kB]
Réception de:4 /home/test/Téléchargements/Brackets.Release.1.11.64-bit.deb brackets amd64 1.11.0-17524 [62,1 MB]
510 ko réceptionnés en 1s (337 ko/s)
Sélection du paquet libpangox-1.0-0:amd64 précédemment désélectionné.
(Lecture de la base de données... 100947 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libpangox-1.0-0_0.0.2-5+b2_amd64.deb ...
Dépaquetage de libpangox-1.0-0:amd64 (0.0.2-5+b2) ...
Sélection du paquet libpango1.0-0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libpango1.0-0_1.40.5-1_amd64.deb ...
Dépaquetage de libpango1.0-0:amd64 (1.40.5-1) ...
Sélection du paquet libcurl3:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libcurl3_7.52.1-5+deb9u2_amd64.deb ...
Dépaquetage de libcurl3:amd64 (7.52.1-5+deb9u2) ...
Sélection du paquet brackets précédemment désélectionné.
Préparation du dépaquetage de .../Brackets.Release.1.11.64-bit.deb ...
Dépaquetage de brackets (1.11.0-17524) ...
Paramétrage de libcurl3:amd64 (7.52.1-5+deb9u2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Paramétrage de libpangox-1.0-0:amd64 (0.0.2-5+b2) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Paramétrage de libpango1.0-0:amd64 (1.40.5-1) ...
Paramétrage de brackets (1.11.0-17524) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
test@debian:~/Téléchargements$


la commande apt install gère donc les dépendances pour l'installation d'un paquet en local et il faut bien préciser le chemin du paquet
yes.gif cette découverte

Edit : le site de Brackets http://brackets.io/ se comporte comme celui d'Opera dans un autre fil, il m'a proposé le téléchargement du paquet .deb pour amd64 directement en cliquant sur le bouton de téléchargement, ça doit détecter le système installé sans doute.

Hors ligne

#11 08-11-2017 17:42:57

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : [Résolu] Brackets

Croutons a écrit :

ba je vois pas comment alors merci de développer
Edit: @Herbert west...oui la méthode classique en somme
en mettant le bon chemin ça le fait mieux wink  (en respectant la casse)



désolé je ne sait pas dans quel chemin il l'a téléchargé .->d'ou par exemple
je vois pas comment quoi?que ça marche ?
lapin kompri


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#12 08-11-2017 17:56:50

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Brackets

Croutons a écrit :

ba je vois pas comment alors merci de développer


@Herbert west : ceci s'adressait à nIQnutn qui nous a fait découvrir une possibilité de apt install que l'on ne connaissait pas, voir mon message #10 wink

Hors ligne

#13 08-11-2017 18:00:29

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

Re : [Résolu] Brackets

Salut A tous
Merci de vos réponses, j'ai tenté la dernière solution mais ça ne fonctionne pas.
Voilà ce que cela me donne

jean-luc@PC-Debian:~$ sudo apt install ~/Téléchargements/Brackets.Release.1.11.64-bit.deb
[sudo] Mot de passe de jean-luc : 
jean-luc n'apparaît pas dans le fichier sudoers. Cet événement sera signalé.

Hors ligne

#14 08-11-2017 18:01:34

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

ba mince j'ai du faire une erreur de frappe la simulation a pas fonctionné chez moi
ba sinon oui super

Dernière modification par Croutons (08-11-2017 18:03:31)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#15 08-11-2017 18:06:04

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Brackets

robertjl a écrit :

Salut A tous
Merci de vos réponses, j'ai tenté la dernière solution mais ça ne fonctionne pas.
Voilà ce que cela me donne

jean-luc@PC-Debian:~$ sudo apt install ~/Téléchargements/Brackets.Release.1.11.64-bit.deb
[sudo] Mot de passe de jean-luc : 
jean-luc n'apparaît pas dans le fichier sudoers. Cet événement sera signalé.


Ah oui zut ! emportée par mon enthousiasme j'ai mis ma commande avec sudo, tu ne dois pas utiliser sudo toi pour passer en root et administrer le système non ?
dans ce cas en supposant que le .deb est bien dans le dossier Téléchargements

apt install /home/identifiant-USER/Téléchargements/Brackets.Release.1.11.64-bit.deb



Croutons a écrit :

ba mince j'ai du faire une erreur de frappe la simulation a pas fonctionné chez moi


Pour moi non plus en ne mettant pas le chemin complet

Hors ligne

#16 08-11-2017 18:09:35

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

Alors oui je comprend mon erreur
Je m'éttais mis directement dans le dossier Téléchargements avec cd et la pour le coup ça fonctionne pas
ce qui est logique quand on y réfléchi

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#17 08-11-2017 18:18:56

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Brackets

Croutons a écrit :

ce qui est logique quand on y réfléchi


non j'ai fait la même erreur et avec dpkg -i se placer dans le dossier suffit me semble-t-il ?
J'espère que je n'ai pas dit de bêtise avec la commande root en mettant le chemin contrairement à la commande de nIQnutn qui ne le mettait pas
je n'ai pas de machine avec un compte root pour voir si le comportement est différent (mais d'un autre côté, je ne vois pas pourquoi il le serait)

Hors ligne

#18 08-11-2017 18:32:27

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

oui vu que apt install va chercher dans les sources , qu'est qu'il en sait le terminale que j'utilise la commande cd pour me placer dans un répertoire pour installer un paquet...il est pas devin le bougre lol

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#19 09-11-2017 18:11:47

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

Re : [Résolu] Brackets

salut

Alors je pense avoir tout tenté, mais je n'y arrive pas.
Est-t-il possible qu'un logiciel qui n'est pas dans les dépôts officiels de Debian ne puisse s'installer ?

Merci

Jean-Luc

Hors ligne

#20 09-11-2017 18:39:19

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

salut

Alors je pense avoir tout tenté, mais je n'y arrive pas


c'est un peu vague pour apporter une aide

Le chemin du fichier dans le message #15 de Chalu n'est pas bon
En supposant que le paquet .deb est Téléchargé dans le répertoire par defaut, une fois coriigé cela donne

apt install /home/identifiantUSER/Téléchargements/Brackets.Release.1.11.64-bit.deb



commande a passer en root cela veux dire, que tu dois être sous ton compte root
Pour passer en root

su

Dernière modification par Croutons (12-11-2017 13:12:35)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#21 09-11-2017 19:16:43

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

Re : [Résolu] Brackets

Merci pour ta réponse

J'ai tenté comme tu me l'a indiqué, et je reçoit le message ci-dessous, a mon avis, le paquet n'est pas supporté

ean-luc@PC-Debian:~$ su
Mot de passe :
root@PC-Debian:/home/jean-luc# apt install /home/$USER/Téléchargements/Brackets.Release.1.11.64-bit.deb
Lecture des listes de paquets... Fait
E: Unsupported file /home/root/Téléchargements/Brackets.Release.1.11.64-bit.deb given on commandline

Hors ligne

#22 09-11-2017 19:32:37

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Brackets

Croutons a écrit :

Le chemin du fichier dans le message #15 de Chalu n'est pas bon


C’est corrigé merci smile je n’avais pensé qu’à la correction du wiki !

A robertj tu écris ton nom d’utilsateur c’est à dire le nom du dossier dans le dossier home à la place de $USER

Hors ligne

#23 09-11-2017 19:34:27

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

arf quel idiot je fais
oui la variable $USER renvoi root forcement , des que tu valides su
Du coup refais avec ton nom d'utilisateur

apt install /home/jean-luc/Téléchargements/Brackets.Release.1.11.64-bit.deb


çà m'apprendra a vouloir faire le malin jte jure ops.gif

Edit: comme ça on voit de suite que ma proposition pour le wiki était pas bonne
dsl Chalu le message #15 est de nouveau pas bon par ma faute

/me <---Smiley20.gif

Dernière modification par Croutons (09-11-2017 19:38:15)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#24 09-11-2017 20:18:01

robertjl
Membre
Lieu : La Chaux-de-Fonds (Suisse)
Distrib. : Portable = Stretch / Tour = Stretch
Noyau : 4.9.0-3-amd64
(G)UI : Portable Cinnamon 3.2.7 / Tour Gnome
Inscription : 26-06-2017

Re : [Résolu] Brackets

J'ai éssayé

Mais il y à des dépendances non satisfaite.

Après il me propose d'essayer apt --fix-broken, ce que j'ai fais.
Le problème est que je n'ai pas tout compris vu mon niveau bas de connaissance GNU/Linux

jean-luc@PC-Debian:~$ su
Mot de passe :
root@PC-Debian:/home/jean-luc# apt install /home/jean-luc/Téléchargements/Brackets.Release.1.11.64-bit.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
brackets : Dépend: libpango1.0-0 (>= 1.22.0) mais il n'est pas installé
            Dépend: libcurl3 mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
root@PC-Debian:/home/jean-luc# apt --fix-broken install 
E: Command line option --fix-broken is not understood in combination with the other options
root@PC-Debian:/home/jean-luc# apt install libpangol
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libpangol
root@PC-Debian:/home/jean-luc#

Hors ligne

#25 09-11-2017 20:44:09

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Brackets

Que renvoi

apt-cache policy libcurl3 libpango-1.0-0


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums