Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-11-2017 12:52:23

alexis998
Membre
Inscription : 09-11-2017

Installation driver AMD APU A4 4000 handylinux

bonjour


je suis en train de monter un pc pour mon grand pére mais j'ai un soucis concernant l'installation des drivers graphique.

j'ai ce message lorsque j'execute le driver téléchargé sur le site d'AMD :

https://image.noelshack.com/fichiers/20 … -35-30.png

du coup j'ai installer fglr driver mais toujours le même message sad

voici ce que j'ai dans le log :

Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.16.0-4-amd64/build/include/generated/uapi/linux/version.h cannot be found on this system.
fglrx installation requires that the system has gcc tool. gcc cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.


merci de votre aide

Dernière modification par alexis998 (09-11-2017 12:54:49)

Hors ligne

#2 09-11-2017 13:00:28

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Installation driver AMD APU A4 4000 handylinux

Bonjour

j'ai ce message lorsque j'execute le driver téléchargé sur le site d'AMD :


A savoir quel driver ? on pourrait avoir le lien siou plait
Surtout que surement pas besoin d'installer des drivers depuis un site extérieur


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 09-11-2017 13:03:57

alexis998
Membre
Inscription : 09-11-2017

Re : Installation driver AMD APU A4 4000 handylinux

Hors ligne

#4 09-11-2017 13:10:06

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : Installation driver AMD APU A4 4000 handylinux

Bonjour et bienvenue ! smile
A tous les coups, tu n'as même pas besoin d'ajouter de driver, oui ! Tu constates des lenteurs sans ce driver ?
Tu peux nous donner le modèle de carte graphique en nous donnant le retour de cette commande :

lspci

Hors ligne

#5 09-11-2017 13:14:18

alexis998
Membre
Inscription : 09-11-2017

Re : Installation driver AMD APU A4 4000 handylinux

bonjour et merci

je le trouve pas forcément lent à part en lecture vidéo ou sa saccade mais après ce n'est qu'une apu donc je sais pas trop si c'est normal.


voici le retour de lspci :

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7480D]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Port
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 16)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 5
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)

Hors ligne

#6 09-11-2017 14:37:04

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : Installation driver AMD APU A4 4000 handylinux

A ta place, j'aurais laissé le pilote libre s'il marche bien. C'est un vieux PC ?
Tu peux nous donner éventuellement des infos sur le CPU et la RAM avec ces retours :

cat /proc/cpuinfo


free -m

Hors ligne

#7 09-11-2017 14:49:07

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Installation driver AMD APU A4 4000 handylinux

Bonjour smile
Si c’est un PC monté avec du matériel assez récent, j’installerais plutôt DFlinux basée sur Stretch ou même Debian stretch avec le bureau Gnome ou Mate avec les dépôts contrib et non-free : https://debian-facile.org/doc:install:i … non-libres
Handylinux est basée sur Jessie avec un noyau et des logiciels dans une version ancienne, elle va se périmer plus vite

Hors ligne

#8 09-11-2017 15:13:53

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : Installation driver AMD APU A4 4000 handylinux

@Chalu : Tout à fait, mais l'installation étant apparemment pour un sénior, Handy Linux est sans doute préférée smile (Et la migrer de Jessie vers Stretch n'est pas impossible.)

Hors ligne

#9 09-11-2017 15:28:12

alexis998
Membre
Inscription : 09-11-2017

Re : Installation driver AMD APU A4 4000 handylinux

bon... je viens de faire mes test sous Lubuntu et tout fonctionne correctement. Pas  de freeze,de clipping.

concernant la config : APU AMD A4 4000, 4go de ram, DD 500go.

J'ai déjà tester DFLINUX et j'ai été confronter a un bug du menu démarrage qui s'ouvre une fois sur dix ( au vu de mon amateurisme sur linux j'ai pas chercher plus loin )

Je me tâte a rester sur lubuntu, y'aurait un moyen d'ajouter le handymenu dans lubuntu ?

Hors ligne

#10 09-11-2017 16:36:37

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Installation driver AMD APU A4 4000 handylinux

Caribou22 a écrit :

@Chalu : Tout à fait, mais l'installation étant apparemment pour un sénior, Handy Linux est sans doute préférée smile (Et la migrer de Jessie vers Stretch n'est pas impossible.)

j’avoue ne pas comprendre pourquoi en terme d’utilisation mais c’est un autre sujet wink

Hors ligne

#11 09-11-2017 17:15:13

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : Installation driver AMD APU A4 4000 handylinux

alexis998 a écrit :

J'ai déjà tester DFLINUX et j'ai été confronter a un bug du menu démarrage qui s'ouvre une fois sur dix ( au vu de mon amateurisme sur linux j'ai pas chercher plus loin )



Si tu veux parler du Handy Menu c'est un bug résolu ou en cours de résolution. Une fois les mises à jour faites, tout rentre dans l'ordre.
Je te suggère d'installer DFlinux, le mettre à jour et nous faire un retour ici si ça ne marche pas smile https://debian-facile.org/viewtopic.php … 14#p243114

Sinon pour Lubuntu, on peut en théorie installer le Handy Menu mais c'est expérimental donc sans garantie.

@Chalu : simplement le thème et les grosses polices par défaut je dirais wink

Dernière modification par Caribou22 (09-11-2017 17:18:15)

Hors ligne

#12 09-11-2017 21:46:26

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS / Salix
Noyau : 4.13.14 & 4.9.59 / 4.4.88
(G)UI : Plasma 5.11.3 / XFCE 4.12.3
Inscription : 05-03-2014

Re : Installation driver AMD APU A4 4000 handylinux

Salut,

De plus, il me semble que le pilote proprio fglrx (ou catalyst) n'est plus supporté sous un Xorg récent.
Maintenant c'est "radeon" ou "amdgpu".

Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 2 Go ddr3. GeForce GT 710.

Hors ligne

#13 10-11-2017 08:56:08

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Installation driver AMD APU A4 4000 handylinux

C’est firmware-amd-graphics sous stretch ?
https://packages.debian.org/stretch/fir … d-graphics
C’est ce que j’ai installé avec aussi le paquet firmware-linux-nonfree

Hors ligne

#14 10-11-2017 10:47:51

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Installation driver AMD APU A4 4000 handylinux

Bonjour
oui c'est le paquet firmware-amd-graphics  a installer
pour le gpu ou apu c'est la meme chose , si la carte est bien reconnu par le firmware
en libre ça doit fonctionner du premier coup après installation du firmware-amd-graphics (pour stretch , se nomme autrement sur jessie).
je suppose que ce sera le paquet xserver-xorg-video-radeon qui sera utilisé mais c'est transparent pour l'utilisateur .
nota : peut etre vérifier si le paquet xserver-xorg-video-amdgpu est installé par défaut sur strech (a linstallation)  mais le gpu (apu) semble ancien ).
ps : plus de driver nonfree dans stretch pour AMD (préférer stretch a jessie , plus récent )

regarder rapidement le retour du log de X et tester mesa permet de savoir si tout va bien (regarder si les DRM sont bien prises en charge par le noyau pour cet APU )

Dernière modification par robert2a (10-11-2017 10:48:45)

Hors ligne

Pied de page des forums