Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-11-2017 12:02:23

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

[Résolu] Stopper l'interface graphique "à la demande"

Hallo la communauté,

J'ai un Desktop sur lequel une Debian Stretch est installée avec Gnome (3.22.2). Sur cette machine, je fais essentiellement tourner des VMs avec un accès via RDP.

Cela représente environ 80 % de l'activité de cette machine.

Je souhaite pouvoir descativer l'interface graphique pour dégager le maximum de RAM. Et pouvoir la relancer à la demande. En gros, switcher entre les 2. Malheureusement je ne trouve pas du tout la ligne de commande adéquat.

Des idées ?

Go10

Dernière modification par Go10 (11-11-2017 17:30:47)


Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#2 11-11-2017 12:35:02

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Stopper l'interface graphique "à la demande"

Bonjour

tourner des VMs avec un accès via RDP.


c'est à dire ?
Je comprend pas trop l'histoire de libérer de la RAM, tu as ta partition Swap qui est la pour ça
Peut être tu peux changer la valeur swappiness, quoi que on aurait plutot tendance a déclencher la swap le plus tard possible avec un disque rapide et la quantité de mémoire que tu as
https://doc.ubuntu-fr.org/swap#optimise … nge_avance


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 11-11-2017 13:20:54

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Bonjour,

Ma machine fait tourner simultanément plusieurs VMs (Linux et Windows) et j'accède aux VMs Windows à distance en RDP.  D'où le besoin de RAM. Mon swapiness est réglé sur 5.

Je n'ai simplement pas besoin de l'interface graphique pour 80% du temps. D'où ma question.

Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#4 11-11-2017 14:03:36

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Stopper l'interface graphique "à la demande"

@Go10

Passer en mode console avant d'ouvrir la session graphique le ferait pas ?
https://debian-facile.org/doc:systeme:console

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 11-11-2017 14:28:44

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Merci Smolski pour la suggestion.

J'arrive bien à switcher de la console à l'interface graphique avec une combinaison de touche type CTRL + alt + F1. Malheureusement, la conso mémoire ne varie pas d'un iota. L'interface graphique semble encore lancée "en tâche de fond".

Dommage qu'on ne puisse plus stopper le service comme avant via un "bête" sudo service ... stop

Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#6 11-11-2017 14:55:33

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Archlinux DFLinux
(G)UI : Gnome-shell XFCE
Inscription : 17-09-2016

Re : [Résolu] Stopper l'interface graphique "à la demande"

Bonjour,
(Dans ce mode, le contrôle de la machine est accessible uniquement via SSH)
http://www.quennec.fr/trucs-astuces/app … ne-console

Hors ligne

#7 11-11-2017 14:58:41

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Bonjour,

Je pense que je me suis mal exprimé. Ma demande ne concerne pas les VMs (qui sont effectivement lancé de cette façon) mais ma machine Hôte sous Debian.

Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#8 11-11-2017 15:03:31

trentanel
Membre
Lieu : Comtat Venaissin
Distrib. : Archlinux DFLinux
(G)UI : Gnome-shell XFCE
Inscription : 17-09-2016

Re : [Résolu] Stopper l'interface graphique "à la demande"

Ah ! Pour désactiver le lancement du gestionnaire graphique de connexion au démarrage :

systemctl disable ton-gestionnaire-de-connexion.service.

Mais je n'ai jamais fait fonctionner de VM dans cette configuration.

Dernière modification par trentanel (11-11-2017 15:09:36)

Hors ligne

#9 11-11-2017 15:35:26

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Hello,

Merci pour cette suggestion.
Avec un

sudo systemctl stop gdm3.service

cela descative bien l'interface graphique : nickel.

Le problème est que je n'arrive pas à la relancer avec une commande inverse "start". Je n'ai pas de message, juste un freeze de l'écran.


Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#10 11-11-2017 16:32:26

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Stopper l'interface graphique "à la demande"

Peut-être restart ?

Edit :
J'a passé le truc sur irc freenode #debian-facile et voici la réponse obtenue :

cemoi a écrit :

cemoi | perso j'ai des machines qui demarrent sans x
cemoi | et pour lancer le serveur xorg je fais un startx en user
cemoi | comme j'ai qu'n seul type de gestionnaire de bureau je precise rien vu qu'il y en a que un...
cemoi | j'ai que du xfce sous la main du coup je peux pas tester ce que je dis



Le salon #debian-facile, voir ici : https://debian-facile.org/asso:salon-irc-df big_smile

Dernière modification par smolski (11-11-2017 17:07:19)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#11 11-11-2017 17:18:20

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Merci Smolski.

Mon idée était également de relancer l'interface par un startx. mais voici le problème :

Je stoppe l'interface graphique par un :

sudo service gdm stop


Puis pour relancer l'ensemble un :

startx


Malheureusement je ne peux pas switcher de l'un à l'autre dans la mesure ou GDM est toujours stopper.
Il faudrait pouvoir switcher entre un :

sudo service gdm stop


et un

sudo service gdm start


Ce qui provoque un freeze chez moi.

Bref, pas simple tout ca.

J'ai cependant trouvé une solution de contournement en remplaçant GDM par LightDM. Et dans ce cas de figure, cela fonctionne bien.

Merci pour vos contributions.

Go10

Edit : ajout de user dans les balises codes Voir le tuto : Le code, ça pique moins les yeux en couleur


Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#12 11-11-2017 17:24:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Stopper l'interface graphique "à la demande"

Ne soyons pas chiche d'un point chocodf alors :
    \o/
    Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#13 11-11-2017 17:27:16

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Stopper l'interface graphique "à la demande"

de toute façon ton problème est sans solution si tu veux switcher c'est que le service reste en mémoire
Un peu comme quand tu changes d'utilisateur en restant connecté
Edit: le mieux pour ce que tu veux faire c'est ouvrir une session plus légère genre lxde , openbox ou xfce

Dernière modification par Croutons (11-11-2017 17:29:18)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 11-11-2017 17:30:09

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Oui c'est sur mais au final c'est étrange qu'avec LightDM ça fonctionne et pas avec GDM.

Je passe le fil en résolu.

Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#15 11-11-2017 17:32:27

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [Résolu] Stopper l'interface graphique "à la demande"

Merci encore à tous yes.gif

Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#16 12-11-2017 10:40:56

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu] Stopper l'interface graphique "à la demande"

Bonjour

pour stopper un serveur X , j'utilise pour Mate + lightdm
le status du serveur X


service lightdm status
 


puis pour le stopper


service lightdm stop
 



pour gdm3  idem , mais sur buster ça plante la machine ( et Ctrl+Alt+F1 ne fonctionne pas ) , avec 2 cartes video GLX750TI et le driver "nouveau"
tu peu tester


service gdm3 status
 


nota : pas gdm mais gdm3

les fonctions , status , stop , start et restart devraient fonctionner

ps : sur gnome + gdm3 je n'ai que "status" qui fonctionne correctement

Hors ligne

Pied de page des forums