Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-11-2017 16:10:32

Raony
Membre
Inscription : 11-11-2017

Stretch ne démarre pas après un ugrade jessie ---> stretch

Bonjour à tous
voila, le problème vient de l'upgrade jessie vers strech.
Par contre le boot sous jessie boot sans problème.
Voici une partie du grub.cfg:
     (boot sous stretch)
#
menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9' {
        load_video
        insmod gzio
        if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9
        else
          search --no-floppy --fs-uuid --set=root a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9
        fi
        echo    'Chargement de Linux 4.9.0-4-amd64…'
        linux   /boot/vmlinuz-4.9.0-4-amd64 root=UUID=a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9 ro  quiet
        echo    'Chargement du disque mémoire initial…'
        initrd  /boot/initrd.img-4.9.0-4-amd64
}

#
boot sous jessie
#menuentry 'Debian GNU/Linux, avec Linux 3.16.0-4-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.0-4-amd64-advanced-a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9' {
                load_video
                insmod gzio
                if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
                insmod part_msdos
                insmod ext2
                set root='hd0,msdos1'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9
                else
                  search --no-floppy --fs-uuid --set=root a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9
                fi
                echo    'Chargement de Linux 3.16.0-4-amd64…'
                linux   /boot/vmlinuz-3.16.0-4-amd64 root=UUID=a92c9ccb-ca55-435b-b85f-ad9ccb62e5b9 ro  quiet
                echo    'Chargement du disque mémoire initial…'
                initrd  /boot/initrd.img-3.16.0-4-amd64
        }

Merci de vos suggestions.
Raony

Hors ligne

#2 15-11-2017 17:03:45

raleur
Membre
Inscription : 03-10-2014

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

Ce n'est pas un boot de Jessie qui a été remplacée par Stretch par la mise à jour, mais un boot avec le noyau 3.16 de Jessie (et le reste de Stretch).
Pourrais-tu décrire ce qui se passe concrètement lors d'un démarrage avec le noyau 4.9 de Stretch ?

Hors ligne

#3 15-11-2017 17:52:44

Raony
Membre
Inscription : 11-11-2017

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

bonjour,
merci pour la réponse.
Avec l'option par défaut 4.9, j' ai juste le curseur qui clignote et j'attends......., avec le 3.16, la machine démarre sans problème.
Si vous voulez, je peux mettre tout le grub.cfg  intégral pour voir

Hors ligne

#4 15-11-2017 18:51:18

raleur
Membre
Inscription : 03-10-2014

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

Non merci, ça ira.
Rien ne s'affiche  avant ? Pas même "Chargement du noyau 4.9" et "Chargement du disque mémoire initial" ?
Qu'est-ce que ça donne avec le noyau 4.9 en mode dépannage ?
N'aurais-tu pas installé précédemment quelque pilote propriétaire qui aurait besoin d'être recompilé pour le nouveau noyau ?

Dernière modification par raleur (15-11-2017 18:53:17)

Hors ligne

#5 15-11-2017 20:14:50

Raony
Membre
Inscription : 11-11-2017

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

Si l'interface habituelle s'affiche.
  - si le choix par défaut démarre,
  - "chargement du noyau 4.9" et "Chargement du disque mémoire initial"
  - l'interface de connexion habituelle s'affiche après presque 30 mn
  là c'est 4.9 qui est lancé, mais avec un temps assez long.
la commande

uname -a

me donne:

Linux debian-server 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux



Edit à toto : Mis les codes en ordre avec les balises du forum.

Hors ligne

#6 16-11-2017 11:05:17

raleur
Membre
Inscription : 03-10-2014

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

Donc Stretch démarre et fonctionne ensuite correctement avec le noyau 4.9, c'est juste très long au démarrage ?
Est-ce que toutes les étapes du démarrage sont plus longues, ou bien y a-t-il une longue pause pendant une étape ? Dans le second cas, qu'est-ce qui s'affiche en dernier avant cette pose ? Y a-t-il des messages répétitifs ?

A essayer :
- Démarrer avec le noyau 4.9 en mode dépannage depuis le sous-menu des options avancées de GRUB. Il y aura plus de messages affichés et à un moment le démarrage s'interrompra pour proposer de lancer une console d'urgence. Taper Ctrl+d pour continuer. L'information intéressante sera le moment de la pause ou des lenteurs (avant ou après l'interruption) et les messages affichés à ce moment.
- Une fois le système démarré, exécuter la commande suivante pour afficher les temps de démarrage des "unités" system :

systemd-analyze blame

Hors ligne

#7 16-11-2017 12:54:10

Raony
Membre
Inscription : 11-11-2017

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

bonjour,
et merci encore pour ce coup de main.
Voici le message au début du mode rescue.

fbcon: nouveaufb (fb0) is primary device
  ......
  ......
floppy0: no floppy controller found

begin:
  ......

  divers messages

   ......



A la fin juste avant le control-D

"no floppy controllers found"



et le résultat de la commande

systemd-analyze


# systemd-analyze blame
         31.446s exim4.service
           900ms dev-sda1.device
           681ms lvm2-monitor.service
           606ms keyboard-setup.service
           500ms libvirtd.service
           495ms systemd-journald.service
           485ms systemd-tmpfiles-setup-dev.service
           463ms systemd-remount-fs.service
           443ms systemd-sysctl.service
           327ms ebtables.service
           278ms run-rpc_pipefs.mount
           269ms rpcbind.service
           237ms lightdm.service
           226ms networking.service
           216ms systemd-logind.service
           184ms rsyslog.service
           166ms rtkit-daemon.service
           160ms rc-local.service
           154ms systemd-user-sessions.service
           141ms ssh.service



           .........

Edit à toto : Mis les commandes en couleur avec les balises Code du forum

Hors ligne

#8 16-11-2017 13:24:46

raleur
Membre
Inscription : 03-10-2014

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

A quel(s) moment(s) y a-t-il une ou des longues pauses ? Si plusieurs, de quelle durée ?

Le contenu de la sortie de la commande dmesg envoyée dans un fichier pourrait contenir des indications. Mais c'est long, tu ne pourras pas forcément tout mettre dans le forum et il peut être nécessaire de le déposer sur un site de téléchargement. Ou bien tu ne copies que les quelques (20) lignes qui entourent les pauses.

Rien d'exagéré dans les temps de démarrages des unités.

Hors ligne

#9 16-11-2017 13:52:06

Raony
Membre
Inscription : 11-11-2017

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

merci pour les conseils
là, la machine a planté, j'ai clonné juste un VM dessus et impossible de  récuperer la machine, sauf un reboot brutal je pense.
Je vais redémarrer la machine et voir s'il y a quelques choses de probant.

Hors ligne

#10 16-11-2017 15:35:05

Raony
Membre
Inscription : 11-11-2017

Re : Stretch ne démarre pas après un ugrade jessie ---> stretch

Merci encore raleur,
comme je dois continuer le travail, je vais rester sur Jessie pour le moment.
Je passerais sous Stretch une autre fois.
Merci encore pour tes conseils.

Hors ligne

Pied de page des forums