Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-11-2017 20:46:19

ToxicTigerQc
Membre
Lieu : Drummondville (Québec)
Distrib. : Debian Stretch 9.3
Noyau : 4.9 LTS Custom XanMod
(G)UI : Mate 1.16.2
Inscription : 26-11-2017

[Résolu] Problèmes d'installation pilote graphique & Xorg

Bonjour.

Voilà du à une mort de mon SSD, J'ai du réinstallé le système sad Mais le problèmes c'est quand j'arrive a la fin de l'installation j'ai toujours se problèmes avec xorg qui me dit "Server error: no screen found" Pourtant je fais comme suis pour installé ma debian Sid ou stretch. Je vais rajouter une photo dans 1h je rentre chez moi. smile

Voici ma démarche d'installation

Pour installé Mate desktop

apt install --no-install-recommends mate-desktop-environment



Installation de xorg

apt install --no-install-recommends xserver-xorg-input-all xinit server-xorg-video-nouveau



Installation Lightdm

apt install lightdm



Pourtant j'ai faite les même commande que ma dernière installation et sa bien passé. Merci pour les future réponse woohoo.gif

Dernière modification par ToxicTigerQc (30-11-2017 21:54:17)


Ma configuration Linux : OS Debian 9.3, Kernel 4.9 LTS XanMod
Processeur : Core i7 5820k, Carte mère : EVGA X99 Classified, Mémoire vive : Corsair Vengeance LED Édition 32Go, Carte Graphique : GTX 1060 3Go, Alimentation : EVGA G3 850W, Carte son : Xonar Pheobus non compatible linux, Ventirad Watercooling : Nzxt Kraken X62, Boîtier : Phanteks Evolv Tempered Glass Édition, Voilà ma configuration wink

Hors ligne

#2 30-11-2017 13:04:13

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] Problèmes d'installation pilote graphique & Xorg

Bonjour

tu peu simuler cette commande (avec l'option -s )


apt-get -s install mate-core lightdm
 



ou pour éviter de passer les paquets en "installé manuellement" (l'option --reinstall )


apt-get -s --reinstall install mate-core lightdm
 


pour les autres paquets ils viennent en dépendance du bureau (pas la peine de les installer a part )

tu peu donner la référence de ta carte vidéo nvidia , je suppose qu'elle est prise en charge par le driver libre "nouveau"

le log de xorg te répond qu il ne trouve pas d'écran  ?   =>  "Server error: no screen found"  (mon anglais pas terrible mais il me semble tongue  )

si tu veut tester la commande en réel  ci dessus tu retire le "-s" , l'installation se fera .............

nota : mate-core ne te met que les paquets essentiel , a toi de compléter après
j'installe a partir d une debian minimale Mate sans soucis comme ceci.

Dernière modification par robert2a (30-11-2017 13:07:55)

En ligne

#3 30-11-2017 19:03:39

ToxicTigerQc
Membre
Lieu : Drummondville (Québec)
Distrib. : Debian Stretch 9.3
Noyau : 4.9 LTS Custom XanMod
(G)UI : Mate 1.16.2
Inscription : 26-11-2017

Re : [Résolu] Problèmes d'installation pilote graphique & Xorg

Yeah merci beaucoup l'ami.

Je vais testée les commande que tu me propose j'espère que tout va bien se passé. Pour ma carte graphique c'est une GTX 1060 qui est pourtant bien détecté par nouveau. Mais toute façon je dois installé les pilote propriétaire NVIDIA pour profité de ma carte graphique neutral Je te redonne des nouvelle d'ici 1 heure smile

Dernière modification par ToxicTigerQc (30-11-2017 19:04:57)


Ma configuration Linux : OS Debian 9.3, Kernel 4.9 LTS XanMod
Processeur : Core i7 5820k, Carte mère : EVGA X99 Classified, Mémoire vive : Corsair Vengeance LED Édition 32Go, Carte Graphique : GTX 1060 3Go, Alimentation : EVGA G3 850W, Carte son : Xonar Pheobus non compatible linux, Ventirad Watercooling : Nzxt Kraken X62, Boîtier : Phanteks Evolv Tempered Glass Édition, Voilà ma configuration wink

Hors ligne

#4 30-11-2017 20:07:42

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] Problèmes d'installation pilote graphique & Xorg

avec la la GTX1060 , le noyau 4.13.0-1 de buster/sid pas parfait , j'ai eu une bonne prise en charge avec le noyau 4.14 de expérimental (gnome+gdm3  sous sid avec la 1060 ).
donc soit tu l installe en console pure (le driver nvidia des dépots debian ) soit si le bureau fonctionne a partir du wiki en console graphique.
ton profil indique sid et 4.14.2 ça doit rouler , juste tu a mal installé mate (doit manqué des dépendances )
ps : sur sid deux mise a jour du driver nvidia (avant hier et hier ) justement sur ma GTX1060 6Go

la version actuelle =>  https://packages.debian.org/fr/sid/xser … deo-nvidia

la commande qui va bien (du wiki D_F)


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 


tu peu simuler avant (avec l option -s )


apt-get -s install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 



nota : je suppose que tu suis ceci =>  https://www.kernel.org/   (4.14.3 )  et 4.15-rc1
ps: comme les machines bossent , je suis revenu au 4.13 et j'attends que debian l intègre dans sid    (je suis sous le driver nonfree ça pose pas de problème )

pour l'installation de mate pense a retirer le " -s "  si tu fais un copier/coller (sinon tu simule )

Dernière modification par robert2a (30-11-2017 20:22:09)

En ligne

#5 30-11-2017 20:56:04

ToxicTigerQc
Membre
Lieu : Drummondville (Québec)
Distrib. : Debian Stretch 9.3
Noyau : 4.9 LTS Custom XanMod
(G)UI : Mate 1.16.2
Inscription : 26-11-2017

Re : [Résolu] Problèmes d'installation pilote graphique & Xorg

Mon profile l'indique c'était avant que le SSD crame lol J'ai du refaire une installations propre. J'ai réinstallé lightdm y'a du mieux, Mais maintenant je demarre sur lightdm je rentre mon login et pass ecran noir 2 seconde et retour aux login. Je vais essayer d'installer le pilote NVIDIA depuis la console TTY1 GW4XHIh.jpg Comme ont peux le voir j'ai des fichier de session qui ont des erreur

Ma configuration Linux : OS Debian 9.3, Kernel 4.9 LTS XanMod
Processeur : Core i7 5820k, Carte mère : EVGA X99 Classified, Mémoire vive : Corsair Vengeance LED Édition 32Go, Carte Graphique : GTX 1060 3Go, Alimentation : EVGA G3 850W, Carte son : Xonar Pheobus non compatible linux, Ventirad Watercooling : Nzxt Kraken X62, Boîtier : Phanteks Evolv Tempered Glass Édition, Voilà ma configuration wink

Hors ligne

#6 30-11-2017 21:02:09

ToxicTigerQc
Membre
Lieu : Drummondville (Québec)
Distrib. : Debian Stretch 9.3
Noyau : 4.9 LTS Custom XanMod
(G)UI : Mate 1.16.2
Inscription : 26-11-2017

Re : [Résolu] Problèmes d'installation pilote graphique & Xorg

pilote NVIDIA installée et tout fonction. Je te dis un gros merci pour ton aide très précieuses mon ami big_smile Maintenant je go mettre dans le système y'a du tuning qui m'attend lol

Ma configuration Linux : OS Debian 9.3, Kernel 4.9 LTS XanMod
Processeur : Core i7 5820k, Carte mère : EVGA X99 Classified, Mémoire vive : Corsair Vengeance LED Édition 32Go, Carte Graphique : GTX 1060 3Go, Alimentation : EVGA G3 850W, Carte son : Xonar Pheobus non compatible linux, Ventirad Watercooling : Nzxt Kraken X62, Boîtier : Phanteks Evolv Tempered Glass Édition, Voilà ma configuration wink

Hors ligne

#7 30-11-2017 21:48:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Problèmes d'installation pilote graphique & Xorg

ToxicTigerQc a écrit :

Maintenant je go mettre dans le système y'a du tuning qui m'attend


Auparavant, mettre le post en résolu alors.
Voici le lien à ouvrir pour découvrir comment le faire :

    \o/
    Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. big_smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums