Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-12-2017 16:34:39

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

[Résolu] Touchpad xserver-xorg-libinput utilisation de xinput

Bonjour smile
Suite à cette discussion, j'ai fait quelques découvertes (il n'est jamais trop tard) sur xinput qui permet de gérer libinput
Comme xserver-xorg-input-synaptics ne sera plus maintenu, j'ai décidé de le désinstaller bien que son installation me permet d'avoir un onglet dans le Centre de control de Mate 1.16 pour régler le touchpad et activer le tap-to-click
J'ai donc installé xinput

xinput --list



⎡ Virtual core pointer                      id=2  [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4  [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=9  [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12 [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3  [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5  [slave  keyboard (3)]
    ↳ Power Button                              id=6  [slave  keyboard (3)]
    ↳ Video Bus                                 id=7  [slave  keyboard (3)]
    ↳ Sleep Button                              id=8  [slave  keyboard (3)]
    ↳ Video WebCam                              id=10 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11 [slave  keyboard (3)]
 


Mon touchpad a l'id 12

xinput list-props 12


Device 'SynPS/2 Synaptics TouchPad':
  Device Enabled (141): 1
  Coordinate Transformation Matrix (143): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
  libinput Tapping Enabled (297): 0
  libinput Tapping Enabled Default (298): 0
  libinput Tapping Drag Enabled (299):  1
  libinput Tapping Drag Enabled Default (300):  1
  libinput Tapping Drag Lock Enabled (301): 0
  libinput Tapping Drag Lock Enabled Default (302): 0
  libinput Tapping Button Mapping Enabled (303):  1, 0
  libinput Tapping Button Mapping Default (304):  1, 0
  libinput Accel Speed (279): 0.000000
  libinput Accel Speed Default (280): 0.000000
  libinput Natural Scrolling Enabled (284): 0
  libinput Natural Scrolling Enabled Default (285): 0
  libinput Send Events Modes Available (264): 1, 1
  libinput Send Events Mode Enabled (265):  0, 0
  libinput Send Events Mode Enabled Default (266):  0, 0
  libinput Left Handed Enabled (286): 0
  libinput Left Handed Enabled Default (287): 0
  libinput Scroll Methods Available (288):  1, 1, 0
  libinput Scroll Method Enabled (289): 1, 0, 0
  libinput Scroll Method Enabled Default (290): 1, 0, 0
  libinput Disable While Typing Enabled (305):  1
  libinput Disable While Typing Enabled Default (306):  1
  Device Node (267):  "/dev/input/event2"
  Device Product ID (268):  2, 7
  libinput Drag Lock Buttons (295): <no items>
  libinput Horizontal Scroll Enabled (296): 1
 


L'activation du touchpad correspond aux lignes :


libinput Tapping Enabled (297): 0
libinput Tapping Enabled Default (298): 0
 


0 indique qu'il est désactivé.
La commande suivant me permet de l'activer pour la session en cours

xinput --set-prop 12 297 1



libinput Tapping Enabled (297): 1
libinput Tapping Enabled Default (298): 0
 


Ce réglage pour le tap-to-click n'est pas préservé si on redémarre le PC.
J'ai essayé la commande pour changer le réglage par défaut mais ça ne marche pas que la commande soit passée en user ou en root.

xinput --set-prop 12 298 1


X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Serial number of failed request:  19
  Current serial number in output stream:  20


sudo xinput --set-prop 12 298 1


X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Serial number of failed request:  19
  Current serial number in output stream:  20



Y a-t-il moyen avec xinput de conserver le réglage par défaut du tap-to-click ou doit-on procéder comme indiqué dans le fil cité plus haut en créant un fichier de configuration ?
Finalement quand j'active le tap-to-click dans l'onglet du Centre de control de Mate pour le touchpad lorsque le paquet xserver-xorg-synaptics est installé, cette case coché a-t-elle pour effet de créer ce fichier de configuration ?

Hors ligne

#2 01-12-2017 17:10:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Touchpad xserver-xorg-libinput utilisation de xinput

Bonjour,

Y a-t-il moyen avec xinput de conserver le réglage par défaut du tap-to-click ou doit-on procéder comme indiqué dans le fil cité plus haut en créant un fichier de configuration ?

Oui et non, tu peux aussi choisir d'exécuter automatiquement la commande xinput qui va bien au démarrage, mais bon, le fichier de configuration paraît assez naturel. À noter que le fichier /usr/share/X11/xorg.conf.d/40-libinput.conf fourni par le paquet xserver-xorg-input-libinput peut servir de modèle, et être copié dans le répertoire /etc/X11. Comme d'habitude il y a plusieurs façons de parvenir au même résultat !

Dernière modification par èfpé (01-12-2017 18:20:42)

Hors ligne

#3 01-12-2017 20:46:45

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Touchpad xserver-xorg-libinput utilisation de xinput

Merci pour la réponse smile
La méthode avec le fichier de configuration fonctionne bien et n’est pas plus difficile à mettre en œuvre que l’execution automatique de la commande.
Je pense que le problème sera réglé dans deux ans et qu’on retrouvera le moyen de faire des réglages dans les paramètres.

Hors ligne

Pied de page des forums