Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-12-2017 14:13:01

keo
Membre
Inscription : 21-02-2017

problème d'install ngnix

Bonjour, j'ai un souci d'installer nginx, lorsque je lance cette commande j'ai un erreur:


/etc/nginx/sites-enabled# systemctl status nginx
● nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2017-12-08 12:57:40 CET; 4s ago
     Docs: man:nginx(8)
  Process: 13469 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)
  Process: 13669 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
 Main PID: 13295 (code=exited, status=0/SUCCESS)

Dec 08 12:57:40 vps787878 systemd[1]: Starting A high performance web server and a reverse proxy server...
Dec 08 12:57:40 vps787878 nginx[13669]: nginx: [emerg] "location" directive is not allowed here in /etc/nginx/conf.d/default.conf:1
Dec 08 12:57:40 vps787878 nginx[13669]: nginx: configuration file /etc/nginx/nginx.conf test failed
Dec 08 12:57:40 vps787878 systemd[1]: nginx.service: Control process exited, code=exited status=1
Dec 08 12:57:40 vps787878 systemd[1]: Failed to start A high performance web server and a reverse proxy server.
Dec 08 12:57:40 vps787878 systemd[1]: nginx.service: Unit entered failed state.
Dec 08 12:57:40 vps787878 systemd[1]: nginx.service: Failed with result 'exit-code'.
root@vps787878:/etc/nginx/sites-enabled# nano /etc/nginx/conf.d/default.conf
root@vps787878:/etc/nginx/sites-enabled# systemctl restart php7.0-fpm
root@vps787878:/etc/nginx/sites-enabled# systemctl restart nginx
 



voici le fichier


  GNU nano 2.7.4                                            File: /etc/nginx/conf.d/default.conf                                                      

location ~ \.php$ {
        root           /usr/share/nginx/html;
        fastcgi_pass   unix:/run/php/php7.0-fpm.sock;
        fastcgi_index  index.php;
        include        fastcgi_params;
        fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
    }

 



merci de me guider pour résoudre ce problème

merci d'avance de vos réponse smile

Hors ligne

Pied de page des forums