Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-12-2017 08:38:59

AqwelF
Membre
Distrib. : Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : GNOME
Inscription : 24-12-2017

[Résolu] USB3 DD externe ne se monte pas

Bonjour,

Je viens d'acheter un PC LDLC sans OS (ce modèle : https://www.ldlc.com/fiche/PB00217428.html2)

J'ai installer une version stable récente de debian strecth dessus.

Aujourd'hui je sèche sur un problème de reconnaissance de mon DD externe WD Elements en USB3 sur les trois ports USB3. le DD est alimenté mais ne se monte pas. or lorsque je le branche sur le port USB2 il est reconnu et se monte correctement. En revanche quand je branche une clé usb2 sur le port usb3 il est reconnu

Voici ce que j'ai déjà tenté :

- Le disk n’apparaît pas dans disk utility.
- Formater le DD en FAT/NTFS/EXT4
- Ajouter la ligne pci=nomsi noaer ou pci=nomsi dans la ligne GRUB_DEFAULT
- Ajouter une blacklist au modprobe https://forum.siduction.org/index.php?topic=3716.0 sauf que la la commande rmmod me renvoie "impossible xhci_hcd en cours d'utilisation"
- Enlever le suspend des usb avec for foo in /sys/bus/usb/devices/*/power/level; do echo on > $foo; done et for F in /sys/bus/usb/devices/*/power/control; do echo on >"${F}"; done

rien ne fonctionne.

Mon UEFI est disable dans mon bios
Mon DD interne SSD est en AHCI et je ne peux pas désactiver dans le bios le EHCI

voici les rapports :

lsusb


Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 04f2:b5a7 Chicony Electronics Co., Ltd
Bus 001 Device 005: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


lsusb -t


Quand rien est connecté :

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/8p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/16p, 480M
    |__ Port 2: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 3: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 3: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 11: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 11: Dev 5, If 1, Class=Human Interface Device, Driver=usbhid, 12M


Quand le DD est sur usb 2

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/8p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/16p, 480M
    |__ Port 2: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 3: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 3: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 11: Dev 6, If 0, Class=Mass Storage, Driver=usb-storage, 480M


Quand le DD est sur usb 3

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/8p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/16p, 480M
    |__ Port 2: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 2: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 3: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 3: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 11: Dev 7, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 11: Dev 7, If 1, Class=Human Interface Device, Driver=usbhid, 12M


 dmesg


Quand le DD est sur un port USB2 :

[25639.697509] usb 1-11: new high-speed USB device number 17 using xhci_hcd
[25639.902242] usb 1-11: New USB device found, idVendor=1058, idProduct=25a2
[25639.902247] usb 1-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[25639.902250] usb 1-11: Product: Elements 25A2
[25639.902252] usb 1-11: Manufacturer: Western Digital
[25639.902254] usb 1-11: SerialNumber: 575839314131363535555046
[25639.903013] usb-storage 1-11:1.0: USB Mass Storage device detected
[25639.903293] scsi host4: usb-storage 1-11:1.0
[25640.925066] scsi 4:0:0:0: Direct-Access     WD       Elements 25A2    1019 PQ: 0 ANSI: 6
[25640.926110] sd 4:0:0:0: Attached scsi generic sg2 type 0
[25640.926721] sd 4:0:0:0: [sdb] Spinning up disk...


Ensuite j'ai clear le dmesg et quand je le met sur USB3 le dmesg ne ressort rien...

Mes firmwares sont tous à jour, j'ai installé le paquet linux-firmware et le dmseg ne fait ressortir aucun firmware en défaut ou manquant.

J'ai testé avec un live CD Ubuntu aussi le DD n'est pas reconnus sur les ports usb3.

Pouvez-vous m'aider ?
Merci d'avance.

Dernière modification par AqwelF (25-12-2017 10:10:15)

Hors ligne

#2 24-12-2017 09:14:12

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-2 4.14.7-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu] USB3 DD externe ne se monte pas

Bonjour

le lien que tu donne ne fonctionne pas , quel type de machine ? (pc de bureau , intel ou amd ?  etc ......  )

sur une machine en Ryzen voila le retour de lspci et lsusb


lspci
 


retour pour l usb uniquement


03:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 43b9 (rev 02)
25:00.0 USB controller: ASMedia Technology Inc. Device 1343
29:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) USB 3.0 Host Controller
 




lsusb
 


retour (je n'ai qu'une souris branché en usb sur cet exemple)


Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 046d:c01d Logitech, Inc. MX510 Optical Mouse
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 



je pense que ton controleur usb3 est mal reconnu par stretch d'après ton explication

le retour de lsusb quand je branche un DD en usb3


Bus 006 Device 002: ID 0480:a00a Toshiba America Inc
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 046d:c01d Logitech, Inc. MX510 Optical Mouse
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 



il est ici  =>  "Bus 006 Device 002: ID 0480:a00a Toshiba America Inc"

comme ton DD externe fonctionne bien en usb2 , ce n'est pas un problème d'alimentation ni du disque dur externe
une souris sur les ports usb3  fonctionne ?  (sur l un des 3 ports que tu a testé pour le DD )

Dernière modification par robert2a (24-12-2017 09:23:51)

Hors ligne

#3 24-12-2017 09:29:04

AqwelF
Membre
Distrib. : Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : GNOME
Inscription : 24-12-2017

Re : [Résolu] USB3 DD externe ne se monte pas

Il s'agit d'un pc portable, voici les caractéristiques : https://www.ldlc.com/fiche/PB00217428.html

    Processeur Intel Skylake : Intel Core i3-6100H (Dual-Core 2.7 GHz - Cache 3 Mo)
    8 Go de mémoire DDR4 (1x 8 Go - 2 slots - maximum 32 Go)
    Ecran mat de 15.6 pouces avec résolution Full HD (1920 x 1080)
    Dalle IPS : couleurs lumineuses et angles de vision larges
    Sortie HDMI, pour la connexion à un grand écran HD
    SSD Curcial de 275 Go (SATA 2.5 pouces) + slot libre pour SSD M.2 SATA ou M.2 PCIe x4
    Connexion réseau Gigabit Ethernet + communication sans fil Wi-Fi N + Bluetooth 4.0
    Transferts haut débit avec 3 ports USB 3.0
    Aucun système d'exploitation : installez l'OS de votre choix

lspci


00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
02:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
03:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)
 



lsusb


Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 04f2:b5a7 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 



idem que la souris sans fil logitech de branchée

Hors ligne

#4 24-12-2017 12:04:53

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-2 4.14.7-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [Résolu] USB3 DD externe ne se monte pas

normalement sur stretch et une machine en skylake (intel) ça devrait fonctionner
j'ai testé sur une de mes machines de bureau en skylake et en stretch
la version du noyau


uname -a
 



Linux debian12 4.9.0-4-amd64 #1 SMP Debian 4.9.65-3 (2017-12-03) x86_64 GNU/Linux
 



le type de circuit pour l usb3 (identique au tien )


00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
 


le test d un disque externe en usb3 a partir du bureau (bureau Mate + ligtdm en stretch )


Bus 002 Device 002: ID 0480:a00a Toshiba America Inc
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 001 Device 002: ID 04b3:3025 IBM Corp. NetVista Full Width Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 


ps:j'ai un clavier et une souris en usb sur cette machine

tu a testé autre chose que le DD externe sur ces fameux ports usb3 ?  (oui une clé usb2 après relecture de ton premier post )

la je comprend pas pourquoi tu a ce problème  hmm

nota : je vois le disque en autre dans /dev/disk/by-label/THOSIBA\x20EXT

ps: mise a jour de sécurité du noyau


Linux debian12 4.9.0-4-amd64 #1 SMP Debian 4.9.65-3+deb9u1 (2017-12-23) x86_64 GNU/Linux
 



donne les caractéristiques de ton disque externe (capacité , marque etc ..... )
je suis sur cette machine en EFI et mon disque externe fait 2To  (qu il y ai un souci avec le noyau pour ton DD externe mais ça dépasse mes compétences  roll   )

Dernière modification par robert2a (24-12-2017 12:28:19)

Hors ligne

#5 24-12-2017 12:49:00

AqwelF
Membre
Distrib. : Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : GNOME
Inscription : 24-12-2017

Re : [Résolu] USB3 DD externe ne se monte pas

Il s'agit d'un western Digital Elements 1To

Tu me propose de faire une mise à jour de sécurité du noyau ? comment dois-je procéder stp? (ok je viens de le faire avec un apt-get upgrade)

uname -a


Linux axel 4.9.0-4-amd64 #1 SMP Debian 4.9.65-3+deb9u1 (2017-12-23) x86_64 GNU/Linux



voila ce que donne le dmesg quand je branche sur le usb 2 :

dmesg


[ 4638.761398] usb 1-11: new high-speed USB device number 6 using xhci_hcd
[ 4638.966252] usb 1-11: New USB device found, idVendor=1058, idProduct=25a2
[ 4638.966256] usb 1-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4638.966259] usb 1-11: Product: Elements 25A2
[ 4638.966262] usb 1-11: Manufacturer: Western Digital
[ 4638.966264] usb 1-11: SerialNumber: 575839314131363535555046
[ 4638.966957] usb-storage 1-11:1.0: USB Mass Storage device detected
[ 4638.967131] scsi host4: usb-storage 1-11:1.0
[ 4639.973934] scsi 4:0:0:0: Direct-Access     WD       Elements 25A2    1019 PQ: 0 ANSI: 6
[ 4639.974806] sd 4:0:0:0: Attached scsi generic sg2 type 0
[ 4639.975803] sd 4:0:0:0: [sdb] Spinning up disk...
[ 4640.997417] .
[ 4642.021272] .
[ 4643.045235] .
[ 4644.069373] .
[ 4645.093376] .
[ 4645.093604] ready
[ 4645.093812] sd 4:0:0:0: [sdb] 1953458176 512-byte logical blocks: (1.00 TB/931 GiB)
[ 4645.094088] sd 4:0:0:0: [sdb] Write Protect is off
[ 4645.094093] sd 4:0:0:0: [sdb] Mode Sense: 47 00 10 08
[ 4645.094379] sd 4:0:0:0: [sdb] No Caching mode page found
[ 4645.094387] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 4645.186735]  sdb: sdb1
[ 4645.188162] sd 4:0:0:0: [sdb] Attached SCSI disk
 



Ces deux lignes ressortent en rouge...

[ 4645.094379] sd 4:0:0:0: [sdb] No Caching mode page found
[ 4645.094387] sd 4:0:0:0: [sdb] Assuming drive cache: write through

Dernière modification par AqwelF (24-12-2017 13:06:34)

Hors ligne

#6 25-12-2017 05:16:33

AqwelF
Membre
Distrib. : Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : GNOME
Inscription : 24-12-2017

Re : [Résolu] USB3 DD externe ne se monte pas

J'ai eu l'occasion de tester ce soir le DD sur un PC muni de Windows 10 et équipé de ports usb3.
Cela ne fonctionnant pas avec Windows non plus j'en ai conclu que c'était matériel.

Mais alors pourquoi le DD fonctionnerait sur USB2 et pas sur usb3 ?

J'ai creusé la question et en fait le câble de mon DD en USB3 (voir photo) est décomposé d'un premier câble identique à l'USB2 (rouge sur la photo) et une deuxième partie câblé qui concerne l’USB3 (vert sur la photo). Or j'ai changé le câble et cela fonctionne sur ma Debian. Je pense donc que la partie USB3 du câble est HS et la partie USB2 est fonctionnelle. voila pourquoi !!

Le problème est donc résolu.

Merci de votre aide.

1.jpg

Dernière modification par AqwelF (25-12-2017 05:19:21)

Hors ligne

#7 25-12-2017 05:48:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] USB3 DD externe ne se monte pas

AqwelF a écrit :

Le problème est donc résolu.


Ah super, la magie de noël avec un peu de jugeotte, merci du retour !

Reste à l'indiquer dans l'titre.
Voir le tuto en lien ici :
\o/
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 25-12-2017 10:11:27

AqwelF
Membre
Distrib. : Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : GNOME
Inscription : 24-12-2017

Re : [Résolu] USB3 DD externe ne se monte pas

Done !
Joyeux Noël à tous !

Hors ligne

Pied de page des forums