Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-01-2018 14:06:31

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

m.a.j. vers le kernel 4.15 commentaires

le kernel 4.15 est disponible en RC5 dans expérimental et en RC6 sur kernel.org

~$ sudo apt search linux-image-4.15


[sudo] Mot de passe de alain-buster : 
En train de trier... Fait
Recherche en texte intégral... Fait
linux-headers-4.15.0-rc5-686/experimental 4.15~rc5-1~exp1 i386
  Header files for Linux 4.15.0-rc5-686

linux-headers-4.15.0-rc5-686-pae/experimental 4.15~rc5-1~exp1 i386
  Header files for Linux 4.15.0-rc5-686-pae

linux-headers-4.15.0-rc5-amd64/experimental 4.15~rc5-1~exp1 amd64
  Header files for Linux 4.15.0-rc5-amd64

linux-image-4.15.0-rc5-686/experimental 4.15~rc5-1~exp1 i386
  Linux 4.15-rc5 for older PCs

linux-image-4.15.0-rc5-686-dbg/experimental 4.15~rc5-1~exp1 i386
  Debug symbols for linux-image-4.15.0-rc5-686

linux-image-4.15.0-rc5-686-pae/experimental 4.15~rc5-1~exp1 i386
  Linux 4.15-rc5 for modern PCs

linux-image-4.15.0-rc5-686-pae-dbg/experimental 4.15~rc5-1~exp1 i386
  Debug symbols for linux-image-4.15.0-rc5-686-pae

linux-image-4.15.0-rc5-amd64/experimental 4.15~rc5-1~exp1 amd64
  Linux 4.15-rc5 for 64-bit PCs

linux-image-4.15.0-rc5-amd64-dbg/experimental 4.15~rc5-1~exp1 amd64
  Debug symbols for linux-image-4.15.0-rc5-amd64



https://www.kernel.org/

quelqun les aurait il testés ?

en attendant la RC8 et la version définitive prévue le 21 janvier .  https://www.phoronix.com/scan.php?page= … 6-Released

pour ma part , ayant testé les  noyaux 4.15-rc5 et 4.15-rc6 , je suis un peu déçu .

même si , pour la prise en charge des températures , il semble y avoir eu du progrès (plus besoin de patcher le 4.14) , pour virtual box , par exemple , cela ne  fonctionne pas .

pas moyen d'ouvrir une machine ou d'en créer une .
virtualbox demande les headers et le dkms alors que déjà installés .

voilà pour commencer .

j'attends vos commentaires .

Dernière modification par Debian Alain (02-01-2018 14:07:01)


1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#2 02-01-2018 15:08:37

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

Bonjour

surement que le 4.15 demande a installer des paquet d' "experimental"  (ou qui n'existe pas encore sur les dépots debian)
faut patienter

nota : comme les outils , ou par exemple le driver actuel (sid) nonfree nvidia qui fonctionne plus mais disponible dans expérimental en nouvelle version
les libc6 et autres .....

ps: pour pas casser buster (ou sid )  faut rester prudent

je  le compile a chaque nouvelle version, mais juste testé (une fois le rc5 ) sur une machine sans importance , pas eu de souci particulier . (mais le minimum de logiciel , pas de VM , et que des paquets "free" )

Hors ligne

#3 21-01-2018 12:14:34

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : m.a.j. vers le kernel 4.15 commentaires

bonjour ,

le noyau 4.15 rc8 est dispo sur expérimental .

d'après vous , vaut mieux attendre la version finale ou je peux tester la rc8 ?

quels sont les risques ? et les chances ?

merci

https://lkml.org/lkml/2018/1/14/210

https://www.linuxtoday.com/developer/li … 5-rc8.html

http://www.tuxmachines.org/node/108141

The 4.15-rc8 kernel prepatch is out for testing. Among other things, it includes the "retpoline" mechanism intended to mitigate variant 2 of the Spectre vulnerability. Testing of this change will be hard, though, since it requires a version of GCC that almost nobody has — watch LWN for a full article in the near future.


mal traduit mais on comprend l'essentiel :

Le prepatch du noyau 4.15-rc8 est sorti pour le test. Il inclut entre autres le mécanisme "retpoline" destiné à atténuer la variante 2 de la vulnérabilité des spectres. La mise à l'essai de ce changement sera toutefois difficile, car il exige une version de GCC que presque personne n' a - surveiller LWN pour un article complet dans un avenir proche.

Dernière modification par Debian Alain (24-01-2018 20:23:18)


1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#4 21-01-2018 13:15:44

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS
Noyau : 4.17.7
(G)UI : KDE Plasma 5.13.3
Inscription : 05-03-2014

Re : m.a.j. vers le kernel 4.15 commentaires

En mieux traduit:

Le prepatch du noyau 4.15-rc8 est sorti pour le test. Il inclut entre autres le mécanisme "retpoline" destiné à atténuer la variante 2 de la vulnérabilité de spectre. La mise à l'essai de ce changement sera toutefois difficile, car il exige une version de GCC que presque personne n' a - surveiller LWN pour un article complet dans un avenir proche.


Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

#5 21-01-2018 13:17:47

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS
Noyau : 4.17.7
(G)UI : KDE Plasma 5.13.3
Inscription : 05-03-2014

Re : m.a.j. vers le kernel 4.15 commentaires

Pour traduire, même des termes techniques:

https://www.deepl.com/translator

Il n'y a pas mieux.

Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

#6 21-01-2018 13:23:26

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS
Noyau : 4.17.7
(G)UI : KDE Plasma 5.13.3
Inscription : 05-03-2014

Re : m.a.j. vers le kernel 4.15 commentaires

En gros, pour ce 4.15-rc8, ça dit que ça risque d'être très compliqué à tester, surtout pour un utilisateur lambda.
Il vaut mieux je pense attendre la disponibilité du 4.15.1 sur les distributions, ainsi que tous les changements qui iront avec.
je dis 4.15.1 car les nouvelles versions du kernel n'arrivent dans les distros qu'en .1 pas en .0

Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

#7 21-01-2018 13:33:12

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : m.a.j. vers le kernel 4.15 commentaires

Une question reste en suspend… quelle version de GCC faut-il pour bénéficier des effets du patch retpoline ?

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#8 21-01-2018 13:45:06

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS
Noyau : 4.17.7
(G)UI : KDE Plasma 5.13.3
Inscription : 05-03-2014

Re : m.a.j. vers le kernel 4.15 commentaires

Une version à venir semble t-il.
Puisqu'il est dit que presque personne ne l'a .....

Dernière modification par yoshi (21-01-2018 13:45:37)


Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

#9 21-01-2018 13:45:36

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : m.a.j. vers le kernel 4.15 commentaires

ouaip , remarque , je suis pas étonné .

vu les difficultés que j'ai rencontré  avec les rc5 entre autres .

donc , j'attends  .

merci

1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#10 21-01-2018 14:12:48

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : m.a.j. vers le kernel 4.15 commentaires

Dans experimental, il y a gcc-8, c'est peut-être cette version là. En sid on utilise gcc-7 par défaut.

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#11 21-01-2018 14:57:15

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : m.a.j. vers le kernel 4.15 commentaires

eeeuuuuhhhh , très  bien , enicar . wink

et tu installes lequel sur une plateforme amd64 ?

~$ gcc -v


Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/7/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 7.2.0-19' --with-bugurl=file:///usr/share/doc/gcc-7/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++ --prefix=/usr --with-gcc-major-version-only --program-suffix=-7 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 7.2.0 (Debian 7.2.0-19)
 



en parlant compilation , c'est quoi exactement les  fichiers *.c / *.o / *.ko  ?

d'après ce que j'ai trouvé :

fichiers en *.c

A C file is a source code file for a C or C++ program. It may include an entire program's source code, or may be one of many source files referenced within a programming project. C files can be edited using a basic text editor, but will not show syntax highlighting like most software development programs do.


Un fichier C est un fichier de code source pour un programme C ou C++. Il peut inclure le code source d'un programme entier, ou peut être l'un des nombreux fichiers sources référencés dans un projet de programmation. Les fichiers C peuvent être édités à l'aide d'un éditeur de texte de base, mais ils n'affichent pas la syntaxe en surbrillance comme la plupart des logiciels de développement.



fichiers en *.o

Object file produced by a C compiler; often created instead of a program file during the development process.


Fichier objet produit par un compilateur C; souvent créé au lieu d'un fichier programme pendant le processus de développement.



fichiers en *.ko

Module file used by the Linux kernel, the central component of the Linux operating system; contains program code that extends the functionality of the Linux kernel, such as code for a computer device driver; can be loaded without restarting the operating system; may have other required module dependencies that must be loaded first.


Fichier de module utilisé par le noyau Linux, composant central du système d'exploitation Linux; contient le code de programme qui étend les fonctionnalités du noyau Linux, tel que le code pour un pilote de périphérique d'ordinateur; peut être chargé sans redémarrer le système d'exploitation; peut avoir d'autres dépendances de module requises qui doivent être chargées en premier.



confirmation ?

complément d'information ?

j'ai trouvé ça : https://openclassrooms.com/courses/comp … -gnu-linux

il semble , apparemment , que

apt-get install build-essential


installe gcc .

donc pour gcc-8 , je pense qu'il faut faire :

apt-get -t experimental install build-essential



c'est bien ça ?

curieusement :

~$ sudo apt-get -s -t experimental install build-essential


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
build-essential is already the newest version (12.4).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 430 non mis à jour.
 



~$ apt policy build-essential


build-essential:
  Installé : 12.4
  Candidat : 12.4
 Table de version :
 *** 12.4 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par Debian Alain (21-01-2018 17:14:55)


1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#12 21-01-2018 17:09:24

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : m.a.j. vers le kernel 4.15 commentaires

Il n'y a pas de paquet « build-essential » dans experimental. Pour installer gcc-8 il suffit de faire


apt-get install gcc-8 gcc-8-locales
 


Il faut bien entendu avoir les dépôts experimental activés dans le sources.list. Le gestionnaire de paquet
installe la version qui correspond à ton architecture (à moins de lui demander explicitement d'en installer une autre).


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#13 21-01-2018 17:17:12

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : m.a.j. vers le kernel 4.15 commentaires

merci enicar .

1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#14 21-01-2018 20:36:16

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

Bonjour
une simulation  sur sid


apt-get -s install -t experimental linux-image-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-amd64
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libyaml-cpp0.3v5
Veuillez utiliser « apt autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés :
  linux-headers-4.15.0-rc8-common linux-kbuild-4.15
Paquets suggérés :
  linux-doc-4.15 debian-kernel-handbook
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-common linux-image-4.15.0-rc8-amd64 linux-kbuild-4.15
0 mis à jour, 4 nouvellement installés, 0 à enlever et 232 non mis à jour.
Inst linux-headers-4.15.0-rc8-common (4.15~rc8-1~exp1 Debian:experimental [all])
Inst linux-kbuild-4.15 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Inst linux-headers-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Inst linux-image-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Conf linux-headers-4.15.0-rc8-common (4.15~rc8-1~exp1 Debian:experimental [all])
Conf linux-kbuild-4.15 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Conf linux-headers-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Conf linux-image-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
 



le sources.list


#debian buster 10
deb http://deb.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free

#sid
deb http://deb.debian.org/debian/ sid main contrib non-free

#experimental
deb http://deb.debian.org/debian/ experimental main contrib non-free
 



a priori les dépendances sont bonnes (comme paquets en général =>  linux-compiler , linux-kbuild , linux-headers , linux-headers-common , linux-image )
ne demande pas gcc8 ni autres paquets a mettre a jour

je peu tester sur une machine sans "driver vidéo nonfree" , mais pour moi il y tout ce qu il faut pour le tester

avec aptitude


aptitude -s install -t experimental linux-image-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-amd64
 


retour


Les NOUVEAUX paquets suivants vont être installés :    
  linux-headers-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-common{a} linux-image-4.15.0-rc8-amd64 linux-kbuild-4.15{a}
Les paquets suivants seront ENLEVÉS :
  libyaml-cpp0.3v5{u}
0 paquets mis à jour, 4 nouvellement installés, 1 à enlever et 232 non mis à jour.
Il est nécessaire de télécharger 53,4 Mo d'archives. Après dépaquetage, 301 Mo seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?]
Charger/installer/enlever des paquets.
 



NE PAS LE FAIRE
pour gcc8


apt-get -s install -t experimental gcc-8 gcc-8-locales
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libyaml-cpp0.3v5
Veuillez utiliser « apt autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés :
  cpp-8 gcc-8-base gcc-8-base:i386 libasan5 libatomic1 libcc1-0 libgcc-8-dev libgcc1 libgcc1:i386 libgomp1 libitm1 liblsan0 libmpx2
  libquadmath0 libtsan0 libubsan1
Paquets suggérés :
  gcc-8-multilib gcc-8-doc libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan5-dbg liblsan0-dbg libtsan0-dbg libubsan1-dbg
  libmpx2-dbg libquadmath0-dbg
Les NOUVEAUX paquets suivants seront installés :
  cpp-8 gcc-8 gcc-8-base gcc-8-base:i386 gcc-8-locales libasan5 libgcc-8-dev libubsan1
Les paquets suivants seront mis à jour :
  libatomic1 libcc1-0 libgcc1 libgcc1:i386 libgomp1 libitm1 liblsan0 libmpx2 libquadmath0 libtsan0
10 mis à jour, 8 nouvellement installés, 0 à enlever et 222 non mis à jour.
Inst gcc-8-base (8-20180110-1 Debian:experimental [amd64])
Inst gcc-8-base:i386 (8-20180110-1 Debian:experimental [i386])
Conf gcc-8-base (8-20180110-1 Debian:experimental [amd64])
Conf gcc-8-base:i386 (8-20180110-1 Debian:experimental [i386])
Inst libgcc1 [1:7.2.0-19] (1:8-20180110-1 Debian:experimental [amd64]) [libgcc1:amd64 on libgcc1:i386] [libgcc1:i386 on libgcc1:amd64] [libgcc1:i386 ]
Inst libgcc1:i386 [1:7.2.0-19] (1:8-20180110-1 Debian:experimental [i386])
Inst cpp-8 (8-20180110-1 Debian:experimental [amd64])
Inst libcc1-0 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libgomp1 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libitm1 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libatomic1 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libasan5 (8-20180110-1 Debian:experimental [amd64])
Inst liblsan0 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libtsan0 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libubsan1 (8-20180110-1 Debian:experimental [amd64])
Inst libmpx2 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libquadmath0 [7.2.0-19] (8-20180110-1 Debian:experimental [amd64])
Inst libgcc-8-dev (8-20180110-1 Debian:experimental [amd64])
Inst gcc-8 (8-20180110-1 Debian:experimental [amd64])
Inst gcc-8-locales (8-20180110-1 Debian:experimental [all])
Conf libgcc1 (1:8-20180110-1 Debian:experimental [amd64])
Conf libgcc1:i386 (1:8-20180110-1 Debian:experimental [i386])
Conf cpp-8 (8-20180110-1 Debian:experimental [amd64])
Conf libcc1-0 (8-20180110-1 Debian:experimental [amd64])
Conf libgomp1 (8-20180110-1 Debian:experimental [amd64])
Conf libitm1 (8-20180110-1 Debian:experimental [amd64])
Conf libatomic1 (8-20180110-1 Debian:experimental [amd64])
Conf libasan5 (8-20180110-1 Debian:experimental [amd64])
Conf liblsan0 (8-20180110-1 Debian:experimental [amd64])
Conf libtsan0 (8-20180110-1 Debian:experimental [amd64])
Conf libubsan1 (8-20180110-1 Debian:experimental [amd64])
Conf libmpx2 (8-20180110-1 Debian:experimental [amd64])
Conf libquadmath0 (8-20180110-1 Debian:experimental [amd64])
Conf libgcc-8-dev (8-20180110-1 Debian:experimental [amd64])
Conf gcc-8 (8-20180110-1 Debian:experimental [amd64])
Conf gcc-8-locales (8-20180110-1 Debian:experimental [all])
 


les dépendances de gcc8

Dernière modification par robert2a (21-01-2018 20:40:23)

Hors ligne

#15 21-01-2018 21:04:53

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : m.a.j. vers le kernel 4.15 commentaires

ah oui ... merci robert

1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#16 21-01-2018 21:12:24

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : m.a.j. vers le kernel 4.15 commentaires

Installer gcc-8, c'est facile. Par contre encore faut-il qu'il soit effectivement utilisé pour la compilation
du noyau. C'est quelques fois un peu scabreux, surtout avec make-kpkg… et pour tout dire je ne sais
pas comment on peut choisir le compilateur utilisé pour la construction du noyau avec make-kpkg.
Par défaut ça sera gcc-7 qui sera utilisé.

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#17 21-01-2018 21:32:54

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

j'ai plusieurs versions sur la machine , je sais pas , je pense qu il ira chercher la version dont il a besoin

mais bon il a pas besoin de compiler , il est disponible sur debian expérimental  tongue
je suis en train de le faire et en plus avec un driver nonfree nvidia , pour l'instant je met a jour sid  , 259 paquets hmm
la carte est une GTX750 1Go , avec le 4.15 pas besoin du driver nonfree ........... on purgera si écran noir  tongue

Hors ligne

#18 21-01-2018 21:43:05

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : m.a.j. vers le kernel 4.15 commentaires

robert2a a écrit :

mais bon il a pas besoin de compiler , il est disponible sur debian expérimental


Et avec quelle version de gcc le noyau d'experimental a-t-il été compilé ?…


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#19 21-01-2018 23:05:43

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

je sais pas avec quoi il a été compilé
mais voila de quoi je suis parti


uname -a
 


retour


Linux opterontest 4.14.0-2-amd64 #1 SMP Debian 4.14.7-1 (2017-12-22) x86_64 GNU/Linux
 



glxinfo -B
 


retour


name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 750/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 384.98
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5.0 NVIDIA 384.98
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 384.98
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 


le sources.list


deb [url]http://security.debian.org/debian-security[/url] stretch/updates main contrib non-free
deb [url]http://deb.debian.org/debian/[/url] stretch-updates main contrib non-free
deb [url]http://deb.debian.org/debian/[/url] stretch main contrib non-free

deb [url]http://security.debian.org/debian-security[/url] buster/updates main contrib non-free
deb [url]http://deb.debian.org/debian/[/url] buster-updates main contrib non-free
deb [url]http://deb.debian.org/debian/[/url] buster main contrib non-free

deb [url]http://deb.debian.org/debian/[/url] sid main contrib non-free

deb [url]http://deb.debian.org/debian/[/url] experimental main contrib non-free
 


l installation du noyau 4.15-rc8


apt-get install -t experimental linux-image-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-amd64
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcublas8.0 libcudart8.0 libcufft8.0 libcufftw8.0 libcuinj64-8.0 libcurand8.0 libcusolver8.0 libcusparse8.0
  libevent-2.0-5 libgles-nvidia1 libgles1-glvnd-nvidia libhunspell-1.4-0 libnppc8.0 libnppi8.0 libnppial8.0 libnppicc8.0
  libnppicom8.0 libnppidei8.0 libnppif8.0 libnppig8.0 libnppim8.0 libnppist8.0 libnppisu8.0 libnppitc8.0 libnpps8.0
  libnvblas8.0 libnvgraph8.0 libnvrtc8.0 libtxc-dxtn-s2tc linux-image-4.9.0-4-amd64
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  linux-headers-4.15.0-rc8-common linux-kbuild-4.15
Paquets suggérés :
  linux-doc-4.15 debian-kernel-handbook
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-common linux-image-4.15.0-rc8-amd64 linux-kbuild-4.15
0 mis à jour, 4 nouvellement installés, 0 à enlever et 94 non mis à jour.
Il est nécessaire de prendre 53,4 Mo dans les archives.
Après cette opération, 302 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Sélection du paquet linux-headers-4.15.0-rc8-common précédemment désélectionné.
(Lecture de la base de données... 169824 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-headers-4.15.0-rc8-common_4.15~rc8-1~exp1_all.deb ...
Dépaquetage de linux-headers-4.15.0-rc8-common (4.15~rc8-1~exp1) ...
Sélection du paquet linux-kbuild-4.15 précédemment désélectionné.
Préparation du dépaquetage de .../linux-kbuild-4.15_4.15~rc8-1~exp1_amd64.deb ...
Dépaquetage de linux-kbuild-4.15 (4.15~rc8-1~exp1) ...
Sélection du paquet linux-headers-4.15.0-rc8-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../linux-headers-4.15.0-rc8-amd64_4.15~rc8-1~exp1_amd64.deb ...
Dépaquetage de linux-headers-4.15.0-rc8-amd64 (4.15~rc8-1~exp1) ...
Sélection du paquet linux-image-4.15.0-rc8-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../linux-image-4.15.0-rc8-amd64_4.15~rc8-1~exp1_amd64.deb ...
Dépaquetage de linux-image-4.15.0-rc8-amd64 (4.15~rc8-1~exp1) ...
Paramétrage de linux-kbuild-4.15 (4.15~rc8-1~exp1) ...
Paramétrage de linux-image-4.15.0-rc8-amd64 (4.15~rc8-1~exp1) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.14.0-3-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-4.14.0-3-amd64
I: /vmlinuz is now a symlink to boot/vmlinuz-4.15.0-rc8-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-rc8-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-rc8-amd64
/etc/kernel/postinst.d/zz-update-grub:
Création du fichier de configuration GRUB…
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Image Linux trouvée : /boot/vmlinuz-4.15.0-rc8-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.15.0-rc8-amd64
Image Linux trouvée : /boot/vmlinuz-4.14.0-3-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.14.0-3-amd64
Image Linux trouvée : /boot/vmlinuz-4.14.0-2-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.14.0-2-amd64
Image Linux trouvée : /boot/vmlinuz-4.9.0-4-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.9.0-4-amd64
fait
Paramétrage de linux-headers-4.15.0-rc8-common (4.15~rc8-1~exp1) ...
Paramétrage de linux-headers-4.15.0-rc8-amd64 (4.15~rc8-1~exp1) ...
 



uname -a
 


retour


Linux opterontest 4.15.0-rc8-amd64 #1 SMP Debian 4.15~rc8-1~exp1 (2018-01-15) x86_64 GNU/Linux
 



 glxinfo -B
 


retour


name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 750/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 384.111
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5.0 NVIDIA 384.111
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 384.111
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 


si le noyau est capable de compiler le driver nvidia nonfree c'est que il y a les bonnes versions des outils
sur sid pour moi il est fonctionnel et peut etre testé.

je vais tester cuda voir si il fonctionne bien

Dernière modification par robert2a (21-01-2018 23:12:35)

Hors ligne

#20 21-01-2018 23:46:13

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

re,

j'ai un problème avec OpenCL , faut que je regarde pourquoi (cuda ne fonctionne plus )
la version de linux-compiler-gcc7  (en gcc7) , j'ai nettoyé les versions du noyau 4.9 , kbuild j'ai pour le noyau 4.14 et 4.15
le driver nvidia fonctionne bien


clinfo
 


retour


Number of platforms                               2
  Platform Name                                   Clover
  Platform Vendor                                 Mesa
  Platform Version                                OpenCL 1.1 Mesa 17.3.3
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd
  Platform Extensions function suffix             MESA

  Platform Name                                   NVIDIA CUDA
  Platform Vendor                                 NVIDIA Corporation
  Platform Version                                OpenCL 1.2 CUDA 9.0.282
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer
  Platform Extensions function suffix             NV

  Platform Name                                   Clover
Number of devices                                 0

  Platform Name                                   NVIDIA CUDA
Number of devices                                 1
  Device Name                                     GeForce GTX 750
  Device Vendor                                   NVIDIA Corporation
  Device Vendor ID                                0x10de
  Device Version                                  OpenCL 1.2 CUDA
  Driver Version                                  384.111
  Device OpenCL C Version                         OpenCL C 1.2
  Device Type                                     GPU
  Device Available                                Yes
  Device Profile                                  FULL_PROFILE
  Device Topology (NV)                            PCI-E, 01:00.0
  Max compute units                               4
  Max clock frequency                             1137MHz
  Compute Capability (NV)                         5.0
  Device Partition                                (core)
    Max number of sub-devices                     1
    Supported partition types                     None
  Max work item dimensions                        3
  Max work item sizes                             1024x1024x64
  Max work group size                             1024
  Compiler Available                              Yes
  Linker Available                                Yes
  Preferred work group size multiple              32
  Warp size (NV)                                  32
  Preferred / native vector sizes                
    char                                                 1 / 1      
    short                                                1 / 1      
    int                                                  1 / 1      
    long                                                 1 / 1      
    half                                                 0 / 0        (n/a)
    float                                                1 / 1      
    double                                               1 / 1        (cl_khr_fp64)
  Half-precision Floating-point support           (n/a)
  Single-precision Floating-point support         (core)
    Denormals                                     Yes
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 Yes
    Round to infinity                             Yes
    IEEE754-2008 fused multiply-add               Yes
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  Yes
  Double-precision Floating-point support         (cl_khr_fp64)
    Denormals                                     Yes
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 Yes
    Round to infinity                             Yes
    IEEE754-2008 fused multiply-add               Yes
    Support is emulated in software               No
  Address bits                                    64, Little-Endian
  Global memory size                              1027014656 (979.4MiB)
  Error Correction support                        No
  Max memory allocation                           256753664 (244.9MiB)
  Unified memory for Host and Device              No
  Integrated memory (NV)                          No
  Minimum alignment for any data type             128 bytes
  Alignment of base address                       4096 bits (512 bytes)
  Global Memory cache type                        Read/Write
  Global Memory cache size                        65536 (64KiB)
  Global Memory cache line size                   128 bytes
  Image support                                   Yes
    Max number of samplers per kernel             32
    Max size for 1D images from buffer            134217728 pixels
    Max 1D or 2D image array size                 2048 images
    Max 2D image size                             16384x16384 pixels
    Max 3D image size                             4096x4096x4096 pixels
    Max number of read image args                 256
    Max number of write image args                16
  Local memory type                               Local
  Local memory size                               49152 (48KiB)
  Registers per block (NV)                        65536
  Max constant buffer size                        65536 (64KiB)
  Max number of constant args                     9
  Max size of kernel argument                     4352 (4.25KiB)
  Queue properties                                
    Out-of-order execution                        Yes
    Profiling                                     Yes
  Prefer user sync for interop                    No
  Profiling timer resolution                      1000ns
  Execution capabilities                          
    Run OpenCL kernels                            Yes
    Run native kernels                            No
    Kernel execution timeout (NV)                 Yes
  Concurrent copy and kernel execution (NV)       Yes
    Number of async copy engines                  1
  printf() buffer size                            1048576 (1024KiB)
  Built-in kernels                                
  Device Extensions                               cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer

NULL platform behavior
  clGetPlatformInfo(NULL, CL_PLATFORM_NAME, ...)  No platform
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   No platform
  clCreateContext(NULL, ...) [default]            No platform
  clCreateContext(NULL, ...) [other]              Success [NV]
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_DEFAULT)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ACCELERATOR)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CUSTOM)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ALL)  No platform
 

Dernière modification par robert2a (21-01-2018 23:47:02)

Hors ligne

#21 22-01-2018 07:03:54

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS
Noyau : 4.17.7
(G)UI : KDE Plasma 5.13.3
Inscription : 05-03-2014

Re : m.a.j. vers le kernel 4.15 commentaires

Je viens de voir que Linus Torvalds avait décidé d'un 4.15-rc9.
Une rc9 c'est rare ...... On voit que ça turbine au niveau dev kernel ....

https://www.kernel.org/

Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

#22 22-01-2018 09:20:48

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

Bonjour
j'ai vu ça aussi ce matin , tant mieux , il n'en sera que meilleur smile
il est disponible sur kernel.org .

Hors ligne

#23 22-01-2018 14:37:53

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : m.a.j. vers le kernel 4.15 commentaires

suite au petit mot de robert2a , j'ai fait ceci  :

~$ sudo apt-get -s install -t experimental linux-image-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-amd64


[sudo] Mot de passe de alain : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data eclipse-rcp
  fastjar jarwrapper libasm-java libasm3-java libcglib-java
  libcommons-beanutils-java libcommons-cli-java libcommons-compress-java
  libcommons-dbcp-java libcommons-digester-java libcommons-httpclient-java
  libcommons-pool-java libdb-java libdb-je-java libdb5.3-java
  libdb5.3-java-jni libeasymock-java libecj-java libequinox-osgi-java
  libfelix-bundlerepository-java libfelix-gogo-command-java
  libfelix-gogo-runtime-java libfelix-gogo-shell-java libfelix-osgi-obr-java
  libfelix-shell-java libfelix-utils-java libicu4j-4.2-java libicu4j-49-java
  libjetty9-java libjline-java libjtidy-java libkxml2-java liblucene2-java
  libobjenesis-java libosgi-annotation-java libosgi-compendium-java
  libosgi-core-java libserf-1-1 libsvn1 libswt-cairo-gtk-3-jni
  libswt-glx-gtk-3-jni libswt-gnome-gtk-3-jni libswt-gtk-3-java
  libswt-gtk-3-jni libswt-webkit-gtk-3-jni libtomcat8-java python-rope
  python-svn python3-pygments python3-pyqt5.qsci python3-pyqt5.qtsql
  python3-pyqt5.qtsvg python3-pyqt5.qtwebkit sat4j
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  linux-headers-4.15.0-rc8-common linux-kbuild-4.15
Paquets suggérés :
  linux-doc-4.15 debian-kernel-handbook
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.15.0-rc8-amd64 linux-headers-4.15.0-rc8-common
  linux-image-4.15.0-rc8-amd64 linux-kbuild-4.15
0 mis à jour, 4 nouvellement installés, 0 à enlever et 435 non mis à jour.
Inst linux-headers-4.15.0-rc8-common (4.15~rc8-1~exp1 Debian:experimental [all])
Inst linux-kbuild-4.15 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Inst linux-headers-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Inst linux-image-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Conf linux-headers-4.15.0-rc8-common (4.15~rc8-1~exp1 Debian:experimental [all])
Conf linux-kbuild-4.15 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Conf linux-headers-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
Conf linux-image-4.15.0-rc8-amd64 (4.15~rc8-1~exp1 Debian:experimental [amd64])
 



quand même :

0 mis à jour, 4 nouvellement installés, 0 à enlever et 435 non mis à jour.


435 non mis à jour : pas très rassurant .


1498812139.jpg NIGHTWISH - STORYTIME -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#24 22-01-2018 15:06:47

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.16.2
(G)UI : openbox
Inscription : 26-08-2010

Re : m.a.j. vers le kernel 4.15 commentaires

Debian Alain a écrit :

435 non mis à jour : pas très rassurant .



Il suffit peut-être de faire : « apt-get update ; apt-get upgrade » auparavant…


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#25 22-01-2018 17:20:24

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : m.a.j. vers le kernel 4.15 commentaires

non les 435 font partie de experimental ,

0 mis à jour,  => ta buster est a jour

4 nouvellement installés,  => nouveau paquet provenant de experimental a installé (option "-t")

0 à enlever   (c'est réconfortant  lol  )

et 435 non mis à jour.  paquet disponible dans experimental non mit a jour

a priori tu n'a pas activé la ligne pour sid (je l'utilise quand je met quelque chose de experimental , le cas échéant ça récupère des dépendances sur sid )

mais bon c'est un truc de vieux ça tongue

nota: pour sid tu fais peut etre du pinning

Dernière modification par robert2a (22-01-2018 17:22:54)

Hors ligne

Pied de page des forums