Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-11-2009 10:48:28

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

[RESOLU] Esperanto - .Xmodmap

Bonjour a tous !

Voila mon problème :

Je voudrais pouvoir écrire en esperanto (donc [c +^=ĉ], [g+^=ĝ], etc ...) avec ma Debian, je pense qu'il faut modifier mon .Xmodmap.

J'ai lu un article fort bien fait sur le sujet, malheureusement, celui-ci ne semble ne pas fonctionner sur Debian, alors que sur Ubuntu 9.10, tout fonctionne à merveille.

En attendant de trouver une solution complète sous Debian, j'utilise un "Esperanto Toolbar" réalisé par Olivier Faurax.

Voici le contenu de mon .Xmodmap :

# cd /home/monhome
# gedit .Xmodmap
keycode 115 = F13
keycode 30 = u U ubreve Ubreve
keycode 39 = s S scircumflex Scircumflex
keycode 42 = g G gcircumflex Gcircumflex
keycode 43 = h H hcircumflex Hcircumflex
keycode 44 = j J jcircumflex Jcircumflex
keycode 54 = c C ccircumflex Ccircumflex
keycode 115 = Mode_switch


Alors, si un utilisateur Debian a déjà été confronté avec ce problème et a trouvé une solution, peut-il en donner l'explication?

Merci d'aider la communauté Debian.

Dernière modification par vanpatr (05-12-2009 13:20:43)


C'est par ici qu'on va par là!

Hors ligne

#2 15-11-2009 12:19:44

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [RESOLU] Esperanto - .Xmodmap

Salut vanpatr

Ubuntu 9.10 est tirée de la version sid de debian
Il faudrait essayer de mettre à jour ta debian en version squeeze déjà.
Squeeze te propose des paquets plus récents.

Pour mettre à jour ta debian lenny (stable) en version squeeze voici la méthode
Pour se faire tu modifies ton fichier sources.list du genre

# securité
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# main, contrib et non-free
deb http://ftp.fr.debian.org/debian squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian squeeze main contrib non-free


Pour éviter les problèmes utilise aptitude.
Ensuite un

aptitude update


Si tu as une carte nvidia je te conseille d'éxécuter cette commande

aptitude unmarkauto xserver-xorg-video-nv


Edite aussi ton fichier xorg.conf pour remplacer nvidia par nv

Section "Device"

#    Option      "UseDisplayDevice"    "DFP"
     Identifier     "Carte vidéo générique"
     Driver         "nv"
EndSection


Puis

aptitude full-upgrade


On ma conseillé d'utiliser pour squeeze plutôt

aptitude safe-upgrade


full-upgrade est utilisé pour sid
Moi j'ai choisi full-upgrade et ça à fonctionné

Après 22 heures de téléchargement
L'install se lance.

A un moment, tu auras une question concernant le nouveau grub2.
Voici la réponse sur cette discussion http://debian-facile.org/forum/viewtopic.php?id=1919

Une fois installée et tout configurée correctement, tu vas enfin pouvoir tester ta nouvelle debian "Squeeze"

Et pour finir, si tu as une carte nvidia ; pour l'installer correctement jettes un oeuil sur ce lien
http://debian-facile.org/forum/viewtopic.php?id=1924

Bon courage !
damien


logo_3dminfographie_signature.png

Hors ligne

#3 15-11-2009 13:51:56

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : [RESOLU] Esperanto - .Xmodmap

Bonjour Damien,

Merci pour ta longue et prompte réponse, mais elle me fait hésiter, pas que j'ai peur d'entreprendre une mise à jour vers Squeeze; je serais même prêt à passer vers Sid (L'enfant qui casse les jouets);

En effet, j'ai une partition opérationelle avec ubuntu 9.10, Il y a peut-être une autre solution, réponse, et je la cherche!!

Que va m'apporter cette version Debian qui fera que le problème sera résolu, autrement-dit, d'où vient le problème?

J'essaye de comprendre pourquoi ce problème sous Debian, afin d'essayer de re-trouver l'environnement dont j'ai besoin et ne pas être dépendant de solution toute faite.

Si cela continue Ubuntu va ressembler à windows, c'est peut-être une bonne solution pour la majorité des utilisateurs, mais perso, je préfère essayer de comprendre le dessous ... des cartes.

C'est mon credo, que penses-tu de m'a réflexion, peux-tu m'aider dans ce sens?

Merci d'avance pour la poursuite de ton aide.

@+

C'est par ici qu'on va par là!

Hors ligne

#4 15-11-2009 21:16:57

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [RESOLU] Esperanto - .Xmodmap

Salut vanpatr

Je te proposais la version testing car elle bénéficie de paquets plus récent.
De plus ce sera la prochaine version stable de debian.

Il faudrait que tu puisse trouver le paquet qui correspond à ce que tu recherche.
Peut-être q'une simple installation de gedit en version squeeze peux suffire ? Je n'en saiis rien du tout.
Tu peux donc rester en version lenny (stable).
Il suffit juste d'installer le paquet qui t'intéresse tirés des dépôts squeeze.
Voici donc l'utilité du fichier preferences wink

Je suis d'accord avec toi sur le fait que ubuntu se windowsifie de plus en plus surtout l'environnement KDE.
Je ne veux pas non plus casser KDE, mais il mon vraiment déçu avec leur dernier Amarok (Version 2)
Un vrai programme windowsifié comme je n'aime pas.
Su ces belles paroles...
A chao, Bonsoir

logo_3dminfographie_signature.png

Hors ligne

#5 16-11-2009 03:36:52

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [RESOLU] Esperanto - .Xmodmap

Salut

Si je comprends bien tu cherches à avoir une disposition du clavier te permettant d'écrire en esperanto. Pour le moment, tu as seulement trouvé quelque chose pour Iceweasel (Firefox). La méthode utilisant le fichier .Xmodmap ne semble pas fonctionner je suis d'accord avec toi pour dire qu'il faut trouver la source du problème. Je ne connais pas la solution. Par contre, mes recherches m'ont amené à trouver le paquet keyboards-rg
qui permettrait d'avoir une disposition du clavier pour l'esperanto. J'écris permettrait car je ne connais pas ce paquet je ne ce n'est pas si on peut l'utiliser facilement. En tout cas, c'est une piste à explorer. Une simulation avec aptitude pour installer ce paquet n'ajoute rien d'autre. Donc pas trop de problème pour tester le truc. Dans le cas où cela fonctionne, il y aura probablement à faire un dpkg-reconfigure locales pour choisir eo.utf8. Bien sûr, encore une fois, ce n'est que des suppositions.

Sinon, il faut fouiller pour savoir de quoi il en retourne de Xmpdmad avec Debian. À moins que quelqu'un passant par ici sache déjà la réponse.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 18-11-2009 04:17:52

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : [RESOLU] Esperanto - .Xmodmap

Bonjour, damien, martin_mtl,

Merci déjà pour votre aide.
Je ne manquerai pas d'explorer vos pistes dès que possible.
Evidemment, je ferai part ici de mes trouvailles éventuelles!

@+

C'est par ici qu'on va par là!

Hors ligne

#7 18-11-2009 07:42:15

le_fada
Membre
Lieu : Toujours à l'ouest
Distrib. : Sid «ad vitam æternam»
Noyau : 2.6.33-amd64
(G)UI : gnome-shell
Inscription : 23-09-2009

Re : [RESOLU] Esperanto - .Xmodmap

Salut,

cette page, en Anglais, peux peut-être t'aider. En bas de page on y propose des fichiers .xmodmap pour le Grec et l'Esperanto.

Esperanto layout

Hors ligne

#8 05-12-2009 13:20:11

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : [RESOLU] Esperanto - .Xmodmap

Bonjour,

J'ai trouvé, c'était bêtement, une mauvaise lecture de l'explication donnée sur le lien "article" actuellement mort, dès que je le retrouve ou un similaire, je corrige!

Avec la touche compose (windows gauche) entre le "Ctrl" et "Alt" à gauche de la barre d'espace, on obtient : pour les minuscules, ŭ ŝ ĝ ĥ ĵ ĉ et pour les majuscules "Shift-Lock" enfoncée, Ŭ Ŝ Ĝ Ĥ Ĵ Ĉ.

Si quelqu'un n'a pas compris, il peut me demander, je ré-expliquerai!

Donc pour moi c'est [RESOLU].

@+

C'est par ici qu'on va par là!

Hors ligne

Pied de page des forums