Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-01-2018 13:16:51

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

[Résolu] m.a.j. kdepim-themeeditors

bonjour tout le monde et bonne  année .

j'ai un petit souci avec un paquet de kde  que apt ne veut pas mettre à jour :

voilà mes commandes mais pourriez vous m'expliquer cela  ?

à défaut de résoudre le problème .

c'est pas très grave mais j'aime bien avoir une machine à jour .

je suis sous buster / sid bureau gnome 3.26.2 et je vais parfois  sur plasma .

~$ sudo apt update


[sudo] Mot de passe de alain-buster : 
Atteint:1 http://ftp.fr.debian.org/debian testing InRelease
Atteint:2 http://ftp.fr.debian.org/debian testing-updates InRelease            
Atteint:3 http://security.debian.org testing/updates InRelease                
Atteint:4 http://ftp.fr.debian.org/debian unstable InRelease                
Atteint:5 http://ftp.fr.debian.org/debian experimental InRelease            
Lecture des listes de paquets... Fait                          
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 package can be upgraded. Run 'apt list --upgradable' to see it.



~$ sudo apt list --upgradable


En train de lister... Fait
kdepim-themeeditors/testing,unstable 4:17.08.3-1 amd64 [upgradable from: 4:16.04.3-4]
N: There is 1 additional version. Please use the '-a' switch to see it



~$ sudo apt list --upgradable -a


En train de lister... Fait
kdepim-themeeditors/testing,unstable 4:17.08.3-1 amd64 [upgradable from: 4:16.04.3-4]
kdepim-themeeditors/now 4:16.04.3-4 amd64 [installed,upgradable to: 4:17.08.3-1]



~$ sudo apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  kdepim-themeeditors
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

Dernière modification par Debian Alain (12-01-2018 12:54:44)


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#2 10-01-2018 15:50:26

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] m.a.j. kdepim-themeeditors

Salut
çà donne quoi ?

apt policy kdepim-themeeditors


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 10-01-2018 17:05:49

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

merci pour ton aide croutons :

~$ apt policy kdepim-themeeditors


kdepim-themeeditors:
  Installé : 4:16.04.3-4
  Candidat : 4:17.08.3-1
 Table de version :
     4:17.08.3-1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
 *** 4:16.04.3-4 100
        100 /var/lib/dpkg/status


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#4 10-01-2018 19:04:32

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] m.a.j. kdepim-themeeditors

regarde si il serait pas marqué hold

apt-mark showhold


man apt-mark a écrit :

hold
           hold permet de marquer un paquet comme retenu, ce qui empêchera qu'il soit installé, mis à jour ou supprimé
           automatiquement.

unhold
           unhold est utilisé pour supprimer l'état « hold » (retenu) d'un paquet afin de permettre toute action qui y
           est liée.

Dernière modification par Croutons (10-01-2018 19:06:25)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 10-01-2018 19:16:06

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

salut ,

ben apparemment non , le paquet n'est pas  "hold" .
il ne semble pas y en avoir dans mon systeme .

~$ apt-mark showhold


bloc à supprimer si la commande n’affiche rien


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#6 10-01-2018 19:24:11

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] m.a.j. kdepim-themeeditors

oui moi pareil pas de hold
étrange c'est pourtant bien la version candidat
regarde si ça mettrait pas a jour avec

apt full-upgrade


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 10-01-2018 19:28:06

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

re -

regarde :

~$ sudo apt full-upgrade


[sudo] Mot de passe de alain-buster : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  kdepim-themeeditors
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#8 10-01-2018 19:44:02

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] m.a.j. kdepim-themeeditors

man apt-get a écrit :

--with-new-pkgs
           Cette commande permet d'installer de nouveaux paquets lorsqu'elle est utilisée en conjonction avec la
           commande upgrade. C'est utile si la mise à jour d'un paquet installé exige l'installation de nouveaux
           paquets. Plutôt que de conserver le paquet, upgrade mettra à jour le paquet et installera les nouvelles
           dépendances. Remarquez que la commande upgrade avec cette option ne retirera jamais de paquets : elle ne
           permettra que l'ajout de nouveaux. Élément de configuration : APT::Get::Upgrade-Allow-New.


apt-get upgrade --with-new-pkgs


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 10-01-2018 19:50:32

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

salut croutons  ,

ben tu va pas me  croire :

# apt-get upgrade --with-new-pkgs


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  kdepim-themeeditors
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#10 10-01-2018 20:11:55

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] m.a.j. kdepim-themeeditors

lol
Je ne sais plus trop, tu as peut être une configuration particulière

https://debian-facile.org/doc:systeme:apt:apt.conf

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 10-01-2018 20:23:23

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

salut croutons ,

ben , je me suis pas trop cassé la nénette .

c'est une vieille installation (enfin ,vieille ...) qui date de ma précédente config .

asus P8Z77 VLX et I7 2600

vieille bête mais il fonctionnait très bien .

jusqu'au jour où ...

paix à son âme .

à l'époque , j'avais installé stretch avec tous les bureaux puis ensuite passé à buster , et , donc , gardé les bureaux .

je me sers très peu de plasma . plus par  curiosité . d'ordinaire , je suis plutôt gnome (3.26.2 actuellement)

mais parfois , pour aider ou pour comprendre quelqu'un , j'utilise un de mes bureaux .

mais sur tes  conseils , je veux bien le désinstaller , si tu le juges pertinent .

plasma , je m'en sers très peu . donc ....

j'ai trouvé ceci  : désinstallation de plasma

j'attends ton avis .

Dernière modification par Debian Alain (10-01-2018 20:33:16)


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#12 10-01-2018 20:32:02

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] m.a.j. kdepim-themeeditors

a oui non je voulais dire configuration de apt particulière
Des fois sur des paquets ou il y a un probleme il y a le message le paquet est conservé en état essai avec l'option -f et retente un upgrade

apt-get install -f


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#13 10-01-2018 20:37:13

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

~$ sudo apt install -f


[sudo] Mot de passe de alain-buster : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.



~$ sudo apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  kdepim-themeeditors
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.



~$ uname -a


Linux Alain-PC-BUSTER 4.14.12-amd64 #1 SMP Fri Jan 5 19:58:58 CET 2018 x86_64 GNU/Linux


j'espère que tu n'y verras pas malice de ma part .

Dernière modification par Debian Alain (10-01-2018 20:43:50)


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

#14 12-01-2018 12:53:51

Debian Alain
Adhérent(e)
Lieu : BREST 29200
Distrib. : W$10 1709 / stretch / ubuntu 17.10 / buster-sid
Noyau : Linux 4.14.13-amd64 #1 (patché)
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017

Re : [Résolu] m.a.j. kdepim-themeeditors

bonjour à tous .

j'ai fait ce que je ne voulais pas .

c.a.d. désinstaller le paquet et le réinstaller à la main .

j'aurai préféré  que apt s'en charge mais il n'a pas  voulu .

donc :

# apt remove --purge kdepim-themeeditors


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  kdepim-themeeditors*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 957 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 531671 fichiers et répertoires déjà installés.)
Suppression de kdepim-themeeditors (4:16.04.3-4) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.26-2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11) ...
root@Alain-PC-BUSTER:/home/alain-buster# apt update
Atteint:1 http://ftp.fr.debian.org/debian testing InRelease
Atteint:2 http://ftp.fr.debian.org/debian testing-updates InRelease            
Atteint:3 http://security.debian.org testing/updates InRelease                
Atteint:4 http://ftp.fr.debian.org/debian unstable InRelease  
Atteint:5 http://ftp.fr.debian.org/debian experimental InRelease
Lecture des listes de paquets... Fait                          
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
All packages are up to date.
 



# apt full-upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@Alain-PC-BUSTER:/home/alain-buster# apt policy kdepim-themeeditors
kdepim-themeeditors:
  Installé : (aucun)
  Candidat : 4:17.08.3-1
 Table de version :
     4:17.08.3-1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages



# apt install kdepim-themeeditors


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  kdepim-doc
Les NOUVEAUX paquets suivants seront installés :
  kdepim-themeeditors
0 mis à jour, 1 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/227 ko dans les archives.
Après cette opération, 3 401 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
(Lecture de la base de données... 531660 fichiers et répertoires déjà installés.)
Suppression de kdepim-doc (4:16.04.3-4) ...
Sélection du paquet kdepim-themeeditors précédemment désélectionné.
(Lecture de la base de données... 531472 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../kdepim-themeeditors_4%3a17.08.3-1_amd64.deb ...
Dépaquetage de kdepim-themeeditors (4:17.08.3-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.26-2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11) ...
Paramétrage de kdepim-themeeditors (4:17.08.3-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.26-2) ...



# apt policy kdepim-themeeditors


kdepim-themeeditors:
  Installé : 4:17.08.3-1
  Candidat : 4:17.08.3-1
 Table de version :
 *** 4:17.08.3-1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status



voilà , c'est fait .

merci les gars .


1515092778.jpg 1498812139.jpg Bip ! Bip ! 
- AMD RYZEN7 1700X - ASUS PRIME X370 PRO - 2 X 8 Go DDR4 VENGEANCE LPX - SAPPHIRE RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X -

Hors ligne

Pied de page des forums