Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-11-2009 22:08:24

gustave
Membre
Distrib. : Debian
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 01-04-2009

passer de lenny a squeze

Bonjour, avez vous un sources list et un préférence pour un ordi portable récents Hp 6730.
Ca fonctionne bien sauf la connexion ,wifi aprés la veille ou au premier demmarage. Je pense que ce serait un probleme difficile a resoudre, mon fichier interfaces et hosts ou rersolv sont bon, enfin ils n'ont pas changer depuis que j'ai ce probleme. Donc upgrader peut peu etre resoudre ca ?

Hors ligne

#2 17-11-2009 22:41:06

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : passer de lenny a squeze

Salut gustave smile

Pour passer de lenny à squeeze ; tu dois modifier ton fichier sources.list comme celui-là

# securité
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# main, contrib et non-free
deb http://ftp.fr.debian.org/debian squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian squeeze main contrib non-free


Pour éviter certains problèmes de dépendences et de paquets cassés je te conseille d'utiliser aptitude.

Pour mettre à jour la listes des paquets

aptitude update


Si tu as une carte nvidia je te conseille d'éxécuter cette commande

aptitude unmarkauto xserver-xorg-video-nv


Edite aussi ton fichier xorg.conf pour remplacer nvidia par nv

Section "Device"

#    Option      "UseDisplayDevice"    "DFP"
     Identifier     "Carte vidéo générique"
     Driver         "nv"
EndSection


Puis tu lances la mises à jour avec cette commande

aptitude full-upgrade


Pour squeeze, on m'a conseillé d'utiliser aptitude safe-upgrade

full-upgrade est plus utilisé pour sid
Moi j'ai choisi full-upgrade et ça à fonctionné

Après 22 heures de téléchargement l'install se lance.
Il faut être patient wink

A un moment, tu auras une question concernant le nouveau grub2.
Voici la réponse sur cette discussion http://debian-facile.org/forum/viewtopic.php?id=1919

Une fois installé et tout configuré correctement, tu vas enfin pouvoir tester ta nouvelle debian "Squeeze"

Pour finir, si tu as une carte nvidia tu peux jeter un oeuil sur ce lien
http://debian-facile.org/forum/viewtopic.php?id=1924

Franchement tu ne seras pas déçu de la dernière version testing "Squeeze" de debian.

En espérant que squeeze trouev une solution à ton soucis de wifi.

Si toutefois ta carte wifi ne fonctionne toujours pas, tu peux compiler le pilote windows.
Il éxiste un outil fort intéressant qui te permet d'éviter une bonne partie de ligne de commande

aptitude install ndisgtk


Si avec ndisgtk ça ne fonctionne toujours pas alors j'ai écrit une explication sur le wiki pour compiler le pilote windows avec ndiswrapper
http://debian-facile.org/wiki/manuel:nd … diswrapper

Bon courage !

damien


logo_3dminfographie_signature.png

Hors ligne

#3 18-11-2009 03:57:06

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : passer de lenny a squeze

Salut

Il se peut que le passage à testing règle ton problème. Mais peut-être que non.

Tu dis que certains fichiers n'ont pas été modifiés depuis que tu as ce problème. Faut-il comprendre que le wifi a bien fonctionné avant. Ta carte wifi est bien reconnue ? La commande # ifconfig le montre bien ? Des renseignements nous indiquant quelle sorte de carte exactement aiderais à y voir plus claire. Il se peut que la version du firmware dans testing soit la solution mais sans trop de détails difficile à savoir.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#4 18-11-2009 21:01:42

gustave
Membre
Distrib. : Debian
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 01-04-2009

Re : passer de lenny a squeze

Merci Damien, c'est bien entendu pas plus compliqué que ca.
Je fait un nouveau sujet pour mon probleeme reseau, c'est pas normal de penser faire un upgrade pour regler un problme de ce type, c'est en fait mon reseau local auquel je n'ai plus acces, le wifi ne me pose plus de probleme, ca devait etre passager et du coup plus acces au routeur 192.168.0.1 ni au 192.168.0.33 (apache d'un autre pc), si je fait un restart networking ca remarche, par contre plus de probleme wifi. donc connexion internet fonctionne.

Dernière modification par gustave (18-11-2009 21:05:33)

Hors ligne

#5 29-11-2009 16:07:00

gustave
Membre
Distrib. : Debian
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 01-04-2009

Re : passer de lenny a squeze

Est-ce normal ?
Vous faites Y/N dans ce cas ?

Les paquets suivants seront ENLEVÉS :
  app-install-data{u} arj{u} brasero-common{u} cdrdao{u} cheese{u}
  dhcdbd{u} djvulibre-desktop{u} dmz-cursor-theme{u} dvd+rw-tools{u}
  ekiga{u} eog{u} evince{u} evolution-exchange{u}
  fast-user-switch-applet{u} file-roller{u} gcalctool{u} gconf-editor{u}
  gdm{u} gdm-themes{u} gedit{u} gedit-common{u} genisoimage{u}
  gnome-backgrounds{u} gnome-cards-data{u} gnome-core{u} gnome-games{u}
  gnome-games-data{u} gnome-nettool{u} gnome-power-manager{u}
  gnome-screensaver{u} gnome-spell{u} gnome-system-tools{u} gnome-themes{u}
  gnome-themes-extras{u} gnome-vfs-obexftp{u} gnome-volume-manager{u}
  gnuchess{u} gstreamer0.10-gnomevfs{u} gstreamer0.10-tools{u}
  gtk2-engines{u} gtk2-engines-pixbuf{u} gucharmap{u} guile-1.8-libs{u}
  libavahi-compat-libdnssd1{u} libavahi-core5{u} libavahi-ui0{u}
  libbeagle1{u} libbluetooth2{u} libbrasero-media0{u} libcamel1.2-11{u}
  libcdio7{u} libcucul0{u} libcupsys2{u} libdirectfb-1.0-0{u} libdmx1{u}
  libdvdread3{u} libedataserver1.2-9{u} libeel2-2.20{u} libeel2-data{u}
  libepc-1.0-1{u} libepc-ui-1.0-1{u} libfaad0{u} libfreebob0{u}
  libgail-common{u} libgalago3{u} libgda3-3{u} libgda3-common{u}
  libgksu1.2-0{u} libgksuui1.0-1{u} libgmime-2.4-2{u} libgnome-desktop-2{u}
  libgnome2-canvas-perl{u} libgnome2-perl{u} libgnome2-vfs-perl{u}
  libgnomecups1.0-1{u} libgnomeprint2.2-0{u} libgnomeprint2.2-data{u}
  libgnomeprintui2.2-0{u} libgnomeprintui2.2-common{u} libgnomevfs2-bin{u}
  libgpod-common{u} libgpod3{u} libgpod4{u} libgraphviz4{u}
  libgtk-vnc-1.0-0{u} libgtkhtml2-0{u} libgtksourceview-common{u}
  libgtksourceview1.0-0{u} libgtksourceview2.0-0{u}
  libgtksourceview2.0-common{u} libgucharmap6{u} libhesiod0{u} libicu38{u}
  libilmbase6{u} liblircclient0{u} libltdl3{u} libmagick++10{u}
  libmagick10{u} libmalaga7{u} libmpcdec3{u} libmtp7{u} libmtp8{u}
  libnautilus-burn4{u} libneon27-gnutls{u} libnm-util0{u} libopal-2.2{u}
  libopenexr6{u} libopenobex1{u} libparted1.8-10{u} libpoppler-glib3{u}
  libpoppler3{u} libpt-1.10.10{u} libpt-1.10.10-plugins-alsa{u}
  libpt-1.10.10-plugins-v4l{u} libraw1394-8{u} libsensors3{u}
  libsgutils2-2{u} libsmbios2{u} libsoup2.2-8{u} libsuitesparse-3.1.0{u}
  libswfdec-0.6-90{u} libtalloc1{u} libtotem-plparser10{u}
  libtotem-plparser12{u} libtrackerclient0{u} libx264-65{u}
  libxalan2-java{u} libxalan2-java-gcj{u} libxerces2-java{u}
  libxerces2-java-gcj{u} libzephyr3{u} lsb-release{u} nautilus{u}
  nautilus-data{u} openoffice.org-style-andromeda{u}
  openoffice.org-writer2latex{u} openssl-blacklist{u} p7zip{u}
  pkg-config{u} python-4suite-xml{u} python-eggtrayicon{u}
  python-evolution{u} python-gdata{u} python-gdbm{u}
  python-gnome2-desktop{u} python-gnome2-extras{u} python-gnomeprint{u}
  python-gnupginterface{u} python-gst0.10{u} python-gtkhtml2{u}
  python-gtkmozembed{u} python-gtksourceview{u} python-gtksourceview2{u}
  python-gtop{u} python-mediaprofiles{u} python-metacity{u}
  python-nautilusburn{u} python-notify{u} python-numeric{u}
  python-pkg-resources{u} python-rdflib{u} python-rsvg{u} python-sexy{u}
  python-totem-plparser{u} python-vte{u} python-xdg{u} rhythmbox{u}
  seahorse{u} serpentine{u} sound-juicer{u} svgalibg1{u} swfdec-gnome{u}
  system-config-printer{u} totem-common{u} totem-gstreamer{u}
  totem-mozilla{u} totem-plugins{u} transmission-common{u}
  transmission-gtk{u} unzip{u} update-notifier-common{u} vinagre{u} vino{u}
  wodim{u} zip{u}

Hors ligne

#6 29-11-2009 16:48:29

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : passer de lenny a squeze

Bjr,
Perso je dis non.
Met ton sources.list ici qu'on regarde

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 29-11-2009 19:36:08

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : passer de lenny a squeze

Salut Gustave !

Peux-tu retourner les autres infos que aptitude safe-upgarde te propose.
Il ne fait pas que enlever des paquets. Il doit en installer aussi.

@+

damien

logo_3dminfographie_signature.png

Hors ligne

#8 29-11-2009 20:11:05

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : passer de lenny a squeze

Salut

On dirait que cela ressemble à des paquets automatiquement installés qui "deviendrait" inutiles parce qu'un méta-paquet, gnome ou gnome-desktop-environment à été enlevé. Si c'est le cas, tu peux soit installer le méta-paquet manquant soit passer tous les paquets que tu désires garder en manuellement installés. Un aptitude show le_paquet permet de voir facilement si un paquet est automatiquement installé ou non.

Ce message c'est à la suite d'un aptitude safe-upgrade ou d'un aptitude full-upgrade ?

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 29-11-2009 21:20:37

gustave
Membre
Distrib. : Debian
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 01-04-2009

Re : passer de lenny a squeze

c'est bien en faisant "aptitude safe-upgrade"


# securité
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# main, contrib et non-free
deb http://ftp.fr.debian.org/debian squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian squeeze main contrib non-free


aptitude safe-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Résolution des dépendances...
Résolution des dépendances...
Les NOUVEAUX paquets suivants vont être installés :
  ghostscript-cups{a}
Les paquets suivants seront ENLEVÉS :
  gnome-spell{u} gnome-themes-extras{u} gnome-vfs-obexftp{u}
  gnome-volume-manager{u} libavahi-compat-libdnssd1{u} libavahi-core5{u}
  libbluetooth2{u} libcamel1.2-11{u} libcdio7{u} libcucul0{u} libcupsys2{u}
  libdecoration0{u} libdirectfb-1.0-0{u} libdvdread3{u}
  libedataserver1.2-9{u} libeel2-2.20{u} libeel2-data{u} libepc-1.0-1{u}
  libepc-ui-1.0-1{u} libfaad0{u} libfreebob0{u} libgda3-3{u}
  libgda3-common{u} libgksu1.2-0{u} libgksuui1.0-1{u} libgnome-desktop-2{u}
  libgnomecups1.0-1{u} libgnomeprint2.2-0{u} libgnomeprint2.2-data{u}
  libgnomeprintui2.2-0{u} libgnomeprintui2.2-common{u} libgnomevfs2-bin{u}
  libgpod-common{u} libgpod3{u} libgpod4{u} libgraphviz4{u}
  libgtkhtml2-0{u} libgtksourceview-common{u} libgtksourceview1.0-0{u}
  libgucharmap6{u} libhesiod0{u} libicu38{u} libilmbase6{u} libltdl3{u}
  libmagick++10{u} libmagick10{u} libmalaga7{u} libmpcdec3{u} libmtp7{u}
  libmtp8{u} libnautilus-burn4{u} libneon27-gnutls{u} libnm-util0{u}
  libopal-2.2{u} libopenexr6{u} libparted1.8-10{u} libpoppler-glib3{u}
  libpoppler3{u} libpt-1.10.10{u} libpt-1.10.10-plugins-alsa{u}
  libpt-1.10.10-plugins-v4l{u} libraw1394-8{u} libsensors3{u}
  libsgutils2-2{u} libsmbios2{u} libsoup2.2-8{u} libsuitesparse-3.1.0{u}
  libswfdec-0.6-90{u} libtalloc1{u} libtotem-plparser10{u} libx264-65{u}
  libxalan2-java{u} libxalan2-java-gcj{u} libxerces2-java{u}
  libxerces2-java-gcj{u} libzephyr3{u} lsb-release{u}
  openoffice.org-style-andromeda{u} openoffice.org-writer2latex{u}
  openssl-blacklist{u} p7zip{u} python-4suite-xml{u} python-eggtrayicon{u}
  python-gnome2-desktop{u} python-gnome2-extras{u} python-gnomeprint{u}
  python-gnupginterface{u} python-gtkhtml2{u} python-gtkmozembed{u}
  python-gtksourceview{u} python-gtop{u} python-mediaprofiles{u}
  python-metacity{u} python-nautilusburn{u} python-numeric{u}
  python-rsvg{u} python-sexy{u} python-totem-plparser{u} python-vte{u}
  serpentine{u} svgalibg1{u} system-config-printer{u}
  transmission-common{u} transmission-gtk{u} unzip{u}
  update-notifier-common{u} zip{u}
Les paquets suivants seront mis à jour :
  cups-driver-gutenprint
1 paquets mis à jour, 1 nouvellement installés, 107 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 042ko d'archives. Après dépaquetage, 162Mo seront libérés.
Voulez-vous continuer ? [Y/n/?] n

Hors ligne

#10 29-11-2009 21:32:26

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : passer de lenny a squeze

Salut

Et si tu fais un aptitude -s full-upgrade ?

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#11 29-11-2009 22:06:07

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : passer de lenny a squeze

re-
et aussi comparer avec un apt-get -s (si c'était utilisé avant)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#12 29-11-2009 22:22:54

gustave
Membre
Distrib. : Debian
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 01-04-2009

Re : passer de lenny a squeze

Oui en général j'utilise

apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  cups-driver-gutenprint
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

Hors ligne

#13 30-11-2009 14:18:36

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : passer de lenny a squeze

Perso je dirais oui. S'il doit les supprimer qu'il le fasse.
Ensuite il devrait réinstaller tous les nouveaux paquets de squeeze.
Comme dit martin essaie l'otion -s
En fait un full-upgrade ne serait pas plus mal.

aptitude -s full-upgrade


@+

damien


logo_3dminfographie_signature.png

Hors ligne

#14 30-11-2009 14:42:38

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : passer de lenny a squeze

re-
Je ne veux pas aller contre ce qui a été indiqué plus haut, mais pourquoi utiliser aptitude quand il est pratiquement prouvé qu'il y a des différences de gestion avec apt-get ? et que dans ce cas il faut qu'aptitude reprenne la main en générant sa propre liste de dépendances.
Est-ce que certaines dépendances dans squeeze n'auraient pas changé de nom depuis lenny ? ce qui empêcherait un upgrade direct pour certains paquets ?
On peut aussi copier/coller en texte la liste des paquets "à enlever d'aptitude", faire le dist-upgrade, et refaire un aptitude install "liste des paquets" : une façon de voir ce qui cloche.
Et toujours le même conseil : dist-upgrade en recovery = beaucoup moins de services démarrés et  de tout façon il faudra rebooter

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

Pied de page des forums