Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-01-2018 19:23:16

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-1-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017
Site Web

[Clos] EDIs

bonsoir , big_smile

connaissez vous ces deux IDE que sont Eclipse et Eric ? scratchhead.gif

et que pouvez vous m'en dire ?

si mon post n'est pas au bon endroit , vous pouvez le déplacer .

merci.

~$ apt policy eclipse eric


eclipse:
  Installé : (aucun)
  Candidat : 3.8.1-10
 Table de version :
     3.8.1-10 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
eric:
  Installé : (aucun)
  Candidat : 17.11.1-1
 Table de version :
     17.11.1-1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
 



le wiki sur eclipse

ce que j'ai trouvé en français  sur Eric (non fiable (ubuntu))

Dernière modification par Debian Alain (26-01-2018 20:22:12)


1498812139.jpg Live is Life - Opus 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#2 23-01-2018 19:00:24

David5647
Membre
Distrib. : Debian Buster
Noyau : 4.17.0-3-amd64
(G)UI : KDE
Inscription : 27-08-2017

Re : [Clos] EDIs

mmmh,

j'ai brièvement essayé eric,,
j'ai trouvé que ça faisait un peu usine à gaz,
il y a des options dans tous les sens, l'interface est assez chargée (et je n'ai pas vraiment réussi à la configurer en fait)
cet IDE propose surement un environnement adapté au plus aguerris,
étant assez novice,
je m'y retrouve mieux avec un IDE plus simple spyder qui est plus facilement configurable et propose une console Ipython,

après les IDE faut essayer,
ça dépend de ce que tu veux faire/ de ton niveau
j'exagère un peu mais, idle peut parfois suffire smile

En ligne

#3 23-01-2018 19:03:36

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-1-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017
Site Web

Re : [Clos] EDIs

non , non , tu n'exagères pas .

pour avoir un peu essayé avec du perl , je sais que idle peut parfois suffire .

comparatifs pour python

quel IDE pour python ?

eclipse aussi , avec Pydev , permet de faire du python . enfin , je crois .

tout compte fait , pour du python , geany est suffisant . et même très bien .

~$ sudo apt policy eclipse eric geany


[sudo] Mot de passe de alain : 
eclipse:
  Installé : (aucun)
  Candidat : 3.8.1-10
 Table de version :
     3.8.1-10 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        500 http://ftp.fr.debian.org/debian testing/main i386 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
eric:
  Installé : (aucun)
  Candidat : 17.11.1-1
 Table de version :
     17.11.1-1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        500 http://ftp.fr.debian.org/debian testing/main i386 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
geany:
  Installé : 1.32-2
  Candidat : 1.32-2
 Table de version :
 *** 1.32-2 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par Debian Alain (24-01-2018 12:02:35)


1498812139.jpg Live is Life - Opus 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

Pied de page des forums