Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-11-2009 20:58:42

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

[Résolu] Downgrader xmms

Bonjour,

Je voudrais essyer d'installer xmms mais en version 1.2.11-1
Depuis lenny le paquet xmms est devenu xmms2
cf. http://debian-facile.org/wiki/logiciel:xmms
J'ai donc installé xmms version 1.2.11-1 en suivant la procédure comme indiqué sur le wiki

Donc voilà ce que je compte faire

1- Retirer xmms

aptitude remove xmms


2- Ajouter les dépots oldstable au fichier sources.list comme ci-dessous

## etch
# main, contrib et non-free
deb http://ftp.fr.debian.org/debian etch main contrib non-free
deb-src http://ftp.fr.debian.org/debian etch main contrib non-free


## lenny
# main, contrib et non-free
deb http://ftp.fr.debian.org/debian lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian lenny main contrib non-free

## squeeze
# securité
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# main, contrib et non-free
deb http://ftp.fr.debian.org/debian squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian squeeze main contrib non-free

## sid
# main, contrib et non-free
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free


3- Ecrire le fichier preference comme ceci

Package: *
Pin: release a=testing
Pin-priority: 900

Package: *
Pin: release a=unstable
Pin-priority: 90

Package: *
Pin: release a=stable
Pin-priority: 90

Package: *
Pin: release a=oldstable
Pin-priority: 90


4- Puis pour finir installer le paquet xmms des dépôts oldstable

aptitude install -t oldstable xmms


Est-ce correct comme méthode ?
Merci


logo_3dminfographie_signature.png

Hors ligne

#2 22-11-2009 04:17:30

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Downgrader xmms

Salut damien

Pour moi ta méthode est correcte. L'entrée pour oldstable dans le fichier preférences m'apparaît inutile. Comme tu es en testing, les paquets dans la branche oldstable ne seront pas installés lors d'une mise à jour (j'aimerais bien savoir la priorité par défaut de oldstable, donc sans rien mentionner dans le preferences, avec un apt-cache policy).Pour te rassurer tu peux malgré tout mettre ton fichier prefereces comme indiqué. Tu peux aussi toujours faire une simulation avant d'installer pour vrai.

Si tu désires prendre seulement xmms dans oldstable, les dépôts contrib et non-free ne sont pas nécessaires.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 22-11-2009 10:28:38

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Downgrader xmms

Salut Martin

J'avais oublié d'ajouter dans ma méthode entre 3 et 4 de faire un

aptitude update


Sauf que lorsque je lance l'update il me met un message d'erreur

Lecture des listes de paquets... Erreur !          
E: La zone dynamique d'allocation mémoire (« Dynamic MMap ») n'a plus de place. Vous devriez augmenter la taille de APT::Cache-Limit, dont la valeur actuelle est de 25165824 (voir « man 5 apt.conf »).
E: Erreur apparue lors du traitement de libcurl3-gnutls (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_sid_main_binary-i386_Packages
W: Unable to munmap
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.
E: Impossible de reconstruire le cache des paquets
E: La zone dynamique d'allocation mémoire (« Dynamic MMap ») n'a plus de place. Vous devriez augmenter la taille de APT::Cache-Limit, dont la valeur actuelle est de 25165824 (voir « man 5 apt.conf »).
E: Erreur apparue lors du traitement de libcurl3-gnutls (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_sid_main_binary-i386_Packages
W: Unable to munmap
E: Les listes de paquets ou le fichier d'état ne peuvent pas être ouverts, ou sont incompréhensibles.

E: La zone dynamique d'allocation mémoire (« Dynamic MMap ») n'a plus de place. Vous devriez augmenter la taille de APT::Cache-Limit, dont la valeur actuelle est de 25165824 (voir « man 5 apt.conf »).
E: Erreur apparue lors du traitement de libcurl3-gnutls (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_sid_main_binary-i386_Packages
W: Unable to munmap
E: Les listes de paquets ou le fichier d'état ne peuvent pas être ouverts, ou sont incompréhensibles.


Oups je ne peus même plus rien installer.
Je reviens donc en arrière pour le moment.


logo_3dminfographie_signature.png

Hors ligne

#4 23-11-2009 02:40:11

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Downgrader xmms

Salut

Le problème de "Dynamic MMap ran out of room" est un problème connu dont la solution se trouve assez facilement sur le web. On a même évoqué récemment ce problème ici sur le forum : voir . En gros, ce message signifie que la base de données apt est configurée trop petite pour gérer tous les paquets auxquels debian a accès. Une manière de résoudre ce problème est d'en augmenter la taille, d'où le APT::Cache-Limit 141943904

On peut arriver au même résultat avec la commande suivante :

echo 'APT::Cache-Limit 141943904;' >> /etc/apt/apt.conf.d/00configperso


Au lieu d'ajouter une ligne dans le apt.conf on crée un nouveau fichier dans /etc/apt/apt.conf.d. En bout de ligne le résultat est le même.

Il serait bon de mettre cette astuce dans le wiki tiens.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 23-11-2009 20:26:41

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Downgrader xmms

Salut martin_mtl

Merci pour cette petite astuce qui mériterait une explication dans le wiki
Mon sources.list fonctionne sauf que lorsque je veux installer xmms avec cette commande

aptitude install -t oldstable xmms


il me dit qu'il veux installer la version oldstable de libglib1.2-dev, libgtk1.2 & libglib1.2ldbl
J'ai donc downgrader ces librairies en version oldstable.

Merci


logo_3dminfographie_signature.png

Hors ligne

#6 24-11-2009 03:53:33

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Downgrader xmms

il me dit qu'il veux installer la version oldstable de libglib1.2-dev, libgtk1.2 & libglib1.2ldbl
J'ai donc downgrader ces librairies en version oldstable.


C'est normal. Avec l'option -t tu te trouves à utiliser par défaut, temporairement, la branche oldstable. En installant xmms, tu installes du même coup les dépendances qui vont avec. Reste à voir maintenant si tes prochaines mises à jour/installation, ne vont pas nécessiter de changer de version pour les 3 paquets que tu mentionnes et casser ton xmms.

À la prochaine
Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 24-11-2009 13:55:28

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Downgrader xmms

Merci martin_mtl

J'espère aussi que xmms ne sera pas cassé.
Pour l'instant ça fonctionne.
J'ai essayé aussi aptitude update et aptitude safe-upgrade et il ne m'a pas proposé de mettre à jour ces paquets.

@+
damien

logo_3dminfographie_signature.png

Hors ligne

Pied de page des forums