Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-11-2009 01:34:35

quentin
Membre
Lieu : Nouvelle-Calédonie
Inscription : 27-12-2007

[Résolu]Erreur Apt dans le cadre d'une MAJ

Bonjour,

J'ai un probleme sur un ordi tournant sous debian etch. C'est vieux mais pour ce que ma petite soeur en fait c'est largement suffisant (internet et films essentiellement).

En fait, je suis parti en France quelque mois et pendant ce temps il y a eu une erreur avec apt. Apt refusait de se lancer pendant plusieurs mois, le temps que la nouvelle stable arrive en somme.
J'ai pu résoudre ce problème hier soir en créant un fichier apt.conf dans /etc/apt/ .

Mais voila il a décider de me faire des misères. Après téléchargement des 10420 paquets, un nouveau message d'erreur est apparu et il refuse d'installer les paquets nécessaires pour cette grosse MAJ

E: Cette installation va temporairement nécessiter l'enlèvement du paquet essentiel libungif4g en raison d'une boucle entre les champs Conflicts et Pre-Depends. C'est souvent une mauvaise chose, mais si vous souhaitez réellement le faire, activez l'option APT::Force-LoopBreak.
E: Internal Error, Could not early remove libungif4g


Et la je ne sais pas trop quoi faire. J'ai rajouter APT::Force-LoopBreak dans le fichier apt.conf et rebooter par la suite, mais ça ne change rien.

Merci d'avance
Quentin

Dernière modification par quentin (22-11-2009 06:16:53)

Hors ligne

#2 22-11-2009 04:03:07

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

Salut

J'aimerais bien cerner ton problème. Etch est l'ancienne stable et elle est encore supportée. Donc, en principe, on ne devrait pas avoir de problème de mise à jour. Je ne saisi pas pas la raison qui explique cette phrase :

Apt refusait de se lancer pendant plusieurs mois, le temps que la nouvelle stable arrive en somme.


De plus, télécharger 10420 paquets je trouve que c'est énorme. Tu n'as quand même pas obtenu cette mise à jour en conservant un fichier souces.list avec etch. Les mises à jour pour les branches stables sont peu nombreuses. D'où viennent tous ces paquets. J'aimerais bien comprendre.

Ajout :
Une recherche sur internet m'a amené vers ce lien où l'on rencontre un problème semblable au tien. En espérant que cela peut aider.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 22-11-2009 05:39:26

quentin
Membre
Lieu : Nouvelle-Calédonie
Inscription : 27-12-2007

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

Merci de ta réponse, je vais regarder attentivement tt ça

Pour APT il me sortait cette erreur (Problème résolu pour rappel ):

E: Dynamic MMap ran out of room
E: Erreur apparue lors du traitement de sympa (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_stable_main_binary-i386_Packages
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.


En fouillant sur le forum j'ai trouvé la solution qui se résume ainsi :

sinon tu peux créer le fichier apt.conf dans /etc/apt/ avec ton éditeur de textes préféré
comme tu l'as fait pour ton fichier preferences et y rajouté ceci --> APT::Cache-Limit 141943904;
ou tu télécharges celui-ci --> apt.conf
et tu le mets ds /etc/apt/.


De plus, télécharger 10420 paquets je trouve que c'est énorme. Tu n'as quand même pas obtenu cette mise à jour en conservant un fichier souces.list avec etch. Les mises à jour pour les branches stables sont peu nombreuses. D'où viennent tous ces paquets. J'aimerais bien comprendre.


Le système n'a pas été mis à jour pendant au moins 6 bons mois peut être plus du fait de l'erreur ci-dessus. 
Par ailleurs, j'ai changé de sources.list, les dépôts ENS cachan que j'avais précédement ne répondant plus. J'ai mis celui là

deb http://ftp.fr.debian.org/debian/ etch main
deb-src http://ftp.fr.debian.org/debian/ etch main
## security
deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free
# non free
deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free
# multimedia
deb http://www.debian-multimedia.org etch main


Merci
Quentin

Dernière modification par quentin (22-11-2009 06:11:35)

Hors ligne

#4 22-11-2009 05:49:18

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

Salut

En regardant ton fichier sources.list, je comprends un peu mieux le pourquoi du nombre de paquets mis à jour. Tu as le dépôt main pour etch seulement. Par contre, tu as aussi la même chose pour stable (avec en plus les dépôts contrib et non-free). Comme la branche stable est maintenant lenny, tu as changé de branche maintenant (à moins que tu aies un fichier preferences pour rester en oldstable).

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 22-11-2009 06:06:32

quentin
Membre
Lieu : Nouvelle-Calédonie
Inscription : 27-12-2007

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

martin_mtl a écrit :

Salut

En regardant ton fichier sources.list, je comprends un peu mieux le pourquoi du nombre de paquets mis à jour. Tu as le dépôt main pour etch seulement. Par contre, tu as aussi la même chose pour stable (avec en plus les dépôts contrib et non-free). Comme la branche stable est maintenant lenny, tu as changé de branche maintenant (à moins que tu aies un fichier preferences pour rester en oldstable).


Ce sources.list est un mix entre Etch et Lenny alors ? Ce n'est pas préjudiciable pour le système ? Est-ce que je dois le modifier en conséquence ?
Je fais mes sources.lit moi-même pour ma ubuntu, mais sous debian j'ai moins l'habitude.

EDIT : Problème résolu

Je met la solution si un souci similaire se reproduit pour quelque d'autre
Certaines lignes du lien m'ont aidé
Voila ce que j'ai fait

- Ajouter dans le fichier /etc/apt/apt.conf la ligne suivante :
APT::Force-LoopBreak "1";
- faire ensuite un apt-get -f install nom-du-paquet-ds-le-message-d'erreur"

J'ai relancé synaptic pour mettre à jour et tout roule !

Dernière modification par quentin (22-11-2009 06:11:59)

Hors ligne

#6 22-11-2009 06:12:00

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

Sans fichier /etc/apt/preferences, je dirais que tu as plutôt une lenny qu'une etch. Si tu fais un apt-cache policy, tu verras la priorité des dépôts de ton sources.list. Tu peux faire aussi un apt-cache policy un_paquet pour voir quelle version est installée. Maintenant comme Lenny est une branche stable, je ne vois pas en quoi cela pourrait être préjudiciable pour le système. Cela serait différent si tu étais passé en testing par exemple.

Ajout : Pour ceux qui utilisent synaptic, on peut facilement voir la liste des paquets selon l'origine des dépôts (menu dans la partie gauche de l'écran), c'est encore plus facile pour avoir une image complète de la situation.

Dernière modification par martinux_qc (22-11-2009 06:50:07)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 22-11-2009 06:16:27

quentin
Membre
Lieu : Nouvelle-Calédonie
Inscription : 27-12-2007

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

Merci pour ton aide
Quentin

Hors ligne

#8 22-11-2009 06:20:29

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Erreur Apt dans le cadre d'une MAJ

Pas de quoi. Il est toujours bon de pouvoir aider à résoudre un problème. Cela nous fait apprendre des trucs du même coup.

À la prochaine
Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums