Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-02-2018 15:43:43

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

[Résolu] Disque dur en lecture seule

Bonjour,

j'utilise 3 disques sur mon ordinateur (60go pour Debian, 1To pour les données, et 250go pour Windaub). Je ne peux pas modifier les fichiers du disque dur de données ou même créer un simple dossier dessus puisqu'il est en lecture seule... hmm

Voila un exemple:

root@debyl:/media/Données/...# mkdir nouveauDossier


La réponse:

mkdir: impossible de créer le répertoire « nouveauDossier »: Système de fichiers accessible en lecture seulement



J'ai bien essayé de décocher la case "lecture seule" depuis windows mais j'ai l'impression que "l'option" se remet par elle même à chaque fois que je touche au DD depuis windows.

Est-ce qu'il est possible de faire sauter la lecture seule depuis Debian et donc de pouvoir jouer avec les fichiers comme bon nous semble ?

Merci.

Dernière modification par Karmazani (02-02-2018 20:55:38)

Hors ligne

#2 02-02-2018 16:00:15

hyrr0
Membre
Distrib. : Debain stable
Noyau : 4.9
(G)UI : KDE 5.8 LTS
Inscription : 12-01-2018

Re : [Résolu] Disque dur en lecture seule

Bonjour,

C'est quoi le format de ta partition ?

Si c'est une partition qui est montée depuis le boot, tu peux modifier ton fichier /etc/fstab pour lui indiquer de le mettre en rw plutôt qu'en lecture seule. Mais pour ça faut connaitre ton format smile

Hors ligne

#3 02-02-2018 16:03:26

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Disque dur en lecture seule

Bonjour
Que renvoie

fdisk -l


mount


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 02-02-2018 18:05:27

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

Merci pour vos réponses.

Le DD est en NTFS.

fdisk -m


Disque /dev/sda : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xe3e88346

Périphérique Amorçage  Début        Fin   Secteurs Taille Id Type
/dev/sda1    *          2048     206847     204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2             206848 1953519615 1953312768 931,4G  7 HPFS/NTFS/exFAT




Disque /dev/sdb : 256,2 GiB, 275064201216 octets, 537234768 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xe7d45bc0

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sdb1    *             2048 535372859 535370812 255,3G  7 HPFS/NTFS/exFAT
/dev/sdb2             535373824 536305663    931840   455M 27 TFS WinRE masquée
/dev/sdb3             536307712 537229311    921600   450M 27 TFS WinRE masquée


Disque /dev/sdc : 55,9 GiB, 60022480896 octets, 117231408 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 7E969DE4-5FDF-46FC-B77C-2F65A68C6AAD

Périphérique     Début       Fin Secteurs Taille Type
/dev/sdc1         2048   1050623  1048576   512M Système EFI
/dev/sdc2      1050624 100501503 99450880  47,4G Système de fichiers Linux
/dev/sdc3    100501504 117229567 16728064     8G Partition d'échange Linux
 




mount



sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=4066792k,nr_inodes=1016698,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=815608k,mode=755)
/dev/sdc2 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=11670)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
/dev/sdc1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)
tmpfs on /run/user/115 type tmpfs (rw,nosuid,nodev,relatime,size=815604k,mode=700,uid=115,gid=120)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=815604k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sdb1 on /media/michel/Windaub type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sda2 on /media/michel/Données type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

 

Dernière modification par Karmazani (02-02-2018 18:32:40)

Hors ligne

#5 02-02-2018 18:22:41

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

Après une petite recherche sur le montage au boot j'ai trouvé ceci: http://www.linux-note.com/commande-moun … demarrage/

j'ai obtenu via:

blkid


/dev/sda1: LABEL="System Reserved" UUID="AC80FD9780FD686A" TYPE="ntfs" PARTUUID="e3e88346-01"
/dev/sda2: LABEL="DonnM-CM-)es" UUID="529EB9C19EB99DC3" TYPE="ntfs" PARTUUID="e3e88346-02"
/dev/sdb1: LABEL="Windaub" UUID="2AA803C7A803910D" TYPE="ntfs" PARTUUID="e7d45bc0-01"
/dev/sdb2: UUID="0C66451866450444" TYPE="ntfs" PARTUUID="e7d45bc0-02"
/dev/sdb3: UUID="ACB45863B45831D6" TYPE="ntfs" PARTUUID="e7d45bc0-03"
/dev/sdc1: UUID="A3EA-8CC1" TYPE="vfat" PARTUUID="2701f5a1-13ff-4d2b-8019-06c0147aa597"
/dev/sdc2: UUID="f35117cb-7b27-4245-82da-a72a3cc059fa" TYPE="ext4" PARTUUID="b6d9aa11-4d21-446b-ae49-6223b3f15145"
/dev/sdc3: UUID="98c2d714-0912-4d7b-9364-817326c8c28f" TYPE="swap" PARTUUID="efc08a36-527e-4d98-8962-cf88503a7f1f"
 



Je viens de modifier le

/etc/fstab

en ajoutant cette ligne:

# dique dur de données 1To
UUID=529EB9C19EB99DC3 /media/nomUtilisateur/ ntfs uid=1000,gid=1000,umask=027 0 2



Dans le chemin de montage, est ce que je dois spécifier le nom du DD: "Données" (/media/nomUtilisateur/Données) ?
Pour les droits est ce que je dois mettre "777" après uid et gid ?
Pourquoi il y a 4 chiffres: "1000" et pas 3 comme pour les droits sur les fichiers ou dossiers ?
C'est quoi uid,gid et umask ?

Dernière modification par Karmazani (02-02-2018 18:42:41)

Hors ligne

#6 02-02-2018 18:36:50

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Disque dur en lecture seule

Oui, sinon tu va monter le disque dans nomUtilisateur ce qui est certainement non souhaité wink

Sinon dans le man de ntfs-3g tu as pas mal d'infos sur les options

Au passage, constaté sous Win10 / UEFI : désactiver le « redémarrage rapide » de windows, sinon ton disque va être bloqué en lecture seule par EFI

« la France d'en bas manque peut-être de hauteur mais la France d'en haut ne manque jamais de bassesse... »
    Georges Coulonges

Hors ligne

#7 02-02-2018 18:48:01

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

Je suis un peu perdu pour le fichier /etc/fstab

Sur le

man mount

dans la section "option de montages pour ntfs" il est écrit:

Options de montage pour ntfs
       iocharset=nom
              Jeu de caractère à utiliser pour renvoyer les noms de fichiers. Contrairement à VFAT, NTFS supprime les noms qui contiennent des caractères non convertibles.
              Obsolète.

       nls=nom
              Nouveau nom pour l'option précédemment nommée iocharset.

       utf8   Utiliser UTF-8 pour convertir les noms de fichiers.

       uni_xlate={0|1|2}
              Si 0 (ou no ou false), ne pas utiliser de séquences d'échappements pour les caractères Unicode inconnus. Si 1 (ou yes, ou true) ou 2, utiliser les  séquences
              d'échappement  sur  quatre octets de style vfat en commençant par « : ». Avec 2, un codage petit boutiste (« little-endian ») est utilisé et avec 1 un codage
              grand boutiste (« big-endian »).

       posix=[0|1]
              Si actif (posix=1), le système de fichiers distingue les majuscules des minuscules. Les noms d'alias 8.3 sont présentés sous forme de liens physiques  plutôt
              qu'être supprimés. Cette option est obsolète.

       uid=valeur, gid=valeur et umask=valeur
              Définir les permissions des fichiers sur le système de fichiers. La valeur d'umask est fournie en octal. Par défaut les fichiers appartiennent au superutili‐
              sateur et ne sont lisibles par personne d'autre.
 



Bref, il n'est pas question de ro ou rw.

Par contre dans le

man ntfs-3g

je vois l'exemple suivant:

       /etc/fstab entry for the above (the sixth and last field has to be zero
       to avoid a file system check at boot time) :

              /dev/sda5 /home/user/mnt ntfs-3g ro,uid=1000 0 0
 



Donc au final je dois suivre quelle doc ?

J'ose pas redémarrer pour le moment big_smile

Dernière modification par Karmazani (02-02-2018 18:50:35)

Hors ligne

#8 02-02-2018 19:06:30

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

Je viens de faire un test de redémarrage avec cette ligne en plus dans /etc/fstab:

# disque de données 1To
UUID=529EB9C19EB99DC3 /media/michel/Données ntfs-3g rw 0 2



Le DD est bien monté au démarrage mais tout es toujours en lecture seule.

Dernière modification par Karmazani (02-02-2018 19:06:47)

Hors ligne

#9 02-02-2018 19:14:00

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

Haricophile a écrit :

...

Au passage, constaté sous Win10 / UEFI : désactiver le « redémarrage rapide » de windows, sinon ton disque va être bloqué en lecture seule par EFI



J'ai pas compris sad

Hors ligne

#10 02-02-2018 19:18:59

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Disque dur en lecture seule

Tu dois t'assurer que le paquet ntfs-3g est bien installé

apt policy ntfs-3g


ntfs est géré par le noyau mais pas avec autant d'options

Pour le montage de ta partition voir dans le wiki
https://debian-facile.org/doc:systeme:mount
https://debian-facile.org/doc:systeme:fstab

a lire aussi le man

man ntfs-3g


man ntfs-3g a écrit :


   Windows hibernation and fast restarting
       On  computers  which  can  be dual-booted into Windows or Linux, Windows has to be fully shut down before booting
       into Linux, otherwise the NTFS file systems on internal disks may be left in an inconsistent  state  and  changes
       made by Linux may be ignored by Windows.

       So,  Windows may not be left in hibernation when starting Linux, in order to avoid inconsistencies. Moreover, the
       fast restart feature available on recent Windows systems has to be disabled. This can be achieved by  issuing  as
       an Administrator the Windows command which disables both hibernation and fast restarting :

              powercfg /h off




Sur les ordinateurs qui peuvent être bi-bootés sous Windows ou Linux, Windows doit être complètement arrêté avant le démarrage.
       dans Linux, sinon les systèmes de fichiers NTFS sur les disques internes peuvent être laissés dans un état incohérent et les modifications peuvent être apportées.
       faite par Linux peut être ignorée par Windows.

       Ainsi, Windows ne peut pas rester en hibernation au démarrage de Linux, afin d'éviter les incohérences. De plus, le
       La fonction de redémarrage rapide disponible sur les systèmes Windows récents doit être désactivée. Pour ce faire, il est possible d'émettre en tant que
       une commande Administrateur de Windows qui désactive à la fois l'hibernation et le redémarrage rapide:

powercfg /h off


Traduit avec www.DeepL.com/Translator


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 02-02-2018 19:27:26

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Disque dur en lecture seule

Si tu as un double boot avec Windows 10 et un "bios" UEFI,  dans Windows 10 il y a une option "démarrage rapide" qui fonctionne avec UEFI et qui va te bloquer en lecture seule  la partition NTFS si tu démarre Linux derrière. Il faut donc désactiver cette option je ne sais plus où, au profit d'un redémarrage normal dans windows 10 pour ne pas être emmerdé.

Pour les 2 derniers chiffres, je laisse 0 0  car je considère que tester/réparer NTFS est du ressort de Windows, Linux n'a qu'un support partiel de cette usine à gaz. Pareil pour la défragmentation qui n'est faisable que depuis Windows. Sous Linux il y a ntfsfix, mais il ne fait que les opérations de base et l'effacement du journal. Ce n'est pas très satisfaisant même si ça permet d'utiliser quand même un  NTFS mal démonté.

P.S. Le redémarrage rapide, ce n'est pas la mise en hibernation, mais si je ne dis pas de bêtise, il pré-charge un certain nombre de trucs mis en mémoire au lieu de charger tout normalement avec les test d'usages pour chaque service. Il faut donc être sûr que l'état du système n'a pas changé entre temps (d'où le read-only).

Dernière modification par Haricophile (02-02-2018 19:31:56)


« la France d'en bas manque peut-être de hauteur mais la France d'en haut ne manque jamais de bassesse... »
    Georges Coulonges

Hors ligne

#12 02-02-2018 19:32:24

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Disque dur en lecture seule

sur un précédent poste j'avais noté

raleur a dit: La page du manuel de mount ne mentionne que les descriptions du pilote ntfs interne au noyau qui n'est pas utilisé puisque ntfs-3g est installé. Il faut regarder dans la page manuel de ntfs-3g


Donc voir le man ntfs-3g et non pas le man de mount pour les options

https://debian-facile.org/viewtopic.php?id=20057


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#13 02-02-2018 20:55:06

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

C'est reglé !

Pour ce qui est de l'existence de ntfs-3g j'avais déjà vérifié et le paquet est à jour.

Finalement la ligne que j'ai rajouté à /etc/fstab est celle ci:

UUID=529EB9C19EB99DC3 /media/nomUtilisateur/Données ntfs rw 0 0


ce qui me permet monter le disque automatiquement au démarrage. En revanche effectivement tout reste en lecture seule.

J'ai en plus désactivé l'hibernation de windaub et le démarrage rapide. D'ailleurs il semble que microbsoft ait encore changé l'interface graphique pour désactiver le démarrage rapide. Impossible de retrouver le petit bouton. J'ai du trifouiller dans les registres pour désactiver ça "à la main".

A terme je pense que je formaterai ce disque dur en ext4 (si je ne me trompe pas) puisque je n'utilise que son contenu quand je suis sous Debian.

Merci pour votre aide en tout cas et à bientôt 0/

Dernière modification par Karmazani (02-02-2018 20:56:38)

Hors ligne

#14 03-02-2018 10:48:31

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur en lecture seule

Je pense que des clarifications s'imposent.

Un système de fichiers monté en lecture seule (read-only, ro) n'a rien à voir avec les permissions. C'est comme un CD-ROM : quelles que soient les permissions sur les fichiers, on ne peut pas le modifier. Inutile de s'acharner sur les options de montage comme uid, gid ou umask qui définissent les permissions.

ntfs-3g force le montage d'un volume NTFS en lecture seule quand celui-ci est dans un état "incohérent", pour éviter une corruption de données qui pourrait être causée par une écriture. Comme pour les systèmes de fichiers Linux, cet état incohérent peut s'observer après un arrêt "sauvage" du système sans démontage propre du volume, ou une mise en hibernation dont le réveil n'est pas encore intervenu. Or la fonctionnalité de "démarrage rapide" introduite dans Windows 8 remplace l'arrêt par une mise en hibernation hybride. Donc lorsqu'on sélectionne "arrêter" dans Windows, on le met en fait en hibernation et les volumes montés ne sont pas démontés. En revanche lorsqu'on sélectionne "redémarrer" dans Windows, cela passe par une phase complète d'arrêt du système et tous les volumes sont démontés proprement. Si on redémarre ensuite sous Debian, les volumes NTFS pourront être montés en lecture-écriture.

Habituellement la raison du montage d'un système de fichiers forcé en lecture seule est indiquée dans les messages du noyau. Mais ntfs-3g est un pilote de système de fichiers en espace utilisateur (FUSE), et ce message ne va pas dans le tampon du noyau. On pourrait le voir lors d'un montage manuel avec la commande mount en console.

Haricophile a écrit :

Si tu as un double boot avec Windows 10 et un "bios" UEFI,  dans Windows 10 il y a une option "démarrage rapide" qui fonctionne avec UEFI et qui va te bloquer en lecture seule  la partition NTFS si tu démarre Linux derrière.


A ma connaissance, l'option de démarrage rapide de Windows n'a rien à voir avec l'UEFI et existe aussi en mode BIOS. D'autre part ce n'est pas cette option elle-même mais le fait d'avoir arrêté Windows avec cette option activée qui laisse les volumes montés. La commande de redémarrage, même avec l'option activée, démonte proprement les volumes.

Haricophile a écrit :

Le redémarrage rapide, ce n'est pas la mise en hibernation


Si. Les sessions utilisateur sont arrêtées mais le système est hiberné.

Karmazani a écrit :

Pour les droits est ce que je dois mettre "777" après uid et gid ?
Pourquoi il y a 4 chiffres: "1000" et pas 3 comme pour les droits sur les fichiers ou dossiers ?
C'est quoi uid,gid et umask ?


uid et gid ne sont pas des permissions mais les identifiants de l'utilisateur et du  groupe propriétaires. La commande id affiche l'UID de l'utilisateur courant et les GID de ses groupes. L'UID de root est 0, et par défaut sous Debian l'UID du premier utilisateur est 1000, les valeurs inférieures étant réservées aux "utilisateurs" système utilisés pour exécuter les services.
umask est le masque des permissions, le complément logique des bits de permissions. Pour des permissions 777 (tout autorisé), umask vaut 000.

Hors ligne

#15 03-02-2018 11:06:23

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Disque dur en lecture seule

Salut

En revanche effectivement tout reste en lecture seule.


Donc pour le coup rien, n'est résolu tongue

Ne serait ce pas la commande cité dans le man ntfs-3g (voir message #10)

powercfg /h


A entré dans un terminale windows


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#16 03-02-2018 11:53:22

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

Croutons a écrit :


Donc pour le coup rien, n'est résolu tongue



Si justement. La ligne rajoutée dans /etc/fstab permet bien de monter le DD automatiquement. En revanche le problème de lecture seule se règle du côté Windows en désactivant l’hibernation, ce que j'ai fais.

Merci raleur pour tes précisions.

Hors ligne

#17 03-02-2018 12:03:30

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur en lecture seule

Karmazani a écrit :

La ligne rajoutée dans /etc/fstab permet bien de monter le DD automatiquement


Ce n'était pas le sujet de départ qui concernait le montage en lecture seule.

Hors ligne

#18 04-02-2018 13:29:50

Karmazani
Membre
Distrib. : Debian GNU/Linux 9.3
Noyau : Linux 4.9.0-5amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] Disque dur en lecture seule

raleur a écrit :

Karmazani a écrit :

La ligne rajoutée dans /etc/fstab permet bien de monter le DD automatiquement


Ce n'était pas le sujet de départ qui concernait le montage en lecture seule.



C'est vrai. Je n'aurai peut être pas du tout mélanger. smile

Hors ligne

Pied de page des forums