Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-11-2009 20:00:27

tuxmania
Membre
Inscription : 18-11-2009

3d avec ati radeon 2400

bonsoir,
D'après mes recherches,et sous réserve que j'ai bien compris le "schmiblick",
Pour ne pas avoir de problème avec un éventuel changement de noyau,pour garder la 3d,
il faut passer par module-assistant,et modifié son fichier xorg.
Chose que j'ai faite,mais visiblement mal.....
Je vais essayer de mettre une capture de mon écran.
Si elle sera chargé et visible,elle sera plus explicite que je ne saurais l' être.
D'avance merci de votre soutien,bonne soirée.
[img]file:///home/ric/images/Capture-1.png[/img]
Bon,je n'arrive pas a mètre une capture d'écran.
j'essaie autrement
                               
         _sudZUZ#Z#XZo=_         DDDD   EEEEEE BBBB   IIIIII  AAAA   NN   NN
      _jmZZ2!!~---~!!X##wa       DD DD  EE     BB BB    II   AA  AA  NNN  NN
   .<wdP~~            -!YZL,     DD  DD EEEEE  BBBBB    II   AAAAAA  NNNN NN
  .mX2'       _%aaa__     XZ[.   DD DD  EE     BB  BB   II   AA  AA  NN NNNN
  oZ[      _jdXY!~?S#wa   ]Xb;   DDDD   EEEEEE BBBBB  IIIIII AA  AA  NN   NN
_#e'     .]X2(     ~Xw|  )XXc
.2Z`      ]X[.       xY|  ]oZ(   Linux Version 2.6.26-2-686
.2#;      )3k;     _s!~   jXf`   Compiled #1 SMP Wed Nov 4 20:45:37 UTC 2009
1Z>      -]Xb/    ~    __#2(    Two 1GHz Intel Intel(R) Pentium(R) Dual  CPU  T3200  @ 2.00GHz Processors, 2GB RAM
-Zo;       +!4ZwaaaauZZXY'      7984,00 Bogomips Total
  *#[,        ~-?!!!!!!-~        debian68
   XUb;.                       
    )YXL,,                     
      +3#bc,                   
        -)SSL,,               
           ~~~~~               
debian68:/home/ric# compiz config
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity

Et la deuxième:

ric@debian68:~$ cat /etc/apt/X11/xorg.conf
cat: /etc/apt/X11/xorg.conf: Aucun fichier ou répertoire de ce type
ric@debian68:~$ cat /etc/X11/xorg.conf
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
EndSection

Section "Device"
    Identifier    "--aticonfig"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
EndSection
ric@debian68:~$

D'avance merci de votre soutien.
Bonne soirée.

Dernière modification par tuxmania (22-11-2009 20:50:19)

Hors ligne

#2 22-11-2009 21:33:29

tuxmania
Membre
Inscription : 18-11-2009

Re : 3d avec ati radeon 2400

Si cela peut être aussi utile...

ric@debian68:~$ glxgears
4804 frames in 5.0 seconds = 957.137 FPS
4840 frames in 5.0 seconds = 967.511 FPS
4880 frames in 5.0 seconds = 972.971 FPS
4900 frames in 5.0 seconds = 979.537 FPS
4880 frames in 5.0 seconds = 975.293 FPS
4840 frames in 5.0 seconds = 964.572 FPS
4860 frames in 5.0 seconds = 971.619 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 69769 requests (61818 known processed) with 0 events remaining.
ric@debian68:~$ glxgearsinfo
bash: glxgearsinfo: command not found
ric@debian68:~$ glxgears info
Usage:
  -display <displayname>  set the display to run on
  -stereo                 run in stereo mode
  -fullscreen             run in fullscreen mode
  -info                   display OpenGL renderer info
ric@debian68:~$

Dernière modification par tuxmania (22-11-2009 21:33:59)

Hors ligne

#3 22-11-2009 22:13:12

guilhem91
Membre
Lieu : Essonne
Distrib. : Squeeze 6.0.1
Noyau : 2.6.32-5-amd64
(G)UI : KDE 4.4.5
Inscription : 26-06-2009
Site Web

Re : 3d avec ati radeon 2400

Bonsoir,

et glxinfo | grep "direct rendering", ça donne quoi ?

Sinon, vu ton FPS, effectivement, l'accélération matérielle n'a pas l'air activée... Tu as été voir la page dans le wiki ?

Debian Squeeze 6.0.1 64 bits sur AMD Phenom II X4 3GHz + Nvidia Geforce 9600 GT

Mon site : GNU/Linux et conseils en vrac...

Hors ligne

#4 22-11-2009 22:55:11

tuxmania
Membre
Inscription : 18-11-2009

Re : 3d avec ati radeon 2400

bonsoir,

voila:

ric@debian68:~$ glxinfo | grep "direct rendering"
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
ric@debian68:~$

Debian facile,debian facile,ben comparé a d'autres distris....

Dernière modification par tuxmania (22-11-2009 23:00:04)

Hors ligne

#5 23-11-2009 10:04:41

tuxmania
Membre
Inscription : 18-11-2009

Re : 3d avec ati radeon 2400

bonjour,

Petite amélioration,mes fps ok.

Quand je clique sue système administration,préférence,ati,plus de message d'erreur.

J'ai la 3d quand je la lance au travers d'un shell.(compiz config).

Par contre je perd la barre supérieur des fenêtres(réduire,agrandir,fermer la fenêtre).

Mais, je n'ai pas  la 3d au redémarrage de la machine.

Que dois-je faire encore?,pour avoir ma barre de fenêtre et la 3d en automatique?

Je suis près du but,et je n'ose plus rien toucher.

MERCI

Petite précision:c'est quand je ferme le shell qui a lancer compiz que je perd la barre des fenêtres.

Dernière modification par tuxmania (23-11-2009 10:12:42)

Hors ligne

#6 23-11-2009 22:44:43

tuxmania
Membre
Inscription : 18-11-2009

Re : 3d avec ati radeon 2400

c'est bon j'ai trouvé!
Un problème de trouvé,un autre qui surgit,saccade au niveau vidéo....
Cela ne s'arrête jamais sous débian?
Faut vraiment être un petit génie de l'informatique avec débian,ou elle est faite pour qu'on le devienne?
Je mesure bien l'importance du logo de la distri.
c'est vraiment une distri qui se mérite!:).Je vous soupçonne d'être des partisans du 100% libre!
M' enfin...(je déconne).
Bonne soirée au fantômes,oups que dis-je? au génie:D.
@+

Hors ligne

#7 23-11-2009 23:06:53

guilhem91
Membre
Lieu : Essonne
Distrib. : Squeeze 6.0.1
Noyau : 2.6.32-5-amd64
(G)UI : KDE 4.4.5
Inscription : 26-06-2009
Site Web

Re : 3d avec ati radeon 2400

Bonsoir,

j'ai monté moi-même une unité centrale de PC il y a quelques semaines, avec notamment une carte Nvidia 9600 GT. J'avais aussi des problèmes multiples, dont des saccades. Et ceux-ci ont disparus en installant le .run de chez Nvidia.

Donc, je ne sais pas si chez ATI il en sera de même, m'enfin tu peux toujours essayer. Attention néanmoins : si tu installes le .run, tu auras à la prochaine upgrade un écran noir. Ceci est normal, étant donné que les pilotes auront été installé pour un seul noyau. Il faudra les réinstaller en mode console. À toi de voir...

Enfin je peux te dire que pour moi, le gain était flagrant. Après, pour les ATI, je ne sais pas trop...

Note : d'après ce que retourne glxinfo, la 3D n'est pas activée. M'enfin si tu dis que tu y es arrivé wink

Debian Squeeze 6.0.1 64 bits sur AMD Phenom II X4 3GHz + Nvidia Geforce 9600 GT

Mon site : GNU/Linux et conseils en vrac...

Hors ligne

#8 24-11-2009 09:44:38

tuxmania
Membre
Inscription : 18-11-2009

Re : 3d avec ati radeon 2400

bonjour,

ric@debian68:~$ glxinfo | grep "direct rendering"
direct rendering: Yes
ric@debian68:~$ .

Trouvé pour les saccades sous vlc,maintenant y a encore gxine,cheese,et je ne sait encore quoi...

Si vous avez des tuyaux...

@+

J'oubliais:

J'ai utilisé la méthode que tu préconise via le site ati.

A titre d'info aucun problème,que je ne rencontre maintenant.

Ati et nvidia en passant par leur run marche bien.

Dernière modification par tuxmania (24-11-2009 10:07:43)

Hors ligne

#9 24-11-2009 23:06:36

guilhem91
Membre
Lieu : Essonne
Distrib. : Squeeze 6.0.1
Noyau : 2.6.32-5-amd64
(G)UI : KDE 4.4.5
Inscription : 26-06-2009
Site Web

Re : 3d avec ati radeon 2400

Bonsoir,

les "problèmes" dont je parlais viendront en fait avec le changement de noyau, lié avec la future upgrade vers squeeze. Enfin problèmes... disons qu'il suffit juste de réinstaller les pilotes en ligne de commande via la console smile Rien de mortel, assurément.

Sinon, content pour toi que ça marche big_smile

Debian Squeeze 6.0.1 64 bits sur AMD Phenom II X4 3GHz + Nvidia Geforce 9600 GT

Mon site : GNU/Linux et conseils en vrac...

Hors ligne

#10 25-11-2009 17:54:19

tuxmania
Membre
Inscription : 18-11-2009

Re : 3d avec ati radeon 2400

salut,

Visiblement nous sommes coincé,d'une manière ou d'une autre.

J'ai opté pour la compile,donc vive la galère avec cheese et compagnie.

Je suis toujours preneur d'infos,de mon coté,pas encore trouvé.

@+ les "debianeux"

Hors ligne

Pied de page des forums