Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-02-2018 14:10:13

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Raccourci clavier unique défecteux

Bonjour à tous,

Comme j'utilise pas mal de raccourcis claviers, je les ai tous configurés avec la même syntaxe dans le fichier ~/.config/openbox/lxde-rc.xml avant d'exécuter la commande

openbox --reconfigure


Or, j'ai tout récemment tenté de configurer le raccourci Ctrl + Alt + P pour lancer pidgin mais celui-ci ne fonctionne pas. C'est pourtant la même syntaxe que les autres et ces derniers fonctionnent bien. Voici un extrait de mon lxde-rc.xml :

    <!-- Keybindings for running applications -->
    <keybind key="W-e">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>PCManFM</name>
        </startupnotify>
        <command>pcmanfm</command>
      </action>
    </keybind>
    <keybind key="C-A-i">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>Firefox-ESR</name>
        </startupnotify>
        <command>firefox-esr</command>
      </action>
    </keybind>
    <keybind key="C-A-t">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>Terminal</name>
        </startupnotify>
        <command>lxterminal</command>
      </action>
    </keybind>
    <keybind key="C-A-m">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>Thunderbird</name>
        </startupnotify>
        <command>thunderbird</command>
      </action>
    </keybind>
    <keybind key="C-A-p">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>Pidgin</name>
        </startupnotify>
        <command>pidgin</command>
      </action>
    </keybind>
    <keybind key="C-A-w">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>LibreOffice</name>
        </startupnotify>
        <command>lowriter</command>
      </action>
    </keybind>
    <keybind key="C-A-l">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>Leafpad</name>
        </startupnotify>
        <command>leafpad</command>
      </action>
    </keybind>


La commande qui lance pidgin ne me semble pas différer des autres, la raccourci Ctrl + Alt + P n'est pas pris par une autre application, donc très franchement je ne vois pas pourquoi il refuse de se lancer avec ce raccourci. En plus il m'est arrivé d'utiliser le même raccourci avec pidgin sur openbox sous Archlinux et je n'avais pas eu de problèmes. Si quelqu'un sait pourquoi ça cloche il sera remercié big_smile


Dell-Latitude D430

Hors ligne

#2 04-02-2018 10:01:46

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : Raccourci clavier unique défecteux

Bonjour,
La commande

pidgin

dans un terminal lance le logiciel ?
Et si tu changes de raccourci, ça ne fonctionne pas non plus ?

Hors ligne

#3 04-02-2018 17:19:55

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : Raccourci clavier unique défecteux

La commande lance bien le logiciel, mais effectivement en changeant le raccourci (Ctrl + Alt + N, au hasard) cela fonctionne. Ce qui est étrange c'est que rien n'est attribué à la commande Ctrl + Alt + P (en tout cas pas dans le lxde-rc.xml). Je l'ai tapée quand même pour voir mais rien ne semble se lancer.

C'est assez étrange, j'aimerai bien savoir pourquoi ce raccourci précis est bloqué.

Dell-Latitude D430

Hors ligne

#4 04-02-2018 20:20:43

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : Raccourci clavier unique défecteux

Je n' ai aucune idée neutral

Hors ligne

#5 04-02-2018 23:05:58

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Raccourci clavier unique défecteux

Bonsoir,

<!-- Launch Pidgin with Windows+P -->
 <keybind key="W-p">
    <action name="Execute">
       <command>pidgin</command>
    </action>
 </keybind>


cette commande lance bien pidgin chez moi. mais c'est du copie-collé, vu que je plane en la matière. Si ça te dit quelque chose...

Hors ligne

#6 05-02-2018 10:35:29

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Raccourci clavier unique défecteux

bonsoir
essais de regarder dans le fichier .xsession-errors lorsque tu lance la commande et que rien ne se passe

Hors ligne

#7 06-02-2018 18:15:24

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : Raccourci clavier unique défecteux

Bonsoir,

La syntaxe de potemkine17 fonctionne avec W-p mais pas avec C-A-p, c'est vraiment cette combinaison-là qui cloche.

Je n'ai pas vraiment l'impression que .xsession-errors renvoie quelque chose à ce sujet :

Xsession: X session started for harashi at mardi 6 février 2018, 17:03:20 (UTC+0100)
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/harashi/.Xauthority
localuser:harashi being added to access control list
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
OpenGL version: 2.
dbus-update-activation-environment: setting USER=harashi
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/harashi
dbus-update-activation-environment: setting DESKTOP_SESSION=lightdm-xsession
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting LOGNAME=harashi
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting GDM_LANG=fr_FR.utf8
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=fr_FR.UTF-8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=lightdm-xsession
dbus-update-activation-environment: setting XAUTHORITY=/home/harashi/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/harashi
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=lightdm-xsession
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/harashi
** Message: main.vala:102: Session is LXDE
** Message: main.vala:103: DE is LXDE
** Message: main.vala:134: log directory: /home/harashi/.cache/lxsession/LXDE
** Message: main.vala:135: log path: /home/harashi/.cache/lxsession/LXDE/run.log
 


Dell-Latitude D430

Hors ligne

#8 10-02-2018 21:28:20

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Raccourci clavier unique défecteux

Harashi, Je ne sais pas si c'est résolu mais je constate que le raccourci "C-A-p" fonctionne sur mon portable. C'est long à l'ouverture mais c'est sûrement mon matos fatigué.

Hors ligne

#9 11-02-2018 12:52:18

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : Raccourci clavier unique défecteux

Disons que c'est contourné car "A-p" fonctionne et c'est ce que j'ai mis. Par contre "C-A-p" ne fonctionne toujours pas (je viens de réessayer), et je ne comprend pas pourquoi (et à dire vrai ça dépasse probablement mes compétences hmm).

Dell-Latitude D430

Hors ligne

#10 11-02-2018 16:30:27

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Raccourci clavier unique défecteux

J'ai légerement modifier ce que j'ai rajouté au script :

</keybind>
    <!-- Launch Pidgin when Ctrl+Alt+p is pressed -->
    <keybind key="C-A-p">
      <action name="Execute">
        <command>pidgin</command>
      </action


Ca roule mais ça reste lent à l'ouverture. Peut-être plus facile à configurer avec LXhotkey ?

Hors ligne

#11 21-02-2018 15:29:11

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : Raccourci clavier unique défecteux

Oulah, j'avais pas vu la réponse, désolé ^^

potemkine17 a écrit :

Peut-être plus facile à configurer avec LXhotkey ?


En fait LXhotkey ne veut pas prendre en compte la touche Ctrl quand je tente de faire des réglages. A chaque fois je valide mais il affiche <Primary><Alt>p (et le raccourci ne fonctionne pas), tandis que quand je fais mes réglages à partir de ~/.config/openbox/lxde-rc.xml je retrouve bien la syntaxe <Control><Alt>i (pour internet en occurrence) dans LXhotkey.


Dell-Latitude D430

Hors ligne

#12 21-02-2018 18:12:07

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Raccourci clavier unique défecteux

Je ne suis pas calé en raccourcis. Comme tu as modifié le script, je  ne peux pas trop comparer tes résultats aux miens. Au final, ça fonctionne ou pas ?

Hors ligne

#13 21-02-2018 18:56:45

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : Raccourci clavier unique défecteux

Non, toujours pas. Je continue de faire avec Alt + P configuré depuis le lxde-rc.xml (c'est interdit par LXhotkey), mais je me sens un peu sale wink

potemkine17 a écrit :

Comme tu as modifié le script, je  ne peux pas trop comparer tes résultats aux miens


C'est-à-dire ? J'ai exactement le même script que dans ton post (le #10).


Dell-Latitude D430

Hors ligne

#14 21-02-2018 20:20:15

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Raccourci clavier unique défecteux

J'en étais toujours à celui de ton 1° méssage. Bon. Je ne vois pas pourquoi ça ne marche pas chez toi. J'ai testé- à tout hasard- sur 3 pc avec un D.D.externe, le resultat est bon partout mais...alors que l'ouverture est laborieuse sur un Acer et une tour, il est très rapide sur un Dell. Je ne sais pas si c'est important. peut-être que certains claviers ou variantes de claviers ont des soucis avec ce raccourcis ???

Hors ligne

#15 22-02-2018 13:35:37

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : Raccourci clavier unique défecteux

Pourtant j'ai un clavier azerty français tout ce qu'il y a de plus standard, et en plus c'est un Dell ^^

Je pense que je vais me contenter d'un W-p, après tout cette combinaison n'est pas encore utilisée (et c'est moins sale que A-p), mais je laisse le sujet ouvert au cas ou quelqu'un aurait une explication (ça doit être un truc tout bête qui nous échappe, comme c'est souvent le cas). En tout cas merci de t'être penché sur le sujet wink

Dell-Latitude D430

Hors ligne

Pied de page des forums