Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-02-2018 14:59:48

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

[resolu] Debian sur Raspberry PI3

Bonjour

j'ai installé debian Stretch sur un rpi3 avec un peu de galère hmm roll tongue
et préparé une image de buster


/home/robert/test/rpi23-gen-image-master/images/buster/2018-02-04-arm-CURRENT-rpi3-buster-armhf.img (544M) : successfully created
 



la stretch est en pae (32bits) , pour la buster je sais pas encore

la page => https://wiki.debian.org/RaspberryPi

le script => https://github.com/drtyhlpr/rpi23-gen-image  ( rpi23-gen-image.sh )

pour stretch c'est moins fluide que raspbian , j'ai installé LXDE comme bureau , pas de fichier syslog (dans /var/log ) et le disque a des accès en permanence je sais pas pourquoi
sinon tout fonctionne pour stretch ( quelques soucis pour passer la distribution en FR (clavier , fuseau , locale .... )  mais j'ai finalement réussi )

le log de X


[   269.177]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[   269.177] X Protocol Version 11, Revision 0
[   269.177] Build Operating System: Linux 4.9.0-4-armmp-lpae armv7l Debian
[   269.177] Current Operating System: Linux rpi3-stretch 4.9.79-v7 #1 SMP Sun Feb 4 02:30:18 CET 2018 armv7l
[   269.177] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=1280 bcm2708_fb.fbheight=1024 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 root=/dev/sda2 rootfstype=ext4 rootflags=commit=100,data=writeback elevator=deadline rootwait console=tty1 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 net.ifnames=1 init=/bin/systemd
[   269.177] Build Date: 16 October 2017  09:48:39AM
[   269.177] xorg-server 2:1.19.2-1+deb9u2 (https://www.debian.org/support)
[   269.178] Current version of pixman: 0.34.0
[   269.178]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[   269.178] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   269.178] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb  4 12:16:14 2018
[   269.256] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   269.289] (==) No Layout section.  Using the first Screen section.
[   269.289] (==) No screen section available. Using defaults.
[   269.289] (**) |-->Screen "Default Screen Section" (0)
[   269.289] (**) |   |-->Monitor "<default monitor>"
[   269.290] (==) No monitor specified for screen "Default Screen Section".
  Using a default monitor configuration.
[   269.290] (==) Automatically adding devices
[   269.290] (==) Automatically enabling devices
[   269.290] (==) Automatically adding GPU devices
[   269.290] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   269.347] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   269.347]  Entry deleted from font path.
[   269.347] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   269.347]  Entry deleted from font path.
[   269.347] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   269.347]  Entry deleted from font path.
[   269.347] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[   269.347]  Entry deleted from font path.
[   269.347] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   269.347]  Entry deleted from font path.
[   269.347] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   269.347]  Entry deleted from font path.
[   269.347] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  built-ins
[   269.347] (==) ModulePath set to "/usr/lib/xorg/modules"
[   269.347] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[   269.348] (II) Loader magic: 0x5b9f60
[   269.348] (II) Module ABI versions:
[   269.348]  X.Org ANSI C Emulation: 0.4
[   269.348]  X.Org Video Driver: 23.0
[   269.348]  X.Org XInput driver : 24.1
[   269.348]  X.Org Server Extension : 10.0
[   269.351] (++) using VT number 7

[   269.351] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   269.351] (II) no primary bus or device found
[   269.351] (II) LoadModule: "glx"
[   269.359] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   269.518] (II) Module glx: vendor="X.Org Foundation"
[   269.518]  compiled for 1.19.2, module version = 1.0.0
[   269.518]  ABI class: X.Org Server Extension, version 10.0
[   269.519] (==) Matched modesetting as autoconfigured driver 0
[   269.519] (==) Matched fbdev as autoconfigured driver 1
[   269.519] (==) Assigned the driver to the xf86ConfigLayout
[   269.519] (II) LoadModule: "modesetting"
[   269.519] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   269.523] (II) Module modesetting: vendor="X.Org Foundation"
[   269.524]  compiled for 1.19.2, module version = 1.19.2
[   269.524]  Module class: X.Org Video Driver
[   269.524]  ABI class: X.Org Video Driver, version 23.0
[   269.524] (II) LoadModule: "fbdev"
[   269.524] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   269.539] (II) Module fbdev: vendor="X.Org Foundation"
[   269.539]  compiled for 1.19.0, module version = 0.4.4
[   269.539]  Module class: X.Org Video Driver
[   269.539]  ABI class: X.Org Video Driver, version 23.0
[   269.539] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   269.539] (II) FBDEV: driver for framebuffer: fbdev
[   269.561] (WW) Falling back to old probe method for modesetting
[   269.562] (EE) open /dev/dri/card0: No such file or directory
[   269.562] (WW) Falling back to old probe method for fbdev
[   269.562] (II) Loading sub module "fbdevhw"
[   269.562] (II) LoadModule: "fbdevhw"
[   269.562] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   269.574] (II) Module fbdevhw: vendor="X.Org Foundation"
[   269.574]  compiled for 1.19.2, module version = 0.0.2
[   269.574]  ABI class: X.Org Video Driver, version 23.0
[   269.575] (II) FBDEV(0): using default device
[   269.575] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   269.575] (II) FBDEV(0): Creating default Display subsection in Screen section
  "Default Screen Section" for depth/fbbpp 24/32
[   269.575] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[   269.575] (==) FBDEV(0): RGB weight 888
[   269.575] (==) FBDEV(0): Default visual is TrueColor
[   269.575] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[   269.575] (II) FBDEV(0): hardware: BCM2708 FB (video memory: 5120kB)
[   269.575] (II) FBDEV(0): checking modes against framebuffer device...
[   269.575] (II) FBDEV(0): checking modes against monitor...
[   269.575] (--) FBDEV(0): Virtual size is 1280x1024 (pitch 1280)
[   269.575] (**) FBDEV(0):  Built-in mode "current"
[   269.575] (==) FBDEV(0): DPI set to (96, 96)
[   269.576] (II) Loading sub module "fb"
[   269.576] (II) LoadModule: "fb"
[   269.576] (II) Loading /usr/lib/xorg/modules/libfb.so
[   269.588] (II) Module fb: vendor="X.Org Foundation"
[   269.588]  compiled for 1.19.2, module version = 1.0.0
[   269.588]  ABI class: X.Org ANSI C Emulation, version 0.4
[   269.588] (**) FBDEV(0): using shadow framebuffer
[   269.588] (II) Loading sub module "shadow"
[   269.588] (II) LoadModule: "shadow"
[   269.589] (II) Loading /usr/lib/xorg/modules/libshadow.so
[   269.591] (II) Module shadow: vendor="X.Org Foundation"
[   269.591]  compiled for 1.19.2, module version = 1.1.0
[   269.591]  ABI class: X.Org ANSI C Emulation, version 0.4
[   269.591] (II) UnloadModule: "modesetting"
[   269.591] (II) Unloading modesetting
[   269.592] (==) Depth 24 pixmap format is 32 bpp
[   269.613] (==) FBDEV(0): Backing store enabled
[   269.617] (==) FBDEV(0): DPMS enabled
[   269.617] (==) RandR enabled
[   269.660] (II) SELinux: Disabled on system
[   269.665] (II) AIGLX: Screen 0 is not DRI2 capable
[   269.665] (EE) AIGLX: reverting to software rendering
[   271.308] (II) IGLX: enabled GLX_MESA_copy_sub_buffer
[   271.313] (II) IGLX: Loaded and initialized swrast
[   271.313] (II) GLX: Initialized DRISWRAST GL provider for screen 0
 



pas de prise en charge matérielle

Dernière modification par robert2a (08-02-2018 14:45:30)

Hors ligne

#2 04-02-2018 22:31:16

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [resolu] Debian sur Raspberry PI3

Bon je poste depuis ma buster sur rpi3 , meme installé mate et synaptic
le souci c'est le noyau 4.9
on a peur de rien , j'ai modifié le script pour tenter d'avoir le 4.14 (je suis sur un disque dur avec de la place )
de mémoire le noyau ressemble a celui de Raspdebian (il est récupéré sur un dépot git je sais pas si possible de le faire a partir des dépots debian )
par contre la mise a jour du noyau a partir de debian ne fonctionne pas  (pas de grub)
il y a un kernel.img je sais pas si c'est le noyau renommé
pour l'instant


Linux rpi3-buster 4.9.79-v7 #1 SMP Sun Feb 4 13:43:16 CET 2018 armv7l GNU/Linux
 


nota: le 4.14 est disponible sur le dépot git , j'ai vérifié .

325Mo sur 1024  ,  swap non disponible avec une console et chromium ouvert  (ou je poste )

si j'arrive a activer kms ce serait mieux  .........


name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 5.0, 128 bits) (0xffffffff)
    Version: 17.3.3
    Accelerated: no
    Video memory: 927MB
    Unified memory: no
 

Dernière modification par robert2a (04-02-2018 22:56:56)

Hors ligne

#3 08-02-2018 14:44:37

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [resolu] Debian sur Raspberry PI3

Bonjour
je vais terminer ce post , trop de soucis avec debian , Raspbian est beaucoup plus optimisé pour le raspberry .
j'aurai quand meme testé  smile

pour les disques externe j'ai testé en 2.5 un boitier Advance
le Mobility disk s8  et le Stell disk
il permet le bout du raspery sur disque externe sans problème .
la référence du controleur  sata/usb :


Bus 001 Device 006: ID 174c:55aa ASMedia Technology Inc. ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge
 



ASM1051E et ASM1053E

il supporte jusqu'a 2To en disque 2.5 (attention a l'épaisseur du disque )

Hors ligne

Pied de page des forums