Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-02-2018 01:38:08

Grompf
Adhérent(e)
Distrib. : KDE Neon User
Noyau : 4.13.0 generic
(G)UI : KDE Plasma
Inscription : 08-06-2016

Curiosité : le wi-fi ne s'enclenche pas sans session graphique

Pas une demande d'aide, juste une observation à partager.

Je fais des essais avec un vieux mini PC, en 32 bits. J'y ai installé Debian Stretch avec KDE. La carte wifi est une Broadcom BCM4312.
Je me suis décidé à faire passer tout ça en Testing. Je modifie mon fichier sources avec Nano : remplacement de "Stretch" par "Buster", désactivation des Backports, ajout d'une ligne dédiée à Sid (en "roue de secours"). J'en profite pour changer l'adresse du dépôt et utiliser "httpredir.debian.org". Je crée un fichier de pining dans /etc/apt/preferences.d histoire de veiller à ce que les dépôts Sid ne prennent pas le dessus. Et je redémarre ma machine. Je ne lance pas de session graphique, je vais dans la console. L'idée et de faire le passage Stretch -> Buster, sans lancer l'environnement de bureau.

Je lance apt-get update et j'ai un message d'erreur. ??? Impossible. Je me dis que j'ai cochonné un truc, que je me suis planté.

Et en fait la réponse est simple : tant que je n'ai pas lancé de session graphique, je n'ai pas de wifi. Si j'ouvre mon environnement de bureau et que je reviens ensuite sur la console, là ça marche. Mieux : si j'ouvre mon environnement de bureau, que je ferme la session et que je lance la console, ça marche aussi. Mais après un redémarrage, je dois impérativement lancer une session graphique pour que le wifi s'active.

Je ne cherche pas à solutionner quoi que ce soit, juste à partager une expérience qui pourrait en être utiles à plus d'un...

CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - KDE Neon User

Hors ligne

#2 12-02-2018 08:41:01

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-6-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

Le wifi est configuré par networkmanager. Le service doit démarrer avec la session graphique sans doute et non au boot

Hors ligne

#3 12-02-2018 10:22:33

Grompf
Adhérent(e)
Distrib. : KDE Neon User
Noyau : 4.13.0 generic
(G)UI : KDE Plasma
Inscription : 08-06-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

Ben je découvre.
Ce qui est drôle c'est que si je démarre une session graphique, que je la referme et que j'ouvre une console, là le wifi fonctionne. Refermer la session graphique n'éteint pas ma xarte graphique.

CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - KDE Neon User

Hors ligne

#4 12-02-2018 14:35:11

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-6-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

se déconnecter n'arrête pas le service alors ?
je vais regarder comme ça se passe sur mon portable.

Edit : non sur le mien, la connexion wifi est active avant de me connecter sur ma session
Le retour de la commande nmcli te dirait peut-être des infos quand tu ne peut pas te connecter

nmcli


ou

ip -a link

Hors ligne

#5 12-02-2018 15:07:57

raleur
Membre
Inscription : 03-10-2014

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

chalu a écrit :

Le wifi est configuré par networkmanager. Le service doit démarrer avec la session graphique sans doute et non au boot


Non, le service NetworkManager démarre en même temps que le reste du système, pas lors d'une session. Ce n'est que l'applet graphique de NetworkManager qui est lancée à l'ouverture du bureau.

Par contre une connexion réseau ou wifi configurée avec l'option "disponible pour tous les utilisateurs" décochée n'est activée que lorsqu'une session de l'utilisateur qui l'a configurée est ouverte.

Dernière modification par raleur (17-02-2018 10:39:57)

Hors ligne

#6 15-02-2018 17:43:42

Grompf
Adhérent(e)
Distrib. : KDE Neon User
Noyau : 4.13.0 generic
(G)UI : KDE Plasma
Inscription : 08-06-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

C'est curieux, mais il me semble que j'ai le même genre d'histoires avec un autre PC, avec une toute autre configuration...
Je vais regarder ça de plus près.

CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - KDE Neon User

Hors ligne

#7 15-02-2018 19:59:49

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16 / 4.17-rc5
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

raleur a écrit :

chalu a écrit :

Le wifi est configuré par networkmanager. Le service doit démarrer avec la session graphique sans doute et non au boot


Non, le service NetworkManager démarre en même temps que le reste du système, pas lors d'une session. Ce n'est que l'applet graphique qui est lance à l'ouverture de session.
Par contre une connexion réseau ou wifi configurée avec l'option "accessible à tous les utilisateurs" (ou quelque chose dans le genre) décochée n'est activée que lorsqu'une session de l'utilisateur qui l'a configurée est ouverte.



Bonjour raleur
je sais pas ce que tu nome "applet graphique , mais le serveur X  est lancé a l invite du gestionnaire de session
j'utilise mes cartes graphiques sans ouvrir de session.
et pour le wifi bien sur qu il fonctionne sans bureau , comment je ferais avec mes Raspberry sinon.
je suis pas trop wifi , mais je dirai que avec un fichier interfaces ça doit déja fonctionner (comme test )
network-manager il me semble qu il dépend du système et pas du bureau (le network-manager-gnome lui doit dépendre du bureau )

donc le driver vidéo est lancé par le système et utilisable sans ouvrir de session  smile

nota : si il n'y a pas de gestionnaire de session , pas de serveur X et donc pas de driver vidéo (installation type serveur ) mais le "kernel-mode-setting" du noyau prendra en charge quand méme le gpu (au niveau de la définition en mode console pure par exemple )

Dernière modification par robert2a (15-02-2018 20:05:06)

Hors ligne

#8 17-02-2018 02:05:37

Grompf
Adhérent(e)
Distrib. : KDE Neon User
Noyau : 4.13.0 generic
(G)UI : KDE Plasma
Inscription : 08-06-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

Grrrmllll...
Depuis que j'ai repéré cette "curiosité", j'ai un problème.
J'ai probablement créé ce problème.
Je lance mon pc et le wi-fi ne se connecte plus automatiquement à l'ouverture de la session graphique. Je dois aller sur Network-Manager pour connecter le wi-fi.
Lorsque j'ai posté ce sujet, je me suis amusé à fouiller sur le net. Et j'ai lancé 2-3 commandes en console, en console, histoire de voir si le réseau était branché, etc.... Et j'ai dû toucher un truc, je ne sais pas quoi. Maintenant, je suis obligé de refaire la connection manuellement à chaque démarrage.
Rien de grave. On parle d'un PC d'appoint, équipé de Debian Testing.
Mais je suis curieux et j'aimerais bien comprendre ce que j'ai fait (à moins que ce ne soit un bug de Testing).

Je vous fait une liste des hypothèses à exclure :
- Dans "configurer le réseau", l'option "se configurer automatiquement à ce réseau..." est cochée
- Les conflits potentiels avec d'autres softs, j'ai contrôlé : https://debian-facile.org/doc:reseau:ne … potentiels . Wicd et resolvconf ne sont pas installés. Pour ce qui est de ifupodows, j'ai vérifié les fichiers indiqués et tout devrait être ok.
- J'ai résintallé Network-Manager (mais je n'avais pas fait une suppression complète).

Est-ce que j'essaie de faire une suppression complète de Network-Manager ? Mais ensuite je réinstalle comment ?
Qqn a une autre suggestion ?

CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - KDE Neon User

Hors ligne

#9 17-02-2018 10:38:07

raleur
Membre
Inscription : 03-10-2014

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

robert2a a écrit :

je sais pas ce que tu nome "applet graphique


L'applet de NetworkManager pour la zone de notification du bureau, installée par le paquet network-manager-gnome.
Le wifi n'a rien à voir avec le serveur X ni les cartes graphiques.

robert2a a écrit :

et pour le wifi bien sur qu il fonctionne sans bureau , comment je ferais avec mes Raspberry sinon.


Tu configures le wifi dans /etc/network/interfaces ou avec dhcpcd.

robert2a a écrit :

network-manager il me semble qu il dépend du système et pas du bureau (le network-manager-gnome lui doit dépendre du bureau )


C'est bien ce que j'écrivais.

Grompf a écrit :

Les conflits potentiels avec d'autres softs (...) Wicd et resolvconf


Il n'y a pas de conflit entre NetworkManager et resolvconf. NetworkManager s'interface avec resolvconf pour la gestion des DNS lorsque ce dernier est installé.

Tu as essayé de supprimer et recréer la connexion wifi ?

Hors ligne

#10 17-02-2018 12:27:31

Grompf
Adhérent(e)
Distrib. : KDE Neon User
Noyau : 4.13.0 generic
(G)UI : KDE Plasma
Inscription : 08-06-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

raleur a écrit :



Tu as essayé de supprimer et recréer la connexion wifi ?



Oui. J'ai essayé.

J'allume le PC. Je vois l'icône "Réseaux" dans ma barre avec un point d'interrogation. Si je clique dessus, je vois que mon réseau wi-fi est détecté (comme les autres). Le réseau en question est bel et bien marqué comme "se connecter automatiquement...".

Pour me connecter, je dois le faire manuellement.
La connection se fait automatiquement dans 2 cas de figure.
1. J'ouvre "Configurer les connections réseau", je vais dans ma connection wi-fi et je valide sans rien changer (vu qu'elle est déjà marquée comme "se connecter automatiquement..."). La connection se fait alors.
2. Je ne touche pas mon PC. Lorsque l'écran se verrouille, je déverrouille en rentrant mon mot de passe. Et là je constate que le wi-fi est connecté.

Je ne sais pas ce que j'ai bricolé pour en arrivé là. Ou alors c'est une fantaisie de testing. Je pourrais peut-être changer de pilote. Je ne comprends pas.


CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - KDE Neon User

Hors ligne

#11 17-02-2018 12:43:39

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

J'allume le PC. Je vois l'icône "Réseaux" dans ma barre avec un point d'interrogation. Si je clique dessus, je vois que mon réseau wi-fi est détecté (comme les autres). Le réseau en question est bel et bien marqué comme "se connecter automatiquement...".



Le point d'interrogation c'est quand il n'y a pas de réseau connecté ou quand le réseau ne trouve pas sa route ? Je ne connais pas bien le comportement de NM, dans le second cas ça pourrait être que tu as bidouillé resolv.conf , normalement devenu un lien symbolique vers   /run/NetworkManager/resolv.conf ce qui pose d'ailleurs des problèmes à avahi au démarrage....

Pour me connecter, je dois le faire manuellement.
La connection se fait automatiquement dans 2 cas de figure.
1. J'ouvre "Configurer les connections réseau", je vais dans ma connection wi-fi et je valide sans rien changer (vu qu'elle est déjà marquée comme "se connecter automatiquement..."). La connection se fait alors.
2. Je ne touche pas mon PC. Lorsque l'écran se verrouille, je déverrouille en rentrant mon mot de passe. Et là je constate que le wi-fi est connecté.

Je ne sais pas ce que j'ai bricolé pour en arrivé là. Ou alors c'est une fantaisie de testing. Je pourrais peut-être changer de pilote. Je ne comprends pas.



A mon avis c'est une fantaisie de l'interface chaise clavier wink combinée a la complexité de ce qu'est devenu network-manager + systemd qui a force de faire des trucs compliqué pour nous simplifier les choses finis par nous rendre la vie compliquée. kernal_panic.gif


« la France d'en bas manque peut-être de hauteur mais la France d'en haut ne manque jamais de bassesse... »
    Georges Coulonges

Hors ligne

#12 17-02-2018 13:00:44

Grompf
Adhérent(e)
Distrib. : KDE Neon User
Noyau : 4.13.0 generic
(G)UI : KDE Plasma
Inscription : 08-06-2016

Re : Curiosité : le wi-fi ne s'enclenche pas sans session graphique

Haricophile a écrit :


A mon avis c'est une fantaisie de l'interface chaise clavier wink


C'est l'hypothèse que je privilégie.
J'ai voulu vérifier le fonctionnemetn de la connection depuis la console en utilisant des commandes que je ne suis pas habitué à utiliser. Il y en avait sûrement une qui ne se contentait pas de vérifier mais qui modifiait un réglage.


CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - KDE Neon User

Hors ligne

Pied de page des forums