Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-02-2018 18:04:56

j57jp
Membre
Inscription : 24-11-2016

(abandon) installer avec install ou dpkg -i

c'est mortel !
je viens de réinstaller debian 9.3 avec xfce
tout neuf

1) j'ai voulu mettre un module mozilla , mozilla répond version ancienne 52.0 mettre la nouvelle 57.0.1
dans la console , etant  dans téléchargements,  j'ai fait apt-get install nouvelle version et
il ne veut pas

2) sur thunderbird  anglais ,j'ai fait :
root@j57jp-X751LD:/home/j57jp/Téléchargements# apt-get install  thunderbird-l10n-fr_52.6.0-1_all.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet thunderbird-l10n-fr_52.6.0-1_all.deb
E: Couldn't find any package by glob 'thunderbird-l10n-fr_52.6.0-1_all.deb'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « thunderbird-l10n-fr_52.6.0-1_all.deb »

puis
root@j57jp-X751LD:/home/j57jp/Téléchargements# dpkg -i thunderbird-l10n-fr_52.6.0-1_all.deb
Sélection du paquet thunderbird-l10n-fr précédemment désélectionné.
(Lecture de la base de données... 97393 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de thunderbird-l10n-fr_52.6.0-1_all.deb ...
Dépaquetage de thunderbird-l10n-fr (1:52.6.0-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de thunderbird-l10n-fr :
thunderbird-l10n-fr dépend de thunderbird (>= 1:52.6.0-1) ; cependant :
  La version de thunderbird sur le système est 1:52.6.0-1~deb9u1.

dpkg: erreur de traitement du paquet thunderbird-l10n-fr (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
thunderbird-l10n-fr

Dernière modification par j57jp (13-02-2018 14:59:15)

Hors ligne

#2 12-02-2018 18:20:48

raleur
Membre
Inscription : 03-10-2014

Re : (abandon) installer avec install ou dpkg -i

Tout cela est parfaitement normal.
apt-get installe un paquet (et ses dépendances), pas un fichier .deb.
dpkg installe un fichier .deb mais pas ses dépendances, il faut donc qu'elles soient déjà satisfaites.

Où as-tu pêché ce fichier .deb ?

Hors ligne

#3 12-02-2018 18:26:45

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS / Debian 9
Noyau : 4.15.4 / 4.9.0-5-amd64
(G)UI : Plasma 5.12.1 /Mate 1.16.2
Inscription : 05-03-2014

Re : (abandon) installer avec install ou dpkg -i

Les install de paquets "tiers" avec dpkg -i sont souvent suivies d'un apt-get -f install pour installer les dépendances.

Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

#4 12-02-2018 18:33:39

raleur
Membre
Inscription : 03-10-2014

Re : (abandon) installer avec install ou dpkg -i

Dans ce cas j'imagine qu'il faut passer à dpkg une option pour forcer l'installation sans les dépendances.
Ceci dit, si les dépendances de ce paquet sont dans les dépôts configurés (sans quoi apt-get -f install n'aura aucun effet), il y est aussi et je ne vois pas l'intérêt de passer par dpkg.

Dernière modification par raleur (12-02-2018 18:35:11)

Hors ligne

#5 12-02-2018 18:33:52

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (abandon) installer avec install ou dpkg -i

Salut c'est une nouveauté avec apt , mais pas apt-get qui est une commande plus ancienne
voir paquet-telecharge-depuis-un-site
apt tout comme gdebi gere les dépendances

Dernière modification par Croutons (12-02-2018 18:36:46)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#6 12-02-2018 18:59:36

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

exemple, je fais comment pour mettre thunderbird en francais ?

Hors ligne

#7 12-02-2018 19:10:15

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (abandon) installer avec install ou dpkg -i

c'est comme pour Firefox y'a un paquet pour la langue

apt install thunderbird-l10n-fr


c'est dit dans le wiki https://debian-facile.org/doc:reseau:thunderbird


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#8 12-02-2018 19:39:07

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

root@j57jp-X751LD:/home/j57jp# apt install thunderbird-l10n-fr
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
thunderbird-l10n-fr is already the newest version (1:52.6.0-1).
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
thunderbird-l10n-fr : Dépend: thunderbird (>= 1:52.6.0-1) mais 1:52.6.0-1~deb9u1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

ben   j'ai retrouvé ca comme réponse ?

Hors ligne

#9 12-02-2018 19:40:38

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (abandon) installer avec install ou dpkg -i

tu fais comme conseillé

apt --fix-broken install


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#10 12-02-2018 19:52:12

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

j'ai fait , j'ai fait update et upgrade
puis redemarre et ça marche pas
ouinnnn merci quand meme ,
on va faire avec

Hors ligne

#11 12-02-2018 20:17:55

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : 9 (stretch) 64bits Ordi.: Asus R511L
Noyau : 4.9.0-2 amd64
Inscription : 04-03-2017

Re : (abandon) installer avec install ou dpkg -i

Tu rentres la commande Suivante dans un terminal

apt-get install thunderbird


Distrib. : 8 (jessie) 64 bits
Ordinateur : Asus R511L

Hors ligne

#12 12-02-2018 20:21:12

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

avec thunderbird , il me dit

---root@j57jp-X751LD:/home/j57jp/Téléchargements# apt-get install thunderbird
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
thunderbird is already the newest version (1:52.6.0-1~deb9u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
-----------------------------------
j'ai essayé avec skype sur le site officiel
c'est la meme chose

---oot@j57jp-X751LD:/home/j57jp/Téléchargements# apt install skypeforlinux-64.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet skypeforlinux-64.deb
E: Couldn't find any package by glob 'skypeforlinux-64.deb'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « skypeforlinux-64.deb »

Hors ligne

#13 12-02-2018 20:35:35

raleur
Membre
Inscription : 03-10-2014

Re : (abandon) installer avec install ou dpkg -i

j57jp a écrit :

j'ai essayé avec skype sur le site officiel
c'est la meme chose


Non, rien à voir.
Apt, pas plus qu'apt-get, ne sert à à installer un .deb. C'est le rôle de dpkg.

Pour en revenir à thunderbird, peut-on voir la sortie de la commande suivante ?

apt-cache policy thunderbird thunderbird-l10n-fr

Dernière modification par raleur (12-02-2018 20:35:58)

Hors ligne

#14 12-02-2018 20:38:06

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

OK
Je suis trop nul ou trop vieux pour aller sur du linux libre , grrr et ça  m'emm.....
je tente encore quelques semaines
merci les gars ou  filles

Hors ligne

#15 12-02-2018 20:39:21

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

thunderbird:
  Installé : 1:52.6.0-1~deb9u1
  Candidat : 1:52.6.0-1~deb9u1
Table de version :
*** 1:52.6.0-1~deb9u1 500
        500 http://security.debian.org/debian-security stretch/updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:52.4.0-1~deb9u1 500
        500 http://ftp.fr.debian.org/debian stretch/main i386 Packages
thunderbird-l10n-fr:
  Installé : (aucun)
  Candidat : 1:52.6.0-1~deb9u1
Table de version :
     1:52.6.0-1~deb9u1 500
        500 http://security.debian.org/debian-security stretch/updates/main i386 Packages
     1:52.4.0-1~deb9u1 500
        500 http://ftp.fr.debian.org/debian stretch/main i386 Packages
     1:52.3.0-4~deb9u1 500
        500 http://ftp.fr.debian.org/debian stretch/main i386 Packages
        500 http://security.debian.org/debian-security stretch/updates/main i386 Packages

Hors ligne

#16 12-02-2018 20:39:42

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

ou bien alors c'est mon sources.List qui n'est pas bon,

Hors ligne

#17 12-02-2018 21:03:40

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (abandon) installer avec install ou dpkg -i

la commande message #9 a t'elle été tenté?

apt --fix-broken install




raleur a écrit :

Non, rien à voir.
Apt, pas plus qu'apt-get, ne sert à à installer un .deb. C'est le rôle de dpkg.


Comme je le dis dans mon message #5 voir le lien on peut installer un paquet provenant de l'exterieur avec apt
Seulement il faut respecter la syntaxe, il faut mettre le chemin complet on ne peut utiliser la commande cd et espéré que le system fasse la difference entre sources.list et fichier deb présent dans le répertoire

Donc concernant la commande pour installer skype elle aurait du etre

apt install /home/j57jp/Téléchargements/skypeforlinux-64.deb


seulement tu ne peut installer un paquet 64bit sur une Debian en 32bit
et il me semble que skype ne fais plus de version en 32bit (a vérifié )


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#18 12-02-2018 21:15:21

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de « skypeforlinux:amd64 » au lieu de « /home/j57jp/Téléchargements/skypeforlinux-64.deb »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
skypeforlinux:amd64 : Dépend: libasound2:amd64 (>= 1.0.16) mais il n'est pas installable
                       Dépend: libatk1.0-0:amd64 (>= 1.12.4) mais il n'est pas installable
                       Dépend: libc6:amd64 (>= 2.17) mais il n'est pas installable
                       Dépend: libcairo2:amd64 (>= 1.2.4) mais il n'est pas installable
                       Dépend: libcups2:amd64 (>= 1.4.0) mais il n'est pas installable
                       Dépend: libexpat1:amd64 (>= 2.0.1) mais il n'est pas installable
                       Dépend: libfreetype6:amd64 (>= 2.4.2) mais il n'est pas installable
                       Dépend: libgcc1:amd64 (>= 1:4.1.1) mais il n'est pas installable
                       Dépend: libgconf-2-4:amd64 (>= 3.2.5) mais il n'est pas installable
                       Dépend: libgdk-pixbuf2.0-0:amd64 (>= 2.22.0) mais il n'est pas installable
                       Dépend: libglib2.0-0:amd64 (>= 2.31.8) mais il n'est pas installable
                       Dépend: libgtk2.0-0:amd64 (>= 2.24.0) mais il n'est pas installable
                       Dépend: libnspr4:amd64 (>= 2:4.9-2~) mais il n'est pas installable
                       Dépend: libnss3:amd64 (>= 2:3.13.4-2~) mais il n'est pas installable
                       Dépend: libpango-1.0-0:amd64 (>= 1.14.0) mais il n'est pas installable
                       Dépend: libpangocairo-1.0-0:amd64 (>= 1.14.0) mais il n'est pas installable
                       Dépend: libsecret-1-0:amd64 (>= 0.7) mais il n'est pas installable
                       Dépend: libv4l-0:amd64 (>= 0.5.0) mais il n'est pas installable
                       Dépend: libx11-6:amd64 (>= 2:1.4.99.1) mais il n'est pas installable
                       Dépend: libx11-xcb1:amd64 mais il n'est pas installable
                       Dépend: libxcb1:amd64 (>= 1.6) mais il n'est pas installable
                       Dépend: libxcomposite1:amd64 (>= 1:0.3-1) mais il n'est pas installable
                       Dépend: libxcursor1:amd64 (> 1.1.2) mais il n'est pas installable
                       Dépend: libxdamage1:amd64 (>= 1:1.1) mais il n'est pas installable
                       Dépend: libxext6:amd64 mais il n'est pas installable
                       Dépend: libxfixes3:amd64 mais il n'est pas installable
                       Dépend: libxi6:amd64 (>= 2:1.2.99.4) mais il n'est pas installable
                       Dépend: libxrandr2:amd64 (>= 2:1.2.99.3) mais il n'est pas installable
                       Dépend: libxrender1:amd64 mais il n'est pas installable
                       Dépend: libxss1:amd64 mais il n'est pas installable
                       Dépend: libxtst6:amd64 mais il n'est pas installable
                       Dépend: apt-transport-https:amd64 mais il n'est pas installable
                       Dépend: libfontconfig1:amd64 (>= 2.11.0) mais il n'est pas installable
                       Dépend: libdbus-1-3:amd64 (>= 1.6.18) mais il n'est pas installable
                       Dépend: libstdc++6:amd64 (>= 4.8.1) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#19 12-02-2018 21:32:29

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-5-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : (abandon) installer avec install ou dpkg -i

Croutons a écrit :

il me semble que skype ne fais plus de version en 32bit (a vérifié )


oui c'est vrai donc on ne peut pas installer skypeforlinux-64.deb sur ce PC avec Debian en 32 bits

Par contre c'est possible d'avoir thunderbird en français avec

apt-get install thunderbird-l10n-fr

Hors ligne

#20 12-02-2018 21:49:29

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

ok
et pour thunderbird en français , tu pourrais avoir une solution
ainsi que pour  avoir un sources list performant

Hors ligne

#21 12-02-2018 22:08:27

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : 9 (stretch) 64bits Ordi.: Asus R511L
Noyau : 4.9.0-2 amd64
Inscription : 04-03-2017

Re : (abandon) installer avec install ou dpkg -i

voila mon sources.list qui fonctionne très bien :

# Debian stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian stretch, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian stretch, mises-à-jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
# Debian stretch, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian stretch-backports main contrib non-free

#depots multimedia
deb http://www.deb-multimedia.org stretch main non-free
 


Distrib. : 8 (jessie) 64 bits
Ordinateur : Asus R511L

Hors ligne

#22 12-02-2018 22:16:58

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-5-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : (abandon) installer avec install ou dpkg -i

Pas le dépôt multimédia sans avoir fait de fichier de préférences. Voir le wiki  https://debian-facile.org/doc:systeme:a … multimedia
Ce sources.list est préférable

# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
# Debian Stretch, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free



Édit : pour thunderbird en français c’est la commande que j’ai indiquée

Hors ligne

#23 13-02-2018 09:17:19

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : (abandon) installer avec install ou dpkg -i

Salut
j57jp arrete de lire les messages en diagonale tongue
Je dis que tu ne peux pas installer la version de Skype donc forcement que tu as des messages d'erreur

Pour Thunderbird on ne pourra avancer que quand tu auras decidé d'utiliser la commande conseillé

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#24 13-02-2018 15:01:17

j57jp
Membre
Inscription : 24-11-2016

Re : (abandon) installer avec install ou dpkg -i

Bonjour à tous ,
j'ai bien reçu la leçon, pour l'installation
debian est trop complex pour moi

de plus , je n'a mème pas pu installer à nouveau avec le cd (remise à neuf)

Je suis sur linux mint et l'installation, le bureau , ça marche, c'est simple pour l'instant pour moi ,

Bon  courage et merci à tous

a+

Hors ligne

#25 13-02-2018 15:26:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : (abandon) installer avec install ou dpkg -i

j57jp a écrit :

Je suis sur linux mint et l'installation, le bureau , ça marche, c'est simple pour l'instant pour moi


linux mint big_smile

Ne te gêne de rien avec cette distro sur le forum ! cool


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums