Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-02-2018 17:39:23

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

[RESOLU]Problème de son sur Speakers audio interne ALC269VB

Bonjour,
pour commencer, je suis tout nouveau sur Debian.:)
Je suis sur une installation toute fraîche avec mise à jour recommandée, ma 4ème aujourd'hui suite à des tentatives de résolution de mon problème.:(
Mon problème se résume à peu de chose : au démarrage, je n'ai pas de son, en consultant alsamixer, je constate que c'est pulseaudio qui est par défaut
A2ODgJDp0Jio.png
je choisi ma carte son
0xf4hXylrABe.png
je vois que mes speakers ne sont pas "mute" mais que les écouteurs le sont, du coup je les "démute" et là le son sur les speakers fonctionnent!!!
Bref on dirait qu'il y a une mauvaise configuration ou une mauvaise détection.
j'ai essayé de sauvegarder avec alsactl store mais rien n'y fait à chaque reboot, je dois repasser par alsamixer.
j'ai aussi tenté alsactl init

Quelqu'un aurait il une idée?

Dernière modification par Yves_Lg (21-02-2018 00:43:36)

Hors ligne

#2 20-02-2018 18:56:28

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Salut
J'ai vu dans le man alsamixer

bug Some terminal emulators (e.g. nxterm) may not work quite right with ncurses, but  that's  their  own  damn  fault.
       Plain old xterm seems to be fine.



Certains émulateurs de terminal (par exemple nxterm) peuvent ne pas fonctionner correctement avec les ncurses, mais c'est leur propre faute.
       Le vieil xterm semble aller bien.


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 20-02-2018 19:02:59

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Merci pour la réponse smile

Le vieil xterm semble aller bien.


mais comment revenir à xterm ?

Hors ligne

#4 20-02-2018 20:44:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Bonsoir et bienvenue Yves_Lg,

Il s'agit d'un problème connu (cf. ici ou ) et l'émulateur de terminal utilisé n'a rien à voir là-dedans, que retourne :

amixer -c 0 scontents


Pas de solution miracle, mais la possibilité d'automatiser l'exécution de la commande qui va bien au démarrage hmm

Dernière modification par èfpé (20-02-2018 21:14:42)

En ligne

#5 20-02-2018 22:21:54

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Bonsoir et merci de votre intérêt

èfpé a écrit :



Il s'agit d'un problème connu (cf. ici ou ) et l'émulateur de terminal utilisé n'a rien à voir là-dedans, que retourne :

amixer -c 0 scontents

/



Voici le résultat après un reboot sans aucune intervention sur alsamixer :

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 50 [57%] [-27.75dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'Headphone Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [36.00dB]
  Front Right: 3 [100%] [36.00dB]
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
 

Hors ligne

#6 20-02-2018 22:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Re-,

OK ; est-ce que la commande suivante suffit à régler le souci ?

amixer -q -c 0 sset Headphone unmute


Auquel cas, il n'y aura plus qu'à créer un petit fichier .desktop !

En ligne

#7 20-02-2018 22:48:18

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

èfpé a écrit :

Re-,

OK ; est-ce que la commande suivante suffit à régler le souci ?

amixer -q -c 0 sset Headphone unmute


Auquel cas, il n'y aura plus qu'à créer un petit fichier .desktop !



Non et concernant les liens précédents, je viens de regarder mais je ne trouve pas /etc/rc.local

Hors ligne

#8 20-02-2018 22:55:15

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

je viens d'essayer :

amixer -c 0 set Master playback 100% unmute
amixer -c 0 set Headphone playback 100% unmute
amixer -c 0 set Speaker playback 100% unmute



Et ça marche mais comment et où placer ces commandes pour que ce soit permanent ?

Hors ligne

#9 20-02-2018 23:08:43

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Re-,

OK ; bon l'idéal aurait tout de même été d'avoir le retour de la commande avant/après ajustement, pas à l'arrache.
Le principe est de créer un fichier .desktop dans le répertoire /home/$USER/.config/autostart ou /etc/xdg/autostart.

En ligne

#10 20-02-2018 23:15:51

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

Désolé, fallait le dire, j'ai pas trop l'habitude sad
pour le avant :

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 50 [57%] [-27.75dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]



et après :

yves@Yves-1011PX:~$ amixer -c 0 set Master playback 100% unmute
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
yves@Yves-1011PX:~$ amixer -c 0 set Headphone playback 100% unmute
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
yves@Yves-1011PX:~$ amixer -c 0 set Speaker playback 100% unmute
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
 

Hors ligne

#11 20-02-2018 23:19:30

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

je pense avoir trouver la solution mais je ne comprend pas très bien où la mettre en oeuvre https://askubuntu.com/questions/829520/ … 766#929766

Hors ligne

#12 21-02-2018 00:42:14

Yves_Lg
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 20-02-2018

Re : [RESOLU]Problème de son sur Speakers audio interne ALC269VB

j'ai enfin pu résoudre mon problème avec ce lien https://askubuntu.com/questions/829520/ … 766#929766

Pour info la commande pour identifier le mixer à modifier:

pactl list | grep 'Active Port.*output.*'



ne me donnais rien, j'ai donc fait :

pactl list | grep 'Port actif.*output.*'



j'ai modifié le fichier /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf comme expliqué dans ce lien.

1. Permet au volume PA d'ajuster le volume ALSA du casque.

Original:

[Element Headphone]
switch = off
volume = off

Édité:

[Element Headphone]
switch = off
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

  2. (Facultatif) Désactivez le volume du haut-parleur et évitez que le volume de sonorisation affecte le volume ALSA. (Si vous ne le faites pas, votre son fonctionnera toujours, mais les paramètres de haut-parleurs dans ALSA rebondiront sans résistance.)

Original:

[Element Speaker]
required-any = any
switch = mute 
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

Édité:

[Element Speaker]
required-any = any
switch = mute
volume = off



En espérant que mes explications pourront servir à d'autres et un grand merci à èfpé qui m'a mis sur la piste avec ce lien https://ubuntuforums.org/showthread.php … st13603158 c'est là que j'ai enfin trouvé un autre lien vers la solution !

Hors ligne

Pied de page des forums