Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-02-2018 19:14:42

darkiem
Membre
Lieu : Lyon
Distrib. : Stretch / Linux Mint / W$ 10
Noyau : 4.9.0-6-amd64
(G)UI : XFCE
Inscription : 20-02-2018

[Résolu] Dual Boot DFLinux installé / Pas de Grub

Après diverses tentatives d'installations de DFLinux en Dual Boot, je pense être arrivée à un moment où j'ai enfin réussi à faire quelque chose de concret ! En effet, dans le BIOS, je peux décider si je veux lancer Windows... Ou si je lance Debian ! Les deux sont bien séparés. Si, avant, dès que j'enlevais la clé USB, il n'y avait plus que l'option de Windows, maintenant il y a Debian big_smile Sauf que...

Lorsque je le lance, ça m'amène sur une page de terminal. Je m'étais dit "bon, vu que le GRUB n'a pas pu s'installer, je dois sûrement rentrer ce qu'il m'avait dit. J'avais noté ça sur ce qu'il avait marqué :

noyau/vmlinux sur partition /dev/sda7


root=/dev/sda7



J'ai voulu chercher cet endroit dans le terminal mais les commandes comme cd ne fonctionnent pas. Je peux faire TAB pour montrer les commandes disponibles mais je ne vois pas laquelle pourrait me servir neutral

Lors de l'installation du GRUB, ça m'avait dit :

Machine configurée pour fonctionner avec EFI



J'avais accepté de forcer l'installation, réponse après essai :

exécution de grub-install échoué

->

erreur fatale



Faut-il que je réinstalle le Grub pour que ça fonctionne ? Si oui, comment ? Merci big_smile

Dernière modification par darkiem (21-02-2018 23:52:26)

Hors ligne

#2 20-02-2018 19:27:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Dual Boot DFLinux installé / Pas de Grub

darkiem a écrit :

Faut-il que je réinstalle le Grub pour que ça fonctionne ?


Le terminal où tu aboutis est bien celui de debian mais en console ?
Voir le tuto : https://debian-facile.org/doc:systeme:console


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 20-02-2018 20:01:56

darkiem
Membre
Lieu : Lyon
Distrib. : Stretch / Linux Mint / W$ 10
Noyau : 4.9.0-6-amd64
(G)UI : XFCE
Inscription : 20-02-2018

Re : [Résolu] Dual Boot DFLinux installé / Pas de Grub

En fait c'est le terminal de GRUB (je viens de voir qu'à gauche, c'est marqué GRUB) :

img_2013.jpg

Hors ligne

#4 20-02-2018 22:05:06

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Stretch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [Résolu] Dual Boot DFLinux installé / Pas de Grub

Un tuto qui pourrait peut-être t'aider.

https://debian-facile.org/doc:systeme:grub2:reparer

Hors ligne

#5 21-02-2018 00:14:34

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Dual Boot DFLinux installé / Pas de Grub

C'est la ligne de commande de GRUB. Il manque probablement le fichier /boot/grub/grub.cfg. Si tu sais sur quelle partition tu as installé Debian, tu peux taper les commandes suffisantes pour démarrer le système puis exécuter update-grub.

linux /vmlinuz root=/dev/sda7 ro
initrd /initrd.img
boot
 


Sinon, il suffit de relancer l'installateur en mode rescue, sélectionner la racine, lancer un shell sur la racine et exécuter update-grub.

Hors ligne

#6 21-02-2018 23:45:06

darkiem
Membre
Lieu : Lyon
Distrib. : Stretch / Linux Mint / W$ 10
Noyau : 4.9.0-6-amd64
(G)UI : XFCE
Inscription : 20-02-2018

Re : [Résolu] Dual Boot DFLinux installé / Pas de Grub

J'ai essayé la première solution donnée par raleur et je pense que c'est bon, ça a fonctionné smile

- J'ai pu lancer DFLinux. Quand je voulais faire une mise à jour des paquets, par contre, ça buguait.
- J'ai branché mon ordi en filiaire à l'aide d'un adaptateur USB/RJ45 (pas de port éthernet neutral ) et ai mis à jour les paquets via le gestionnaire des paquets puis, dans un terminal :

sudo apt-get upgrade


et

sudo apt-get update



- Après je suis revenue là et ai vu que j'avais oublié de faire update-grub, donc je l'ai fait aussi.

Maintenant, ça fonctionne, je ne tombe plus sur grub quand je commence, mais sur trois options :

*Debian GNU/Linux


Options avancées pour Debian GNU/Linux


Windows Boot Manager



Du coup, j'ai juste à sélectionner le premier (ou attendre, ça choisit la première tout seul si je ne choisis pas assez vite) et j'arrive sur la page de lancement de session.

Dernière modification par darkiem (21-02-2018 23:46:05)

Hors ligne

Pied de page des forums