Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-02-2018 17:52:20

hott1
Membre
Inscription : 23-02-2018

accéder a la page web

Bonjour à tous !
Je souhaite installé glpi sur mon serveur debian jesssie, j'ai bien téléchargé et déplacer le répertoire glpi dans le dossier /var/www mais qaund je mets comme URL
192.168.x.128/glpi j’ai une page bizarre en PHP.
Merci d'avance!

. -------------------------------------------------------------------------- */ /** @file * @brief */ // Check PHP version not to have trouble if (version_compare(PHP_VERSION, "5.3.0") < 0) { die("PHP >= 5.3.0 required"); } define('DO_NOT_CHECK_HTTP_REFERER', 1); // If config_db doesn't exist -> start installation define('GLPI_ROOT', dirname(__FILE__)); include (GLPI_ROOT . "/config/based_config.php"); if (!file_exists(GLPI_CONFIG_DIR . "/config_db.php")) { include_once (GLPI_ROOT . "/inc/autoload.function.php"); Html::redirect("install/install.php"); die(); } else { $TRY_OLD_CONFIG_FIRST = true; include (GLPI_ROOT . "/inc/includes.php"); $_SESSION["glpicookietest"] = 'testcookie'; // For compatibility reason if (isset($_GET["noCAS"])) { $_GET["noAUTO"] = $_GET["noCAS"]; } Auth::checkAlternateAuthSystems(true, isset($_GET["redirect"])?$_GET["redirect"]:""); // Send UTF8 Headers header("Content-Type: text/html; charset=UTF-8"); // Start the page echo ''."\n"; echo ''; echo ''."\n"; echo ''."\n"; echo ''."\n"; echo ''; // Appel CSS echo ''; // surcharge CSS hack for IE echo ""; // echo ""; echo ""; echo ""; echo "
"; echo "
"; echo "
"; echo nl2br(Toolbox::unclean_html_cross_side_scripting_deep($CFG_GLPI['text_login'])); echo "
"; echo "
"; echo "
"; echo ""; // Other CAS if (isset($_GET["noAUTO"])) { echo ""; } // redirect to ticket if (isset($_GET["redirect"])) { Toolbox::manageRedirect($_GET["redirect"]); echo ''; } echo ''.__('Authentication').'
'; echo '
'.__('Login').''; echo ''; echo '
'; echo '
'; echo '
'.__('Password').''; echo ''; echo '
'; echo '
'; echo "
"; echo '
'; echo '

'; echo '

'; if ($CFG_GLPI["use_mailing"] && countElementsInTable('glpi_notifications', "`itemtype`='User' AND `event`='passwordforget' AND `is_active`=1")) { echo '
'. __('Forgotten password?').'
'; } Html::closeForm(); echo ""; echo "
"; // end login box echo "
"; echo ""; if (isset($_GET['error'])) { switch ($_GET['error']) { case 1 : // cookie error _e('You must accept cookies to reach this application'); break; case 2 : // GLPI_SESSION_DIR not writable _e('Checking write permissions for session files'); echo "
".GLPI_SESSION_DIR; break; case 3 : _e('Invalid use of session ID'); break; } } echo "
"; echo "
"; // end contenu login // Display FAQ is enable if ($CFG_GLPI["use_public_faq"]) { echo '
'. '[ '.__('Access to the Frequently Asked Questions').' ]'; echo '
'; } if (GLPI_DEMO_MODE) { echo "
"; Event::getCountLogin(); echo "
"; } echo "
"; echo ""; echo 'GLPI version '.(isset($CFG_GLPI["version"])?$CFG_GLPI["version"]:""). ' Copyright (C) 2003-'.date("Y").' INDEPNET Development Team.'; echo "
"; } // call cron if (!GLPI_DEMO_MODE) { CronTask::callCronForce(); } echo ""; ?>

Hors ligne

#2 23-02-2018 18:24:33

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc2
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : accéder a la page web

Bonjour
ton serveur Jessie , il utilise apache ?
il te faut installer php je pense aussi (ton script c'est pas du html )
nota: a priori le menu pour ce logger (aucune idée de ce qu'est glpi roll  )

ps: maintenant je connais tongue  =>  http://glpi-project.org/

a mon avis ton serveur web ne doit pas etre configuré convenablement
tu aura besoin peut etre aussi d une base de donnée (mysql ou autres )

Dernière modification par robert2a (23-02-2018 18:28:58)

Hors ligne

#3 25-02-2018 04:42:19

root@rkn
Adhérent(e)
Lieu : Grenoble
Distrib. : Debian Strech Apache2 HTTPS HTTP/2 BROTLI REDIS et
Noyau : PROD: 4.9.88-1+deb9u1
(G)UI : headless - aucun
Inscription : 24-02-2018
Site Web

Re : accéder a la page web

il doit te manquer une ou plusieurs dépendances.

je supputes php-gettext ou php-mbstring


apt-cache policy php-gettext
php-gettext:
  Installé : 1.0.12-0.1
  Candidat : 1.0.12-0.1
 Table de version :
 *** 1.0.12-0.1 500
        500 http://debian.proxad.net/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status

 apt-cache policy php-mbstring
php-mbstring:
  Installé : 1:7.0+49
  Candidat : 1:7.0+49
 Table de version :
 *** 1:7.0+49 500
        500 http://debian.proxad.net/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
 



Si pas installé, alors apt-get install pour les deux

Dernière modification par root@rkn (25-02-2018 04:42:51)


J'ai trouvé dieu https://www.debian.org/doc/manuals/debi … ex.fr.html
- If it works, dont update it.
- You don't know how, just do it, you will learn.
- Test, re-stest, test again, and maybe it will work.

Hors ligne

Pied de page des forums