Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-02-2018 06:39:05

root@rkn
Adhérent(e)
Lieu : Grenoble
Distrib. : Debian Strech Apache2 HTTPS HTTP/2 BROTLI REDIS et
Noyau : PROD: 4.9.88-1+deb9u1
(G)UI : headless - aucun
Inscription : 24-02-2018
Site Web

[RESOLU] ioncube loader

Bonjour,

j'ai besoins d'installer le loader ioncube sur debian 9.3 php 7.0

pour ce faire:


/opt/
wget http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz
tar xfz ioncube_loaders_lin_x86-64.tar.gz
 


puis

cp du bon 7.0.so vers /usr/lib/php/7.0/...

modification des fichiers php.ini rajout

 
zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.0.so
 



lorsque je fait php -v j'obtiens:


php -v
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled)
 


par contre, dans mon info.php aucune trace de ioncube
bzzc.jpg


alors que je devrais avoir:
ioncube_php_info.png


et lorsque je navigue vers /monsite/ioncube/ j'obtiens juste:
Site error: the ionCube PHP Loader needs to be installed.


des idées pour m'éclairer dans ma detresse ?

Dernière modification par root@rkn (03-03-2018 01:09:14)


J'ai trouvé dieu https://www.debian.org/doc/manuals/debi … ex.fr.html
- If it works, dont update it.
- You don't know how, just do it, you will learn.
- Test, re-stest, test again, and maybe it will work.

Hors ligne

#2 28-02-2018 19:06:15

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [RESOLU] ioncube loader

Salut
Je comprend pas grand chose mais j'ai vu ici https://www.evxonline.com/guides/216-in … 5-vps.html

zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.0.so


dans la section

[Zend]


il faut ajouter la ligne si je comprend bien soit [Zend] existe déjà ou soit il faut l'ajouter


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 02-03-2018 23:59:34

root@rkn
Adhérent(e)
Lieu : Grenoble
Distrib. : Debian Strech Apache2 HTTPS HTTP/2 BROTLI REDIS et
Noyau : PROD: 4.9.88-1+deb9u1
(G)UI : headless - aucun
Inscription : 24-02-2018
Site Web

Re : [RESOLU] ioncube loader

Merci.

Je suis en vacances ( youpie ) et je test rapidement.

J'ai trouvé dieu https://www.debian.org/doc/manuals/debi … ex.fr.html
- If it works, dont update it.
- You don't know how, just do it, you will learn.
- Test, re-stest, test again, and maybe it will work.

Hors ligne

#4 03-03-2018 01:07:46

root@rkn
Adhérent(e)
Lieu : Grenoble
Distrib. : Debian Strech Apache2 HTTPS HTTP/2 BROTLI REDIS et
Noyau : PROD: 4.9.88-1+deb9u1
(G)UI : headless - aucun
Inscription : 24-02-2018
Site Web

Re : [RESOLU] ioncube loader

Je'ai piqué un pc et je viens de faire un petit ssh ...

La seul différence entre ce que tu me propose et moi, c'est l'absence du [zend] que je me suis empressé de rajouter. Le chemin de mon .so étant juste.  Un redémarrage des services n'a rien donné. Il, a fallut un reboot de la machine, mais maintenant j'ai bien ce qu'il faut.

Encore merci mais c'est dingue car la doc officiel a simplement oublié les []

La bonne ligne de conf est donc:


/etc/php/7.0/cli/php.ini
/etc/php/7.0/fpm/php.ini
/etc/php/7.0/cgi/php.ini


[zend]
zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.0.so
# dans mon cas, le chemin vers le .so pouvant être différent
 

Dernière modification par root@rkn (03-03-2018 01:13:36)


J'ai trouvé dieu https://www.debian.org/doc/manuals/debi … ex.fr.html
- If it works, dont update it.
- You don't know how, just do it, you will learn.
- Test, re-stest, test again, and maybe it will work.

Hors ligne

Pied de page des forums