Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-02-2018 15:52:42

Kurlrip
Membre
Inscription : 18-09-2016

Problème debian 9 (probablement matériel)

Bonjour
Après avoir désespérément essayer d'avoir mon bureau je viens de faire une installation sans bureau.

DVD debian 9.3 nonfree



Quand je fait installation bureau, à l'ouverture de session gnome le pc fige.

En mode console, si je fait lspci il se fige aussi.

Si je met nomedeset dans grub la il démarre. Et je peux aussi faire lspci.

J'ai fait une install sans bureau et j'ai le même problème : lspci plante.

Je peux vous poster les log ou fichier de conf qui peuvent vous aider.

Fichier source.list :  http://paste.debian.net/1011900

Lspci    http://paste.debian.net/1011901

Je ne sais plus trop quoi faire.

Dernière modification par Kurlrip (25-02-2018 15:58:26)

Hors ligne

#2 25-02-2018 16:14:16

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc2
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Problème debian 9 (probablement matériel)

Bonjour
rien de grave , ton lspci


00:00.0 Host bridge: Intel Corporation Device 5910 (rev 05)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
00:1c.7 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #8 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070] (rev a1)
02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
03:00.0 USB controller: ASMedia Technology Inc. ASM1142 USB 3.1 Host Controller
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5250 PCI Express Card Reader (rev 01)
05:00.0 Ethernet controller: Qualcomm Atheros Device e0b1 (rev 10)
 


c'est la GTX1070 qui doit te faire des misères


01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070] (rev a1)
 



comme solution passer a Buster avec un noyau récent (4.14 ou 4.15 )  ou installer le driver nonfree de nvidia sur stretch

en mode console c'est très facile , quand le driver sera installé il faudra enlever l'option "nomodeset" dans grub (le driver fera ce qu il faut pour que KMS fonctionne bien )
pour les détails je laisse faire les pros

Nota: sur Buster j'ai testé la GTX1070 avec nouveau , pour ceux qui doutent de ce que je dis  roll

Dernière modification par robert2a (25-02-2018 16:15:59)

En ligne

#3 25-02-2018 16:15:07

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Problème debian 9 (probablement matériel)

Déjà tu mets ça dans ton sources.list

# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
# Debian Stretch, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free


Trisquel 8 64bits  Ordi.: Thinkpad T400
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#4 25-02-2018 17:00:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Problème debian 9 (probablement matériel)

Voir le tuto des sources stretch :
https://debian-facile.org/doc:systeme:a … st:stretch smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 25-02-2018 17:06:34

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Merci à vous je teste des retour devant mon pc

Hors ligne

#6 25-02-2018 17:47:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc2
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Problème debian 9 (probablement matériel)

je te met un exemple (sources.list pour stretch )


#stretch 9
deb http://deb.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
 



le # devant une ligne permet de la désactiver , ou de mettre un commentaire => "#stretch 9"

sinon pour ton problème de carte vidéo il y a l'utilisation des backports de stretch mais j'aime pas trop cette méthode mais peu t'éviter d'utiliser un driver nonfree
pour l'utilisation de "nouveau" comme driver , il y a le paquet "firmware-misc-nonfree" a installer.
pour rester correct il faudrait donc prendre un certain nombres de paquets sur les backports

a partir de la console pure (sans bureau ) tu a plusieurs solutions sous stretch pour retrouver ton bureau

nota: j'ai regardé un peu les paquets disponibles dans les backports , il n'y a que le noyau et le firmware.
le driver propriétaire reste la meilleure solution avec une si jolie carte vidéo  smile
la mienne a fonctionné très longtemps sous Stretch avec le driver nonfree 375.82  sans souci

Dernière modification par robert2a (25-02-2018 18:06:09)

En ligne

#7 25-02-2018 19:31:04

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Bon j'avance.
Install propre
J'ai mis les sources.list que Jean Pierre m'a indiqué.
Ensuite install firmware-misc-nonfree
Install firmware-atheros

Install driver nvidia avec dkms (tuto debian facile)

Au reboot sans nomodeset la commande lspci fonctionne et j'ai plus les erreur d'avant

Par contre j'ai plus l'écran de login et à la place j'ai un écran : Oh mince ! Quelque chose s'est mal passé.

Et j'ai accès à la console tty

Dmesg | grep -i firmware   http://paste.debian.net/1011933

/var/log/messages | grep EE   http://paste.debian.net/1011934

Dernière modification par Kurlrip (25-02-2018 19:33:55)

Hors ligne

#8 25-02-2018 21:51:51

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Bon j'ai enlever driver nvidia puis fait installation de bumblebee nvidia suivant tuto de debian facile.
Plus le message avec le smiley. Mais quand j'ouvre la session gnome le pc fige. Je ne sais pas quoi faire ni où regarder.

Hors ligne

#9 25-02-2018 23:41:10

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème debian 9 (probablement matériel)

tu as tenté de mettre un petit fichier pour voir si ça lance X

nano /etc/X11/xorg.conf

Section "Device"
Identifier  "Video Card"
Driver    "nvidia"
Option          "NoLogo"                    "1"
Option          "RenderAccel"               "1"
EndSection

tu reboot pour voir, et si ça marche, tu lances le

nvidia-settings

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).   

Hors ligne

#10 26-02-2018 00:01:09

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Je teste

Hors ligne

#11 26-02-2018 00:28:23

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

En faisant ça ça ne boot plus du tout

Hors ligne

#12 26-02-2018 00:30:54

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème debian 9 (probablement matériel)

scratchhead.gif
ben! en quoi un mauvais xorg peut empêcher un boot ?
ça a rien à voir

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).   

Hors ligne

#13 26-02-2018 00:35:20

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Ha ben je sais pas moi ?
Je l'ai supprimé et maintenant j'arrive à nouveau  jusqu'àu login. Ou plutôt jusqu'à Ho mince quelque chose s'est mal passé..

Hors ligne

#14 26-02-2018 00:38:47

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Ha ben je sais pas moi ?
Je l'ai supprimé et maintenant j'arrive à nouveau  jusqu'àu login. Ou plutôt jusqu'à Ho mince quelque chose s'est mal passé..

J'ai sans les messages (grep sur gdm) des messages qui semble intéressant pour comprendre mon problème : http://paste.debian.net/1011983

Hors ligne

#15 26-02-2018 00:38:47

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème debian 9 (probablement matériel)

curieux tout de même, mais quand c'est pas la personne qui installes qui cherche, c'est pas façile

je suppose que tu as installé  mesa-util   firmware-linux-nonfree
  et aussi
nvidia-driver  nvidia-settings  nvidia-xconfig  nvidia-kernel-dkms  xserver-xorg-video-nvidia

il me semble avoir vu un post où l'installe est réussi avec cette bécane '?

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).   

Hors ligne

#16 26-02-2018 00:39:26

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Je refais pour être sur

Hors ligne

#17 26-02-2018 00:55:31

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème debian 9 (probablement matériel)

y'a pas beaucoup d'erreur dans tes logs
quelques warnings

Falling back to old probe method for vesa
Falling back to old probe method for fbdev
Failed to load module "nouveau" (module does not exist, 0
Warning, couldn't open module nv
Warning, couldn't open module nouveau
The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

xfonts-cyrillic ça tu peux l'installer, mais bon ....
xserver-xorg-video-nouveau  ça coince

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).   

Hors ligne

#18 26-02-2018 00:57:23

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Pas mieux
Je t'assure quand je met le fichier xorg.conf il ne va pas jusqu a la demande de login

Hors ligne

#19 26-02-2018 00:58:28

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Je desinstall xserver nouveau ?

Hors ligne

#20 26-02-2018 01:01:54

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Ha ben xserver nouveau n'est pas installé...

Hors ligne

#21 26-02-2018 01:03:20

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème debian 9 (probablement matériel)

alors il a du mal à le charger ??:D

« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).   

Hors ligne

#22 26-02-2018 01:07:31

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

Je l installe mais ça change rien

Hors ligne

#23 26-02-2018 01:31:14

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème debian 9 (probablement matériel)

moi je ferai une récap tranquillement de ce qui est installé

dpkg -l | grep nvidia

je regarderai si il n'y a pas de restes de désinstallations nal  purgées

dpkg -l | grep -v ^ii

si trop de rc, les virer

dpkg -l | awk '$1~/^rc$/{print $2}')

se poser et voir un peu les posts sur ce sujet, sinon ça prends la tête et on loupe des choses...

tu as essayé le
apt install xserver-xorg-video-fbdev

Dernière modification par lagrenouille (26-02-2018 01:46:48)


« La conscience de soi est en soi et pour soi quand et parce qu'elle est en soi et pour soi pour une autre conscience de soi ; c'est-à-dire qu'elle n'est qu'en tant qu'être reconnu.»
Hegel (Phénoménologie de l'Esprit).   

Hors ligne

#24 26-02-2018 02:36:50

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc2
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Problème debian 9 (probablement matériel)

c'est un portable que tu a ? ou un PC de bureau
moi je suis parti sur une machine de bureau  hmm

Dernière modification par robert2a (26-02-2018 02:50:49)

En ligne

#25 26-02-2018 02:47:08

Kurlrip
Membre
Inscription : 18-09-2016

Re : Problème debian 9 (probablement matériel)

ok merci à vous, je regarde ça en rentrant de déplacement.

je vais vous envoyer le log messages que j'ai avec l"installation de base, avec les drivers nvidia installer. Visiblement en lisant le log tu vois vite le problème, et surtout qu'elle réponse potentielle y apporter.

Hors ligne

Pied de page des forums