Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 10-03-2018 23:20:21

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

voici ce que j'obtiens :

christophe@handylinux ~
$ sudo apt-get -t oldstable ffmpeg
[sudo] password for christophe:
Sorry, try again.
[sudo] password for christophe:         
E: L'option « t » de la ligne de commande [d'origine -t] est inconnue.
christophe@handylinux ~
$

Hors ligne

#27 10-03-2018 23:36:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] problème de gravure

Bonsoir,

@eric2954 : la commande que tu essaies d'exécuter est erronée, tente la commande suivante,

sudo apt-get -t oldstable install ffmpeg


@chalu : le paquet ffmpeg est disponible dans le dépôt jessie-backports mais j'dis ça, j'dis rien.

Hors ligne

#28 11-03-2018 00:13:04

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

chalu a écrit :

Bonjour smile
Avec le dépôt deb-multimedia, ne pas oublier de faire un fichier de préférences comme sur le wiki
https://debian-facile.org/doc:systeme:a … multimedia
Sinon on risque de se retrouver plus tard après des installations/suppressions avec des conflits sur des paquet communs avec les dépôts stables comme plusieurs fils du forum l’indiquent



Autant pour moi mais depuis que je suis Debian, j'ai toujours installé le dépôt deb-multimedia de la manière que je l'ai décrite au poste #6 et je n'ai jamais eu de problème de conflit (peut-être par chance ?), mais je vais devoir aussi me mettre aussi à la page. tongue

Sinon j'avoue que j'ai de l'admiration pour toi, eric2954, tu te dis novice mais d'autres aurai laisser tomber... en fait c'est aussi comme ça qu'on apprends. wink

Si l’installation du paquet ffmpeg qui t'as très bien été expliqué dans les précédents postes, a réussi, retourne nous cette commande:

ffmpeg -i "/home/$USER/video.avi" 2>&1 | grep "Stream"


(n'oublie pas d'adapté si nécessaire le chemin de vidéo.avi ...)

Dernière modification par Slyfox (11-03-2018 01:12:55)

Hors ligne

#29 11-03-2018 08:21:28

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-6-amd64
(G)UI : Mate 1.18
Inscription : 11-03-2016

Re : [Résolu] problème de gravure

J’ai effectivement oublié install dans la commande roll
Pour èfpé : je n’ai fait que répondre à la demande d’installation du dépot deb-multimedia initié par slyfox. Je ne saurais dire s’il y a un avantage ou pas pour l’usage de ffmpeg du dépôt , je ne l’utilise pas smile
Je laisse d’ailleurs slyfox poursuivre ce fil car je ne saurais aider pour cette usage

En ligne

#30 11-03-2018 15:03:07

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

Bonjour èfpé, chalu et Slyfox,

Merci pour votre aide précieuse. Je trouve qu'il est normal que je sois persévérant, eu égard à toute l'aide que vous m'apportez.

Merci èfpé, car, ta commande m'a permis d'installer ffmpeg sans problème.

Merci chalu, car, grâce à toi, j'ai quand même bien avancé.

Slyfox, ta commande ne donne rien. J'ai tapé : ffmpeg -i "/home/$christophe/videos/la_reine_margot.avi 2>&1 | grep "stream"
J'ai même varié en tapant le titre  comme çà : la reine margot ou la reine margot. N'hésite pas à me le dire si j'ai commis une erreur. Merci.

Cordialement à tous,

Hors ligne

#31 11-03-2018 15:26:03

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

eric2954 a écrit :

Slyfox, ta commande ne donne rien. J'ai tapé : ffmpeg -i "/home/$christophe/videos/la_reine_margot.avi 2>&1 | grep "stream"



Alors essaies:

ffmpeg -i "/home/christophe/videos/la_reine_margot.avi" 2>&1



il faut enlever le "$" devant ton user. smile

A+

Hors ligne

#32 11-03-2018 15:52:26

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

Voici ce que j'obtiens :

christophe@handylinux ~
$

ffmpeg -i "/home/christophe/videos/la_reine_margot.avi" 2>&1


ffmpeg version 2.6.9 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 4.9.2 (Debian 4.9.2-10)
  configuration: --prefix=/usr --extra-cflags='-g -O2 -fstack-protector-strong -Wformat -Werror=format-security ' --extra-ldflags='-Wl,-z,relro' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-nonfree --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-libvpx --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-librtmp --enable-avfilter --enable-libfreetype --enable-libvo-aacenc --disable-decoder=amrnb --enable-libvo-amrwbenc --enable-libaacplus --libdir=/usr/lib/i386-linux-gnu --disable-vda --enable-libbluray --enable-libcdio --enable-gnutls --enable-frei0r --enable-openssl --enable-libass --enable-libopus --enable-fontconfig --enable-libpulse --disable-mips32r2 --disable-mipsdspr1 --disable-mipsdspr2 --enable-libvidstab --enable-libzvbi --enable-avresample --disable-htmlpages --disable-podpages --enable-libutvideo --enable-libfdk-aac --enable-libx265 --enable-libiec61883 --enable-vaapi --enable-libdc1394 --disable-altivec --shlibdir=/usr/lib/i386-linux-gnu
  libavutil      54. 20.100 / 54. 20.100
  libavcodec     56. 26.100 / 56. 26.100
  libavformat    56. 25.101 / 56. 25.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 11.102 /  5. 11.102
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
/home/christophe/videos/la_reine_margot.avi: No such file or directory


christophe@handylinux ~
$
Et pourtant, le fichier est bien dans mon dossier "videos". J'ai fais la même commande pour rechercher mes autres videos, avec le même résultat. Le fichier est nommé la reine margot.avi

Edit à toto : mis la commande user avec la balise Commande user (le gros bouton au-dessus du post édité).

Dernière modification par eric2954 (11-03-2018 16:38:22)

Hors ligne

#33 11-03-2018 17:12:23

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] problème de gravure

eric2954 a écrit :

Le fichier est nommé la reine margot.avi


En ligne de code, s'il y a des espaces il faut les écrire ainsi :

ffmpeg -i "/home/christophe/videos/la\ reine\ margot.avi" 2>&1


Le caractère d'échappement (nommé anti-slash soit la combinaison des 2 touches du clavier : Altgr 8) : \ indique au système d'ignorer le caractère qui le suit immédiatement. smile

Le tuto un peu rude mais sympa : https://debian-facile.org/doc:programma … s-echappes


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#34 11-03-2018 17:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] problème de gravure

Bonjour,

eric2954 a écrit :

Et pourtant, le fichier est bien dans mon dossier "videos". J'ai fais la même commande pour rechercher mes autres videos, avec le même résultat. Le fichier est nommé la reine margot.avi


Le shell étant sensible à la casse et HandyLinux correctement francisé⋅e, essaie la commande :

ffmpeg -i "/home/christophe/Vidéos/la reine margot.avi"

équivalant ;

ffmpeg -i "/home/$USER/Vidéos/la reine margot.avi"


Encore faut-il être clair sur le nom du fichier : « la reine margot.avi » ou « la_reine_margot.avi » ?

Hors ligne

#35 11-03-2018 18:04:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] problème de gravure

Pour être sur du chemin, autant utiliser l'autocomplétion ainsi :
Tu tapes d'abords :

ffmpeg -i "/home/christophe/V


Et tu tapes sur la touche Tabulation du clavier (celle avec 2 flèches inversées au-dessus de la touche Verrouillant les Majuscules)

1/le mot ne se complète pas (pas d'ajout) essaie avec v minuscule... smile
2/Si cela se complète, tu ajoutes juste le mot suivant après le / désignant le fichier avi, soit : la
Et de nouveau tu autocomplètes avec la touche tabulation, etc...

Le tuto de l'autocomplétion pas à pas : https://debian-facile.org/doc:programma … completion cool


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#36 11-03-2018 19:32:37

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

Plusieurs solutions:

Celle proposée par l'ami smolski (autocomplétion) poste #35.

Autre solution:
Retourne-nous les commandes suivantes:

ls /home/$USER


et

ls /home/$USER/Vidéos


et

ls /home/$USER/videos



EDIT:
Autre solution...
Ouvre un terminal graphique (Applications --> Outils système --> Terminal)

ffmpeg -i "$(zenity --file-selection)" 2>&1


Retourne-nous le résultat. smile

Dernière modification par Slyfox (11-03-2018 20:02:19)

Hors ligne

#37 11-03-2018 21:38:02

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

Bonjour à tous,

Avec la commande d'èfpé, le terminal semble avoir retrouvé la video, comme indiqué ci-dessous : christophe@handylinux ~
$

ffmpeg -i "/home/christophe/Vidéos/la reine margot.avi"


ffmpeg version 2.6.9 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 4.9.2 (Debian 4.9.2-10)
  configuration: --prefix=/usr --extra-cflags='-g -O2 -fstack-protector-strong -Wformat -Werror=format-security ' --extra-ldflags='-Wl,-z,relro' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-nonfree --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-libvpx --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-librtmp --enable-avfilter --enable-libfreetype --enable-libvo-aacenc --disable-decoder=amrnb --enable-libvo-amrwbenc --enable-libaacplus --libdir=/usr/lib/i386-linux-gnu --disable-vda --enable-libbluray --enable-libcdio --enable-gnutls --enable-frei0r --enable-openssl --enable-libass --enable-libopus --enable-fontconfig --enable-libpulse --disable-mips32r2 --disable-mipsdspr1 --disable-mipsdspr2 --enable-libvidstab --enable-libzvbi --enable-avresample --disable-htmlpages --disable-podpages --enable-libutvideo --enable-libfdk-aac --enable-libx265 --enable-libiec61883 --enable-vaapi --enable-libdc1394 --disable-altivec --shlibdir=/usr/lib/i386-linux-gnu
  libavutil      54. 20.100 / 54. 20.100
  libavcodec     56. 26.100 / 56. 26.100
  libavformat    56. 25.101 / 56. 25.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 11.102 /  5. 11.102
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
Input #0, avi, from '/home/christophe/Vidéos/la reine margot.avi':
  Metadata:
    encoder         : Lavf56.31.102
  Duration: 02:11:39.02, start: 0.000000, bitrate: 2070 kb/s
    Stream #0:0: Video: h264 (High) (H264 / 0x34363248), yuv420p(tv), 720x576 [SAR 16:15 DAR 4:3], 1952 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc
    Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, s16p, 104 kb/s
At least one output file must be specified


christophe@handylinux ~
$

Edit à toto : Utilisé la balise Commande user (le Gros bouton) pour mettre la commande et son retour en valeur sur le forum.

Hors ligne

#38 11-03-2018 21:56:22

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

Je pense avoir trouvé ton problème...

Tu as une vidéo.avi mais le codec vidéo selon le retour de commande de ffmpeg est en h264.

Hors selon le manuel de ton lecteur en page 6 il est spécifié:

Utilisation de disques MPEG4
Les fichiers vidéo possédant les extensions suivantes peuvent être lus. : .avi, .divx, .AVI, .DIVX
Format vidéo DivX (Codec) : DivX 3.11, DivX .x, DivX 5.x (sans QPEL et GMC)
Format Audio DivX (Codec)  : MP3, MPEG1 Audio Layer
... (un peu plus loin)
Les disques d’une résolution supérieure à 720 x 576 pixels ne peuvent pas être lus.



Lien manuel DVD: http://downloadcenter.samsung.com/conte … 75-XEF.pdf

La solution est de réencoder la vidéo avec le bon codec vidéo... je reviens dans un instant avec une ligne de commande... wink

Dernière modification par Slyfox (12-03-2018 00:06:50)

Hors ligne

#39 11-03-2018 22:00:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] problème de gravure

voir le tuto ffmpeg pour le réencodage video :
https://debian-facile.org/doc:media:ffmpeg smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#40 11-03-2018 22:08:27

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

Bon voilà une ligne de commande qui devrai faire l'affaire:

ffmpeg -y -i "/home/$USER/videoSource.avi" -c:v libxvid -qscale:v 1 -s 720x576 -c:a libmp3lame -b:a 320k "/home/$USER/new-video.avi"


NB
Remplace "/home/$USER/videoSource.avi" par le chemin de fichier vidéo à convertir. wink

Ensuite grave ton DVD... et fait un test sur ton lecteur.

Dernière modification par Slyfox (12-03-2018 00:07:15)

Hors ligne

#41 11-03-2018 22:20:57

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

Merci smolski, mais le tuto pour le réencodage semble un peu compliqué pour moi.

Merci Slyfox pour la ligne de commande. Comment faire pour le réencodage ? Merci.

Merci à tous les deux.
Cordialement,

Dernière modification par eric2954 (11-03-2018 22:26:52)

Hors ligne

#42 11-03-2018 22:22:28

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

Voilà une mini version en graphique.

Fais un copier/coller dans un terminal de cette ligne de commande (sans la modifier):

ffmpeg -y -i "$(zenity --file-selection)" -c:v libxvid -qscale:v 3 -s 720x576 -c:a libmp3lame -b:a 320k "/home/$USER/new_video.avi"


Tapes ENTER
Dans la fenêtre graphique, choisis le fichier vidéo à convertir.
Attends un moment que la conversion se fasse (peut être long selon la puissance de ton ordinateur).
A la fin de conversion tu trouveras dans ton /home un fichier qui s'appelle "new-video.avi", renomme le à souhait (si possible évite les espaces).
Et pour finir grave le DVD, bon film... smile

Dernière modification par Slyfox (12-03-2018 00:14:30)

Hors ligne

#43 11-03-2018 22:22:58

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] problème de gravure

eric2954 a écrit :

le tuto pour le réencodage semble un peu compliqué pour moi.


Crée un fichier video d'essai et puis tu testes les commandes dessus, c'est le mieux. smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#44 11-03-2018 22:32:24

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

Merci Slyfox et smolski,

Tout est clair. Je ferai tout ça demain, car ça prendra pas mal de temps. Je suivrai toute vos indications.

Je vous remercie beaucoup de tout ce temps que vous prenez pour m'aider, et de votre patience.

Cordialement,

Hors ligne

#45 11-03-2018 22:33:40

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : [Résolu] problème de gravure

smolski a écrit :

Crée un fichier video d'essai et puis tu testes les commandes dessus, c'est le mieux. smile



Pas faux... cool

J'ai modifié la ligne de commande du poste #42 et celle de dessous crée une vidéo test de 30 secondes.
Donc fais un copier/coller de cette ligne de commande sans la modifier dans un terminal.

ffmpeg -y -i "$(zenity --file-selection)" -t 30 -c:v libxvid -s 720x576 -qscale:v 3 -c:a libmp3lame -b:a 320k "/home/$USER/new_video.avi"


et suis la procédure du poste #42.

NB
Bien entendu si tu arrives à lire la vidéo de test via ton lecteur DVD tu peux maintenant suivre la procédure comme expliquer dans le poste #42 dans son intégralité y compris la ligne de commande.

Dernière modification par Slyfox (12-03-2018 00:13:53)

Hors ligne

#46 12-03-2018 08:40:46

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.16.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] problème de gravure

Salut,

Un peu hors sujet mais pas tant que ça : en complément du wiki sur ffmpeg indiqué par smolski : https://debian-facile.org/doc:media:ffmpeg,
il existe aussi une interface graphique à ffmpeg / avconf : winff -> https://packages.debian.org/stable/winff
Sur le wiki : https://debian-facile.org/doc:media:winff

Exemple de capture d'écran où je demande à winff de convertir un avi en mp4 avec la ligne de commande générée par défaut : http://pix.toile-libre.org/?img=1520836509.png
Ça peut permettre de convertir sans connaître toutes les options, ou encore être un point de départ pour les apprendre . big_smile

Dernière modification par nono47 (12-03-2018 08:43:08)

Hors ligne

#47 12-03-2018 15:13:06

eric2954
Membre
Distrib. : Handylinux 2.5.1
Inscription : 24-09-2016

Re : [Résolu] problème de gravure

Bonjour à tous,

Je vous informe qu'après avoir suivi toutes les indications de Slyfox, notamment sa ligne de commande, le réencodage s'est fait sans problème, ainsi que la gravure sur DVD. J'ai pu visionner la vidéo sur mon lecteur de salon. Tout a fonctionné parfaitement.

Grand merci à Slyfox, èfpé, smolski et chalu, sans vous, je n'y serais pas arrivé.

Merci à toi nono47 pour tes informations, qui pourront-être utiles.

Ce forum est vraiment formidable. Si dans la vie de tous les jours, tout le monde faisait preuve de la même solidarité, le monde serait bien meilleurs.

Bonne journée à tous,
Cordialement,

Hors ligne

#48 12-03-2018 15:40:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] problème de gravure

eric2954 a écrit :

Tout a fonctionné parfaitement.


Y te reste plus qu'à le signaler dans le titre, voir le tuto en lien : \o/
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums