Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-03-2018 19:08:14

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

[Résolu]Installation de node.js sur stretch impossible

Bonjour,

J'essaye d'installer node.js afin d'utiliser Hexo (créateur de blog).
J'ai suivi la procédure standard:

curl -sL https://deb.nodesource.com/setup_9.x | sudo -E bash -



Puis je fais:

apt-get install y node.js


J'obtiens:

Les paquets suivants contiennent des dépendances non satisfaites :
 node-jssip : Dépend: node-websocket mais ne sera pas installé
                   Dépend: libjs-jssip (=0.6.34-5) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode "garder en l'état".


Je vérifie mais rien n'a été installé:

node -v


bash: node : commande introuvable



Je ne comprend pas bien l'erreur et comment la détourner.

Merci,

Dernière modification par bertaudmarc (12-03-2018 19:16:29)

Hors ligne

#2 09-03-2018 20:52:55

vv222
Modérateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.16 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

Est-ce que tu peux copier ici le retour complet de la commande suivante, à lancer depuis un terminal utilisateur (pas root) ?

apt install -s nodejs


Jouer sous Debian ? Facile !

Hors ligne

#3 10-03-2018 15:31:37

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

jpc@debian:~$

apt install -s node.js


NOTE: Ceci n'est qu'une simulation !
      apt a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de node-json-localizer pour l'expression rationnelle « node.js »
Note : sélection de node-json-stable-stringify pour l'expression rationnelle « node.js »
Note : sélection de node-jsv pour l'expression rationnelle « node.js »
Note : sélection de node-jsonstream pour l'expression rationnelle « node.js »
Note : sélection de node-jsesc pour l'expression rationnelle « node.js »
Note : sélection de node-json-stringify-safe pour l'expression rationnelle « node.js »
Note : sélection de node-json5 pour l'expression rationnelle « node.js »
Note : sélection de node-jscoverage pour l'expression rationnelle « node.js »
Note : sélection de node-js-yaml pour l'expression rationnelle « node.js »
Note : sélection de node-jssip pour l'expression rationnelle « node.js »
Note : sélection de node-jsonminify pour l'expression rationnelle « node.js »
Note : sélection de node-jsonselect pour l'expression rationnelle « node.js »
Note : sélection de node-jsonfile pour l'expression rationnelle « node.js »
Note : sélection de node-jsonparse pour l'expression rationnelle « node.js »
Note : sélection de node-jsonify pour l'expression rationnelle « node.js »
Note : sélection de node-js-tokens pour l'expression rationnelle « node.js »
Note : sélection de node-json-parse-helpfulerror pour l'expression rationnelle « node.js »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 node-jssip : Dépend: node-websocket mais ne sera pas installé
              Dépend: libjs-jssip (= 0.6.34-5) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


jpc@debian:~$

Edit : ajout des balises codes avec le bouton commande utilisateur.  Voir le tuto : Le code, ça pique moins les yeux en couleur

Hors ligne

#4 10-03-2018 16:42:09

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

jpc@debian:~$ apt install -s node.js


NOTE: Ceci n'est qu'une simulation !
      apt a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de node-json-localizer pour l'expression rationnelle « node.js »
Note : sélection de node-json-stable-stringify pour l'expression rationnelle « node.js »
Note : sélection de node-jsv pour l'expression rationnelle « node.js »
Note : sélection de node-jsonstream pour l'expression rationnelle « node.js »
Note : sélection de node-jsesc pour l'expression rationnelle « node.js »
Note : sélection de node-json-stringify-safe pour l'expression rationnelle « node.js »
Note : sélection de node-json5 pour l'expression rationnelle « node.js »
Note : sélection de node-jscoverage pour l'expression rationnelle « node.js »
Note : sélection de node-js-yaml pour l'expression rationnelle « node.js »
Note : sélection de node-jssip pour l'expression rationnelle « node.js »
Note : sélection de node-jsonminify pour l'expression rationnelle « node.js »
Note : sélection de node-jsonselect pour l'expression rationnelle « node.js »
Note : sélection de node-jsonfile pour l'expression rationnelle « node.js »
Note : sélection de node-jsonparse pour l'expression rationnelle « node.js »
Note : sélection de node-jsonify pour l'expression rationnelle « node.js »
Note : sélection de node-js-tokens pour l'expression rationnelle « node.js »
Note : sélection de node-json-parse-helpfulerror pour l'expression rationnelle « node.js »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 node-jssip : Dépend: node-websocket mais ne sera pas installé
              Dépend: libjs-jssip (= 0.6.34-5) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
jpc@debian:~$



Edit à toto : Mis les balises code à la place de quote destiné au texte plutôt qu'au code.

Dernière modification par bertaudmarc (10-03-2018 16:44:22)

Hors ligne

#5 10-03-2018 17:05:44

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Oublié de préciser que je suis passé de Jessie à Stretch il y a quelques mois. Avant cela marchait.



apt-cache policy nodejs


nodejs:
  Installé : (aucun)
  Candidat : 9.8.0-1nodesource1
 Table de version :
     9.8.0-1nodesource1 500
        500 [url]https://deb.nodesource.com/node_9.x[/url] stretch/main amd64 Packages
     4.8.2~dfsg-1 500
        500 [url]http://deb.debian.org/debian[/url] stretch/main amd64 Packages

Dernière modification par bertaudmarc (10-03-2018 17:11:06)

Hors ligne

#6 10-03-2018 18:02:10

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Bonjour smile
Que donne

apt policy libjs-jssip


et

apt -s install libjs-jssip

Hors ligne

#7 11-03-2018 16:09:09

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

apt policy libjs-jssip



libjs-jssip:
  Installé : (aucun)
  Candidat : 0.6.34-5
 Table de version :
     0.6.34-5 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
 



apt -s install libjs-jssip


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libjs-jssip : Dépend: libjs-websocket mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 

Dernière modification par bertaudmarc (11-03-2018 16:11:09)

Hors ligne

#8 11-03-2018 16:22:32

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

Salut smile

Je crois que node.js met un disposition un dépôt permettant d'installer le dernière version (ou la LTS) de l'écosystème, qui évolue bien plus vite que Debian. Le rôle du script de ta première commande est de créer le fichier de source qui va bien pour ça.

Dans tout tes retours de commande, rien ne semble provenir d'autres dépôts que ceux de Debian. Donc, il y a quelques-chose qui semble ne pas aller avec tes sources. Soit, le script d'installation de ces sources n'a pas fonctionné. C'est vérifiable avec

cat /etc/apt/sources.list.d/*.list


Soit, tu n'a pas fait

apt-get update


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#9 11-03-2018 18:12:07

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

cat /etc/apt/sources.list.d/*.list


deb https://deb.nodesource.com/node_9.x stretch main
deb-src https://deb.nodesource.com/node_9.x stretch main
 



Dois-je comprendre qu'après le curl je dois faire un update ?

Dernière modification par bertaudmarc (11-03-2018 18:12:44)

Hors ligne

#10 11-03-2018 18:13:48

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

Oui, je pense.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#11 11-03-2018 19:03:58

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Fait.
J'obtiens le même message !

Hors ligne

#12 11-03-2018 19:06:52

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

As-tu sudo installé et configuré pour que ton utilisateur ait tous les droits (en bref, un sudo à la mode Ubuntu) ?

Edit : Et peux tu mettre le message complets retourné par

apt-get update


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#13 11-03-2018 20:11:57

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Ign:1 http://liveusb.info/multisystem/depot all InRelease
Réception de:2 http://security.debian.org stretch/updates InRelease [63.0 kB]
Atteint:3 http://liveusb.info/multisystem/depot all Release                                            
Ign:4 http://deb.debian.org/debian stretch InRelease                                                    
Réception de:5 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]
Réception de:6 http://deb.debian.org/debian stretch Release [118 kB]  
Réception de:7 http://deb.debian.org/debian stretch Release.gpg [2'434 B]
Atteint:8 https://deb.nodesource.com/node_9.x stretch InRelease  
Réception de:10 http://security.debian.org stretch/updates/main amd64 Packages [340 kB]
Réception de:11 http://security.debian.org stretch/updates/main Translation-en [151 kB]
Réception de:12 http://deb.debian.org/debian stretch/main amd64 Packages [7'122 kB]        
Réception de:13 http://deb.debian.org/debian stretch/main Translation-en [5'394 kB]
13.3 Mo réceptionnés en 4s (3'199 ko/s)                            
Lecture des listes de paquets... Fait
 



J'ai fais l'install en root: fallait pas ?

Dernière modification par bertaudmarc (11-03-2018 20:13:15)

Hors ligne

#14 11-03-2018 20:56:35

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

bertaudmarc a écrit :

J'ai fais l'install en root: fallait pas ?

Si, parfait. Le script téléchargé par Curl au début télécharge la clé du dépôt et l'installe. Je voulais vérifié si il n'y avait pas eu de problème de ce coté là.

Mais, de toute façon, ce qui te bloque ne semble pas provenir de ce dépôt. Peut-être faut-il voir pourquoi libjs-websocket ne veut pas s'installer. Essaye

apt-get install -s libjs-websocket


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#15 11-03-2018 23:36:04

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libjs-websocket : Dépend: nodejs-dev (>= 4.6.1~dfsg-1~)
                   Dépend: nodejs-abi-46
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#16 11-03-2018 23:37:42

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

Il faut continuer la même opération avec tous les.paquets du message.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#17 12-03-2018 00:18:04

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

apt-get install -s nodejs-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation nodejs-abi-46:

Les paquets suivants contiennent des dépendances non satisfaites :
 nodejs-dev : Dépend: nodejs (= 4.8.2~dfsg-1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



apt-get install -s nodejs-abi-46
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet nodejs-abi-46 est un paquet virtuel fourni par :
  nodejs 4.8.2~dfsg-1 [Pas de version candidate]

E: Le paquet « nodejs-abi-46 » n'a pas de version susceptible d'être installée
 



apt-get install -s nodejs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  nodejs
0 mis à jour, 1 nouvellement installés, 0 à enlever et 120 non mis à jour.
Inst nodejs (9.8.0-1nodesource1 Node Source:deb.nodesource.com [amd64])
Conf nodejs (9.8.0-1nodesource1 Node Source:deb.nodesource.com [amd64])
 



Quel sac de noeuds si j'ose dire.
nodejs <> node.js

Dernière modification par bertaudmarc (12-03-2018 00:39:50)

Hors ligne

#18 12-03-2018 09:58:29

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

bertaudmarc a écrit :

E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Essaye peut-être

apt-get install -f


Puis essaye à nouveau l'installation de nodejs


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#19 12-03-2018 13:15:42

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 120 non mis à jour.
 



apt-get install -s nodejs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  nodejs
0 mis à jour, 1 nouvellement installés, 0 à enlever et 120 non mis à jour.
Inst nodejs (9.8.0-1nodesource1 Node Source:deb.nodesource.com [amd64])
Conf nodejs (9.8.0-1nodesource1 Node Source:deb.nodesource.com [amd64])
 



Est-ce normal les deux ont 500 ?

apt-cache policy nodejs



nodejs:
  Installé : (aucun)
  Candidat : 9.8.0-1nodesource1
 Table de version :apt-cache policy nodejs
     9.8.0-1nodesource1 500
        500 https://deb.nodesource.com/node_9.x stretch/main amd64 Packages
     4.8.2~dfsg-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
 

Dernière modification par bertaudmarc (12-03-2018 13:30:08)

Hors ligne

#20 12-03-2018 13:17:01

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Installation de node.js sur stretch impossible

Ah, commence peut être par un upgrade de ton système alors.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#21 12-03-2018 14:22:57

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Bonjour,
après un upgrade, tu peux installer nodejs en enlevant le s de la commande

apt install nodejs


Dans ton premier message, tu mets un point node.js et il n’y en a pas je crois
https://nodejs.org/en/download/package- … tributions

Hors ligne

#22 12-03-2018 14:32:14

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Non, mauvaise piste.
1) apt-get update
2) apt-get dist-upgrade
3) curl ...
4) apt-get install node.js

mêmes messages

Hors ligne

#23 12-03-2018 14:35:47

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu]Installation de node.js sur stretch impossible

Ben non tu mets le point et il ne faut pas c’est nodejs
Je vois pas de messages d’erreurs dans ta simulation

apt-get install -s nodejs



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  nodejs
0 mis à jour, 1 nouvellement installés, 0 à enlever et 120 non mis à jour.
Inst nodejs (9.8.0-1nodesource1 Node Source:deb.nodesource.com [amd64])
Conf nodejs (9.8.0-1nodesource1 Node Source:deb.nodesource.com [amd64])


Ou alors tu as tronqué le retour ?

Hors ligne

#24 12-03-2018 14:45:46

bertaudmarc
Membre
Lieu : suisse
Distrib. : Stretch
Noyau : Linux debian 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+
(G)UI : Xfce 4.12
Inscription : 19-04-2016

Re : [Résolu]Installation de node.js sur stretch impossible

J'ai changé la priorité du paquet 9.8.0, j'ai mis 502
puis apt-get install nodejs
=> s'installe correctement !
node -v donne v9.8.0

Je crois qu'on est bon mais je ne comprends pas qu'il faille bricoler comme cela.
Merci pour ton aide.
p.s: j'attends encore un peu pour mettre "résolu"

Hors ligne

#25 12-03-2018 15:19:56

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu]Installation de node.js sur stretch impossible

tu n'avais pas besoin de bricoler la priorité, saisir dans la commande le nom correct du paquet suffisait smile

Hors ligne

Pied de page des forums