Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-03-2018 22:53:38

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

[Résolu] problème ACPI / pcieport au boot

Bonjour à tous

J'ai installé la dernière version de Debian stable y'a quelques jours. Au demarrage j'ai toute une flopée d'erreur liée aux ports pci et ACPI.

Un jpg sera plus excplicite peut-etre. Desolé pour la qualité.

https://ibb.co/i9DtvS

J'ai toujours tendance à faire une recherche avant de poster, mais au vu du nombres d'erreurs, j'avoue que je sais pas quoi chercher en premier...

Si quelqu'un peux m'aider, j'apprecierais grandement ^^

Merci

Edit : Je ne savais pas ce que faisais ACPI. Maintenant au moins je sais. Ca gere les options de gestion d'alimentation (la luminosité de l'écran entre autre). Ca se confirme par le fait que la barre de gestion de luminosité de l'écran ne s'affiche pas en dessous de la barre de son.

Pour les erreurs pcieport ca à l'air lié à ma carte wifi ath10k. Qui a l'air inconnue ici --> https://wiki.debian.org/WiFi
Ca se confirme aussi par le fait qu'aucune option wifi ne s'affiche en dessous de "filaire connecté" dans le meme menu que la barre de son. J'ai bien une carte wifi usb qui traine, mais quand je vois les erreurs au boot ça fait tilter mon cerveau. Une idée svp ?

J'ai trouvé ce lien vachement utile (si quelqu'un passe par ici et a un problème similaire au mien) https://linuxpanda.wordpress.com/2016/1 … n-stretch/

un sudo apt-get install firmware-linux pourrait m'aider vous croyez ?
ou peut-être apt-get install network-manager-gnome ? (qui est pourtant censé être installé par défaut en choisissant l'environnement Gnome pendant l'installation)

(j'ai aussi installé Debian Stretch sur mon pc portable, aucune de ses erreurs n'apparait, la carte wifi c'est normal vu que c'est pas la même, mais aucun problème ACPI)

Dernière modification par Blob (26-03-2018 17:44:01)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#2 26-03-2018 17:09:20

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] problème ACPI / pcieport au boot

il te manque les firmwares non free pour plusieurs matériel
commencer par mettre a jour ton sources.list avec "main contrib non-free"
puis faire un apt-get update

suivre ce topic pour les détails  => https://debian-facile.org/viewtopic.php … 85#p259185

il te manque les firmwares


firmware-realtek
 

Dernière modification par robert2a (26-03-2018 17:11:37)

Hors ligne

#3 26-03-2018 17:11:14

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

robert2a a écrit :

il te manque les firmwares non free pour plusieurs matériel
commencer par mettre a jour ton sources.list avec "main contrib non-free"
puis faire un apt-get update

suivre ce topic pour les détails  => https://debian-facile.org/viewtopic.php … 85#p259185



Merci pour ta réponse :')

Je pensais pourtant avoir correctement edité le sources.list

# deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main

#deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main

deb [url]http://ftp.fr.debian.org/debian/[/url] stretch main contrib non-free
deb-src [url]http://ftp.fr.debian.org/debian/[/url] stretch main contrib non-free

deb [url]http://security.debian.org/debian-security[/url] stretch/updates main contrib non-free
deb-src [url]http://security.debian.org/debian-security[/url] stretch/updates main

# stretch-updates, previously known as 'volatile'
deb [url]http://ftp.fr.debian.org/debian/[/url] stretch-updates main contrib non-free
deb-src [url]http://ftp.fr.debian.org/debian/[/url] stretch-updates main




J'ai oublié quelque chose ?

Dernière modification par Blob (26-03-2018 17:57:23)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#4 26-03-2018 17:16:48

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] problème ACPI / pcieport au boot

donc le premier  => https://packages.debian.org/fr/stretch/firmware-realtek


apt-get install firmware-realtek
 



pour ton sources.list commente les lignes inutiles avec #


# deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main
# deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
# deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ stretch-updates main
 



pour celui ci  => https://packages.debian.org/fr/stretch/firmware-atheros


apt-get install firmware-atheros
 



un redémarrage pour prendre en compte les deux firmwares  ( si ton matériel est pris en charge (pas trop récent) les erreurs doivent disparaitre )

Dernière modification par robert2a (26-03-2018 17:26:20)

Hors ligne

#5 26-03-2018 17:26:12

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

Fait ! Je savais pas que deb-src n'était pas utile ^^

après un apt update && apt dist-upgrade && apt-get autoclean j'ai ces message qui attirent mon attention

root@Debian:/home/shiddo# apt update && apt dist-upgrade && apt-get autoclean
Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org/debian-security stretch/updates InRelease
Atteint:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Atteint:4 http://ftp.fr.debian.org/debian stretch Release      
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
All packages are up to date.
W: http://security.debian.org/debian-security/dists/stretch/updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://ftp.fr.debian.org/debian/dists/stretch-updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://ftp.fr.debian.org/debian/dists/stretch/Release.gpg: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait



après redemarrage, les erreurs sont toujours presentes

je teste apt-get install firmware-atheros

d'aillleurs
apt-get install acpi-call-dkms ca peux resoudre le problème d'acpi tu crois ?

Edit : L'icone wifi est apparue, mais j'ai encore un bon paquet d'erreur au demarrage. Deux trois lignes en moins je dirais ^^

Dernière modification par Blob (26-03-2018 17:57:42)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#6 26-03-2018 17:31:08

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] problème ACPI / pcieport au boot

efface ce fichier


rm /etc/apt/trusted.gpg
 



il est créé dans certaine circonstance mais ne sert a rien (un bug quoi roll  )

l'important est le dossier /etc/apt/trusted.gpg.d  qu il ne faut pas toucher  (attention a l'utilisation de la commande "rm" )

pour le moment ignore acpi et PCIe port error , pour moi c'est un bug du noyau mais ne doit pas perturber le système

par contre l erreur realtek et atheros ne doit plus etre présente

Dernière modification par robert2a (26-03-2018 17:35:01)

Hors ligne

#7 26-03-2018 17:34:08

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : [Résolu] problème ACPI / pcieport au boot

salut .

pour l'acpi , c'est souvent un problème mineur et irrésolvable .

1498812139.jpg TEXAS - SUMMER SUN (2017)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#8 26-03-2018 17:37:51

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] problème ACPI / pcieport au boot

tu a quoi comme carte graphique , le retour de lspci est possible ?
ou du moins donner le type de machine (portable ? , une ou deux carte video , la référence ? , le type de cpu ?

Hors ligne

#9 26-03-2018 17:39:59

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

robert2a a écrit :

efface ce fichier


rm /etc/apt/trusted.gpg
 



il est créé dans certaine circonstance mais ne sert a rien (un bug quoi roll  )




Ouais j'ai lu ça hier sur un forum. Il est apparu après avoir rechargé synaptic. Jvoulais le virer, merci de m'y avoir fait penser. (Ha mais m*** ca m'apprendra a pas lire mon terminal jusqu'au bout parfois !)

Tout fonctionne nickel, effectivement ça ne perturbe pas le fonctionnement du système. Je met le topic en resolu et je vous remercie beaucoup !


Robert2a

oui ^^

C'est la seule carte.

shiddo@Debian:~$ lspci -v | grep -A 12 VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050] (rev a1) (prog-if 00 [VGA controller])
  Subsystem: ASUSTeK Computer Inc. GP107 [GeForce GTX 1050]
  Flags: bus master, fast devsel, latency 0, IRQ 329
  Memory at de000000 (32-bit, non-prefetchable) [size=16M]
  Memory at c0000000 (64-bit, prefetchable) [size=256M]
  Memory at d0000000 (64-bit, prefetchable) [size=32M]
  I/O ports at e000 [size=128]
  [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
  Capabilities: <access denied>
  Kernel driver in use: nvidia
  Kernel modules: nvidia



CPU


shiddo@Debian:~$ cat /proc/cpuinfo | grep model
model   : 158
model name  : Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz



8Go de RAM. Faudrais que je recupère une barrette de mon ancien PC pour passer à 12Go, ça serait sympa.

Dernière modification par Blob (26-03-2018 18:11:59)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#10 26-03-2018 18:23:54

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] problème ACPI / pcieport au boot

pour nvidia GTX1050  tu utilise le driver nonfree de stretch avec le noyau 4.9
et pour le cpu c'est une serie 7 (KabyLake)  pas très vieux tout ça  wink

sur mon I7 7700


-- Logs begin at Mon 2018-03-26 18:14:08 CEST, end at Mon 2018-03-26 18:22:50 CEST. --
mars 26 18:14:11 kabylake1 kernel: pcieport 0000:00:1c.4:    [ 0] Receiver Error         (First)
mars 26 18:14:11 kabylake1 kernel: pcieport 0000:00:1c.4:   device [8086:a294] error status/mask=00000001/00002000
mars 26 18:14:11 kabylake1 kernel: pcieport 0000:00:1c.4: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e4(Receiver ID)
 


que je n'ai pas sur un petit I3 6100

Hors ligne

#11 26-03-2018 19:00:22

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

Ouais non il est tout recent ^^ Je devrais préférer une autre version du driver ?

J'me suis référé au wiki de Debian par ici https://wiki.debian.org/NvidiaGraphicsD … ion_375.66 ^^

J'essaie encore de comprendre cette ligne

# apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-driver



linux-header ok
$(...) c'est une variable mais pour ce qui est du contenu...
et nvidia-driver ben... ok aussi quoi

Ha merde yikes

jviens de lire ça pour ta deuxieme erreur

I believe this may be due to PCIe Active State Power Management that is transitioning the link to a lower power state and maybe causing the device to trigger these errors. I believe the device in question is the Sunrise Point-LP PCI Express Root Port.

Try using the pcie_aspm=off boot parameter to see if this stops the messages. Note that this will increase the power consumption of your machine as it disables the power savings.

Je peux te link le topic si tu veux, ça peux t'aider ?

Dernière modification par Blob (26-03-2018 19:00:58)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#12 26-03-2018 19:08:40

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] problème ACPI / pcieport au boot

ceci détermine la version de ton noyau => "$(uname -r|sed 's/[^-]*-[^-]*-//')"
donc si par exemple tu a un noyau "4.9.0-3-amd64"
ça va ajouter a "linux-headers-" ceci "4.9.0-3-amd64"
ce qui donne


linux-headers-4.9.0-3-amd64
 


quelle que soit la version du noyau installé la commande fonctionnera
ps: c'est un truc de barbu ça  wink

non ceci => pcie_aspm=off  je ne le fais pas

a cause de ceci


Notez que cela augmentera la consommation d'énergie de votre machine car elle désactive les économies d'énergie.
 



ps: je ne l'ai pas systématiquement ce message , et pour l'instant ça ne touche que intel (et certain processeur/bios )

Dernière modification par robert2a (26-03-2018 19:15:11)

Hors ligne

#13 26-03-2018 19:13:05

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

D'accord je comprends mieux ! Merci !
Je suis en train de voir pour apprendre un langage. J'aime beaucoup Python, mais j'me demande si je devrais pas commencer par bash en fait.
Mais j'aime beaucoup Python.

robert2a a écrit :



non ceci => pcie_aspm=off  je ne le fais pas

a cause de ceci


Notez que cela augmentera la consommation d'énergie de votre machine car elle désactive les économies d'énergie.
 



ps: je ne l'ai pas systématiquement ce message , et pour l'instant ça ne touche que intel (et certain processeur/bios )



Je comprends haha. Bizarre que ce soit un message aléatoire. 'Fin d'un côté si ça impacte pas les perfs et l'utilisation que tu veux faire de ton bureau, tant mieux.

Dernière modification par Blob (26-03-2018 19:22:59)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#14 26-03-2018 19:32:19

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu] problème ACPI / pcieport au boot

Bonjour smile

robert2a a écrit :

ceci détermine la version de ton noyau => "$(uname -r|sed 's/[^-]*-[^-]*-//')"
donc si par exemple tu a un noyau "4.9.0-3-amd64"
ça va ajouter a "linux-headers-" ceci "4.9.0-3-amd64"


Plus exactement linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') installera le paquet linux-headers-amd64 sur un système amd64 ou bien linux-headers-686 sur un système 686 et ainsi de suite suivant le système.
dans un terminal :

uname -r|sed 's/[^-]*-[^-]*-//'


renvoie chez moi et sur les PC ayant un système debian amd64 :

amd64


apt policy linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')


linux-headers-amd64:
  Installé : 4.9+80+deb9u4
  Candidat : 4.9+80+deb9u4
 Table de version :
     4.14+89~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 4.9+80+deb9u4 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        500 http://security.debian.org stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
 


La commande complète

apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')


permet donc d'installer dans ton cas comme sur mon PC le paquet linux-headers-amd64
et en dépendance le paquet linux-headers-4.9.0-6-amd64
L'installation du paquet linux-headers-amd64 est préférable si on veut que les "headers" soient maintenus à jour comme le noyau et que ça "suive" pour l'utilisation du driver avec les (fameux) dkms chers à robert2a pour les nvidia tongue (je n'utilise pas avec une carte ati wink )

Hors ligne

#15 26-03-2018 19:57:50

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

wow. Merci pour ces precisions !

En effet

shiddo@Debian:~$ apt policy linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')
linux-headers-amd64:
  Installé : 4.9+80+deb9u4
  Candidat : 4.9+80+deb9u4
 Table de version :
 *** 4.9+80+deb9u4 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status



si je comprends bien

apt-get remove linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-driver



suivi de

apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')

?

Dernière modification par Blob (26-03-2018 20:04:31)


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#16 26-03-2018 20:09:24

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu] problème ACPI / pcieport au boot

Blob a écrit :

si je comprends bien

apt-get remove linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-driver


Pourquoi tu veux faire ça ? ça va désinstaller ton driver nvidia et le paquet linux-headers-amd64.
Si tout marche bien, tu laisses comme ça smile

Hors ligne

#17 26-03-2018 20:11:32

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

Ouais non c'est ce que je suis en train de me dire. J'étais en train d'éditer mon message pour virer ma conn*** x)

Je lis un pdf sur le fonctionnement tcp/ip tout en anglais à coté. Je vais faire une pause pour le pdf je crois...

Par contre je reste ici. J'apprends beaucoup depuis que je lis les posts.

https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

#18 04-04-2018 17:18:44

Blob
Membre
Distrib. : Arch
Noyau : 4.16.6-1
(G)UI : KDE - 5.12.4
Inscription : 18-03-2018

Re : [Résolu] problème ACPI / pcieport au boot

J'étais en train de jeter un oeil à ce lien --> https://debian-facile.org/doc:materiel: … ia:accueil
Et je me disais que j'avais pas installé nvidia-detect, et je l'ai récupéré par curiosité.

nvidia-detect
Checking card:  NVIDIA Corporation GP107 [GeForce GTX 1050] (rev a1)
Your card is supported by the default drivers.
It is recommended to install the
    nvidia-driver
package.



Comme j'ai dis plus haut j'ai installé mes drivers à la base via

apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-driver



Du coup une question me trotte dans la tête. Le "It is recommended to install the nvidia-driver" retourné plus haut, c'est un message retourné par défaut non ?


https://lescahiersdudebutant.fr/
Iron Maiden's gonna get you, no matter how far

Hors ligne

Pied de page des forums