Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-12-2009 13:18:06

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Déconnexion intempestive de samba

Bonjour

depuis aujourd'hui mon samba me joue des tours, je démarre mon mac (personne n'est parfait) il me connecte directe et au bout de quelque minute, il me déconnecte comme sa, a ce moment là j'étais sur mon serveur en ssh et lui n'a pas été déconnecter, idem le serveur web est accessible et fonctionnel(le?).

ici impossible de ce connecter sur le serveur samba même avec un autre pc sous W7, je redémarre samba, veux tjrs pas, je redémarre mac, il veut, mais au bout de quelque minute bam...

j'ai des outils, denyhosts, fail2ban, mais il sont configurer pour que l'adresse du mac ne soit jamais bloqué (IP locale fixe)

de même j'ai mis en place un parefeu avec iptables, là encore avec iptables c'est du TOR donc jvois pas le pb, pas grand chose dans les logs... pas de mail sur localhost...

edit: àlala moi qui post sans même regarder le log de smbd et nmbd

voici ce que me dit smbd toute les 2min environ

[2009/12/29 11:27:01,  0] printing/print_cups.c:cups_connect(68)
  Unable to connect to CUPS server localhost:631 - Connection refused


bon jmen fou moi des imprimantes j'utilise pas...

en ce qui concerne nmbd il m'engueule juste parce que jlui ai foutu plein de kill -9 dans la tronche et qu'il aime pas sa

Dernière modification par Pollux (29-12-2009 20:51:17)

Hors ligne

#2 29-12-2009 14:11:07

rtfm33
Membre
Lieu : 33
Distrib. : Lenny 5.0.3
(G)UI : LXDE
Inscription : 22-11-2009

Re : Déconnexion intempestive de samba

Pollux a écrit :

voici ce que me dit smbd toute les 2min environ

[2009/12/29 11:27:01,  0] printing/print_cups.c:cups_connect(68)
  Unable to connect to CUPS server localhost:631 - Connection refused


bon jmen fou moi des imprimantes j'utilise pas...


Bonjour.
Si tu n'en as pas l'utilité,  désinstalle les paquets cups. wink

Cordialement.


userbar9mx3.png

Hors ligne

#3 29-12-2009 14:29:03

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Re : Déconnexion intempestive de samba

ok
voici ce que me dit netstat -c quand j'essaie de me connecter

tcp6     457      0 cassini.ho:microsoft-ds Pollux.home:49601       CLOSE_WAIT
tcp6     141      0 cassini.ho:microsoft-ds Pollux.home:49633       ESTABLISHED


de 1.
[mode kev1 =on] ckoi l'tcp6? d'habtude j'ai tcp mowa kikoololXdtropdelabombelol^^[/off]
de 2 j'ai les ports émetteurs mais je m'en fou un petit peu ce qu'es interresant ce sont les ports destinations
enfin on vois bien qu'il me refuse l'accès je ne sais pourquoi

edit: Fait intéressant mais très rageant, samba mais 10 plombe à se redémarrer ensuite je peux me reconnecter, pendant 3 min et rebelote

edit 2: il y avait une regle foireuse dans iptables conservant le dns de mon serveur, maintenant les pc le voit de suite,mais tjrs impossible de se connecter
quand je fait netstat -nt j'ai plusieur ligne me disant que j'ai essayer de me connecter sur le port 139 (smb donc) mais "CLOSED_WAIT"

Dernière modification par Pollux (29-12-2009 20:55:22)

Hors ligne

#4 30-12-2009 22:19:39

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Re : Déconnexion intempestive de samba

il y a quand même quelque chose de bizarre, je peux me connecter mais le temps ou je peux naviguer dans mes fichiers est variables .

il y a vraiment quelque chose un script je ne sais pas, ma machine à pignon sur la toile pourtant j'ai bloqué tous ce qui n'était pas utile avec iptables, installer denyhosts et fail2ban, mes mots de passe sont long et compliqué (pas d'attaque dico possible)... la maintenant tous de suite quand j'ai redémarrer samba, il m'a dit qu'il ne pouvait killer smbd parce qu'il n'était pas démarré, une tarre!!!!  J'ai beau consulter les logs je ne vois rien

Hors ligne

Pied de page des forums