Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-06-2018 22:08:43

ztheoz
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
Inscription : 12-04-2017

Pulseaudio semble désactiver les effets du bureau (KDE Plasma)

Bonjour,

j'ai installé Debian 9 avec KDE comme interface graphique sur mon ordinateur portable.
Cependant quand le son d'une alerte est lancée, le volume monte à 100%, quelque soit sa valeur initiale, ce qui est donc dérangeant.

J'ai donc lu sur un forum que pour résoudre ce problème on peut modifier une valeur du fichier /etc/pulse/daemon.conf.
Ce que j'ai fait, j'ai donc dé-commenté la ligne "flat-volumes = yes" et passé la valeur à "no", ce qui a réglé le problème après un redémarrage.

Mais maintenant une notification apparaît lors de l'ouverture de ma session, me disant qu'un programme a désactivé le effets du bureau et qu'il faut que j'entre Alt + Maj + F12 pour les réactiver.
Ce que j'ai fait, mais le problème réapparaît à chaque démarrage.
J'ai donc re-commenté la ligne "flat-volumes = no", ce qui a enlevé le problème des effets du bureau, ce qui prouve que cette modification est bien à l'origine de ce problème.

Quelqu'un sait-il comment résoudre cela?
Merci!

Hors ligne

#2 13-06-2018 12:14:23

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Pulseaudio semble désactiver les effets du bureau (KDE Plasma)

Salut
Problème résolu  avec la même solution mais pas de soucis avec les effets bureau
Essai de voir en installant phonon comme il est dit dans le sujet
https://debian-facile.org/viewtopic.php?id=13103

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 13-06-2018 15:59:18

ztheoz
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
Inscription : 12-04-2017

Re : Pulseaudio semble désactiver les effets du bureau (KDE Plasma)

Merci pour ta réponse.

J'ai donc cherché à installer les packets phonon et gstreamer, mais j'ai vu qu'ils l'étaient de base.
J'ai aussi téléchargé les packets suivants :

gstreamer* libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer0.10-plugins-* gstreamer1.0-plugins-*


Malheureusement, après un redémarrage le problème de son est toujours là.

J'ai ensuite dé-commenté la ligne flat-volumes = no, mais les effets du bureau sont toujours désactivés. Aussi j'ai vu sur le lien que tu m'as donné qu'il fallait sélectionner "Phonon VLC" comme moteur audio, mais il l'était de base, et je n'ai aucun autre choix de moteur.

[EDIT] J'ai installé le packet "phonon4qt5-backend-gstreamer", ce qui m'a permis de sélectionner "PhononGstreamer" comme moteur audio, mais maintenant à chaque redémarrage j'ai encore le problème de la désactivation du moteur graphique... kernal_panic.gif

Dernière modification par ztheoz (13-06-2018 16:09:22)

Hors ligne

#4 13-06-2018 21:12:58

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS
Noyau : 4.17.14
(G)UI : KDE Plasma 5.13.4
Inscription : 05-03-2014

Re : Pulseaudio semble désactiver les effets du bureau (KDE Plasma)

Pour le moteur, c'est phonon gstreamer qu'il faut prendre. Phonon vlc, de ce que je me souviens,
fonctionne très mal.
Par contre, je n'ai jamais rencontré de problèmes liés son/graphique ....

Desktop: CM Asus KCMA-D8. 2x AMD Opteron 4234 six coeurs @ 3,1 Ghz. 32 Go ddr3. GeForce GTX 1060.
Laptop: Toshiba C660-2D6. Intel core I3 2330M dual-core + HT @ 2,2 Ghz. 8 Go ddr3. GeForce 315M.
Media-Center: HP Compaq 6000 Pro. Intel Celeron E3400 dual-core @ 2,6 Ghz. 6 Go ddr3. GeForce GT 710.

Hors ligne

Pied de page des forums