Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-01-2010 23:07:29

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Erreur safe-upgrade.

Bonsoir,

Lorsque je fais un aptitude safe-upgrade après l'update, j'ai une erreur lors de la configuration d'un paquet. Ce paquet étant console-tools.
Voici ce que me donne la console :

debian:/home/max# aptitude safe-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu... Fait
Initialisation de l'état des paquets... Fait  
Lecture des descriptions de tâches... Fait  
Les paquets partiellement installés suivants seront configurés :
  console-tools
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
Paramétrage de console-tools (1:0.2.3dbs-67) ...
Setting console screen modes and fonts.
Setting console screen modes and fonts.
invoke-rc.d: initscript console-screen.sh, action "start" failed.
dpkg : erreur de traitement de console-tools (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 console-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
Paramétrage de console-tools (1:0.2.3dbs-67) ...
Setting console screen modes and fonts.
Setting console screen modes and fonts.
invoke-rc.d: initscript console-screen.sh, action "start" failed.
dpkg : erreur de traitement de console-tools (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 console-tools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu... Fait
Initialisation de l'état des paquets... Fait  
Lecture des descriptions de tâches... Fait


Avez vous une petite idée de comment résoudre le problème?

Merci

Hors ligne

#2 05-01-2010 03:29:07

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Erreur safe-upgrade.

Salut

Je suis allé faire un tour sur le site officiel Debian pour faire une petite recherche. Ton problème fait justement l'objet d'un rapport de bug. Ce bug est identifié comme grave. Un autre paquet corrigeant ce problème devrait donc arriver très rapidement comme c'est le cas dans ce genre de situation avec sid. Tu peux donc soit attendre un peu pour avoir le paquet corrigé, soit tenter de revenir à la version du paquet dans testing :

aptitude -s install console-tools/testing


J'ai mis un -s pour tester avant de le faire et testing pourrait être remplacé par squeeze dépendant de ce qui est écrit dans ton fichier sources.list

Une option intéressante que je n'ai pas testé encore est d'installer le paquet apt-listbugs qui recherche justement les rapport de bugs et nous permet de prendre une décision. Sous sid, des bugs il y a en beaucoup mais il faut éviter les bugs sévères (les mineurs c'est pas grave).

Bon moi aussi je suis sous sid et je n'ai pas encore fait un aptitude safe-upgrade. Je vais donc m'y mettre et venir éditer ce message pour la suite.

Retour :
Bon hé bien je suis veinard ! Je n'avais pas fait attention mais pour les amd64 (c'est mon cas), le paquet console-tools est encore en version 1:0.2.3dbs-66 qui, elle, fonctionne très bien.

Pour ton problème je te suggère donc d'attendre un peu, surtout si tu n'as pas un paquet cassé (ça c'est une autre histoire). Probablement que demain le bug sera réparé. Sinon, comme j'ai déjà dit, il y a aussi apt-listbugs qui pourrait être très intéressant. Pour ma part, jusqu'à maintenant, je n'ai jamais eu de problème majeur. Les paquets cassés je le répare immédiatement après le aptitude safe-upgrade fautif et le tour est joué. Pour listbugs je ne sais pas trop encore si je vais le mettre ou non (je pourrais au moins essayer pour voir) car je ne suis pas certain s'il n'est pas trop parano ; les bugs plus ou moins importants sont quand même assez nombreux sous testing/sid et il ne faut pas avoir peur de tout. Un peu de recherche sur la toile donc pour avoir une meilleure idée.

Dernière modification par martinux_qc (05-01-2010 03:57:02)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 05-01-2010 19:04:53

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Erreur safe-upgrade.

Bjr,
Si ça bloque il faut downgrader libconsole qui devrait reinstaller aussi console-tools en version inférieure

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#4 07-01-2010 04:37:36

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Erreur safe-upgrade.

Salut

La version du paquet console-tools qui pose problème est arrivé dans sid. On se retrouve à la fin de la mise à jour avec le message : "Des erreurs ont été rencontrées pendant l'exécution : console-tools". et le paquet n'est pas configuré correctement. Pour corriger cela, j'ai fait un :

# aptitude install libconsole/testing console-tools/testing


afin de pouvoir faire passer correctement console-tools en testing.

Par la suite j'ai fait un :

# aptitude forbid-version console-tools=1:0.2.3dbs-67


pour empêcher la mise à jour vers cette version.

Pour rappel, tiré du manuel de aptitude :

forbid-version

    Empêche la mise à jour vers une version précise d'un paquet. Cette option interdit à aptitude la mise à jour automatique vers cette version, mais permettra le passage aux versions suivantes. Par défaut, aptitude choisira la version vers laquelle ce paquet aurait normalement dû être mis à jour. Vous pouvez modifier ce choix en ajoutant « =version » au nom du paquet : par exemple, « aptitude forbid-version vim=1.2.3.broken-4 ».

    Cette commande est pratique pour éviter les versions boguées des paquets sans avoir à définir ou supprimer des gels à la main. Si vous décidez finalement d'installer la version que vous aviez interdite, la commande « install » mettra fin à l'interdiction.


Après cela, on peut continuer à utiliser aptitude sans problème.

Dernière modification par martinux_qc (07-01-2010 05:08:42)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 12-01-2010 04:37:52

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Erreur safe-upgrade.

Salut

Les paquets libconsole (1:0.2.3dbs-68) et de console-tools (1:0.2.3dbs-68) sont arrivés aujourd'hui pour ma sid 64 bits. Les mises à jour se sont effectuées sans problème.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 12-01-2010 12:29:36

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Erreur safe-upgrade.

Bjr,
L'hibernation n'empêche pas d'être serviable.

Merci Martin

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 13-01-2010 04:01:59

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Erreur safe-upgrade.

phlinux a écrit :

Bjr,
L'hibernation n'empêche pas d'être serviable.

Merci Martin


Hé oui ! À l'occasion, il m'arrive de sortir de ma tanière lol.

À la prochaine
Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#8 13-01-2010 08:09:50

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Erreur safe-upgrade.

En parlant de safe-upgrade, j'ai une très belle erreur lorsque j'essaie de mettre en Sid ma Debian.
Comme d'habitude, j'installe seulement le système de base de Debian via NetInstall (décoche Environnement de Bureau), je modifie mon sources.list pour avoir un Stable/Testing/Sid.
Je fais un aptitude update suivi d'un safe-upgrade, et là patatra.

A ce que je peux lire sur mon écran, j'ai une erreur avec le paquet udev_150-2_i386.deb. Le soucis, c'est qu'il veut que j'upgrade le kernel (donc passer en 2.6.32) avant d'installer ce paquet. Donc, je suis un peu coincé afin d'upgrader en Sid.

Tout ce que je peux dire, c'est qu'il télécharge bien tout les paquets mais ca plante à chaque fois...

Hors ligne

#9 13-01-2010 08:29:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Erreur safe-upgrade.

Salut Berillions,

C'est pas bien de bernacler une discussion avec une question !

Ouvres-en une nouvelle !

Pour ton cas, as-tu créées les fichiers preferences tel qu'il est indiqué dans le wiki et apt.conf ?

Amitié, Jojo

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#10 13-01-2010 09:25:18

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Erreur safe-upgrade.

J'utilise pas de fichier preferences. Comme il l'est expliqué ici, si je combine toutes les branches je n'en ai pas besoin. De plus, je n'utilise pas la branche experimentale.

Berillions

Hors ligne

#11 13-01-2010 10:29:48

lol
Membre
Lieu : Madagascar
Distrib. : SID + Experimental
Noyau : 4.x.......
(G)UI : XFCE
Inscription : 27-06-2009
Site Web

Re : Erreur safe-upgrade.

Salut,
Pour éviter ce genre de mésaventure (installer un paquet avec un bug grave), il est fortement conseillé d'installer apt-listbugs qui a l'amabilité de prévenir...

apt-get (aptitude) install apt-listbugs


~# apt-listbugs list console-tools
Lecture des champs des paquets... Fait
Lecture de l'état des paquets... Fait
Récupération des rapports de bogue... Fait
Analyse des informations Trouvé/Corrigé... Fait
Bogues de gravité grave sur console-tools (-> ) <marqué comme corrigé dans une version donnée>
 #563590 - console-tools: Fails to upgrade/install (Corrigé : console-tools/1:0.2.3dbs-68)
   Réuni avec : 563727 563960
Bogues de gravité serious sur console-tools (-> ) <non corrigé>
 #552011 - console-tools: Virtual consoles from tty2 onwards depend on utf-8
Résumé :
 console-tools(2 bugs)


Lors de l'installation d'un paquet ou MAJ, il vérifie les bugs (déclarés) ! IN-DIS-PEN-SA-BLE !!!

~# apt-get install console-tools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libconsole
Paquets suggérés :
  kbd-compat
Les paquets suivants seront ENLEVÉS :
  kbd
Les NOUVEAUX paquets suivants seront installés :
  console-tools libconsole
0 mis à jour, 2 nouvellement installés, 1 à enlever et 21 non mis à jour.
Il est nécessaire de prendre 470ko dans les archives.
Après cette opération, 20,5ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://ftp.fr.debian.org unstable/main libconsole 1:0.2.3dbs-68 [155kB]
Réception de : 2 http://ftp.fr.debian.org unstable/main console-tools 1:0.2.3dbs-68 [315kB]
470ko réceptionnés en 26s (17,7ko/s)
Lecture des champs des paquets... Fait
Lecture de l'état des paquets... Fait
Récupération des rapports de bogue... Fait
Analyse des informations Trouvé/Corrigé... Fait
Bogues de gravité serious sur console-tools (-> 1:0.2.3dbs-68) <non corrigé>
 #552011 - console-tools: Virtual consoles from tty2 onwards depend on utf-8
Résumé :
 console-tools(1 bug)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]

Dernière modification par lol (13-01-2010 10:30:54)

Hors ligne

#12 13-01-2010 13:52:07

le_fada
Membre
Lieu : Toujours à l'ouest
Distrib. : Sid «ad vitam æternam»
Noyau : 2.6.33-amd64
(G)UI : gnome-shell
Inscription : 23-09-2009

Re : Erreur safe-upgrade.

+1 avec lol !

je rajouterais simplement qu'en répondant "p" à la question "Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?", apt-listbugs ajoute ces paquets dans le fichier de préférences pour éviter la version buggée.

Hors ligne

#13 13-01-2010 13:59:58

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Erreur safe-upgrade.

Bjr,
@le_fada merci pour cette superbe info

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#14 13-01-2010 20:03:56

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Erreur safe-upgrade.

Voilà, je sais pas si mon problème peut venir de là mais il se trouve que j'ai une erreur lorsque je fais un apt-safe upgrade.
L'erreur intervient lors de la reception des paquets translation-fr de http://ftp.fr.debian.org sid/contrib

Ign http://ftp.fr.debian.org sid/contrib Translation-fr                      
99% [1 Translation-fr bzip2 0] [Connexion à ftp.fr.debian.org (212.27.32.66)]
bzip2: Data integrity error when decompressing.
  Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.


Impossible de résoudre le problème, à chaque update, j'y ai droit. sad

Hors ligne

#15 14-01-2010 04:20:54

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Erreur safe-upgrade.

Salut Berillions

Ce genre d'erreur provient du serveur utilisé pour les mises à jour. Pour ma part, avec ma sid amd64, j'utilise dans mon sources.list les mots stable, testing et unstable au lieu de lenny, squeeze et sid. Pour ma mise à jour aujourd'hui j'ai remplacé unstable par sid pour tester. Le aptitude update et aptitude safe-upgrade se sont bien déroulés, pas de problèmes. Bon cela vaut pour le 64 bits, pour les autres je ne peux rien dire.

Dans ton cas, tu pourrais tester avec un autre serveur en remplaçant par exemple le ftp.fr par ftp2.fr, donc ceci :

deb http://ftp2.fr.debian.org/debian/ sid main contrib non-free


Sinon, tu pourrais aussi nous mettre un copier/coller de ton sources.list pour être bien certain qu'il est OK.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#16 14-01-2010 07:35:58

lol
Membre
Lieu : Madagascar
Distrib. : SID + Experimental
Noyau : 4.x.......
(G)UI : XFCE
Inscription : 27-06-2009
Site Web

Re : Erreur safe-upgrade.

Re,

le_fada a écrit :

+1 avec lol !

je rajouterais simplement qu'en répondant "p" à la question "Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?", apt-listbugs ajoute ces paquets dans le fichier de préférences pour éviter la version buggée.


Merci pour ce "truc" ! Très pratique !!! smile

Hors ligne

Pied de page des forums