Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-07-2018 07:34:41

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Problème pendant l'execution de apt-get update

Bonjour, je suis bloqué sur ce problème depuis un bout de temps,  a chaque fois que je fais

 sudo apt-get update

j'ai l'erreur suivant

Ign:1 http://deb.debian.org/debian stretch InRelease                                                                                                                              
Ign:2 http://packages.ntop.org/apt-stable/sid x64/ InRelease                                                                                                                      
Ign:3 http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0 ./ InRelease                                                                
Ign:4 http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic InRelease                                                                                                      
Ign:5 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                      
Atteint:6 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                                            
Ign:7 http://packages.ntop.org/apt-stable/sid all/ InRelease                                                                                                                      
Atteint:9 http://ftp.de.debian.org/debian sid InRelease                                                                                                                          
Err:10 http://packages.ntop.org/apt-stable/sid x64/ Release                                                                                                                      
  404  Not Found [IP : 151.11.50.180 80]
Atteint:11 http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0 ./ Release                                                            
Err:14 http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0 ./ Release.gpg                                                            
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 62EB1A0917280DDF
Atteint:15 http://deb.debian.org/debian stretch-updates InRelease                                                                                                                
Err:16 http://packages.ntop.org/apt-stable/sid all/ Release                                                                                                                      
  404  Not Found [IP : 151.11.50.180 80]
Réception de:17 http://dl.google.com/linux/chrome/deb stable Release [1189 B]                                                                                                    
Ign:18 http://ppa.launchpad.net/noobslab/apps/ubuntu bionic InRelease                                                                                                            
Réception de:20 http://deb.debian.org/debian stretch Release [118 kB]                                                                                                            
Atteint:21 https://deb.nodesource.com/node_8.x stretch InRelease                                                                                                                  
Réception de:12 http://qgis.org/debian stretch InRelease [3347 B]                                                                                                                
Ign:8 http://cdn-fastly.deb.debian.org/debian stretch InRelease                                                                                                                  
Err:21 https://deb.nodesource.com/node_8.x stretch InRelease                                                                                                                      
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1655A0AB68576280
Atteint:22 http://security.debian.org/debian-security stretch/updates InRelease                                                                                                  
Err:12 http://qgis.org/debian stretch InRelease                                                                                                                                  
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY CAEB3DC3BDF7FB45
Atteint:24 https://repo.skype.com/deb stable InRelease                                                                                                                            
Err:24 https://repo.skype.com/deb stable InRelease                                                                                                                                
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1F3045A5DF7587C3
Ign:25 https://dl.winehq.org/wine-builds/debian/tretch stretch InRelease                                                                                                          
Ign:26 https://packages.sury.org/php sid InRelease                                                                                                                                
Err:27 https://dl.winehq.org/wine-builds/debian/tretch stretch Release                                                                                                            
  404  Not Found [IP : 151.101.16.69 443]
Err:28 https://packages.sury.org/php sid Release                                                                                                                                  
  404  Not Found [IP : 217.31.192.150 443]
Ign:30 http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic InRelease                                                                                                          
Réception de:23 http://cdn-fastly.deb.debian.org/debian stretch Release [118 kB]                                                
Réception de:32 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease [20,8 kB]                                                            
Err:32 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease                                                
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 4F4EA0AAE5267A6C
Ign:35 http://ppa.launchpad.net/peek-developers/stable/ubuntu cosmic InRelease
Err:37 http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic Release                                                                                                      
  404  Not Found [IP : 91.189.95.83 80]
Réception de:13 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease [15,4 kB]                                                                                  
Err:13 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease                                                                                                      
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 531EE72F4C9D234C
Err:38 http://ppa.launchpad.net/noobslab/apps/ubuntu bionic Release                                                                                                              
  404  Not Found [IP : 91.189.95.83 80]
Atteint:31 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease                                                                                                
Réception de:29 http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic InRelease [20,7 kB]                                                                                        
Err:29 http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic InRelease                                                                                                            
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 4F4EA0AAE5267A6C
Err:39 http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic Release                                                                                                            
  404  Not Found [IP : 91.189.95.83 80]
Err:40 http://ppa.launchpad.net/peek-developers/stable/ubuntu cosmic Release
  404  Not Found [IP : 91.189.95.83 80]
Réception de:36 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease [17,5 kB]
Err:36 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY C2518248EEA14886
Lecture des listes de paquets... Fait
N: « google-chrome.list’ » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Le dépôt http://packages.ntop.org/apt-stable/sid x64/ Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0 ./ Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 62EB1A0917280DDF
E: Le dépôt http://packages.ntop.org/apt-stable/sid all/ Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://deb.nodesource.com/node_8.x stretch InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1655A0AB68576280
W: Erreur de GPG : http://qgis.org/debian stretch InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY CAEB3DC3BDF7FB45
E: Le dépôt http://qgis.org/debian stretch InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://repo.skype.com/deb stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1F3045A5DF7587C3
E: Le dépôt https://dl.winehq.org/wine-builds/debian/tretch stretch Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt https://packages.sury.org/php sid Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 4F4EA0AAE5267A6C
E: Le dépôt http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 531EE72F4C9D234C
E: Le dépôt http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/noobslab/apps/ubuntu bionic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 4F4EA0AAE5267A6C
E: Le dépôt http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/peek-developers/stable/ubuntu cosmic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY C2518248EEA14886
E: Le dépôt http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
 



Besoins d'aide SVP et merci d'avance.

Hors ligne

#2 10-07-2018 07:50:16

solar66
Adhérent(e)
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : Problème pendant l'execution de apt-get update

Bonjour,
au vu de ta commande update, on pourrait croire que tu es sous ubuntu (et en plus, plusieurs version:cosmic, bionic, xenial.....)
reprends ton source-list, et ne garde que les debian stretch
avec un tel source-list, tu ne pourras jamais avoir une debian stable
thierry

Hors ligne

#3 10-07-2018 09:19:54

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Problème pendant l'execution de apt-get update

bonsoir
pourrais tu donner le retour des commandes

find /etc/apt -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;



lsb_release -a



uname -sr

Dernière modification par Severian (10-07-2018 09:22:57)

Hors ligne

#4 10-07-2018 09:36:07

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Re : Problème pendant l'execution de apt-get update

Severain, voila le resultat du commande

find /etc/apt -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;


/etc/apt/sources.list~


/etc/apt/sources.list.save

     1  #
     2
     3  # deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main
     4
     5  # deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main
     6
     7  deb http://deb.debian.org/debian/ stretch main
     8  deb-src http://deb.debian.org/debian/ stretch main
     9
    10  deb http://security.debian.org/debian-security stretch/updates main contrib
    11  deb-src http://security.debian.org/debian-security stretch/updates main contrib
    12
    13  # stretch-updates, previously known as 'volatile'
    14  deb http://deb.debian.org/debian/ stretch-updates main contrib
    15  deb-src http://deb.debian.org/debian/ stretch-updates main contrib
    16
    17  deb http://httpredir.debian.org/debian/ stretch main contrib non-free
    18
    19  deb http://qgis.org/debian stretch main
    20  deb-src http://qgis.org/debian stretch main
    21
    22  deb http://ftp.de.debian.org/debian sid main
    23  deb https://dl.winehq.org/wine-builds/debian/tretch stretch main
    24  deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./

/etc/apt/sources.list.d

nl: /etc/apt/sources.list.d: est un dossier

/etc/apt/sources.list.d/slack.list

     1  ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2  # You may comment out this entry, but any other modifications may be lost.
     3  deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main

/etc/apt/sources.list.d/ondrej-ubuntu-mysql-5_6-bionic.list

     1  deb http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic main

/etc/apt/sources.list.d/webupd8team-java.list.save

     1  deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
     2  deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main

/etc/apt/sources.list.d/google-chrome.list.save

     1  ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2  # You may comment out this entry, but any other modifications may be lost.
     3  deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

/etc/apt/sources.list.d/ondrej-ubuntu-php-bionic.list

     1  deb http://ppa.launchpad.net/ondrej/php/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/ondrej/php/ubuntu bionic main

/etc/apt/sources.list.d/skype-stable.list

     1  deb [arch=amd64] https://repo.skype.com/deb stable main

/etc/apt/sources.list.d/slack.list.save

     1  ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2  # You may comment out this entry, but any other modifications may be lost.
     3  deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main

/etc/apt/sources.list.d/morphis-ubuntu-anbox-support-cosmic.list.save

     1  deb http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic main
     2  # deb-src http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic main

/etc/apt/sources.list.d/google-chrome.list’


/etc/apt/sources.list.d/php.list

     1  deb https://packages.sury.org/php/ sid main

/etc/apt/sources.list.d/ondrej-ubuntu-apache2-bionic.list

     1  deb http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic main

/etc/apt/sources.list.d/noobslab-ubuntu-apps-bionic.list.save

     1  deb http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main

/etc/apt/sources.list.d/noobslab-ubuntu-apps-bionic.list

     1  deb http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main

/etc/apt/sources.list.d/ondrej-ubuntu-apache2-bionic.list.save

     1  deb http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/ondrej/apache2/ubuntu bionic main

/etc/apt/sources.list.d/nodesource.list.save

     1  deb https://deb.nodesource.com/node_8.x stretch main
     2  deb-src https://deb.nodesource.com/node_8.x stretch main

/etc/apt/sources.list.d/ondrej-ubuntu-php-bionic.list.save

     1  deb http://ppa.launchpad.net/ondrej/php/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/ondrej/php/ubuntu bionic main

/etc/apt/sources.list.d/ondrej-ubuntu-mysql-5_6-bionic.list.save

     1  deb http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/ondrej/mysql-5.6/ubuntu bionic main

/etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-bionic.list.save

     1  deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main

/etc/apt/sources.list.d/morphis-ubuntu-anbox-support-cosmic.list

     1  deb http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic main
     2  # deb-src http://ppa.launchpad.net/morphis/anbox-support/ubuntu cosmic main

/etc/apt/sources.list.d/ntop-stable.list.save

     1  deb http://packages.ntop.org/apt-stable/sid/ x64/
     2  deb http://packages.ntop.org/apt-stable/sid/ all/

/etc/apt/sources.list.d/vscode.list.save

     1  ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2  # You may comment out this entry, but any other modifications may be lost.
     3  deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main

/etc/apt/sources.list.d/nodesource.list

     1  deb https://deb.nodesource.com/node_8.x stretch main
     2  deb-src https://deb.nodesource.com/node_8.x stretch main

/etc/apt/sources.list.d/php.list.save

     1  deb https://packages.sury.org/php/ sid main

/etc/apt/sources.list.d/google-chrome.list

     1  ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2  # You may comment out this entry, but any other modifications may be lost.
     3  deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

/etc/apt/sources.list.d/ntop-stable.list

     1  deb http://packages.ntop.org/apt-stable/sid/ x64/
     2  deb http://packages.ntop.org/apt-stable/sid/ all/

/etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-bionic.list

     1  deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
     2  # deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main

/etc/apt/sources.list.d/vscode.list

     1  ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2  # You may comment out this entry, but any other modifications may be lost.
     3  deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main

/etc/apt/sources.list.d/skype-stable.list.save

     1  deb [arch=amd64] https://repo.skype.com/deb stable main

/etc/apt/sources.list.d/peek-developers-ubuntu-stable-cosmic.list

     1  deb http://ppa.launchpad.net/peek-developers/stable/ubuntu cosmic main
     2  # deb-src http://ppa.launchpad.net/peek-developers/stable/ubuntu cosmic main

/etc/apt/sources.list.d/webupd8team-java.list

     1  deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
     2  deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main

/etc/apt/sources.list

     1  #
     2
     3  # deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main
     4
     5  # deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main
     6
     7  deb http://deb.debian.org/debian/ stretch main
     8  deb-src http://deb.debian.org/debian/ stretch main
     9
    10  deb http://security.debian.org/debian-security stretch/updates main contrib
    11  deb-src http://security.debian.org/debian-security stretch/updates main contrib
    12
    13  # stretch-updates, previously known as 'volatile'
    14  deb http://deb.debian.org/debian/ stretch-updates main contrib
    15  deb-src http://deb.debian.org/debian/ stretch-updates main contrib
    16
    17  deb http://httpredir.debian.org/debian/ stretch main contrib non-free
    18
    19  deb http://qgis.org/debian stretch main
    20  deb-src http://qgis.org/debian stretch main
    21
    22  deb http://ftp.de.debian.org/debian sid main
    23  deb https://dl.winehq.org/wine-builds/debian/tretch stretch main
    24  deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./



et puis le resultat de

lsb_release -a


No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux stable-updates (sid)
Release:        stable-updates
Codename:       sid



et enfin

uname -sr


Linux 4.16.0-2-amd64
 

Hors ligne

#5 10-07-2018 10:13:33

phreg
Membre
Distrib. : Debian Testing
Noyau : 4.13 amd64
(G)UI : Xfce
Inscription : 02-04-2011

Re : Problème pendant l'execution de apt-get update

Bonjour,
lecture du sources.list surprenante ! Des dépots très variés allant d'ubuntu à opensuse en passant par google et microsoft... et ça tournait quand même avant l'essai d'update ?

Hors ligne

#6 10-07-2018 10:18:54

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Re : Problème pendant l'execution de apt-get update

Oui phreg, ç'a marché scratchhead.gif

Hors ligne

#7 10-07-2018 11:22:22

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème pendant l'execution de apt-get update

avec ce source, tu vas avoir souvent des ennuis, mais si c'est ton choix.
déjà vire le httpredir qui est proscrit depuis un moment, et qui fait doublon

Dernière modification par lagrenouille (10-07-2018 11:22:51)


:"Où vas tu petit garçon ?" -"je vais à l'école"
:"Quand reviendras tu ?" -"Jamais !"
   

Hors ligne

#8 10-07-2018 11:25:49

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Re : Problème pendant l'execution de apt-get update

Ok, pourras-tu me guider SVP sad

Hors ligne

#9 10-07-2018 11:34:29

phreg
Membre
Distrib. : Debian Testing
Noyau : 4.13 amd64
(G)UI : Xfce
Inscription : 02-04-2011

Re : Problème pendant l'execution de apt-get update

Combien de temps ? Debian, c'est quand même du costaud !
Compte le nombre de clefs de sécurité manquantes ou de dépôts non trouvés (les messages "la clé publique n'est pas disponible... mises à jour désactivées" et "404  Not Found") dans ton log d'erreur.
Pour les 404, pas grand chose à faire de ton côté à part attendre que le serveur refonctionne.
Pour les clefs manquantes, il est possible d'en récupérer mais dans la plupart des cas, je préférerais supprimer le dépôt des sources.

Hors ligne

#10 10-07-2018 12:00:07

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Re : Problème pendant l'execution de apt-get update

Il y a 19 clefs de sécurité manquantes et 8 dépôts non trouvés.
Je reste flexible sur tes suggestions phreg.

Hors ligne

#11 10-07-2018 12:00:16

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : Problème pendant l'execution de apt-get update


1498812139.jpg - DELAIN - STARDUST -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#12 10-07-2018 12:18:42

èfpé
Membre
Inscription : 10-07-2016

Re : Problème pendant l'execution de apt-get update

Bonjour,

cat -n /etc/apt/sources.list

     1  #
     2
     3  # deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main
     4
     5  # deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main
     6
     7  deb http://deb.debian.org/debian/ stretch main
     8  deb-src http://deb.debian.org/debian/ stretch main
     9
    10  deb http://security.debian.org/debian-security stretch/updates main contrib
    11  deb-src http://security.debian.org/debian-security stretch/updates main contrib
    12
    13  # stretch-updates, previously known as 'volatile'
    14  deb http://deb.debian.org/debian/ stretch-updates main contrib
    15  deb-src http://deb.debian.org/debian/ stretch-updates main contrib
    16
    17  deb http://httpredir.debian.org/debian/ stretch main contrib non-free
    18
    19  deb http://qgis.org/debian stretch main
    20  deb-src http://qgis.org/debian stretch main
    21
    22  deb http://ftp.de.debian.org/debian sid main
    23  deb https://dl.winehq.org/wine-builds/debian/tretch stretch main
    24  deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./
 


Le « httpredir » ligne 17 est plus anecdotique que le « sid » ligne 22 ; tu es sous sid actuellement...

Les 7 clés publiques manquantes et les 7 dépôts inexistants peuvent être corrigés... reste le reste !

sed -i s,sid,stretch, /etc/apt/sources.list.d/ntop-stable.list
sed -i s,/tretch,/, /etc/apt/sources.list
sed -i s,sid,stretch, /etc/apt/sources.list.d/php.list
sed -i s,cosmic,xenial, /etc/apt/sources.list.d/morphis-ubuntu-anbox-support-cosmic.list
sed -i s,bionic,xenial, /etc/apt/sources.list.d/noobslab-ubuntu-apps-bionic.list
sed -i s,bionic,xenial, /etc/apt/sources.list.d/ondrej-ubuntu-mysql-5_6-bionic.list
sed -i s,cosmic,xenial, /etc/apt/sources.list.d/peek-developers-ubuntu-stable-cosmic.list

apt install dirmngr
apt-key adv --recv-keys 1655A0AB68576280 1F3045A5DF7587C3 4F4EA0AAE5267A6C 531EE72F4C9D234C 62EB1A0917280DDF C2518248EEA14886 CAEB3DC3BDF7FB45


Dépôts PPA : il paraît « cohérent » d'envoyer du xenial sur du stretch mais à voir selon les paquets.

Dernière modification par èfpé (15-07-2018 13:18:42)

Hors ligne

#13 10-07-2018 13:35:32

phreg
Membre
Distrib. : Debian Testing
Noyau : 4.13 amd64
(G)UI : Xfce
Inscription : 02-04-2011

Re : Problème pendant l'execution de apt-get update

Je rejoins Debian Alain !
Non èfpé, ce n'est pas une sid mais une FrankenDebian bien typique.
@justinien4all

Je reste flexible sur tes suggestions phreg.

Simple :
- définir les besoins
- ne pas installer trop vite, il existe peut être un autre soft moins risqué sous Debian
- lire les docs
- utiliser des machines virtuelles si besoins non couverts sous Debian

Sans vouloir détailler tous les dépôts folkloriques (car aucune idée de ce qu'ils offrent), j'ai vu un dépôt Google et un autre chez Microsoft.
Pourquoi Chrome et pas Chromium qui est quasi la même chose avec quelques désagréments en moins ?
Visual Studio sous Linux, je ne savais même pas que ça existait. Certainement très bien mais j'aurai pensé plus à Eclipse, enfin ce n'est pas dans mon scope.

Fais quand même la lecture suggérée par Debian Alain, tu vas comprendre.

Hors ligne

#14 10-07-2018 14:28:33

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Problème pendant l'execution de apt-get update

justinien4all :   https://debian-facile.org/doc:systeme:a … st:stretch

Édite ce sources.list :

# Debian Stretch, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates main contrib non-free
# Debian Stretch, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
# Debian Stretch, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free


Trisquel 8 64bits  Ordi.: Thinkpad T400
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#15 12-07-2018 10:21:22

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Re : Problème pendant l'execution de apt-get update

Merci Jean-Pierre Pinson,

J'ai édité le sources.list avec le contenu que t'a posté et voila le résultat après

sudo apt-get update


Atteint:1 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                                                                                                                                        
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                                                                                                  
Ign:4 https://packages.sury.org/php sid InRelease                                                                                                                                                                                                                            
Ign:5 http://packages.ntop.org/apt-stable/sid x64/ InRelease                                                                                                                                                                                                                  
Err:6 https://packages.sury.org/php sid Release                                                                                                                                                                                                                              
  404  Not Found [IP : 217.31.192.150 443]
Ign:7 http://packages.ntop.org/apt-stable/sid all/ InRelease                                                                                                                                                                                                                  
Atteint:9 https://deb.nodesource.com/node_8.x stretch InRelease                                                                                                                                                                                                              
Réception de:2 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease [17,5 kB]                                                                                                                                                                                    
Err:10 http://packages.ntop.org/apt-stable/sid x64/ Release                                                                                                                                                                                                                  
  404  Not Found [IP : 151.11.50.180 80]
Err:9 https://deb.nodesource.com/node_8.x stretch InRelease                                                                                                                                                                                                          
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1655A0AB68576280
Atteint:11 https://repo.skype.com/deb stable InRelease                                                                                                                                                                                      
Err:12 http://packages.ntop.org/apt-stable/sid all/ Release                                                                                                                                                                                  
  404  Not Found [IP : 151.11.50.180 80]
Err:11 https://repo.skype.com/deb stable InRelease                                                                                                                                      
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1F3045A5DF7587C3
Err:2 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease                                                                                                                                                          
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY C2518248EEA14886
Atteint:13 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                                                                  
Ign:15 http://deb.debian.org/debian stretch InRelease                                                                                                                                                
Atteint:16 http://security.debian.org stretch/updates InRelease                                                                                                    
Atteint:17 http://deb.debian.org/debian stretch-updates InRelease                                                                            
Réception de:18 http://deb.debian.org/debian stretch Release [118 kB]                                                            
Atteint:8 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease                                                
Lecture des listes de paquets... Fait                                                                                                                                                                                                                                        
N: « google-chrome.list’ » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Le dépôt https://packages.sury.org/php sid Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://packages.ntop.org/apt-stable/sid x64/ Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://deb.nodesource.com/node_8.x stretch InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1655A0AB68576280
E: Le dépôt http://packages.ntop.org/apt-stable/sid all/ Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://repo.skype.com/deb stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1F3045A5DF7587C3
W: Erreur de GPG : http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY C2518248EEA14886
E: Le dépôt http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

Hors ligne

#16 12-07-2018 11:21:14

celp
Membre
Lieu : Chartres
Distrib. : Debian Testing
Noyau : Linux 4.16.0-2-amd64
(G)UI : i3 wm
Inscription : 14-09-2016

Re : Problème pendant l'execution de apt-get update

Peut tu taper ceci et nous donner le résultat

ls -al  /etc/apt/sources.list.d/

Hors ligne

#17 12-07-2018 11:28:30

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / fedora / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : Problème pendant l'execution de apt-get update

salut justinien4all  big_smile

tu ferai bien de réfléchir pour savoir si tu veux utiliser une jessie , une stretch ou une sid .

pour l'instant , c'est tout sauf clair .

lol

Dernière modification par Debian Alain (12-07-2018 11:28:50)


1498812139.jpg - DELAIN - STARDUST -
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#18 12-07-2018 11:40:00

justinien4all
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Re : Problème pendant l'execution de apt-get update

Voila le resultat celp

total 72
drwxr-xr-x 2 root root 4096 juil. 12 11:16 .
drwxr-xr-x 6 root root 4096 juil. 12 11:15 ..
-rw-r--r-- 1 root root  189 juil.  9 16:11 google-chrome.list
-rw-r--r-- 1 root root    0 nov.  23  2017 google-chrome.list’
-rw-r--r-- 1 root root  189 juil.  9 16:11 google-chrome.list.save
-rw-r--r-- 1 root root  110 juil.  9 16:11 nodesource.list
-rw-r--r-- 1 root root  110 juil.  9 16:11 nodesource.list.save
-rw-r--r-- 1 root root  100 juil.  9 16:11 ntop-stable.list
-rw-r--r-- 1 root root  100 juil.  9 16:11 ntop-stable.list.save
-rw-r--r-- 1 root root   44 juil. 12 11:16 php.list
-rw-r--r-- 1 root root   44 juil.  9 16:11 php.list.save
-rw-r--r-- 1 root root   56 juil.  9 16:11 skype-stable.list
-rw-r--r-- 1 root root   56 juil.  9 16:11 skype-stable.list.save
-rw-r--r-- 1 root root  193 juil.  9 16:11 slack.list
-rw-r--r-- 1 root root  193 juil.  9 16:11 slack.list.save
-rw-r--r-- 1 root root  193 juil.  9 16:11 vscode.list
-rw-r--r-- 1 root root  193 juil. 10 13:59 vscode.list.save
-rw-r--r-- 1 root root  134 juil.  9 16:11 webupd8team-java.list
-rw-r--r-- 1 root root  134 juil.  9 16:11 webupd8team-java.list.save

Hors ligne

#19 12-07-2018 11:51:25

celp
Membre
Lieu : Chartres
Distrib. : Debian Testing
Noyau : Linux 4.16.0-2-amd64
(G)UI : i3 wm
Inscription : 14-09-2016

Re : Problème pendant l'execution de apt-get update

Purée ça fais peur.

sudo mv  /etc/apt/sources.list.d/  /etc/apt/sources.list.d.bak/



Déjà, Il faut nettoyer cela.

Apres à toi de choisir la branche de Debian que tu souhaite.

Hors ligne

#20 12-07-2018 12:33:12

lagrenouille
CA Debian-Facile
Lieu : dans mes rêves
Distrib. : stretch
Noyau : linux-4.9.63--amd64
(G)UI : env- i3-weechat-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Problème pendant l'execution de apt-get update

franchement, faudrait que tu te mettes un source stretch propre, et que tout soit nickel sur ta debian..

ensuite si tu veux rajouter des sources , tu verras, mais là tu vois bien que c'est pas jouable ces conneries.:P

fais un dpkg -l | grep -v ^ii

doit y avoir personne si tout va bien, ce qui m'éttonerait

:"Où vas tu petit garçon ?" -"je vais à l'école"
:"Quand reviendras tu ?" -"Jamais !"
   

Hors ligne

#21 12-07-2018 12:52:38

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Problème pendant l'execution de apt-get update

justinien4all, Il ne faut mettre dans ton sources.list, que ce que j'ai mis en #14, qui concerne la debian stretch.Le reste n'a rien à faire là.

Trisquel 8 64bits  Ordi.: Thinkpad T400
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#22 12-07-2018 12:56:09

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Problème pendant l'execution de apt-get update

(étant donné que justinien4all doit avoir des paquets venant de sid (et autres dépôts), de repasser à un sources.list pure stretch, ça ne va pas lui causer des soucis de dépendances et autres ??)

Hors ligne

#23 12-07-2018 12:59:45

celp
Membre
Lieu : Chartres
Distrib. : Debian Testing
Noyau : Linux 4.16.0-2-amd64
(G)UI : i3 wm
Inscription : 14-09-2016

Re : Problème pendant l'execution de apt-get update

Severian a écrit :

(étant donné que justinien4all doit avoir des paquets venant de sid (et autres dépôts), de repasser à un sources.list pure stretch, ça ne va pas lui causer des soucis de dépendances et autres ??)



On peut essayer mais autant rester en testing, c'est un bon compromis.

Hors ligne

#24 12-07-2018 13:04:45

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Problème pendant l'execution de apt-get update

Si vous savez lire justinien4all Dispose bien d'une distribution stretch :

Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018

Dernière modification par Jean-Pierre Pinson (12-07-2018 13:06:21)


Trisquel 8 64bits  Ordi.: Thinkpad T400
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#25 12-07-2018 13:10:08

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Problème pendant l'execution de apt-get update

oui je sais lire (enfin ill me semble tongue)
message #4

et puis le resultat de
lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux stable-updates (sid)
Release:        stable-updates
Codename:       sid

Dernière modification par Severian (12-07-2018 13:10:48)

Hors ligne

Pied de page des forums