Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-01-2010 16:39:24

eleguen
Membre
Lieu : 34
Distrib. : Voyager 7
(G)UI : Xfce
Inscription : 19-09-2007

kmymoney arrêter les mises à jour

Bonjour,

j'ai kmymoney2 1.02, et depuis les mises à jour me propose le 3.95. Mais cette version bug carrément. Dans synactic je lui ai dit de revenir sur la 1.02 çà à marcher, mais pourquoi il me propose toujours la 3.95 comment stopper cette mise à jour?

Décocher kmymoney2 à chaque fois c'est pénible surtout avec sid où j'ai tous les jours des mises à jour à faire.

merci

Hors ligne

#2 12-01-2010 17:24:18

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : kmymoney arrêter les mises à jour

Bonjour eleguen,

Si tu n'as pas de fichier preferences en place, il faut le créer :
    # touch /etc/apt/preferences
Ensuite, indiquer une preference supérieure pour le paquet de la version que tu veux conserver.

Pour un paquet XYZ de la branche unstable nous ajouterions au fichier preferences ces lignes :

Package: XYZ
Pin: release a=unstable
Pin-Priority: 900


Issu du tuto sur les preferences là :
http://debian-facile.org/doc:obsolete:f … _option_-t

et la suite...

J'ai mis une priorité de 900 car la priorité par defaut de sid est 500 sans preferences.

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 13-01-2010 05:11:37

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : kmymoney arrêter les mises à jour

Salut

Dans Synaptic, il y a aussi la possibilité de bloquer un paquet, voir le menu Paquet pour ce faire. Comme je n'utilise pas synaptic, j'imagine que ton paquet va rester bloquer à la version indiquée. Pour avoir une autre version, il faudra alors débloquer le paquet.

Pour ma part, j'utilise aptitude et je peux empêcher la mise à jour vers une version précise mais avoir les mises à jour pour les versions suivantes, on peut donc ainsi sauter une version buggée, ou même geler un paquet à une version donnée. On peut faire la même chose avec apt-get. Il y aussi la façon mentionnée par Joel. Tout cela pour te montrer les possibilités. Si tu désires plus de détails sur comment utiliser apt-get ou aptitude tu n'as qu'à le demander.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#4 14-01-2010 10:40:10

eleguen
Membre
Lieu : 34
Distrib. : Voyager 7
(G)UI : Xfce
Inscription : 19-09-2007

Re : kmymoney arrêter les mises à jour

je vous remercie, sur synaptic je n'ai pas réussi à bloquer la mise à jour seulement rétrogradé. Il faut créer le fichier preferences

et j'ai mis çà

Package: kmymoney2 kmymoney2-common
Pin: release a=stable
Pin-Priority: 900

Hors ligne

Pied de page des forums