Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-10-2018 00:03:22

zano972
Membre
Inscription : 20-10-2018

Debian 9 - Gnome 3 - Multiscreen - Multiboot

Bonsoir,

Allez, je vais essayer - sans m'énerver  - de vous soumettre le petit pb qui me gonfle depuis 2 jours... ( eh oui, je suis patient big_smile )
je dispose d'un pc dont voici les principales caractéristiques:

Carte mère:

Type de processeur      QuadCore Intel Core i5-3570, 4000 MHz (40 x 100)
Nom de la carte mère      Asus P8Z77-V LK (2 PCI, 2 PCI-E x1, 3 PCI-E x16, 4 DDR3 DIMM, Audio, Video, Gigabit LAN)
Chipset de la carte mère      Intel Panther Point Z77, Intel Ivy Bridge
Mémoire système      3541 Mo (DDR3 SDRAM)
DIMM1: Kingston HyperX KHX1600C9D3/4GX      4 Go DDR3-1600 DDR3 SDRAM (11-11-11-28 @ 800 MHz) (10-10-10-27 @ 761 MHz) (9-9-9-24 @ 685 MHz) (8-8-8-22 @ 609 MHz) (7-7-7-19 @ 533 MHz) (6-6-6-16 @ 457 MHz)
DIMM2: Kingston HyperX KHX1600C9D3/4GX      4 Go DDR3-1600 DDR3 SDRAM (11-11-11-28 @ 800 MHz) (10-10-10-27 @ 761 MHz) (9-9-9-24 @ 685 MHz) (8-8-8-22 @ 609 MHz) (7-7-7-19 @ 533 MHz) (6-6-6-16 @ 457 MHz)
DIMM3: Kingston HyperX KHX1600C9D3/4GX      4 Go DDR3-1600 DDR3 SDRAM (11-11-11-28 @ 800 MHz) (10-10-10-27 @ 761 MHz) (9-9-9-24 @ 685 MHz) (8-8-8-22 @ 609 MHz) (7-7-7-19 @ 533 MHz) (6-6-6-16 @ 457 MHz)
DIMM4: Kingston HyperX KHX1600C9D3/4GX      4 Go DDR3-1600 DDR3 SDRAM (11-11-11-28 @ 800 MHz) (10-10-10-27 @ 761 MHz) (9-9-9-24 @ 685 MHz) (8-8-8-22 @ 609 MHz) (7-7-7-19 @ 533 MHz) (6-6-6-16 @ 457 MHz)
Type de Bios      AMI (03/21/2014)

Moniteur:

Carte vidéo      NVIDIA GeForce GTX 1060 6GB (6 Go)
Carte vidéo      NVIDIA GeForce GTX 1060 6GB (6 Go)
Carte vidéo      NVIDIA GeForce GTX 1060 6GB (6 Go)
Carte vidéo      NVIDIA GeForce GTX 1060 6GB (6 Go)
Accélérateur 3D      nVIDIA GeForce GTX 1060 6GB
Moniteur      Moniteur Plug-and-Play générique [NoDB] (271516843009)
Moniteur      Philips 273ELH (273E3LH) [27" LCD] (AU11408002860)
Moniteur      Samsung SyncMaster T28C570 [28" LCD]

Multimédia:

Carte audio      nVIDIA HDMI/DP @ nVIDIA GP106 - High Definition Audio Controller
Carte audio      Realtek ALC892 @ Intel Panther Point PCH - High Definition Audio Controller [C-1]

Stockage:

Contrôleur IDE      Intel(R) 7 Series/C216 Chipset Family SATA AHCI Controller - 1E02
Disque dur      MAXTOR STM3320613AS ATA Device (320 Go, 7200 RPM, SATA-II)
Disque dur      Philips USB Flash Drive USB Device (28 Go, USB)
Disque dur      ST2000DM001-1CH164 ATA Device (2 To, 7200 RPM, SATA-III)
Disque dur      TOSHIBA HDWD130 ATA Device (3 To, 7200 RPM, SATA-III)
Disque dur      WDC WD10EZEX-08WN4A0 ATA Device (1 To, 7200 RPM, SATA-III)
Disque dur      WDC WD10EZEX-08WN4A0 ATA Device (1 To, 7200 RPM, SATA-III)
Lecteur optique      HL-DT-ST BD-RE BH10LS38 ATA Device (10x/2x/10x BD-RE)
État des disques durs SMART      OK

Comme vous pouvez le constater, je dispose de 3 écrans qui se déclinent comme suit :

1 - Moniteur principal sur la CG ( port DVI  ) / 1920x1080
2 - Moniteur auxiliaire sur la CG ( port HDMI-0 ) 1920x1080
3 - Moniteur auxiliaire sur la CG ( port HDMI-1 ) 3840x2160

Dans mon install Debian 9.5.0, voilà les manips que j'ai effectué - au moins 25 fois... Oui je sais je dois être un peu retardé mentalement pour pas capter un peu plus vite roll -

1 ) Voici ce que me montre l'utilitaire Config display (allez... on va dire après la 14eme fois que je suis rentré dedans et que bien sur je l'ai déjà configuré correct 13 fois

http://zupimages.net/viewer.php?id=18/42/5qfr.jpg

comme vous pouvez le constater, j'ai le moniteur Philips FTV a l'extreme droite, et le T28C570 à l'extreme gauche... Or c'est le contraire... Alors , j'indique patiemment a notre cher Debian 9.5 qu'il faut échanger l'emplacement de ces 2 moniteurs - ainsi que leurs résolutions respectives comme sur cette image:

https://zupimages.net/up/18/42/8x8k.jpg

On voit bien sur cette image que la config a été modifiée et valider (le bouton Apply est grisé - donc a éte actionné)

Aller je vais la faire court maintenant... Devinez ce qui se passe au prochain redémarrage de Debian 9.5.0...

Simple voir l'image :

http://zupimages.net/viewer.php?id=18/42/5qfr.jpg

kernal_panic.gif

Pour finir... Cerise sur le gateau... Sur ce même PC j'ai aussi un multiboot composé comme suit :

Windows 10
Windows 8.1
Windows 7

et chose marrante a chacun des ces OS il ne m'a fallut que 2 mn - pff que dis je : 30s - pour leur faire comprendre quel moniteur etait ou... Et ils l'ont compris et mis en mèmoire... Comme quoi Windows n'est pas si daube que ça.

... Cherchez l'erreur...

Moi perso... Je la cherche plus chez Debian

A+++

EDIT: sorry pour l'état d'énervement d'hier... Certes je n'ai toujours pas trouvé de solution à ce pb sous Gnome 3, mais une chose est sure, en choisissant une environnement KDE - tel que Plasma - on peut ajouter icones / lanceur les doigts dans le nez... et devinez quoi? ... d'une session à l'autre, il se rappelle de la dernière configuration des divers moniteurs!... Qui a dit gnome3  dans la salle?  big_smile

mais perso je reste dispo pour discuter avec des développeurs de gnome3... Curieux de voir quels arguments ils avanceraient pour me faire comprendre qu'il n'est pas possible de faire la même chose que la concurrence quand on sait que tout ce petit monde développe en C++, Qt et j'en passe...

Pourra peut-être être utile à ceux qui rencontrerait le même pb.

Pour ma part: Problème résolu. A+++ et bonne continuation. smile

Dernière modification par zano972 (21-10-2018 23:45:22)


Si un matin ta tartine tombe du coté beurré... C'est que le beurre était du mauvais coté. lol

Hors ligne

Pied de page des forums