Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-01-2019 18:56:06

prog-amateur
Membre
Inscription : 19-12-2018

[Debian 9] mon touchpad s'arrête de fonctionner après un certain temps

Bonjour, j'ai installé Debian 9 sur mon Xiaomi Mi Notebook Air 12" (la première génération avec un intel Core M3).
A l'installation, j'ai dû installer le firmware iwlwifi pour faire reconnaître la carte wifi intel, mais depuis grâce à Dieu, ça fait un petit moment que tout se passe bien.

Le seul défaut que je constate est que le touchpad se fige quasi systématiquement au bout d'un certain temps (jamais au démarrage), d'un seul coup. Je peux toujours utiliser une souris sans fil, et le clavier est fonctionnel, mais le touchpad reste indisponible jusqu'au redémarrage.


C'est très étrange, je n'utilise que Firefox en général donc y a rien de particulier, mais j'ai une impression que c'est au moment d'un chargement de page, où lorsque je fais la navette entre les applications (Nautilus, Firefox, Libre office par ex) que ça se fige, bien sûr, ce n'est qu'une impression.

Quelqu'un a-t-il le même souci, même sur un autre ordinateur ?

Dites-moi quels retours vous avez besoin sur le terminal, je sus prêts à vous fournir les éléments pour m'aider. Merci !

Dernière modification par prog-amateur (12-01-2019 00:45:34)

Hors ligne

#2 12-01-2019 06:50:25

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 9
(G)UI : Xfce
Inscription : 21-09-2016

Re : [Debian 9] mon touchpad s'arrête de fonctionner après un certain temps

Bonjour,
as-tu le paquet

xserver-xorg-input-synaptics

d'installé ? Si non, essaye en l'installant.


Acer Aspire 5733 - Debian 9 Xfce

Hors ligne

#3 12-01-2019 07:08:27

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Debian 9] mon touchpad s'arrête de fonctionner après un certain temps

Bonjour
ta machine est quand même récente , pense a tester Buster pour une meilleure prise en charge.

sinon pour stretch
il me faut ton bureau et le gestionnaire de session (par exemple gnome + gdm3)

le contenu du log de X (selon ton bureau dans /var/log ou ton /home )
il te faut enlever le paquet "xserver-xorg-video-intel"
et utiliser le modesetting du noyau
normalement un gpu HD 615  =>  https://ark.intel.com/fr/products/95449 … e-2-60-GHz-


apt-get remove --purge xserver-xorg-video-intel
 


installer le firmware "firmware-misc-nonfree" pour le gpu intégré au cpu


apt-get --reinstall install firmware-misc-nonfree
 



ceci pour la partie serveur X
donner le retour de la commande lspci (en autre connaître ton gpu )


lspci
 


selon ton bureau si tu utilise le serveur X ou Wayland (avec gnome par exemple )

donner le retour de cette commande (pour les erreurs du système )


journalctl -r -p err
 



installer le paquet "mesa-utils" pour les utilitaires de mesa


apt-get --reinstall install mesa-utils
 


le retour de la commande


glxinfo -B
 


pour le touchpad
normalement tu dois avoir ce paquet installé "xserver-xorg-input-libinput"

Ce paquet fournit le pilote d’entrées pour les périphériques utilisant la
bibliothèque libinput. Il peut manipuler les claviers, souris et pavés
tactiles, et remplace les pilotes distincts -evdev et -synaptics.

Ce paquet est compilé à partir du module de pilote xf86-input-libinput d’X.Org.



une alternative


tu a aussi les paquets
xserver-xorg-input-synaptics
xserver-xorg-input-evdev
 



a voir ce qui fonctionne le mieux (selon ta configuration actuelle )
par exemple (pour moi sur buster)


apt-cache policy xserver-xorg-input-libinput
 



xserver-xorg-input-libinput:
  Installé : 0.28.1-1
  Candidat : 0.28.1-1
 Table de version :
 *** 0.28.1-1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
 



pour les deux autres les commandes (je suis sur un PC de bureau en buster)


apt-cache policy xserver-xorg-input-evdev
 



xserver-xorg-input-evdev:
  Installé : (aucun)
  Candidat : 1:2.10.6-1
 Table de version :
     1:2.10.6-1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
 



apt-cache policy xserver-xorg-input-synaptics
 



xserver-xorg-input-synaptics:
  Installé : (aucun)
  Candidat : 1.9.1-1
 Table de version :
     1.9.1-1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
 



une autre alternative en plus de ceci utiliser des paquets des backports
commencer par le noyau de stretch-backports et voir si une amélioration (actuellement le 4.19 )
nota: le firmware-misc-nonfree aussi peut etre installé a partir de stretch-backports

Dernière modification par robert2a (12-01-2019 07:50:02)

Hors ligne

#4 12-01-2019 18:49:46

prog-amateur
Membre
Inscription : 19-12-2018

Re : [Debian 9] mon touchpad s'arrête de fonctionner après un certain temps

Herve33 a écrit :

Bonjour,
as-tu le paquet

xserver-xorg-input-synaptics

d'installé ? Si non, essaye en l'installant.



Bonjour et merci, alors je n'en sais rien du tout, je ne suis pas expert tout ce que je peux confirmer c'est que je n'ai eu à installer manuellement que iwlwifi. S'il y a une ligne de commande pour le savoir, n'hésite pas.

robert2a a écrit :

Bonjour

sinon pour stretch
il me faut ton bureau et le gestionnaire de session (par exemple gnome + gdm3)



C'est du Gnome pour gdm, je ne sais pas, c'est la version de défaut quand j'ai installé Debian 9. 

robert2a a écrit :

donner le retour de la commande lspci (en autre connaître ton gpu )


lspci
 


selon ton bureau si tu utilise le serveur X ou Wayland (avec gnome par exemple )



00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 515 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d46 (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Non-Volatile memory controller: Intel Corporation Device f1a5 (rev 03)
02:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)




donner le retour de cette commande (pour les erreurs du système )


journalctl -r -p err
 



janv. 12 18:11:01 xiaomi kernel: Disabling IRQ #16
janv. 12 18:11:01 xiaomi kernel: [<ffffffffc07cd140>] i2c_dw_isr [i2c_designware_core]
janv. 12 18:11:01 xiaomi kernel: [<ffffffffc0796900>] idma64_irq [idma64]
janv. 12 18:11:01 xiaomi kernel: [<ffffffffc0427340>] i801_isr [i2c_i801]
janv. 12 18:11:01 xiaomi kernel: handlers:
janv. 12 18:11:01 xiaomi kernel: irq 16: nobody cared (try booting with the "irqpoll" option)
janv. 12 18:11:00 xiaomi kernel: i2c_designware i2c_designware.0: controller timed out
janv. 12 18:03:16 xiaomi bluetoothd[786]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
janv. 12 18:03:16 xiaomi bluetoothd[786]: sap-server: Operation not permitted (1)
janv. 12 18:03:16 xiaomi bluetoothd[786]: Sap driver initialization failed.
janv. 12 18:03:16 xiaomi bluetoothd[786]: Failed to obtain handles for "Service Changed" characteristic
janv. 12 18:03:16 xiaomi kernel: usb usb2-port2: cannot disable (err = -32)
janv. 12 18:03:16 xiaomi kernel: usb usb2-port2: cannot disable (err = -32)
janv. 12 18:03:15 xiaomi kernel: usb usb2-port2: cannot disable (err = -32)
janv. 12 17:50:10 xiaomi python3[1697]: backintime (xiaomi/1): ERROR: Back In Time is not configured!
janv. 12 17:50:07 xiaomi bluetoothd[786]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
janv. 12 17:49:36 xiaomi bluetoothd[786]: sap-server: Operation not permitted (1)
janv. 12 17:49:36 xiaomi bluetoothd[786]: Sap driver initialization failed.
janv. 12 17:49:36 xiaomi bluetoothd[786]: Failed to obtain handles for "Service Changed" characteristic
janv. 12 17:49:33 xiaomi avahi-daemon[640]: chroot.c: open() failed: No such file or directory
janv. 12 17:49:32 xiaomi kernel: i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_26.bin (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-23.ucode (-2)
lines 1-23...skipping...
-- Logs begin at Sat 2019-01-12 17:49:32 CET, end at Sat 2019-01-12 18:31:56 CET. --
janv. 12 18:11:01 xiaomi kernel: Disabling IRQ #16
janv. 12 18:11:01 xiaomi kernel: [<ffffffffc07cd140>] i2c_dw_isr [i2c_designware_core]
janv. 12 18:11:01 xiaomi kernel: [<ffffffffc0796900>] idma64_irq [idma64]
janv. 12 18:11:01 xiaomi kernel: [<ffffffffc0427340>] i801_isr [i2c_i801]
janv. 12 18:11:01 xiaomi kernel: handlers:
janv. 12 18:11:01 xiaomi kernel: irq 16: nobody cared (try booting with the "irqpoll" option)
janv. 12 18:11:00 xiaomi kernel: i2c_designware i2c_designware.0: controller timed out
janv. 12 18:03:16 xiaomi bluetoothd[786]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
janv. 12 18:03:16 xiaomi bluetoothd[786]: sap-server: Operation not permitted (1)
janv. 12 18:03:16 xiaomi bluetoothd[786]: Sap driver initialization failed.
janv. 12 18:03:16 xiaomi bluetoothd[786]: Failed to obtain handles for "Service Changed" characteristic
janv. 12 18:03:16 xiaomi kernel: usb usb2-port2: cannot disable (err = -32)
janv. 12 18:03:16 xiaomi kernel: usb usb2-port2: cannot disable (err = -32)
janv. 12 18:03:15 xiaomi kernel: usb usb2-port2: cannot disable (err = -32)
janv. 12 17:50:10 xiaomi python3[1697]: backintime (xiaomi/1): ERROR: Back In Time is not configured!
janv. 12 17:50:07 xiaomi bluetoothd[786]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
janv. 12 17:49:36 xiaomi bluetoothd[786]: sap-server: Operation not permitted (1)
janv. 12 17:49:36 xiaomi bluetoothd[786]: Sap driver initialization failed.
janv. 12 17:49:36 xiaomi bluetoothd[786]: Failed to obtain handles for "Service Changed" characteristic
janv. 12 17:49:33 xiaomi avahi-daemon[640]: chroot.c: open() failed: No such file or directory
janv. 12 17:49:32 xiaomi kernel: i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_26.bin (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-23.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-24.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-25.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-26.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: acpi MSFT0101:00: platform device creation failed: -16
janv. 12 17:49:32 xiaomi kernel: platform MSFT0101:00: failed to claim resource 1
 




robert2a a écrit :


le retour de la commande


glxinfo -B
 



name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 515 (Skylake GT2)  (0x191e)
    Version: 13.0.6
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 515 (Skylake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 




robert2a a écrit :

pour le touchpad


apt-cache policy xserver-xorg-input-evdev
 




xserver-xorg-input-libinput:
  Installé : 0.23.0-2
  Candidat : 0.23.0-2
 Table de version :
 *** 0.23.0-2 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
 



Alors qu'en pensez-vous ? Merci

Hors ligne

#5 12-01-2019 19:04:57

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Debian 9] mon touchpad s'arrête de fonctionner après un certain temps

la commande pour vérifier si installé est celle ci


apt-cache policy xserver-xorg-input-synaptics
 



pour le gpu cela a l' air correct.
tu a des erreurs sûrement qui peuvent être corrigé.

par exemple celle ci (firmware gpu et wifi )


janv. 12 17:49:32 xiaomi kernel: i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_26.bin (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-23.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-24.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-25.ucode (-2)
janv. 12 17:49:32 xiaomi kernel: iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-8000C-26.ucode (-2)
 

Dernière modification par robert2a (12-01-2019 19:11:36)

Hors ligne

#6 12-01-2019 22:08:30

prog-amateur
Membre
Inscription : 19-12-2018

Re : [Debian 9] mon touchpad s'arrête de fonctionner après un certain temps

Merci pour ton aide. Voici le retour de :

apt-cache policy xserver-xorg-input-synaptics


xserver-xorg-input-synaptics:
  Installé : (aucun)
  Candidat : 1.9.0-1+b1
 Table de version :
     1.9.0-1+b1 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
 



Si j'ai bien compris, synaptics n'est pas installé... dois-je l'installer (libinput n'est-il pas suffisant) et si oui comment svp ? merci !

Dernière modification par prog-amateur (12-01-2019 22:08:45)

Hors ligne

Pied de page des forums