Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-02-2010 07:14:27

Owned
Membre
Distrib. : Debian wheezy
Noyau : Custom
Inscription : 02-04-2009

Problème svn

Bonjour all,

j'ai suivis ce tutorial sans la partie ssl :
Installation svn

Sauf qu'a cette endroit :

mkdir /home/svn
mkdir /home/svn/repo
svnadmin create /home/svn/repo/test


Je n'ai pas créé les répertoires mais passé directement à la commande 'svnadmin'...

La conf apache:
cat /etc/apache2/sites-enabled/000-default :

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/
        RequestHeader edit Destination ^https http early

       <Location /svn>
        DAV svn
        #Options Indexes FollowSymLinks MultiViews
        #Order allow,deny
        #allow from all
        Require valid-user

        SVNParentPath /home/svn/repo
        AuthType Basic
        AuthName "Depot du LIM"
        AuthUserFile /home/svn/htpasswd
        AuthzSVNAccessFile /home/svn/access
        </Location>

        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


cat access :

[groups]
admins = admin

[repos:/]
@admins = rw
Owned = rw

[repos:/trunks]
Owned = rw


cat  htpasswd :

Owned:mon_mot_de_passe


Les droits :

ls -all /home/svn
-rw-r--r-- 1 www-data www-data  154 fév 26 06:35 access
-rw-r--r-- 1 www-data www-data   20 fév 26 06:33 htpasswd

repo:
total 16
drwxr-xr-x 4 www-data www-data 4096 fév 26 06:18 .
drwxr-xr-x 4 www-data www-data 4096 fév 26 06:16 ..
drwxr-xr-x 6 www-data www-data 4096 fév 26 06:17 test
drwxr-xr-x 6 root     root     4096 fév 26 06:18 trunk


Je me connecte http://localhost/svn/repo

Il me demande mes identifiants, ok mais erreur :

You don't have permission to access /svn/repo/ on this server.
-------------------------------------------------------------------------------

Apache/2.2.9 (Debian) DAV/2 SVN/1.5.1 PHP/5.2.6-1+lenny6 with Suhosin-Patch


Log apache:

Access denied: 'Owned' GET repo:/


Cordialement

Dernière modification par Owned (26-02-2010 07:37:37)

Hors ligne

#2 01-03-2010 01:43:42

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Problème svn

Bonjour Owned,

cat  htpasswd :
Owned:mon_mot_de_passe


Ne faudrait-il pas plutôt la version cryptée du mot de passe? Le fichier à t-il été généré avec la commande htpasswd ?

Hors ligne

#3 01-03-2010 01:46:28

Owned
Membre
Distrib. : Debian wheezy
Noyau : Custom
Inscription : 02-04-2009

Re : Problème svn

oui le mot de passe est crypté, désolé j'aurais du le signaler

Hors ligne

Pied de page des forums