Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-03-2010 17:22:51

pam
Membre
Lieu : CH 1844 Villeneuve
Distrib. : Wheezy
Noyau : 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3 x86_64
(G)UI : kde
Inscription : 23-10-2009

carte tv

Bonjour à tous,
J'ai installée une carte TV Hauppauge WinTV-HVR-1300. Depuis pas mal de temps, je ne parviens pas à faire fonctionner cette carte. Comme mes connaissances d'anglais sont assez approximatives, j'ai cru comprendre que je devais installer le module ivtv avec module assistant. Mais voila:
m-a
Démarrage de l'interface « Dialog »...
Extracting the package tarball, /usr/src/ivtv.tar.bz2, please wait...
Terminé pour /usr/src/ivtv-modules-2.6.26-2-686_1.2.0-1+2.6.26-21lenny3_i386.deb.
(Lecture de la base de données... 183316 fichiers et répertoires déjà installés.)
Dépaquetage de ivtv-modules-2.6.26-2-686 (à partir de .../ivtv-modules-2.6.26-2-686_1.2.0-1+2.6.26-21lenny3_i386.deb) ...
dpkg : erreur de traitement de /usr/src/ivtv-modules-2.6.26-2-686_1.2.0-1+2.6.26-21lenny3_i386.deb (--install) :
tentative de remplacement de « /lib/modules/2.6.26-2-686/kernel/drivers/media/video/saa717x.ko », qui appartient aussi au paquet linux-image-2.6.26-2-686
Des erreurs ont été rencontrées pendant l'exécution :
/usr/src/ivtv-modules-2.6.26-2-686_1.2.0-1+2.6.26-21lenny3_i386.deb

I: L'installation directe a échoué, tentative de postinstallation des dépendances

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Il y a une erreur! Y a-t-il quelque part une bonne doc qui explique comment s'y prendre avec cette carte. J'ai essayé beaucoup de choses, probablement trop et flanqué le bazar sur mon système!?!

Si une idée ou une piste vous vient à l'esprit, cela me serait bien utile car je ne sais par où commencer.

Merci.

pam

Hors ligne

#2 01-03-2010 18:44:16

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : carte tv

Bonjour pam,

Comme le dit le message que vous nous montrez ...

dpkg : erreur de traitement de /usr/src/ivtv-modules-2.6.26-2-686_1.2.0-1+2.6.26-21lenny3_i386.deb (--install) :
tentative de remplacement de « /lib/modules/2.6.26-2-686/kernel/drivers/media/video/saa717x.ko », qui appartient aussi au paquet linux-image-2.6.26-2-686


... le module fait partie du noyau, il n'est donc pas nécessaire de tenter de l'installer, et le système ne le permet pas.

Par contre, il est possible que le module ne soit pas monté. Pour savoir ce qu'il en est, ouvrez une console (aussi appelée terminal) et lancez la ligne de commandes suivante:

lsmod | grep saa


Ceci devrait vous renvoyer une ou plusieurs lignes dans le cas ou le module est monté (la barre verticale correspond à l'appui de "Alt Gr" et de la touche 6 de la rangée supérieure du clavier).

Si la commande ne renvoie rien, il faut monter le module. Pour cela, toujours en ligne de commande, mais en root cette fois, il faut entrer la ligne

modprobe saa717x


... qui ne devrait rien renvoyer.

Si vous ne comprenez pas mes explications, n'hésitez pas à demander des précisions.

Pour pousuivre, dites nous ce que donnent les commandes ci-dessus. Il faudrait aussi nous donner plus de précisions sur votre problème. Pouvez vous au moins ouvrir une session graphique? Dans ce cas, qu'est ce qui ne fonctionne pas? l'acquisition?

Dernière modification par tux12 (01-03-2010 18:49:49)

Hors ligne

#3 02-03-2010 16:37:37

pam
Membre
Lieu : CH 1844 Villeneuve
Distrib. : Wheezy
Noyau : 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3 x86_64
(G)UI : kde
Inscription : 23-10-2009

Re : carte tv

Oui, je n'ai pas percuté en voyant ce message...

Mais
# lsmod | grep saa         au départ ne donnait rien
# modprobe saa717x      qui ne renvoie rien
# lsmod | grep saa
saa717x                14208  0
i2c_core               19828  13 saa717x,bttv,nvidia,cx22702,cx88_vp3054_i2c,wm8775,tuner_simple,tuner,cx88xx,i2c_algo_bit,tveeprom,v4l2_common,i2c_nforce2

mais le module disparaissait à l'arrêt du pécé, donc j'ai ajouté saa717x dans le fichier /etc/modules et là c'est OK

Pour mes errances, je me suis basé sur
http://www.commentcamarche.net/faq/1663 … sous-linux
cette page à pour moi 2 avantages: elle est en français et elle parle debian Lenny, qui est la distribution que j'utilise.

Mais il y a encore des problèmes:
avec kdetv, j'ai l'image captée par ma webcam. Si je change l'input, l'application plante.
Avec tvtime, j'ai le message pas de signal.

Donc pas de TV!

Je dois vérifier mes branchements!

Ou peut être autre chose. Merci de vos suggestions.

pam

Hors ligne

#4 02-03-2010 17:50:47

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : carte tv

Bonjour,

j'ai ajouté saa717x dans le fichier /etc/modules et là c'est OK


Oui, c'est ce qu'il fallait faire.

Pour la suite, je n'ai pas trop d'idées. J'essaierai bien de lancer kdetv et tvtime depuis une console dans la session graphique pour voir les messages renvoyés par l'application (lors du changement d'input pour kdetv et au démarrage pour tvtime).

Edit: Avez vous suivi les indications de la doc Ubuntu sur tvtime section "Configurer la source vidéo de TVTIME"? Vérifiez le nom du périphérique (/dev/videoX avec X un chiffre).

Dernière modification par tux12 (02-03-2010 17:59:09)

Hors ligne

Pied de page des forums