Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-02-2019 01:38:09

gamato
Membre
Inscription : 10-02-2019

Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Bonsoir,

Je me suis décidé à installer Debian dans mon vieil imac que je n'utilisais plus. Ayant eu des soucis avec l'OS apple, je n'ai pas pu partitionner mon disque dur. J'ai donc formaté le disque dur pendant l'installation de Debian (je me suis rendu compte de mon erreur après avoir réalisé le verrouillage d'Apple sur son EFI, mais bon, c'est désormais trop tard:( ). C'est d'autant plus tard que le lecteur CD de mon imac ne fonctionne plus. Je ne peux donc réinstaller Mac Os pour pouvoir installer Linux par la suite.

Bref, en tout ça, le bon côté de la chose c'est que j'ai réussi à installer Debian sur mon ordinateur. Le mauvais côté c'est qu'à chaque démarrage il freeze. J'ai téléchargé super_grub de manière à pouvoir y voir plus clair dans les soucis de partitionnement du disque qui (d'après ce que j'ai lu sur le net) engendrent ce problème de démarrage. Mais je suis inexpert dans les montages de partitions et dans l'organisation du démarrage (et assez inexpert pour ce qui concerne le reste aussi). C'est pourquoi j'aurais besoin de votre aide, svp.

Je vais éditer ce message en ajoutant des photos de mon ordinateur pour que ceux qui voudront bien m'aider puissent lire ce qui s'affiche au démarrage lorsque mon ordi freeze et ce que m'affiche super grub.

Edit : voici ce qui s'affiche lorsque je démarre Debian Cinnamon normalement :
1549842353-img-20190211-003911.png

Voici ce qui s'affiche lorsque je démarre Debian en recovery mode
1549842368-img-20190211-004019.png1549842416-img-20190211-004024.png

Voici ce qui s'affiche sur Super Grub
1549842434-img-20190211-004139.png

Je vous remercie d'avance pour votre aide.

Bonne soirée !

Dernière modification par gamato (11-02-2019 01:59:52)

Hors ligne

#2 13-02-2019 22:08:38

fred02840
Membre
Lieu : Aisne
Distrib. : Stretch 9.7
Noyau : Linux 4.9.0-8-amd64
(G)UI : Gnome sur Wayland
Inscription : 07-02-2018

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Bonjour,

Je m'interroge sur le fait que le formatage du disque dur ait provoqué les problèmes que tu nous soumets. Je viens de réinstaller la Debian sur un MacBook Pro à peine plus récent, et à un moment donné, il est demandé s'il faut forcer l'installation de l'UEFI, ce qui causera des problèmes ultérieurement si on veut utiliser d'autres OS. Répondre évidemment par la négative. Te rappelles-tu avoir eu cette fenêtre ?

Fred
----
Debian 9 sur MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...), et sur une eMachines, Intel Atom N455, 1Go de Ram, et 250 Go (LXDE minimale)

Hors ligne

#3 18-02-2019 19:44:35

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Bonjour Fred,

Je te remercie pour ton message et m'excuse de ne pas t'avoir répondu plus tôt.
Entre temps la situation a évolué et j'ai fait de nombreuses recherches pour y voir plus clair, malheureusement je n'ai toujours pas pour le moment trouvé de solution.

Voici ce que j'ai appris :
- la génération de mon mac démarre sur un EFI à 32bits mais supporte des systèmes d'exploitation de 64. D'où le fait que les images iso classiques ne fonctionnent pas quand j'essaye de les démarrer (et cela même si j'ai installé Refind) ;
- il existe un site où peuvent être téléchargées des images iso qui correspondent à ce modèle de mac, elles sont à graver sur un DVD. Je les ai gravées telles quelles sur un DVD mais cela n'a pas fonctionné (le lecteur les éjecte, même s'il est parfaitement capable de lire un DVD Apple ou un DVD de données ; je précise, si cela peut avoir une utilité, que j'ai gravé ces images en format iso et non img ou dmg et sur des DVD réinscriptibles) ;
- j'ai également essayé différentes distributions (dont celles de Mattgadient : https://mattgadient.com/2016/07/11/linu … 6-models/) sur virtualbox à partir de Mac Os que je suis parvenu à réinstaller et cela n'a rien donné non plus. Je suis toutefois arrivé à booter via un fichier live Mageia (en 32 et en 64 bits) et Solus sans pour autant que l'installation marche ;
- les différentes clés bootables ont été gravés via Fedora Media Live Writer (j'ai Fedora sur un autre pc) et les DVD via Brasero.

Bref, j'ignore si avec ces éléments supplémentaires toi-même ou la communauté disposez de plus de renseignements pour me suggérer une piste. Je vous remercie dans tous les cas pour le temps que vous avez pris ou prendrez pour lire mon message smile

Hors ligne

#4 18-02-2019 21:19:53

raleur
Membre
Inscription : 03-10-2014

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

gamato a écrit :

Voici ce qui s'affiche lorsque je démarre Debian en recovery mode


Parmi les derniers messages affichés il y a ceux relatifs à l'activation du pilote graphique radeon. Le blocage pourrait venir de là.
Essaie de démarrer en ajoutant l'option "nomodeset" à la ligne de commande du noyau "linux", en éditant l'entrée de menu dans GRUB.

gamato a écrit :

la génération de mon mac démarre sur un EFI à 32bits mais supporte des systèmes d'exploitation de 64. D'où le fait que les images iso classiques ne fonctionnent pas quand j'essaye de les démarrer


Tu as essayé avec l'image d'installation netinstall multi-arch ? Elle est amorçable en mode EFI 32 bits et permet d'installer un système 64 bits.

(PS : Je déteste les Mac)

Hors ligne

#5 18-02-2019 22:19:01

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

raleur a écrit :

gamato a écrit :

Voici ce qui s'affiche lorsque je démarre Debian en recovery mode


Parmi les derniers messages affichés il y a ceux relatifs à l'activation du pilote graphique radeon. Le blocage pourrait venir de là.
Essaie de démarrer en ajoutant l'option "nomodeset" à la ligne de commande du noyau "linux", en éditant l'entrée de menu dans GRUB.

gamato a écrit :

la génération de mon mac démarre sur un EFI à 32bits mais supporte des systèmes d'exploitation de 64. D'où le fait que les images iso classiques ne fonctionnent pas quand j'essaye de les démarrer


Tu as essayé avec l'image d'installation netinstall multi-arch ? Elle est amorçable en mode EFI 32 bits et permet d'installer un système 64 bits.

(PS : Je déteste les Mac)



Je te remercie pour tous ces conseils, je vais essayer les deux choses que tu me conseilles.

Moi aussi je déteste les Mac, j'avais acheté celui-ci à une époque où Mac était moins connu et faisait de meilleurs Pc que Microsoft (tout en ignorant l'univers Linux). Si maintenant je devais racheter un ordi, j'en configurerais un tout exprès pour monter le seul linux

Hors ligne

#6 18-02-2019 22:33:17

raleur
Membre
Inscription : 03-10-2014

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Inutile de citer l'intégralité de mon message, il est juste au dessus.

gamato a écrit :

je vais essayer les deux choses que tu me conseilles.


Deux précisions :
- L'option nomodeset empêche l'activation du pilote radeon, dans le but d'éviter le blocage s'il est dû au pilote (peut-être à cause des firmwares manquants, on verra plus tard).
- L'image netinstall multi-arch ne résoudra pas le blocage, elle permet juste d'installer un système 64 bits avec un UEFI 32 bits si c'est ce que tu souhaites.

gamato a écrit :

Mac était moins connu et faisait de meilleurs Pc que Microsoft


A ma connaissance, Microsoft n'a jamais fait de PC à l'exception de la gamme de tablettes-PC Surface.

Dernière modification par raleur (18-02-2019 22:35:41)

Hors ligne

#7 18-02-2019 22:42:08

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Autant pour moi, pour ce qui concerne l'emploi de "PC", j'ai utilisé ce terme comme équivalent pour ordinateur, mais visiblement il doit avoir une signification que je ne connais pas.
Je te remercie également pour les explications que tu me donnes : j'avoue ne pas comprendre tout ce que je fais étant donné que, même si je fais des choses sans doute un peu plus complexes que ceux qui achètent des ordis sans se poser de questions, je ne connais ni ne saisis pas la logique d'ensemble de ce que je fais.

Hors ligne

#8 18-02-2019 23:20:59

raleur
Membre
Inscription : 03-10-2014

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

gamato a écrit :

pour ce qui concerne l'emploi de "PC", j'ai utilisé ce terme comme équivalent pour ordinateur


J'avais bien compris et je répète qu'à ma connaissance, Microsoft n'a pas fait d'ordinateur avant les tablettes-PC Surface en 2012. Il n'a fait que leur système d'exploitation Windows.

Si tu ne comprends pas tout ce que j'écris, n'hésite pas à demander des explications.

Dernière modification par raleur (18-02-2019 23:22:59)

Hors ligne

#9 19-02-2019 16:52:45

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Bonjour,
Enfin j'ai Debian KDE sur mon imac et ce, grâce à tes conseils, raleur !

Seule chose qui ne fonctionne pas : les pilotes de la carte graphique, même si j'ai suivi la procédure indiquée ici (https://wiki.debian.org/AtiHowTo#Installation), ne fonctionnent toujours pas.

voilà ce que j'obtiens lorsque je lance la commande indiquée comme Troubleshooting dans le wikidebian :


# dmesg | grep -E 'drm|radeon' | grep -iE 'firmware|microcode'


[  332.960402] Modules linked in: rfcomm bnep nls_ascii nls_cp437 vfat fat btusb btrtl btbcm btintel bluetooth iTCO_wdt coretemp iTCO_vendor_support hid_appleir kvm_intel kvm evdev isight_firmware applesmc wl(PO) snd_hda_codec_idt input_polldev irqbypass efi_pstore snd_hda_codec_generic lpc_ich pcspkr efivars mfd_core cfg80211 snd_hda_intel ttm snd_hda_codec drm_kms_helper snd_hda_core drm i2c_algo_bit sg rng_core rfkill snd_hwdep snd_pcm snd_timer snd shpchp apple_bl soundcore video button acpi_cpufreq parport_pc ppdev lp parport efivarfs ip_tables x_tables autofs4 ext4 crc16 jbd2 crc32c_generic fscrypto ecb glue_helper lrw gf128mul ablk_helper cryptd aes_x86_64 mbcache hid_generic usbhid hid sr_mod cdrom sd_mod ata_generic ata_piix ahci i2c_i801 i2c_smbus libahci libata firewire_ohci firewire_core



Aurais-tu une solution à mon problème ?

Dernière modification par gamato (19-02-2019 16:53:59)

Hors ligne

#10 19-02-2019 17:18:11

raleur
Membre
Inscription : 03-10-2014

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

gamato a écrit :

Enfin j'ai Debian KDE sur mon imac et ce, grâce à tes conseils


Quels conseils exactement ?
Tu n'étais pas censé installer Cinnamon ?

gamato a écrit :

Seule chose qui ne fonctionne pas : les pilotes de la carte graphique


C'est-à-dire ?

gamato a écrit :

voilà ce que j'obtiens lorsque je lance la commande indiquée comme Troubleshooting dans le wikidebian


Cette commande a pour but de trouver les messages d'erreur indiquant un firmware manquant, mais le résultat trouvé (par coincidence) est tout autre : il s'agit d'un fragment de message produit par un bug du noyau. On va élargir un peu pour récupérer les messages du pilote DRM radeon et du bug :

dmesg | egrep "radeon|drm"
dmesg | grep -C30 "Modules linked"

Dernière modification par raleur (19-02-2019 17:52:21)

Hors ligne

#11 19-02-2019 18:11:48

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

- J'ai téléchargé l'iso netinstall multiarch et édité la ligne de commande du démarrage avec nomodeset. Si je ne contourne pas les pilotes de la carte graphique, le système ne démarre pas. J'ignore quels pilotes ont été installés avec l'installation du système d'exploitation, ceux-ci ne fonctionnaient pas. Et les pilotes libres que j'ai installés par wiki debian ne fonctionnent pas non plus.

- J'avais installé cinnamon car c'était la seule image qui fonctionnait malgré de multiples tentatives ; je me suis finalement renseigné et ai préféré installer KDE

- Voici ce que j'obtiens lorsque je saisis les deux commandes que tu m'as indiquées, dans l'ordre :

[    7.038024] [drm] Initialized
[    7.443242] [drm] VGACON disable radeon kernel modesetting.
[    7.443281] [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
[  332.960402] Modules linked in: rfcomm bnep nls_ascii nls_cp437 vfat fat btusb btrtl btbcm btintel bluetooth iTCO_wdt coretemp iTCO_vendor_support hid_appleir kvm_intel kvm evdev isight_firmware applesmc wl(PO) snd_hda_codec_idt input_polldev irqbypass efi_pstore snd_hda_codec_generic lpc_ich pcspkr efivars mfd_core cfg80211 snd_hda_intel ttm snd_hda_codec drm_kms_helper snd_hda_core drm i2c_algo_bit sg rng_core rfkill snd_hwdep snd_pcm snd_timer snd shpchp apple_bl soundcore video button acpi_cpufreq parport_pc ppdev lp parport efivarfs ip_tables x_tables autofs4 ext4 crc16 jbd2 crc32c_generic fscrypto ecb glue_helper lrw gf128mul ablk_helper cryptd aes_x86_64 mbcache hid_generic usbhid hid sr_mod cdrom sd_mod ata_generic ata_piix ahci i2c_i801 i2c_smbus libahci libata firewire_ohci firewire_core
 




[   10.467755] usbcore: registered new interface driver btusb
[   11.525693] EXT4-fs (sda8): mounted filesystem with ordered data mode. Opts: (null)
[   11.677171] EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)
[   11.852479] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   11.947926] systemd-journald[193]: Received request to flush runtime journal from PID 1
[   13.859725] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   13.859727] Bluetooth: BNEP filters: protocol multicast
[   13.859733] Bluetooth: BNEP socket layer initialized
[   16.175555] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[   16.177720] sky2 0000:02:00.0 enp2s0: enabling interface
[   16.177808] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[   16.183795] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[   16.965761] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[   63.151678] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[   63.159798] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[   63.160676] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[   85.014389] Bluetooth: RFCOMM TTY layer initialized
[   85.014406] Bluetooth: RFCOMM socket layer initialized
[   85.014424] Bluetooth: RFCOMM ver 1.11
[   96.712803] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[  110.234378] perf: interrupt took too long (2534 > 2500), lowering kernel.perf_event_max_sample_rate to 78750
[  127.707050] perf: interrupt took too long (3180 > 3167), lowering kernel.perf_event_max_sample_rate to 62750
[  149.286479] perf: interrupt took too long (3980 > 3975), lowering kernel.perf_event_max_sample_rate to 50250
[  193.111585] perf: interrupt took too long (4997 > 4975), lowering kernel.perf_event_max_sample_rate to 40000
[  271.577025] perf: interrupt took too long (6252 > 6246), lowering kernel.perf_event_max_sample_rate to 31750
[  312.190051] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[  312.197646] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[  328.713938] IPv6: ADDRCONF(NETDEV_UP): wls1: link is not ready
[  332.960304] ------------[ cut here ]------------
[  332.960401] WARNING: CPU: 0 PID: 97 at /build/linux-dyUzLW/linux-4.9.144/net/wireless/sme.c:733 __cfg80211_connect_result+0x3b0/0x430 [cfg80211]
[  332.960402] Modules linked in: rfcomm bnep nls_ascii nls_cp437 vfat fat btusb btrtl btbcm btintel bluetooth iTCO_wdt coretemp iTCO_vendor_support hid_appleir kvm_intel kvm evdev isight_firmware applesmc wl(PO) snd_hda_codec_idt input_polldev irqbypass efi_pstore snd_hda_codec_generic lpc_ich pcspkr efivars mfd_core cfg80211 snd_hda_intel ttm snd_hda_codec drm_kms_helper snd_hda_core drm i2c_algo_bit sg rng_core rfkill snd_hwdep snd_pcm snd_timer snd shpchp apple_bl soundcore video button acpi_cpufreq parport_pc ppdev lp parport efivarfs ip_tables x_tables autofs4 ext4 crc16 jbd2 crc32c_generic fscrypto ecb glue_helper lrw gf128mul ablk_helper cryptd aes_x86_64 mbcache hid_generic usbhid hid sr_mod cdrom sd_mod ata_generic ata_piix ahci i2c_i801 i2c_smbus libahci libata firewire_ohci firewire_core
[  332.960476]  scsi_mod crc_itu_t ehci_pci uhci_hcd ehci_hcd usbcore usb_common sky2
[  332.960486] CPU: 0 PID: 97 Comm: kworker/u4:2 Tainted: P           O    4.9.0-8-amd64 #1 Debian 4.9.144-3
[  332.960488] Hardware name: Apple Computer, Inc. iMac5,1/Mac-F4228EC8, BIOS     IM51.88Z.0090.B09.0706270921 06/27/07
[  332.960509] Workqueue: cfg80211 cfg80211_event_work [cfg80211]
[  332.960511]  0000000000000000 ffffffff9eb34524 0000000000000000 0000000000000000
[  332.960515]  ffffffff9e87a5cb ffff9603b6776000 ffffaf128093fda0 0000000000000000
[  332.960518]  ffff9603b6534000 ffff96043d537c18 ffff96043d537c50 ffffffffc0861b40
[  332.960522] Call Trace:
[  332.960533]  [<ffffffff9eb34524>] ? dump_stack+0x5c/0x78
[  332.960536]  [<ffffffff9e87a5cb>] ? __warn+0xcb/0xf0
[  332.960555]  [<ffffffffc0861b40>] ? __cfg80211_connect_result+0x3b0/0x430 [cfg80211]
[  332.960560]  [<ffffffff9ee19364>] ? __switch_to_asm+0x34/0x70
[  332.960562]  [<ffffffff9ee19364>] ? __switch_to_asm+0x34/0x70
[  332.960577]  [<ffffffffc0837971>] ? cfg80211_process_wdev_events+0x121/0x190 [cfg80211]
[  332.960593]  [<ffffffffc0837a12>] ? cfg80211_process_rdev_events+0x32/0x70 [cfg80211]
[  332.960609]  [<ffffffffc083201a>] ? cfg80211_event_work+0x1a/0x20 [cfg80211]
[  332.960612]  [<ffffffff9e89427a>] ? process_one_work+0x18a/0x430
[  332.960614]  [<ffffffff9e89456d>] ? worker_thread+0x4d/0x490
[  332.960616]  [<ffffffff9e894520>] ? process_one_work+0x430/0x430
[  332.960619]  [<ffffffff9e89a5d9>] ? kthread+0xd9/0xf0
[  332.960621]  [<ffffffff9ee19364>] ? __switch_to_asm+0x34/0x70
[  332.960624]  [<ffffffff9e89a500>] ? kthread_park+0x60/0x60
[  332.960626]  [<ffffffff9ee193f7>] ? ret_from_fork+0x57/0x70
[  332.960627] ---[ end trace ef242d710dce73d6 ]---
[  346.476985] IPv6: ADDRCONF(NETDEV_CHANGE): wls1: link becomes ready
[ 1952.079182] perf: interrupt took too long (7844 > 7815), lowering kernel.perf_event_max_sample_rate to 25250
 

Hors ligne

#12 19-02-2019 21:37:33

raleur
Membre
Inscription : 03-10-2014

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Le bug du noyau semble lié au wifi, aucun rapport avec l'affichage donc.
Quel est le modèle de GPU affiché par lspci ?

gamato a écrit :

Et les pilotes libres que j'ai installés par wiki debian ne fonctionnent pas non plus.


Tu n'as pas installé de pilote par le wiki. Le pilote qui fait planter est le module radeon du noyau, il est donc installé d'origine avec le noyau. Les pilotes ATI pour Xorg sont normalement déjà installés par défaut, et de toute façon ce ne sont pas eux qui font planter sinon ça ne planterait pas en mode dépannage qui ne démarre pas Xorg.

Quant au 3e larron firmware-linux-nonfree, il n'installe pas de pilote libre mais des firmwares non libres. Parmi eux se trouvent les firmwares pour GPU Radeon, indispensables pour une prise en charge correcte de l'accélération matérielle et des résolutions de l'écran par le pilote libre radeon.

Les logs du noyau indiquent que le module radeon n'est pas pas actif. C'est normal si le paramètre nomodeset est passé au noyau, à vérifier dans /proc/cmdline. Confirmes-tu  que malgré l'installation des firmwares, le démarrage en mode dépannage sans l'option nomodeset bloque au même point que sur ta photo d'écran ?

Hors ligne

#13 20-02-2019 19:48:45

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

- Le wifi a été installé manuellement avec le pilote broadcom (j'ai suivi un tutoriel sur youtube qui a fort heureusement bien fonctionné)
- Voici le modèle du VGA qui correspond à ma carte graphique (est-ce bien cela le GPU ?) : VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV530/M56-P [Mobility Radeon X1600]
- "nomodeset" est bien passé au noyau...

J'ai redémarré hier soir sans l'option nomodeset, en mode dépannage (Recovery mode), certaines informations ont changé, mais l'erreur affichée pour la carte graphique est toujours la même. Voici mon écran en photo :

1550684685-img-20190219-215316.png

1550684703-img-20190219-215327.png

1550684703-img-20190219-215335.png

Dernière modification par gamato (20-02-2019 19:50:53)

Hors ligne

#14 21-02-2019 10:43:55

raleur
Membre
Inscription : 03-10-2014

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

gamato a écrit :

l'erreur affichée pour la carte graphique est toujours la même


Quelle erreur de la carte graphique ? Je n'en vois aucune sur cet écran.

Hors ligne

#15 21-02-2019 11:06:01

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Au temps pour moi, je me suis renseigné après avoir posté ici et ai vu que l'erreur d'ACPI renvoie à l'alimentation et nullement à la carte graphique

Hors ligne

#16 25-02-2019 15:43:12

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

ma quête continue mais toujours pas trouvé de solution malheureusement, alors si toi raleur ou un autre utilisateur du forum aviez une solution ou un conseil pour débloquer la situation, je vous en serais très reconnaissant.

Entre temps j'ai trouvé ce wiki rédigé en français : https://debian-facile.org/doc:materiel: … ue:ati:ati

J'ignore toutefois s'il convient d'installer le firmware propriétaire avec les pilotes libres ou avec les pilotes propriétaires, ou alors le firmware propriétaire avec les pilotes libres et les pilotes propriétaires... je ne comprends pas ce que je fais et c'est la première fois que j'essaye d'installer manuellement des pilotes pour une carte graphique. Je voudrais éviter de faire une bêtise en créant un conflit entre différents pilotes.

J'avais tout de même tenté cette procédure mais au moment de l'installation et de la compilation des pilotes propriétaires cela bloque et affiche le message suivant :

root@macdebian:/home/gamato# apt-get install fglrx-modules-dkms fglrx-driver linux-headers-$(uname -r) fglrx-control
 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
linux-headers-4.9.0-8-amd64 is already the newest version (4.9.144-3.1).
linux-headers-4.9.0-8-amd64 passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 fglrx-driver : Dépend: xorg-video-abi-19 mais il n'est pas installable ou
                         xorg-video-abi-18 ou
                         xorg-video-abi-15 mais il n'est pas installable ou
                         xorg-video-abi-14 mais il n'est pas installable ou
                         xorg-video-abi-13 mais il n'est pas installable ou
                         xorg-video-abi-12 mais il n'est pas installable ou
                         xorg-video-abi-11 mais il n'est pas installable ou
                         xorg-video-abi-10 mais il n'est pas installable ou
                         xorg-video-abi-8 mais il n'est pas installable ou
                         xorg-video-abi-6.0 mais il n'est pas installable
                Dépend: glx-alternative-fglrx (>= 0.4.1~) mais ne sera pas installé
                Recommande: libgl1-fglrx-glx (= 1:15.9-4~deb8u2) mais ne sera pas installé
                Recommande: libgl1-fglrx-glx-i386 mais il n'est pas installable
                Recommande: fglrx-atieventsd mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



Dans la liste qui est affichée, je n'arrive pas à comprendre quels sont les paquets défectueux (en admettant que ceux-ci soient affichés) et comment faire pour qu'ils ne soient plus en mode "garder en l'état".

Cela ne me dérangerait pas de rendre nomodeset permanent en commande de démarrage si ce n'était que la luminosité de mon écran n'est pas réglable et que j'aimerais pouvoir travailler sur cet ordinateur sans perdre les yeux en cours de route hmm

Merci de votre compréhension pour mes maladresses de débutant smile et merci pour votre aide

Hors ligne

#17 03-03-2019 00:04:25

gamato
Membre
Inscription : 10-02-2019

Re : Freeze pendant le démarrage de Debian Cinnamon sur Imac 20" de 2006

Bonsoir tout le monde,

Mes recherchent se poursuivent (sans succès) mais je pense avoir compris qu'il y a incompatibilité entre Debian en version graphique + KDE et ma carte graphique, de sorte qu'elle ne peut être lancée autrement que par "nomodeset".
En effet, j'ai utilisé "aptitude" au lieu d'"apt" et tenté de résoudre le problème de dépendances, aussi bien avec :

root@macdebian:/home/gamato# aptitude install fglrx-modules-dkms fglrx-driver linux-headers-$(uname -r) fglrx-control


qu'avec :

root@macdebian:/home/gamato# aptitude install xserver-xorg-video-modesetting



Si je n'accepte pas la solution consistant à ne pas installer les paquets, voici ce qui ressort avec la 1ère commande :

linux-headers-4.9.0-8-amd64 est déjà installé avec la version demandée (4.9.144-3.1)
linux-headers-4.9.0-8-amd64 est déjà installé avec la version demandée (4.9.144-3.1)
Les NOUVEAUX paquets suivants vont être installés :
  acpi-support-base{a} acpid{a} fglrx-atieventsd{a} fglrx-control fglrx-driver{b} fglrx-modules-dkms glx-alternative-fglrx{ab}
  glx-alternative-mesa{a} glx-diversions{a} libfglrx{a} libfglrx-amdxvba1{a} libgl1-fglrx-glx{a} nvidia-installer-cleanup{a} update-glx{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 29,0 Mo d'archives. Après dépaquetage, 132 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 glx-alternative-fglrx : Dépend: glx-diversions (= 0.5.1) but 0.8.8~deb9u2 is to be installed
 fglrx-driver : Dépend: xorg-video-abi-19 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-18 which is a virtual package, provided by:
                         - xserver-xorg-core (2:1.16.4-1+deb8u2), but 2:1.19.2-1+deb9u5 is installed
 ou
                         xorg-video-abi-15 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-14 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-13 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-12 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-11 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-10 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-8 which is a virtual package and is not provided by any available package
 ou
                         xorg-video-abi-6.0 which is a virtual package and is not provided by any available package

Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     fglrx-atieventsd [Non installé]                          
2)     fglrx-control [Non installé]                            
3)     fglrx-driver [Non installé]                              
4)     glx-alternative-fglrx [Non installé]                    
5)     libfglrx-amdxvba1 [Non installé]                        
6)     libgl1-fglrx-glx [Non installé]                          

     Leave the following dependencies unresolved:              
7)     fglrx-driver recommande fglrx-atieventsd                
8)     libfglrx recommande libfglrx-amdxvba1 (= 1:15.9-4~deb8u2)



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                                      
1)      task-desktop [3.39 (now, stable)]                                                  
2)      task-kde-desktop [3.39 (now, stable)]                                              
3)      xorg [1:7.7+19 (now, stable)]                                                      
4)      xserver-xorg-input-all [1:7.7+19 (now, stable)]                                    
5)      xserver-xorg-input-libinput [0.23.0-2 (now, stable)]                                
6)      xserver-xorg-legacy [2:1.19.2-1+deb9u5 (now, stable)]                              
7)      xserver-xorg-video-all [1:7.7+19 (now, stable)]                                    
8)      xserver-xorg-video-amdgpu [1.2.0-1+b1 (now, stable)]                                
9)      xserver-xorg-video-fbdev [1:0.4.4-1+b5 (now, stable)]                              
10)     xserver-xorg-video-intel [2:2.99.917+git20161206-1 (now, stable)]                  
11)     xserver-xorg-video-nouveau [1:1.0.13-3 (now, stable)]                              
12)     xserver-xorg-video-qxl [0.1.4+20161126git4d7160c-1 (now, stable)]                  
13)     xserver-xorg-video-vesa [1:2.3.4-1+b2 (now, stable)]                                
14)     xserver-xorg-video-vmware [1:13.2.1-1+b1 (now, stable)]                            

      Installer les paquets suivants :                                                      
15)     glx-diversions [0.5.1 (oldstable)]                                                  
16)     xserver-xorg-input-evdev [1:2.9.0-2 (oldstable)]                                    
17)     xserver-xorg-video-mach64 [6.9.4-2 (oldstable)]                                    
18)     xserver-xorg-video-mach64-dbg [6.9.4-2 (oldstable)]                                
19)     xserver-xorg-video-r128 [6.9.2-1+b2 (oldstable)]                                    
20)     xserver-xorg-video-r128-dbg [6.9.2-1+b2 (oldstable)]                                

      Réinstaller à une version antérieure les paquets suivants :                          
21)     xserver-xorg [1:7.7+19 (now, stable) -> 1:7.7+7 (oldstable)]                        
22)     xserver-xorg-core [2:1.19.2-1+deb9u5 (now, stable) -> 2:1.16.4-1+deb8u2 (oldstable)]
23)     xserver-xorg-input-wacom [0.34.0-1 (now, stable) -> 0.26.0+20140918-1 (oldstable)]  
24)     xserver-xorg-video-ati [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]        
25)     xserver-xorg-video-ati-dbg [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]    
26)     xserver-xorg-video-radeon [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]    
27)     xserver-xorg-video-radeon-dbg [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]



et avec la seconde :

Les NOUVEAUX paquets suivants vont être installés :    
  xserver-xorg-video-modesetting{b}
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 31,5 ko d'archives. Après dépaquetage, 62,5 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 xserver-xorg-core : Est en conflit avec: xserver-xorg-video-modesetting but 0.9.0-2 is to be installed
 xserver-xorg-video-modesetting : Dépend: xorg-video-abi-18 which is a virtual package, provided by:
                                           - xserver-xorg-core (2:1.16.4-1+deb8u2), but 2:1.19.2-1+deb9u5 is installed

Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     xserver-xorg-video-modesetting [Non installé]            



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                                      
1)      task-desktop [3.39 (now, stable)]                                                  
2)      task-kde-desktop [3.39 (now, stable)]                                              
3)      xorg [1:7.7+19 (now, stable)]                                                      
4)      xserver-xorg-input-all [1:7.7+19 (now, stable)]                                    
5)      xserver-xorg-input-libinput [0.23.0-2 (now, stable)]                                
6)      xserver-xorg-legacy [2:1.19.2-1+deb9u5 (now, stable)]                              
7)      xserver-xorg-video-all [1:7.7+19 (now, stable)]                                    
8)      xserver-xorg-video-amdgpu [1.2.0-1+b1 (now, stable)]                                
9)      xserver-xorg-video-fbdev [1:0.4.4-1+b5 (now, stable)]                              
10)     xserver-xorg-video-intel [2:2.99.917+git20161206-1 (now, stable)]                  
11)     xserver-xorg-video-nouveau [1:1.0.13-3 (now, stable)]                              
12)     xserver-xorg-video-qxl [0.1.4+20161126git4d7160c-1 (now, stable)]                  
13)     xserver-xorg-video-vesa [1:2.3.4-1+b2 (now, stable)]                                
14)     xserver-xorg-video-vmware [1:13.2.1-1+b1 (now, stable)]                            

      Installer les paquets suivants :                                                      
15)     xserver-xorg-input-evdev [1:2.9.0-2 (oldstable)]                                    
16)     xserver-xorg-video-mach64 [6.9.4-2 (oldstable)]                                    
17)     xserver-xorg-video-mach64-dbg [6.9.4-2 (oldstable)]                                
18)     xserver-xorg-video-r128 [6.9.2-1+b2 (oldstable)]                                    
19)     xserver-xorg-video-r128-dbg [6.9.2-1+b2 (oldstable)]                                

      Réinstaller à une version antérieure les paquets suivants :                          
20)     xserver-xorg [1:7.7+19 (now, stable) -> 1:7.7+7 (oldstable)]                        
21)     xserver-xorg-core [2:1.19.2-1+deb9u5 (now, stable) -> 2:1.16.4-1+deb8u2 (oldstable)]
22)     xserver-xorg-input-wacom [0.34.0-1 (now, stable) -> 0.26.0+20140918-1 (oldstable)]  
23)     xserver-xorg-video-ati [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]        
24)     xserver-xorg-video-ati-dbg [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]    
25)     xserver-xorg-video-radeon [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]    
26)     xserver-xorg-video-radeon-dbg [1:7.8.0-1+b1 (now, stable) -> 1:7.5.0-1 (oldstable)]
 



Dois-je me résigner à l'idée de rendre permanent "nomodeset" car Debian et KDE entrent en conflit avec les pilotes de la carte (comme semble l'indiquer le fait que les paquets task-desktop et task-kde-desktop sont à supprimer pour pouvoir installer les deux paquets de pilotes)?

Merci d'avance pour vos éventuelles réponses smile

Dernière modification par gamato (03-03-2019 00:40:00)

Hors ligne

Pied de page des forums