Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-03-2010 18:14:47

Maufab
Membre
Lieu : Ariège
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 12-03-2010

[Résolu en partie] Imprimante HP Deskjet F2480 et pilote hplip-3.10.2

Bonjour, petit pb d'install de hplip sur lenny: version hplip-3.10.2 en tarball pour une HP Deskjet F2480

dpkg -l python-qt4-dbus:
ii  python-qt4-dbus                  4.4.2-4                   DBus Support for PyQt4


hp-check = Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency.


pourquoi ne le trouve t-il pas?
et puis dans cups :

"Unable to start filter "foomatic-rip-hplip" - No such file or directory."


Je croyais que ça s'était améliorer la facilité d'install des pilotes HP

Dernière modification par Maufab (26-03-2010 19:49:47)


Debian Jessie 64bits
Portable Asus X73S

Hors ligne

#2 26-03-2010 19:48:01

dh
Membre
Lieu : Rhône
Distrib. : SID
Noyau : 4.2.0-1-amd64
(G)UI : Gnome3
Inscription : 23-03-2010

Re : [Résolu en partie] Imprimante HP Deskjet F2480 et pilote hplip-3.10.2

Tu as récupéré les derniers pilotes sur le site HP ?

Libertaire, libéral, libre.

Hors ligne

#3 26-03-2010 19:59:40

Maufab
Membre
Lieu : Ariège
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 12-03-2010

Re : [Résolu en partie] Imprimante HP Deskjet F2480 et pilote hplip-3.10.2

oui, mais le tuto de chez HP http://hplipopensource.com/hplip-web/in … ebian.htmlest à corriger, au moins pour l'erreur de cups avec foomatic-rip-hplip dans ./configure pour
64 bit distro users:

./configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build


que j'ai remplacé par :

./configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --enable-foomatic-ppd-install --enable-hpijs-install --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build --disable-foomatic-rip-install --enable-foomatic-rip-hplip-install


comme indiqué ici: http://hplipopensource.com/node/337

L'erreur sur python-qt4-dbus, et bien je pense que de toute façon ce paquet est seulement nécessaire pour l'interface graphique de l'appli HP. Donc ça n'empếche pas d'imprimer. Peut-être que ça peut être génant pour gérer les niveaux d'encre en mode graphique.

Dernière modification par Maufab (26-03-2010 20:11:05)


Debian Jessie 64bits
Portable Asus X73S

Hors ligne

#4 26-03-2010 20:31:13

dh
Membre
Lieu : Rhône
Distrib. : SID
Noyau : 4.2.0-1-amd64
(G)UI : Gnome3
Inscription : 23-03-2010

Re : [Résolu en partie] Imprimante HP Deskjet F2480 et pilote hplip-3.10.2

J'ai vérifié avec hp-check, j'ai également cette erreur (ou warning, je sais plus) sur python-qt4-dbus, mais mon imprimante fonctionne très bien wink
En revanche j'ai bien python-dbus d'installé.

Libertaire, libéral, libre.

Hors ligne

Pied de page des forums