Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-03-2010 18:13:20

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

[Résolu] Problème lors de la compilation de gimp 2.6.8.

Bonjour à tous et à toutes j'ai essayé de compiler gimp 2.6.8 sur Lenny d'après cette méthode : http://www.debian-facile.org/forum/view … ?pid=12568 mais malheureusement je bloque à l'étape "./configure" voici l'erreur : checking for BABL... configure: error: Package requirements (babl >= 0.0.22) were not met:

No package 'babl' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BABL_CFLAGS
and BABL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

De plus il ne trouve pas le paquet : E: Impossible de trouver le paquet libgegl-0.0-0-dev.
Je précise que je suis sur Lenny 64bits.
Merci pour l'aide.

Dernière modification par unit (02-04-2010 17:15:06)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#2 31-03-2010 19:38:22

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Voici mon source.list : ## lenny
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

## volatile
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-$
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib $

## lenny security
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

## lenny multimedia
deb http://mirror.home-dn.net/debian-multimedia lenny main
deb-src http://mirror.home-dn.net/debian-multimedia lenny main

## backports
deb http://www.backports.org/debian lenny-backports main contrib non-free

deb http://repository.glx-dock.org/debian stable cairo-dock

Et mon fichier préférence : Package: *
Pin: release o=Backports.org Archive,a=lenny-backports,l=Backports.org Archive
Pin-Priority: 200

Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable,l=Unofficial Multimedia Packages
Pin-Priority: 400

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#3 31-03-2010 20:02:10

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

personne pour m'aider.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#4 31-03-2010 20:08:38

dh
Membre
Lieu : Rhône
Distrib. : SID
Noyau : 4.2.0-1-amd64
(G)UI : Gnome3
Inscription : 23-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Tu compiles à titre d'exercice ?

Libertaire, libéral, libre.

Hors ligne

#5 31-03-2010 20:14:55

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Salut,

Merci de ne pas faire de "up" au bout de 20 minutes, nous ne sommes pas connectés en permanence sur le forum et les personnes connectées ne savent pas forcément répondre à tous les problèmes.

Bref, pour ton problème, il y avait une petite coquille dans le post que tu as mis en lien, un zéro en trop dans le nom d'un paquet (c'est corrigé).

Cette commande devrait résoudre ton problème :

apt-get install libbabl-0.0-0-dev libgegl-0.0-dev


Relance le ./configure après.


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#6 31-03-2010 20:15:00

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Non je voudrai avoir une version plus récente de gimp sans avoir à migrer sur Sid ou Testing.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#7 31-03-2010 20:17:21

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Ok désoler pour le "up" au bout de 20 minutes, j'assaye et je te dit ce qu'il en ai.
Merci encore.:P

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#8 01-04-2010 12:13:02

NuDub
Membre
Lieu : OISE
Distrib. : Debian Testing
Noyau : 3.16 amd64
(G)UI : LXDE-GNOME-KDE
Inscription : 31-05-2009

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Salut Unit,

Pense aussi au bouton MODIFIER quand tu veux ajouter quelques choses à un post.

Surtout quand c'est la même journée, sa évite du flood toutes les 2 minutes.

EDIT
Aussi si tu dois dl une lib ou autre fais gaffe car il y a des pb avec les dépôt pour le moment (vu sur un autre topics et je sais pas si c'est régler).

Dernière modification par NuDub (01-04-2010 12:14:33)


VM Debian Testing sur Win7

Hors ligne

#9 01-04-2010 19:59:34

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Suite a l'installation de Gimp 2.6.6 il me retourne ce message d'erreur : Libgimp version mismatch!

The GIMP binary cannot run with a libgimp version
other than its own. This is GIMP 2.6.6, but the
libgimp version is 2.4.7.

Maybe you have GIMP versions in both /usr and /usr/local ?

Je ne comprends pas pourquoi.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#10 01-04-2010 21:14:49

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Salut,

Il faut que tu désinstalles libgimp2.0 avant de lancer le Gimp que tu as compilé :

# apt-get remove libgimp2.0


Ça peut virer d'autres paquets (comme xsane), mais une fois que tu as lancé Gimp 2.6 une première fois, tu pourras réinstaller libgimp2.0 et ce qui va avec, normalement ça devrait fonctionner.

D'ailleurs je viens de voir que le tuto d'origine est faux, je vais corriger ça.


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#11 01-04-2010 22:28:34

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Merci mani ça marche au poil, par contre concernant inkscape est-il possible d'installer la dernière version.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#12 01-04-2010 23:04:27

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

Je ne sais pas, je n'ai pas essayé, mais sans doute que oui, on peut installer plein de choses en compilant. smile

Il y a une page qui explique comment faire sur le wiki d'Inkscape (en anglais). Sinon la version 0.47 se trouve dans les dépôts de Squeeze et de Sid, à voir si c'est possible de l'installer par pinning.

Si tu as d'autres questions sur l'installation d'Inkscape, ouvre un nouveau fil. Et pourras-tu mettre celui-ci en [Résolu] si l'installation de Gimp 2.6 est définitivement réglée pour toi ?

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#13 02-04-2010 17:14:32

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Problème lors de la compilation de gimp 2.6.8.

ok et merci encore.

Dernière modification par unit (02-04-2010 17:15:26)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

Pied de page des forums