Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-03-2010 21:09:31

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

php fast-cgi nginx

Bonsoir à tous ,

J'ai un petit souci ,
Voilà le topo :

1 serveur sous debian lenny Apache + php compilé à la mano .

Mon but est de mettre en place nginx .

Jusque là pas de probléme , mon probléme vient du fait que je n'arrive pas à lancer le daemon qui réceptionne les fichiers ftp envoyé par nginx .

Voilà le script mis en place :

Nginx fastcgi

Seulement au lancement de ce script .. et bien rien pas de message d'erreur , code de retour = 0 , et aucun process lancé .. :-(

la commande netstat -plunt me confirme celà  !

Existe-il un mode debug de php-cgi ou de start-stop-daemon , que je sache ce qui coince .

J'ai fait deux autres install , une sur ubuntu ( avec php compilé à la main mais en V5.3.2 ) .. le code fonctionne à merveille , et l'autre , encore sur une ubuntu mais cette fois avec php version de la distrib .

Voici le fichier de config pour la compilation de php :

./configure --prefix=/usr/local \
        --disable-ipv6 \
        --with-curl \
        --enable-ftp \
        --with-gd \
        --enable-intl \
        --enable-mbstring \
        --with-mcrypt \
        --with-mhash \
        --with-mysql \
        --with-pdo-mysql \
        --enable-soap \
        --with-pear \
        --with-xsl \
        --with-zlib \
        --with-openssl\
  --enable-bcmath \


Merci d'avance pour votre aide .
Ch.

Hors ligne

#2 01-04-2010 10:01:20

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : php fast-cgi nginx

Si ça peut mettre quelqu'un sur la voie , voici le resultat d'un strace ,

strace php-cgi -b 127.0.0.1:9000

-----------

strace log

ch.

Hors ligne

#3 01-04-2010 14:45:53

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : php fast-cgi nginx

Bon ,
Apres moult tests , j'ai assayé avec php V5.3.2 .. et là les process se lancent !

Le problème viendrait donc de la V5.2.12 de php ...

Mais bon , ca ne m'arrange pas cette affaire , sur ce serveur des sites ne sont pas encore compatible avec le v5.3 ...

Si des personnes ont des idées .. smile

Hors ligne

Pied de page des forums