Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-04-2010 23:02:47

BeruLeGras
Membre
Inscription : 15-11-2009

-résolu- Scanner devenu uniquement utilisable en root par xsane

Bonjour,
Ce post est le résumé d'un problème qui avait été traité par Mani mais pour une question avec un titre initial plus flou. Suite à une mise à jour, j'ai eu plusieurs problèmes, y compris celui-ci, traité de manière annexe. Sur conseil de Damien, je suis allé voir ce Topic. Je me suis dit qu'il valait peut mieux reprendre le tout sous forme d'un guide simple:

Le problème:
Suite à une mise à jour/ update système, mon scanner (HP photosmart 3210) n'était plus reconnu par xsane, sauf en lançant xsane en mode root. Je pense que le problème est lié au fait que le fichier libsane.rules ne mentionne pas mon scanner (e je suppose qu'il le mentionnait par le passé).

La solution est la suivante.

1-

$ lsusb
Bus 007 Device 003: ID 03f0:5111 Hewlett-Packard PhotoSmart 3200 series


Je note les valeurs suivantes:
Bus 007 Device 003: ID 03f0:5111 Hewlett-Packard PhotoSmart 3200 series

2- il faut aller éditer le fichier z60_libsane.rules situé dans /etc/udev/rules.d
(Penser à faire une copie au cas où)

3-dans z60_libsane.rules je rajoute la ligne (à adapter suivant besoin: cf résultats trouvés avec lsusb):

# Hewlett-Packard PhotoSmart 3200 series
SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="5111", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"

4- redémarrage.

Espérant que ça servira à d'autres


Un bon système, c'est un système qui marche bien.
Un système qui répond à mes besoins, c'est une utopie big_smile
Actuellement sous 'buntu 10.4. Ai testé debian, fedora, etc. Utilise aussi win$ quand ça marche.

Hors ligne

Pied de page des forums