Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 22-09-2019 19:48:06

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : GIMP de fermeture intempestive à réinstaller Nvidia + Cuda

non nvidia-settings est un utilitaire optionnel , le driver c'est nvidia-driver (qui est un méta-paquet qui appelle d'autres paquet )
le serveur graphique c'est le paquet "xserver-xorg-vidéo-nvidia" qui lui aussi appelle d'autres dépendances
si tu veu savoir fait un :


apt-cache policy xserver-xorg-video-nvidia nvidia-driver
 




xserver-xorg-video-nvidia:
  Installé : 418.74-1
  Candidat : 418.74-1
 Table de version :
 *** 418.74-1 500
        500 https://deb.debian.org/debian buster/non-free amd64 Packages
        100 /var/lib/dpkg/status
nvidia-driver:
  Installé : 418.74-1
  Candidat : 418.74-1
 Table de version :
 *** 418.74-1 500
        500 https://deb.debian.org/debian buster/non-free amd64 Packages
        100 /var/lib/dpkg/status
 


ce ne sont pas les seuls paquets nécessaires , mais le minimum vital

Hors ligne

#27 22-09-2019 20:13:55

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : GIMP de fermeture intempestive à réinstaller Nvidia + Cuda

je te met une liste pris sur une de mes machines (juste pour te donner une idée , il manque des choses )

liste du principal pour le driver (mais pas complette )
xserver-xorg-vidéo-nvidia
nvidia-vulkan
nvidia-vulkan-common
nvidia-vdpau-driver
nvidia-support
nvidia-smi (optionnel)
nvidia-settings (optionnel mais en dépendances)
nvidia-persistenced
nvidia-openjdk-8-jre
nvidia-modprobe
nvidia-legacy-check
nvidia-kernel-support
nvidia-kernel-dkms
nvidia-kernel-common
nvidia-installer-cleanup
nvidia-driver-libs
nvidia-driver-bin
nvidia-driver
nvidia-detect (optionnel)
nvidia-alternative
glx-alternative-nvidia

tu a aussi toutes les "libnvidia*****" (librairies) .

pour cuda
plus les paquets "libcuda***" et tous les paquets "cuda****"



la compilation du driver , => mise a jour du noyau , => modification des liens , => création des modules , que tu retrouve dans   /lib/modules/lenomdunoyau/updates/dkms/nvidia-current-****.ko
il y a 4 modules normalement
ps: "lenomdunoyau" a remplacer pour le dernier par exemple  =>  /4.19.0-6-amd64/
moi par exemple j'ai 3 noyaux installé (donc 3 dossiers) , 4.19.0-4-amd64 et 4.19.0-5-am64 et le dernier 4.19.0-6-amd64

Dernière modification par robert2a (22-09-2019 20:26:29)

Hors ligne

#28 22-09-2019 23:15:39

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Buster +Stretch + Jessie
Noyau : Linux 4.19.0-6-amd64+ Linux 4.9.0-8-amd64 + Linux
(G)UI : Gnome 3.30.02 - 3.22.2
Inscription : 07-01-2012

Re : GIMP de fermeture intempestive à réinstaller Nvidia + Cuda

Je te réponds dans une nouvelle discussion dans installation debian intitulée  Réinstallation du driver Nvidia+Cuda

Guppy

Hors ligne

Pied de page des forums